连接 (导入) 数据概述

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

引用本文讨论导入和连接数据。您将了解任务,例如导入、 更新、 保护和管理您的 Excel 2007 工作表中的数据。

本文内容

使用外部数据连接

刷新数据

从数据源导入数据

使数据访问更安全

有关连接到数据的问题

使用外部数据连接

以下各部分讨论如何外部数据连接的工作,并了解如何查找编辑、 管理和其他应用程序和用户与共享的连接信息。

返回页首

了解有关数据连接的基础知识

Excel 工作簿中的数据可以来自两个不同位置。数据可能存储直接在工作簿,或者它可能存储在外部数据源,如文本文件、 数据库或联机分析处理 (OLAP) 多维数据集。此外部数据源连接到工作簿通过数据连接,这是一组的信息,其中介绍了如何查找、 登录,并访问外部数据源。

连接到外部数据的主要优点是您定期分析该数据而不重复将复制数据,这是一个非常耗时且出错。连接到外部数据后,您可以也会自动刷新 (或更新) 原始数据源的新信息更新时数据源中的 Excel 工作簿。

连接信息存储在工作簿中,也可以存储在 Office 数据连接 (ODC) 文件 (.odc) 或数据源名称文件 (.dsn) 等连接文件中。

要使外部数据导入到 Excel,您需要的数据访问权限。如果您想要访问外部数据源不是在本地计算机上,您可能需要与数据库管理员联系密码、 用户权限或其他连接信息。如果数据源是一个数据库,请确保未在独占模式下打开数据库。如果数据源文本文件或电子表格,请确保到另一个用户没有以独占方式打开它。

许多数据源还需要 ODBC 驱动程序或 OLE DB 提供程序来协调数据在 Excel、连接文件以及数据源之间的流动。

下面的图表概述了有关数据连接的要点。

连接到外部数据源

1.有多种可以连接到的数据源: Analysis Services、 SQL Server、 Microsoft Office Access、 其他 OLAP 和关系数据库、 电子表格和文本文件。

2.许多数据源有关联的 ODBC 驱动程序或 OLE db 访问接口。

3.连接文件定义所有需要访问并从数据源检索数据的信息。

4.连接信息从一个连接文件复制到工作簿,可以对其进行编辑。

5.数据复制到工作簿,以便您可以使用它,就像使用直接在工作簿中存储的数据。

返回页首

查找连接

要查找连接文件,请使用“现有连接”对话框(在“数据”选项卡上的“获取外部数据”组中,单击“现有连接”)。使用此对话框,您可以看到以下类型的连接:

  • 在工作簿中的连接   

    此列表将显示当前连接的所有工作簿中。从您已经定义,通过使用选择数据源对话框中的数据连接向导中,创建的连接或您以前选择此对话框中的连接的连接,则将创建列表。

  • 在您的计算机上的连接文件   

    此列表是根据“我的数据源”文件夹创建的,该文件夹通常存储在“我的文档”(Windows XP) 或“文档”(Windows Vista) 文件夹中。

  • 在网络上的连接文件   

    此列表可根据以下内容创建:

    • 位于您的本地网络上的一组文件夹,其位置可以在该网络范围内部署为 Microsoft Office 组策略部署的一部分。

    • Excel ServicesMicrosoft Office SharePoint Server 2007网站上的数据连接库 (DCL)。有关 Dcl 的详细信息,请参阅发布到 Excel Services

返回页首

编辑连接属性

您还可以将 Excel 用作连接文件编辑器来创建和编辑到存储在工作簿或连接文件中的外部数据源的连接。如果您没有找到想要的连接,那么您可以通过以下方式创建连接:单击“浏览更多”来显示“选择数据源”对话框,然后单击“新建源”来启动数据连接向导。

一旦您创建了连接,您可以使用连接属性对话框 (在数据选项卡的获取外部数据组中,单击属性。) 来控制可以连接到外部数据源的各种设置和要使用,请重复使用,或者切换连接文件。

如果您使用的连接文件来连接到数据源,Excel 将复制的连接信息的连接文件到 Excel 工作簿。当您通过使用连接属性对话框中进行更改时,您正在编辑存储在当前 Excel 工作簿而不是原始数据连接文件可能用来创建该连接的数据连接信息这表示显示在定义选项卡上的连接文件属性中的文件名。一旦您编辑连接信息 (除连接名称连接说明属性中),连接文件的链接将被删除,清除了连接文件属性。

要确保刷新数据源时始终使用连接文件,请单击“定义”选项卡上的“始终尝试使用此文件来刷新此数据”。选中此复选框可确保对连接文件的更新将始终由使用该连接文件的所有工作簿使用,当然该连接文件也必须设置了此属性。

返回页首

管理连接

通过使用工作簿连接对话框中,您可以轻松地管理这些连接,包括创建、 编辑和删除它们。(在数据选项卡的获取外部数据组中,单击连接。)此对话框可用于执行以下操作:

  • 创建、编辑、刷新和删除工作簿中使用的连接。

  • 验证外部数据的来源,这样做有若干原因,例如,连接可能是由其他用户定义的。

  • 显示在当前工作簿中每个连接的使用位置。

  • 诊断有关到外部数据的连接的错误消息。

  • 将连接重定向到其他服务器或数据源,或者替换现有连接的连接文件。

  • 使创建以及与用户共享连接文件变得容易。

返回页首

共享连接

连接文件是共享上以一致的方式的连接,使其更易于查找、 有助于提高安全,和方便数据源管理特别有用。若要共享的连接文件的最佳方式是将它们放在一个安全和受信任位置,如网络文件夹或 SharePoint 库中,用户可以读取文件的位置,但仅指定用户可以修改该文件。

使用 ODC 文件

通过连接到外部数据,在选择数据源对话框中,或使用数据连接向导连接到新的数据源,您可以创建 Office 数据连接 (ODC) 文件 (.odc)。ODC 文件使用自定义 HTML 和 XML 标记来存储连接信息。可以轻松地查看或编辑 Office Excel 中文件的内容。

您可以与其他人共享连接文件,以向他们赋予您对外部数据源的访问权。其他用户不需要设置数据源就可打开该连接文件,但他们可能需要安装在其计算机上访问外部数据所需的 ODBC 驱动程序或 OLE DB 提供程序。

ODC 文件是连接到数据和共享数据的推荐方法。您可以通过以下方式轻松地将其他传统的连接文件(DSN、UDL 和查询文件)转换成 ODC 文件:打开该连接文件,然后单击“连接属性”对话框的“定义”选项卡上的“导出连接文件”按钮。

使用查询文件

查询文件是包含数据源信息(包括数据所在的服务器的名称和创建数据源时提供的连接信息)的文本文件。查询文件是与其他 Excel 用户共享查询的传统方法。

使用.dqy 查询文件    您可以使用 Microsoft Query 保存包含数据的关系数据库查询.dqy 文件或文本文件。当您在 Microsoft Query 中打开这些文件时,您可以查看查询中的数据,并选择不同的查询检索数据。您可以保存任何查询,您将创建使用查询向导或直接在 Microsoft Query.dqy 文件。

使用按查询文件    您可以保存按文件,连接到 OLAP 数据库,服务器上或在脱机多维数据集文件 (.cub) 中的数据。当您使用 Microsoft Query 中的多维连接向导创建数据源的 OLAP 数据库或多维数据集时,按文件自动创建。因为 OLAP 数据库不组织记录或表中,不能创建查询或.dqy 文件来访问这些数据库。

使用.rqy 查询文件    为.rqy 格式,以支持 OLE DB 数据源驱动程序使用此格式,Excel 可以打开查询文件。有关详细信息,请参阅驱动程序的文档。

使用.qry 查询文件    Microsoft Query 可以打开和使用与早期版本的 Microsoft Query 无法打开.dqy 文件.qry 格式保存查询文件。如果您有想要在 Excel 中使用的.qry 格式的查询文件,在 Microsoft Query 中打开该文件,然后将其保存为.dqy 文件。保存.dqy 文件的信息,请参阅 Microsoft Query 帮助。

使用.iqy Web 查询文件    Excel 可以打开.iqy Web 查询文件从 Web 检索数据。

返回页首

使用外部数据区域和属性

外部数据区域(也称为查询表)是定义导入到工作表中的数据的位置的已定义名称或表名称。当您连接到外部数据时,Excel 会自动创建一个外部数据区域。唯一的例外情况是连接到数据源的数据透视表,它不创建外部数据区域。在 Excel 中,您可以设置外部数据区域的格式并进行布局,或者将其用在计算中,就像任何其他数据一样。

Excel 按如下规则自动命名外部数据区域:

  • 使用与文件名相同的名称命名来自 Office 数据连接 (ODC) 文件的外部数据区域。

  • 从数据库的外部数据区域命名查询的名称。默认情况下 Query_from_是用于创建查询的数据源的名称。

  • 使用文本文件名命名来自文本文件的外部数据区域。

  • 从 Web 查询的外部数据区域命名被从中检索数据的网页的名称。

如果您的工作表具有多个来自相同源的外部数据区域,则这些区域会被编号。例如,MyText、MyText_1、MyText_2 等等。

外部数据区域还有其他属性(请不要与连接属性相混淆),您可以使用这些属性来控制数据,例如保留的单元格格式和列宽。您可以通过以下方式来更改这些外部数据区域属性:在“数据”选项卡上的“连接”组中单击“属性”,然后在“外部数据区域属性”“外部数据属性”对话框中进行更改。

注意: 如果您想要共享的汇总或基于外部数据的报表,您可以为他人提供的工作簿包含外部数据区域,也可以创建报表模板。报表模板允许您保存外部数据,以使文件更小的情况下保存汇总或报表。当用户打开的报告模板检索外部数据。

返回页首

了解 Excel 和 Excel Services 中的数据源支持

有多个可用于连接到不同的数据源的数据对象,例如外部数据区域和数据透视表。但是,使用每种数据对象,您可以连接到的数据源的类型不同。您还可以在 Excel Services 中使用和刷新连接的数据,但还有其他的限制和替代方法,您应该了解。

Excel 数据对象和数据源支持

下表概述了对于 Excel 中的每种数据对象,哪些数据源是受支持的。

支持的数据源

Excel
数据
对象

创建
外部
数据
区域?

OLE
DB

ODBC

文本
文件

HTML
文件

XML
文件

共享-

列表

导入文本向导

数据透视表
(非 OLAP)

数据透视表
(OLAP)

Excel 表

XML 映射

Web 查询

数据连接向导

Microsoft Query

注意: 这些文件,请使用导入文本向导导入的文本文件,使用 XML 映射和 HTML 导入的 XML 文件或通过使用 Web 查询导入的 XML 文件不要使用 ODBC 驱动程序或 OLE DB 提供程序建立到数据源连接。

Excel Services 和数据源支持

如果您想要在 Excel Services 中显示 Excel 工作簿,您可以连接到并刷新数据,但必须使用数据透视表。Excel Services 不支持外部数据区域,这意味着 Excel Services 中不支持连接到数据源、 Web 查询、 XML 映射或 Microsoft Query Excel 表格。

但是,您可以将此限制解决使用数据透视表连接到数据源设计和布局的数据透视表作为没有级别、 组或分类汇总的二维表,以便所有所需的行和列的值将显示。有关详细信息,请参阅使用数据透视表报表以使外部表数据的 Excel Services 中提供

返回页首

了解 Microsoft 数据访问组件

Microsoft 数据访问组件 (MDAC) 2.8 是随附于 Microsoft Windows Server 2003、 Windows Vista 和 Windows XP SP2。Mdac,您可以连接到并使用各种关系和非关系型数据源中的数据。您可以通过使用开放式数据库连接 (ODBC) 驱动程序或OLE DB提供程序,这些内置和发运由 Microsoft,或者由各种第三方开发连接到许多不同数据源。安装 Microsoft Office 时,其他 ODBC 驱动程序和 OLE DB 提供程序添加到您的计算机。

要查看计算机上安装的 OLE DB 提供程序的完整列表,请从数据链接文件中显示“数据链接属性”对话框,然后单击“提供程序”选项卡。

要查看您的计算机上安装的 ODBC 提供程序的完整列表,请显示“ODBC 数据库管理器”对话框,然后单击“驱动程序”选项卡。

还可以使用其他制造商提供的 ODBC 驱动程序和 OLE DB 提供程序,以便从除 Microsoft 数据源之外的数据源(包括其他类型的 ODBC 和 OLE DB 数据库)中获取信息。有关安装这些 ODBC 驱动程序或 OLE DB 提供程序的信息,请查阅数据库文档或与数据库供应商联系。

返回页首

使用 ODBC 连接到数据源

下面几节将更加详细地介绍开放式数据库连接 (ODBC)。

ODBC 架构

在 ODBC 体系结构中,应用程序(例如 Excel)连接到 ODBC 驱动程序管理器,而 ODBC 驱动程序管理器又使用特定的 ODBC 驱动程序(例如 Microsoft SQL ODBC 驱动程序)连接到数据源(例如 Microsoft SQL Server 数据库)。

定义连接信息

要连接到 ODBC 数据源,请执行下列操作:

  1. 确保适当的 ODBC 驱动程序安装在包含数据源的计算机上。

  2. 使用以下方法定义数据源名称 (DSN):使用“ODBC 数据源管理器”将连接信息存储在注册表或 DSN 文件中,或者使用 Microsoft Visual Basic 代码形式的连接字符串将连接信息直接传递给 ODBC 驱动程序管理器。

    若要定义数据源,在 Windows Vista 中,单击“开始”按钮然后单击“控制面板”。单击“系统和维护”,然后单击“管理工具”。在 Windows XP 和 Windows Server 中,单击“开始”,然后单击“控制面板”。单击“性能和维护”,再单击“管理工具”,然后单击“数据源(ODBC)”。有关不同选项的详细信息,请单击每个对话框中的“帮助”按钮。

机器数据源

计算机数据源存储在注册表中,使用用户定义的名称的特定计算机上连接信息。您可以在定义的计算机上使用计算机数据源。有两种类型的计算机数据源-用户和系统。用户数据源可以只由当前的用户,并且仅对该用户可见。系统数据源可以由一台计算机上的所有用户,并为计算机上的所有用户都均可见。

如果您想要提供额外的安全性,机器数据源尤为有用,因为它有助于确保只有登录的用户能够查看机器数据源,并且机器数据源不能被远程用户复制到其他计算机上。

文件数据源

文件数据源(也称作 DSN 文件)将连接信息存储在文本文件中,而不是注册表中。通常,使用文件数据源要比使用机器数据源更加灵活。例如,可以将文件数据源复制到装有正确 ODBC 驱动程序的任何计算机上,这样,您的应用程序在任何一台所使用的计算机上都可以获得一致和准确的连接信息。也可以将文件数据源放置到单台服务器上,在网络上的多台计算机之间进行共享,并且可以方便地在一个位置维护连接信息。

文件数据源还可以是不可共享的。不可共享的文件数据源驻留在单台计算机上并指向机器数据源。您可以使用不可共享的文件数据源来从文件数据源中访问现有的机器数据源。

返回页首

使用 OLE DB 连接到数据源

下面几节将更加详细地介绍对象链接和嵌入数据库 (OLE DB)。

OLE DB 架构

在 OLE DB 体系结构中,访问数据的应用程序称为数据使用者(例如 Excel),而允许对数据进行本地访问的程序称为数据库提供程序(例如 Microsoft OLE DB Provider for SQL Server)。

定义连接信息

通用数据链接文件 (.udl) 中包含数据使用者用来通过数据源的 OLE DB 提供程序访问该数据源的连接信息。可以通过执行下列操作之一来创建连接信息:

  • 在数据连接向导中,使用数据链接属性对话框中定义的 OLE db 访问接口的数据链接。有关详细信息,请参阅使用数据连接向导将数据导入

  • 创建一个具有 .udl 文件类型的空文本文件,然后编辑该文件,该文件将显示“数据链接属性”对话框。

返回页首

刷新数据

连接到外部数据源时,您还可以执行刷新操作来检索更新后的数据。每次刷新数据时,您都会看到数据的最新版本,包括自上次刷新以来对数据进行的任何更改。

下图说明了在刷新连接到外部数据源的数据时经历的基本流程。

刷新外部数据的基本流程

1. 刷新操作可获得最新的数据。

2.的连接文件定义所有需要访问并从外部数据源检索数据的信息。

3.有多种可以刷新的数据源: OLAP、 SQL Server、 Access、 OLE DB、 ODBC、 表格和文本的文件。

4. 将最新数据添加到当前工作簿中。

Excel 提供了许多用于刷新导入数据的选项,包括每次打开工作簿时都刷新数据和定期自动刷新数据。在刷新数据时,您仍然可以在 Excel 中工作,并且还可以在刷新数据的同时检查刷新状态。

如果您的外部数据源需要密码来访问数据,您可以要求每次刷新外部数据区域时输入密码。

返回页首

从数据源导入数据

Windows XP、 Windows Vista 和 Microsoft Office 提供的 ODBC 驱动程序和可用于从下列公共数据源检索数据的 OLE DB 提供程序: Microsoft Office Access,万维网,文本文件,Microsoft SQL Server,在 HTML 文件Microsoft SQL Server Analysis Services 和 XML 文件。通过使用数据连接向导和 Microsoft Query,您也可以访问许多具有适当的 OLE DB 提供程序和 ODBC 驱动程序,包括其他 Excel 工作表、 Microsoft FoxPro、 dBASE、 困境、 Oracle 以及 DB2 其他数据源。

返回页首

从 Access 数据库导入数据

存在多种在 Microsoft Office Access 和 Microsoft Office Excel 之间交换数据的方法。

  • 若要将 Access 中的数据装入 Excel,可以从 Access 数据表中复制数据并粘贴到 Excel 工作表中,从 Excel 工作表连接到 Access 数据库,或者将 Access 数据导出到 Excel 工作表中。

  • 若要将 Excel 中的数据装入 Access,可以从 Excel 工作表复制数据并粘贴到 Access 数据表中,将 Excel 工作表导入 Access 表中,或者从 Access 表链接到 Excel 工作表。

注意: “导入”一词在 Excel 和 Access 中的意义各不相同。在 Excel 中,导入指的是建立一个可刷新的永久数据连接。在 Access 中,导入则指将数据装入 Access 中一次,但不建立数据连接。

在 Excel 中使用 Access 数据

您可能想要充分利用数据分析和图表的数据排列和布局或在 Access 中不可用的函数中灵活的功能,才能使用访问 Excel 工作簿中的数据。

从 Excel 中连接到 Access 数据

要将可刷新的 Access 数据导入到 Excel 中,您可以创建到 Access 数据库的连接,然后从表或查询中检索所有数据。例如,您可能希望更新每月分发的 Excel 摘要预算报表,以便它包含当月的数据。

将 Access 数据导出到 Excel

在 Access 中使用导出向导,您可以导出 Access 数据库对象,例如表、 查询、 窗体中或到 Excel 工作表视图中的所选的记录。执行导出操作时,您可以保存将来使用和偶数日程以指定的时间间隔自动运行导出操作的详细信息。

下面是需要将数据从 Access 导出到 Excel 的常见情形:

  • 您的部门或工作组在处理数据时既使用 Access 也使用 Excel。您在 Access 数据库中存储数据,但使用 Excel 来分析数据和分发分析结果。您的小组目前在需要时将数据导出到 Excel,但您想让这个过程更加高效一些。

  • 您多数时间都在使用 Access,但您的经理更愿意在 Excel 中查看报表。您要按固定时间间隔将数据复制到 Excel 中,但您想自动完成这个过程以便节省您自己的时间。

有关将数据从 Access 导出到 Excel 的详细信息,请参阅 Access“帮助”系统。

在 Access 中使用 Excel 数据

您可能希望在 Access 数据库中使用 Excel 数据,以便利用 Access 的数据管理、安全性或多用户功能。虽然 Access 中有很多有用的功能,但是用户发现有两个功能对于 Excel 数据尤为有用:

  • 报表    如果您熟悉 Access 报表设计,并且您想要汇总和组织您这种类型的报表中的 Excel 数据,您可以创建 Access 报表。例如,您可以创建更灵活的报表,例如分组和汇总报表、 打印的标签和图形报表。

  • 窗体    如果您想要使用窗体,若要查找或在 Excel 中显示数据,您可以创建 Access 窗体。例如,您可以创建 Access 窗体以从您的工作表中的列的顺序不同的顺序显示字段,或者您可以在一个屏幕上更轻松地查看较长的行的数据。

有关使用 Access 表单和报表的详细信息,请参阅 Access 帮助系统。

从 Access 中链接到 Excel 数据

为表格,可以将 Excel 区域链接到 Access 数据库。当您打算继续保留在 Excel 中的区域,但还希望可用于从 Access 中的区域,请使用此方法。不能从 Excel 中创建这种类型的从 Access 数据库中的链接。

在链接到 Excel 工作表或命名区域时,Access 会创建一个新表并链接到源单元格。在 Excel 中对源单元格所做的任何更改都会反映到链接的表中。不过,您不能在 Access 中编辑对应表的内容。如果要添加、编辑或删除数据,必须在源文件中进行更改。

下面是需要从 Access 中链接到 Excel 工作表的常见情形:

  • 您想继续在 Excel 工作表中保留数据,但要能够使用 Access 强大的查询和报表功能。

  • 您所在的部门或工作组使用 Access,但与您一起工作的外部源中的数据的 Excel 工作表。您不想维护外部数据的副本,但您希望用户能够在 Access 中使用它。

有关将数据从 Access 链接到 Excel 的详细信息,请参阅 Access 帮助系统。

将 Excel 数据导入到 Access 中

若要将 Excel 中的数据存储到 Access 数据库中,并且此后在 Access 中使用和维护这些数据,您可以导入这些数据。导入数据时,Access 会在新表或现有表中存储这些数据,而无需改变 Excel 中的数据。进行导入操作时,一次只能导入一个工作表。若要导入来自多个工作表的数据,请为每个工作表重复执行导入操作。

下面是需要将 Excel 数据导入 Access 的常见情形:

  • 您多数时间都在使用 Excel,但以后准备使用 Access 处理这些数据。您想将 Excel 工作表的数据移到一个或多个新的 Access 数据库中。

  • 您所在的部门或工作组使用 Access,但有时您会收到 Excel 格式的数据,而这些数据又必须合并到 Access 数据库中。您想在接收到 Excel 工作表时将它们导入到数据库中。

  • 您使用 Access 管理数据,但您所在工作组的其他人员发来的周报是 Excel 工作簿。您想简化导入过程,以确保数据能在每周的特定时间导入到数据库中。

有关将数据从 Excel 导入 Access 的详细信息,请参阅 Access“帮助”系统。

返回页首

从 Web 导入数据

网页中经常包含特别适于在 Excel 中分析的信息。例如,您可以使用直接来自网页的信息在 Excel 中分析股票报价。根据您的需要,您可以检索可刷新的数据(即,您可以使用网页上的最新数据更新 Excel 中的数据),也可以从网页获取数据并将其保存在工作表中,使之成为静态的。

您可以使用 Web 查询来检索存储在 Intranet 或 Internet 上的数据,例如单个表、多个表或网页上的所有文本,并使用 Excel 中的工具和功能来分析这些数据。通过单击按钮,您可以使用网页上的最新信息轻松地刷新数据。例如,您可以从公共网页上检索和更新股票报价,或者从公司网页上检索和更新销售信息表。

通过使用新建 Web 查询对话框中,可以从网页导来源的数据。(在数据选项卡的获取外部数据组中,单击从 Web。)您需要访问万维网通过贵公司的 intranet 或调制解调器上您的计算机或网络,或者您可以对本地 HTML 或 XML 文件中进行查询。

返回页首

导入文本文件

您可以使用 Excel 将来自文本文件的数据导入到工作表中。(在“数据”选项卡上的“获取外部数据”组中,单击“自文本”。)文本导入向导将检查您正在导入的文本文件并帮助您确保按照您希望的方式导入数据。

使用 Excel 有两种方法可导入来自文本文件的数据:您可以在 Excel 中打开该文本文件(这不会建立到文本文件的连接),也可以将该文本文件作为外部数据区域导入(这会建立到文本文件的连接)。

有两种常用的文本文件格式:

  • 带分隔符的文本文件 (.txt),其中通常用 TAB 字符(ASCII 字符代码为 009)来分隔每个文本域。

  • 逗号分隔值 (CSV) 文本文件 (.csv),其中通常用逗号字符 (,) 来分隔每个文本域。

您还可以更改在带分隔符的文本文件和 .csv 文本文件中使用的分隔符。这对于确保导入或导出操作能够按照您所期望的方式进行可能是必需的。

返回页首

从 Microsoft SQL Server 导入数据

Microsoft SQL Server 是功能完备的关系数据库,旨在为要求最优的性能、可用性、可伸缩性和安全性的情况提供企业范围的数据解决方案。在 Excel 中,您可以轻松地连接到 Microsoft SQL Server 数据库。(在“数据”选项卡上的“获取外部数据”组中,单击“自其他来源”,然后单击“来自 SQL Server”。)

当您连接到 Microsoft SQL Server 数据库时,数据连接向导将显示三个页面:

  • 页面 1: 连接到数据库服务器    使用此页面指定服务器并登录到数据库服务器的方式。

  • 页面 2: 选择数据库和表   使用此页面指定数据库和表或查询。

  • 页面 3: 将数据保存文件,并且连接   使用此页面来指定,并介绍用于查找文件的连接文件和搜索短语。

返回页首

从 Microsoft SQL Server Analysis Services 导入数据

支持的商业智能和是联机分析处理 (OLAP) 分析系统、 关键性能指标 (KPI) 的记分卡、 数据挖掘和仪表板报告系统基础的分析服务 (Microsoft SQL Server 的一个组件).在 Excel 中,您可以轻松地连接到 Analysis Services OLAP 数据库使用 OLAP 提供程序。(在数据选项卡上的获取外部数据组中,单击从其他源,然后单击从 Analysis Services)OLAP 提供程序是软件的一套提供对特定类型的 OLAP 数据库的访问。数据源驱动程序和其他客户端软件所需连接到数据库,可以包括此软件。您必须使用数据透视表连接到 OLAP 提供程序。

从 OLAP 数据源断开连接时,您也可以访问 OLAP 数据。脱机多维数据集文件是包含存储源数据从 OLAP 服务器数据库的一部分的文件。使用脱机多维数据集文件以继续对数据透视表和数据透视图报表进行更改,或从网络断开连接时服务器不可用。

当您连接到 Microsoft SQL Server Analysis Services 时,数据连接向导将显示三个网页:

  • 页面 1: 连接到数据库服务器    使用此页面指定服务器并登录到数据库服务器的方式。

  • 页面 2: 选择数据库和表   使用此页面指定数据库和多维数据集。

  • 页面 3: 将数据保存文件,并且连接   使用此页面来指定,并介绍用于查找文件的连接文件和搜索短语。

返回页首

导入 XML 数据

Office Excel 可以轻松地将其他数据库和应用程序,将 XML 元素从 XML 架构映射到工作表单元格中创建的可扩展标记语言 (XML) 数据导入和导出修订与其他数据库进行交互的 XML 数据和应用程序。考虑为到 XML 数据文件生成器使用熟悉的用户界面中启用 Excel 这些新 XML 功能。

通过使用 XML 映射,您可以轻松地添加、 识别和从 Excel 文档中提取业务数据的特定部分。例如,包含名称和地址的客户或包含最后一个季度的财务结果的报告的发票不再只是静态的报表。可以轻松地从数据库和应用程序导入此信息、 对其进行修订并将其导出到相同或其他数据库和应用程序。

重要的 XML 方案

下面是设计 XML 功能以实现的重要方案:

  • 通过将 XML 元素映射到现有单元格来扩展现有 Excel 模板的功能。这使得可以更轻松地将 XML 数据放入模板及从模板中取出,而无需重新设计它们。

  • 通过将 XML 元素映射到现有电子表格将 XML 数据用作现有计算模型的输入。

  • 将 XML 数据文件导入到新的工作簿中。

  • 将 XML 数据从 Web 服务中导入到 Excel 工作表中。

  • 将映射的单元格中的数据导出到独立于工作簿中其他数据的 XML 数据文件中。

在 Excel 中使用 XML 数据的基本过程

下图显示了当您在 Excel 中使用 XML 时不同的文件和操作是如何协同工作的。实质上,该过程有五个阶段。

关于 Excel 如何处理 XML 数据的概述

标注 1 将 XML 架构文件 (.xsd) 添加到工作簿。

标注 2 将 XML 架构元素映射到个别单元格或 XML 列表。

标注 3 导入 XML 数据文件 (.xml),并将 XML 元素绑定到映射的单元格。

标注 4 输入数据、 移动映射的单元格并利用 Excel 功能,同时保留 XML 结构和定义。

标注 5 将经过修改的数据从映射的单元格导出到 XML 数据文件。

使用 XML 数据

当您将 XML 数据文件的内容导入到工作簿中现有的 XML 映射中时,您就会将该文件中的数据绑定到存储在工作簿中的 XML 映射中。这意味着该 XML 数据文件中的每个数据元素在您从 XML 架构文件或推断式架构中映射的 XML 架构中都有对应的元素。每个 XML 映射只能有一个 XML 数据绑定,并且 XML 数据绑定将绑定到从单个 XML 映射创建的所有映射。

您可以显示XML 映射属性对话框 (在开发工具选项卡的XML组中,单击映射属性。),其中有三个选项,在默认情况下,您可以设置或清除控制 XML 数据的行为绑定:

  • 根据导入和导出架构验证数据   指定导入数据时,Excel 是否验证根据 XML 映射数据。当您想要确保导入 XML 数据符合 XML 架构,请设置此选项。

  • 用新数据覆盖现有数据   指定导入数据时,是否覆盖数据。如果要将当前数据替换新数据,例如,当在新的 XML 数据文件中包含的最新数据,请设置此选项。

  • 将新数据追加到现有的 XML 列表   指定是否数据源的内容添加到工作表上的现有数据。设置此选项,例如,当要合并多个类似的 XML 数据文件中的数据转换为 XML 列表,或者您不想覆盖包含函数的单元格的内容。

返回页首

使用数据连接向导导入数据

您可以使用数据连接向导连接到已定义的 OLE DB 和 ODBC 外部数据源。若要打开获取外部数据组中的数据连接向导中,在数据选项卡上,单击从其他源,然后单击来自数据连接向导

如果您在数据连接向导中选择了“其他/高级”数据源选项,则可在“数据链接属性”对话框中查看可用的 OLE DB 提供程序列表。此外,Microsoft OLE DB Provider for ODBC Drivers 也允许访问 ODBC 数据源。有关使用此对话框中的每个选项卡的详细信息,请单击“数据链接属性”对话框中的“帮助”

一般情况下,在数据链接属性对话框中定义连接信息,请执行下列:

  • 单击提供商选项卡、 OLE db 访问接口中,选择,然后单击下一步,以显示连接选项卡,输入 OLE DB 提供程序特定的连接信息。

    每个 OLE DB 提供程序定义的特定连接信息。例如,Microsoft OLE db 访问接口的 SQL Server 需要服务器名称、 服务器位置和用户名,并可能想要定义的其他信息,例如密码或是否希望使用 Microsoft Windows 集成的安全性。

  • 单击“高级”选项卡提供其他信息,例如网络设置和访问权限。

  • 单击“全部”选项卡定义该 OLE DB 提供程序的初始属性。

注意: 不能在数据连接向导中筛选或连接数据。

返回页首

使用 Microsoft Query 导入数据

您可以使用 Microsoft Query 导入数据。(在数据选项卡上的获取外部数据组中,单击从其他源,然后单击来自 Microsoft Query。)使用 Microsoft Query 设置 ODBC 数据源来检索数据。在 Microsoft Query 中,您可以使用查询向导创建简单查询,或可以在查询中使用高级的条件以创建更复杂的查询,然后执行下列:

  • 将行数据或列数据导入 Excel 之前对其进行筛选。

  • 创建参数查询。

  • 将数据导入 Excel 之前对数据进行排序。

  • 连接多个表。

Microsoft Query 提供了一个简单而且很容易从 Excel 中访问的前端来执行这些特殊的查询任务。

返回页首

以编程方式使用函数导入数据

如果您是开发人员,那么在 Excel 中有几个可用来导入数据的方法:

  • 可以使用 Visual Basic 应用程序以访问外部数据源。根据数据源,您可以使用 ActiveX 数据对象或数据访问对象检索数据。您还可以在代码中指定的连接信息定义连接字符串。使用连接字符串非常有用,例如,当您想要避免要求系统管理员或用户首次创建连接文件,或者简化安装的应用程序。

  • 如果您从 SQL Server 数据库导入数据,请考虑使用 SQL 本机客户端,这一个单独的数据访问应用程序编程接口 (API) 用于 OLE DB 和 ODBC。它将组合 SQL OLE db 访问接口和 SQL ODBC 驱动程序成一个本机、 动态链接库 (DLL) 同时还提供了不同从 Microsoft 数据访问组件 (MDAC) 的新功能。您可以使用 SQL 本机客户端创建新的应用程序或增强现有可以利用新的 SQL Server 2005 功能,如多个活动结果集 (火星)、 用户定义类型 (UDT) 和 XML 数据类型支持的应用程序。

  • RTD 函数从支持 COM 自动化的程序中检索实时数据。RTD COM 自动化加载项必须创建并在本地计算机上注册。

  • SQL。请求函数连接到外部数据源并从工作表中运行查询。SQL。然后,请求无需进行宏编程数组形式返回结果。如果此函数不可用,则必须安装 Microsoft Excel ODBC 外接程序 (XLODBC。XLA)。您可以从 Microsoft Office Online 网站安装该加载项。

有关创建 Visual Basic for Applications 的详细信息,请参阅 Visual Basic 帮助。

返回页首

使数据访问更安全

当您连接到外部数据源或刷新数据时,务必要注意的潜在的安全问题,并了解有关这些安全问题可以执行哪些操作。使用以下准则和最佳做法可帮助保护您的数据。

返回页首

将数据连接存储在受信任位置

数据连接文件通常包含一个或多个用于刷新外部数据的查询。通过替换此文件,有恶意企图的用户可以设计查询来访问机密信息并将其分发给其他用户或者执行其他有害的操作。因此,务必请确保以下两点:

  • 连接文件是由可靠的人编写的。

  • 连接文件的安全,来自受信任位置。

若要帮助提高安全性,可能在您的计算机上禁用连接到外部数据。若要打开工作簿时,连接到数据,您必须激活数据连接通过使用信任中心栏中,或者通过将工作簿放在受信任位置。有关详细信息,请参阅创建、 删除或更改您的文件的受信任的位置添加、 删除或查看受信任的发布者查看我在信任中心的安全设置

返回页首

以安全的方式使用凭据

访问外部数据源通常需要凭据(例如用户名和密码),凭据用于验证用户的身份。请确保这些凭据是以安全且受保护的方式提供给您的,并且您不会在无意中将这些凭据泄露给其他人。

使用由大写字母、小写字母、数字和符号组合的强密码。弱密码不混合使用这些元素。例如,Y6dh!et5 是强密码;House27 是弱密码。密码长度应大于等于 8 个字符。最好使用包括 14 个或更多个字符的密码。

记住密码很重要。如果忘记了密码,Microsoft 将无法找回。最好将密码记录下来,保存在一个安全的地方,这个地方应该尽量远离密码所要保护的信息。

避免连接到数据源时保存登录信息。此信息可以存储为纯文本格式的工作簿,并连接文件,并且恶意用户可以访问破坏安全性的数据源的信息。

如果可能,请使用 Windows 身份验证 (也称为信任连接) 使用 Windows 用户帐户来连接到 SQL Server。当用户连接到 Windows 用户帐户时,SQL Server 使用信息在 Windows 操作系统中要验证的帐户名称和密码。您可以使用 Windows 身份验证之前,服务器管理员必须配置 SQL Server 使用此身份验证模式。如果 Windows 身份验证不可用,避免保存用户的登录信息。为用户输入登录信息登录每次更安全。

返回页首

安全地发布到 Excel Services

当您连接到数据源时,您可以使用“Excel Services 身份验证设置”对话框来选择访问 Excel Services 中的数据源时使用的身份验证方法。您可以选择下列选项之一来登录到数据源:

  • Windows 身份验证    选择此选项可使用当前用户的 Windows 用户名和密码。这是最安全的方法,但是如果有多个用户,它可能会影响性能。

  • SSO   选择要使用单一登录,此选项,然后在SSO ID文本框中输入适当的标识字符串。网站管理员可以配置 SharePoint 网站以使用单一登录数据库,可以在其中存储用户名和密码。此方法可以是最有效的时间有多个用户。

  •    选择此选项以在连接文件中保存的用户名和密码。

注意: 验证设置只能由 Excel Services 使用,而不能由 Microsoft Office Excel 使用。如果希望确保无论在 Excel 中还是在 Excel Services 中打开工作簿都能访问相同的数据,请确保 Excel 中的验证设置与 Excel Services 中的相同。

若要提高安全性的连接,请使用数据连接库 (DCL)。DCL 是特殊的 SharePoint 文档库,可以为受信任的位置的库中,定义的这样就可以轻松地存储、 安全、 共享和管理 ODC 文件。例如,管理员可能需要将数据库从测试服务器移到生产服务器,或更新访问数据的查询。通过使用一个 ODC 文件保存在 DCL,此连接信息的管理变得更为轻松,并且用户的访问数据更方便,因为所有工作簿使用相同的连接文件,并刷新操作 (客户端或服务器计算机上是否)获取最新更改对该连接文件。您甚至可以设置为自动检测更改连接文件,并使用该连接文件的最新版本的 Office SharePoint Server 和用户的客户端计算机。有关详细信息,请参阅Office SharePoint Server 2007管理中心帮助。

返回页首

关于连接到数据的问题

以下各部分将讨论连接到外部数据时可能会遇到的几个问题

返回页首

问题:在我尝试导入数据时磁盘空间不足。

如果您在连接到外部数据时磁盘空间用完,请考虑执行下列操作:

检查并增加可用磁盘空间    要解除您的硬盘上的一些空间,请尝试清空回收站、 备份不需要的文件,并将其从您的硬盘或删除不使用的 Windows 组件。关于释放磁盘空间的详细信息,请参阅 Windows 帮助。

当磁盘空间有限时,您可以尝试的策略    如果您的硬盘上有仅在有限的可用空间,请尝试以下操作:

Microsoft Query   执行下列一项或多项操作:

  • 简化查询    请确保包含这些表和字段所需的查询。如果您的查询中包含不必要的表或字段,请从查询来减少文件大小的临时查询将其删除。

  • 使用条件以减小大小的结果的设置    使用条件来检索特定记录,而不是从数据库中检索的所有记录。有关详细信息,请参阅 Microsoft Query 帮助。

  • 设置限制查询返回的记录数    限制查询返回的记录数。Microsoft Query 中单击编辑菜单上的选项,选择用户设置下的限制返回的记录数复选框,然后输入记录以在记录框中返回最大数量。

数据连接向导    虽然您无法限制通过数据连接向导中的数据,您或许能够通过来限制数据源中的数据的数据源中定义查询。如果您没有权限来定义数据源查询或功能,与数据管理员联系。

返回页首

问题:OLAP 多维数据集向导在哪里?

Microsoft Query,从 Jet 数据库中创建的 OLAP 多维数据集,在 OLAP 多维数据集向导不再在 Office Excel 中可用。

返回页首

问题:数据检索服务出了什么问题?

数据检索服务是在 Microsoft Office 2003 中引入的,它使用通用数据连接 (UDC) 文件 (.udcx) 来访问 Web 服务和查询不同的数据源。

欢迎使用数据连接向导页面上数据连接向导中,您可以选择Microsoft Business Solutions数据检索服务数据源选项。数据检索服务选项允许您选择两个数据检索服务: Windows SharePoint Services 列表、 其从列表和运行Windows SharePoint Services和Microsoft SQL Server 的服务器上的文档库中检索数据,其中检索数据从 Microsoft SQL Server 2000 或更高版本。

虽然数据连接向导不再支持编辑 UDC 连接文件了,但是 Excel 继续支持现有的数据检索服务连接,您仍然可以刷新这些连接。

返回页首

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×