连接到 XML 文件 (Power Query)

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

使用 Excel 的获取和转换 (Power Query) 体验来连接到 XML 文件。

  1. 单击数据选项卡,然后获取数据>从文件>从 XML。如果看不到获取数据按钮,单击新建查询>从文件>从 XML

  2. 在“从 XML 浏览”对话框中,通过浏览查找或输入要导入的文件 URL 或文件链接。

  3. 单击“打开”。

    连接成功后,您就能使用“导航器”窗格浏览,并以表格格式预览 XML 文件中项的集合。

  1. Power Query功能区选项卡上,单击从文件>从 XML

    Power Query 从文件对话框
  2. 在“从 XML 浏览”对话框中,通过浏览查找或输入要导入的文件 URL 或文件链接。

  3. 单击“打开”。

    连接成功后,您就能使用“导航器”窗格浏览,并以表格格式预览 XML 文件中项的集合。

重要: 请确保您已下载并安装Power Query 加载项。

注意: 在 Excel 2007 中不支持 power Query,但您可以使用获取外部数据方法导入 XML 数据。

  1. 单击打开数据选项卡,然后获取外部数据>自其他来源>从 XML

  2. 选择数据源对话框中,通过浏览查找或输入要导入的文件 URL 或选择要链接到文件的新的源选项。

公式示例

您可以使用查询编辑器如何编写Powerquery 公式。例如:

= Xml.Tables(File.Contents("C:\Downloads\XML Example.xml"))

注意: 仅当您使用 Power Query 加载、编辑或创建新查询时,“查询编辑器”才会显示。 以下视频显示在 Excel 工作簿中编辑查询后显示的“查询编辑器”窗口。 若要在不加载或编辑现有工作簿的情况下查看“查询编辑器”,请在 Power Query 功能区选项卡的获取外部数据部分中,选择自其他来源 > 空白查询。 以下视频介绍一种显示查询编辑器的方法。

如何在 Excel 中查看查询编辑器

需要更多帮助吗?

可随时在 Excel 技术社区中咨询专家,在解答社区获得支持,或在 Excel User Voice 上建议新功能或功能改进。

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

另请参阅

Power Query 称为获取和转换在 Excel 2016 中

从外部数据源导入数据

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×