连接到另一个工作簿

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

您可以创建现有 Excel 工作簿与另一个工作簿之间的动态连接。第二个工作簿中的数据发生更改时,然后可以刷新的连接。

使用 Excel 的获取和转换 (Power Query)体验连接到 Excel 工作簿。

  1. 单击数据选项卡,然后获取数据>从文件>从工作簿。如果看不到获取数据按钮,单击新建查询>从文件>从工作簿

  2. 浏览到导入数据窗口中的工作簿。

  3. 导航器窗口中,选择要导入,工作表,然后单击加载编辑

在 Excel 2010 和 2013年中,有两种方法来创建连接到另一个工作簿。建议的方法是使用Power Query,它可如果下载 Power Query 加载项。如果您不能下载 Power Query 加载项,您可以使用数据连接向导

Power Query

  1. Power Query功能区选项卡上,单击从文件>从 Excel

  2. 浏览到工作簿。

  3. 导航器窗口中,选择要导入,工作表,然后单击加载编辑


数据连接向导

步骤 1: 与另一个工作簿中创建的连接

  1. 在“数据”选项卡上,单击“连接”。

    连接

  2. 工作簿连接对话框中,单击添加

  3. 在“现有连接”对话框的底部附近,单击“浏览更多”。

  4. 查找您的工作簿,然后单击“打开”。

  5. 在“选择表”对话框中,选择表(工作表),然后单击“确定”。

    注释: 

    • 工作表称为选择表对话框中的"表"。

    • 一次只能添加一个表。

    • 您可以通过单击属性按钮上重命名表。您还可以添加说明。

  6. 若要添加更多表,重复步骤 2 到 5。

  7. 单击“关闭”。

步骤 2: 将表添加到工作表

  1. 单击“现有连接”,选择表,然后单击“打开”。

  2. 导入数据对话框中,选择在何处放置您的工作簿中的数据以及作为表格数据透视表数据透视图查看数据。

    注意: 在 Excel 2013 中,您可以添加到数据模型的数据,以便您可以与其他表或其他来源的数据合并数据创建表之间的关系并完成更多不是您可以使用基本的数据透视表。

数据连接向导

步骤 1: 与另一个工作簿中创建的连接

  1. 在“数据”选项卡上,单击“连接”。

    连接

  2. 工作簿连接对话框中,单击添加

  3. 在“现有连接”对话框的底部附近,单击“浏览更多”。

  4. 查找您的工作簿,然后单击“打开”。

  5. 在“选择表”对话框中,选择表(工作表),然后单击“确定”。

    注释: 

    • 工作表被称为选择表对话框中的"表"

    • 一次只能添加一个表。

    • 您可以通过单击属性按钮上重命名表。您还可以添加说明。

  6. 若要添加更多表,重复步骤 2 到 5。

  7. 单击“关闭”。

步骤 2: 将表添加到工作表

  1. 单击“现有连接”,选择表,然后单击“打开”。

  2. 导入数据对话框中,选择在何处放置您的工作簿中的数据以及作为表格数据透视表数据透视图查看数据。

使工作簿中的数据保持最新

既然您已连接到外部工作簿,就需要其自己的工作簿中显示的最新数据。转到数据>全部刷新以获取最新数据。刷新的详细信息,转到刷新连接到另一个工作簿的数据

需要更多帮助吗?

可随时在 Excel 技术社区中咨询专家,在解答社区获得支持,或在 Excel User Voice 上建议新功能或功能改进。

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

另请参阅

Power Query 称为获取和转换在 Excel 2016 中

从外部数据源导入数据

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×