连接两个数据视图

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

在Microsoft Office SharePoint Designer 2007,您可能习惯于构建大量使用数据源和数据视图的应用程序。通过连接为视图或表单已插入的数据视图,您可以创建它们之间的连接,以便在一个数据视图中执行操作时,它变为另一个数据视图的内容。连接数据视图是一种快速且功能强大的方式将添加到您的网站或应用程序交互。

注意: 数据视图是一种类型的 Web 部件中,因此同样适用的概念和本文中的过程也到可连接的任何两个 Web 部件。

本文介绍了如何创建两个数据视图以及如何使用 Web 部件连接向导将其连接。

若要了解有关数据视图的详细信息,请参阅创建数据视图

本文内容

为什么连接 Web 部件?

使用视图创建第一个数据视图

作为示例数据源创建 XML 文件

通过使用 Suppliers.xml 创建数据视图

连接 Web 部件

测试 Web 部件连接

删除 Web 部件连接

为什么连接 Web 部件?

通过连接两个 Web 部件,可以在它们之间传递数据并同步它们的行为。例如,您可以连接到图像 Web 部件中显示的员工的列表的列表视图 Web 部件。链接两个 Web 部件,每次单击在列表视图 Web 部件,员工的姓名之后图像 Web 部件中显示所选员工的图片。

您可以使用浏览器中建立简单的 Web 部件连接。例如,您可以连接到另一个 Web 部件所在的同一 Web 部件页的一个 Web 部件。但是,您可以通过使用Office SharePoint Designer 2007扩展连接的功能。例如,您可以使用表单 Web 部件筛选的数据在另一个 Web 部件中,或者您可以建立两个单独的 Web 部件页中相同的顶级网站上的 Web 部件之间的连接。这两种操作需要Office SharePoint Designer 2007 ,且不能在浏览器中。

返回页首

使用视图创建第一个数据视图

罗斯文商贸,gourmet 食品分布公司,跟踪其库存.xml 文件命名视图中的,并在数据视图中显示该文件中的数据。此数据视图,以便团队可以通过将更改保存到视图中更新库存通过浏览器以表单形式插入。库存较低,工作组成员呼叫该产品的供应商、 下订单,并使用数据视图,然后更新库存。但是,工作组成员下订单,每次他们必须还查找供应商联系信息。

您建议插入第二个数据视图,显示供应商的联系信息,然后再创建两个 Web 部件之间的连接。这样,当工作组成员准备下订单,他们可以查看库存数据和每个产品的供应商的联系信息通过单击某个超链接。

下面的过程要求两个.xml 文件用作数据源并从每个这些数据源创建数据视图。要关注的示例,请按照下面的文章插入数据视图作为窗体中的过程从视图创建第一个数据视图。然后返回到此文章,从 Suppliers.xml 创建第二个数据视图。

返回页首

作为示例数据源创建 XML 文件

罗斯文商贸公司名为 Suppliers.xml.xml 文件中存储其供应品的联系信息。

创建 Suppliers.xml

  1. 文件菜单上,单击打开网站

  2. 打开网站对话框中,通过浏览找到并选择您的网站,然后单击打开

  3. 如果出现提示,请在连接到对话框中,键入您的用户名和密码,,然后单击确定

  4. “文件”菜单上,单击“新建”

  5. 新建对话框中,双击文本文件

    在您的网站中,将打开一个新的文本文件。

  6. 通过选择它们,然后按 CTRL + C 复制下面的代码行。

    <?xml version="1.0" encoding="utf-8"?>
    <SuppliersRoot>
    <Suppliers>
    <SupplierID>1</SupplierID>
    <CompanyName>Exotic Liquids</CompanyName>
    <ContactName>Charlotte Cooper</ContactName>
    <ContactTitle>Purchasing Manager</ContactTitle>
    <Address>49 Gilbert St.</Address>
    <City>London</City>
    <PostalCode>EC1 4SD</PostalCode>
    <Country>UK</Country>
    <Phone>(171) 555-2222</Phone>
    </Suppliers>
    <Suppliers>
    <SupplierID>2</SupplierID>
    <CompanyName>New Orleans Cajun Delights</CompanyName>
    <ContactName>Shelley Burke</ContactName>
    <ContactTitle>Order Administrator</ContactTitle>
    <Address>P.O. Box 78934</Address>
    <City>New Orleans</City>
    <Region>LA</Region>
    <PostalCode>70117</PostalCode>
    <Country>USA</Country>
    <Phone>(100) 555-4822</Phone>
    <HomePage>#CAJUN.HTM#</HomePage>
    </Suppliers>
    </SuppliersRoot>
  7. 在Office SharePoint Designer 2007,顶部的页面上,将插入点的位置,然后按 CTRL + V 粘贴您刚刚复制到页面的代码。

  8. “文件”菜单上,单击“另存为”

  9. 另存为对话框中,在文件名框中,键入suppliers.xml

  10. 保存类型列表中,单击XML,,然后单击保存

返回页首

通过使用 Suppliers.xml 创建数据视图

  1. 打开包含第一个数据视图,文章插入数据视图作为窗体中创建的页面。

    虽然不必要,这两个数据视图驻留在同一页上,在此例中您希望您的团队能够快速查看供应商的联系信息,单击产品时。

    选择的数据显示为表单

  2. 选择第一个数据视图中,,然后按向右箭头键两次以将光标放在数据视图下方。

  3. 数据视图菜单上,单击插入数据视图

    下方第一个数据视图,现在显示空数据视图和数据源库任务窗格随即打开。

    空数据视图

  4. 数据源库任务窗格中,找到您的数据源,单击它,,然后单击显示数据

    对于此示例中,在XML 文件,下单击Suppliers.xml,,然后单击显示数据。如果XML 文件标题折叠,请单击加号 (+) 以将其展开。

  5. 数据源详细信息任务窗格中,单击要插入数据视图中的字段。

    提示: 若要选择多个字段,请在按住 CTRL 的同时单击它们。

    本示例中,在SuppliersRoot文件夹下供应商,请单击公司名称。按下并按住 CTRL 的同时单击联系人姓名国家/地区电话

  6. 单击插入为选定的域,然后单击单项目视图将所选的数据插入数据视图。

    选择要在数据视图中显示只有一个项目,因为您希望显示一次只能有一个供应商的联系人信息。

    第二个数据视图下方第一个数据视图中现在显示在数据源详细信息任务窗格中选定的域。

    显示在产品数据视图之下的供应商数据视图
    (红色所述) 数据视图的 Suppliers.xml 下方数据视图的视图。

返回页首

连接 Web 部件

名为供应商的常见字段相关 Suppliers.xml 和视图。通过使用 Web 部件连接向导中,Web 部件连接通过链接到 Suppliers.xml 中的供应商 Id 字段的视图中的供应商 Id 字段。

现在,您已创建两个数据视图,您将在数据视图的视图将超链接到数据 Suppliers.xml 视图中添加每个产品旁边的文本。单击第一个数据视图中的产品的超链接时,该产品的供应商的联系信息将显示在第二个数据视图中。

数据视图的视图是源 Web 部件,Suppliers.xml 数据视图是目标 Web 部件。由于您正在使用以表单形式插入的数据视图,您需要创建窗体字段以外的文本超链接。键入的文本之后,您选择的文本,,然后使用 Web 部件连接向导在链接到数据 Suppliers.xml 视图的视图中创建超链接。

  1. 在数据视图中创建的视图,将光标置于右侧的文本框中包含产品名称,按空格键,,然后键入顺序。数据视图使用 XSLT 格式,因为文本"顺序"添加到列表中每个产品的字段。

    显示在列表内每个产品的 ProductName 列中的“订单”

  2. 在数据视图中,选择文本"顺序"右键单击它,然后单击快捷菜单上的Web 部件连接

    Web 部件连接向导随即打开。

  3. 源用于此连接的 Web 部件上选择的操作列表中,单击发送到的数据的行,,然后单击下一步

    Web 部件连接向导中的页面

  4. 选择包含连接的 Web 部件页面部分中,单击连接到此页面上的 Web 部件,然后单击下一步

    Web 部件连接向导中的页面

  5. 目标 Web 部件列表中,单击suppliers.xml

  6. 因为想要筛选 Suppliers.xml 以匹配的特定产品在第一个数据视图中,在目标操作列表中,供应商中的数据从获取筛选值,请单击,然后单击下一步

    Web 部件连接向导中的页面

  7. 输入 Suppliers.xml列中,向下滚动列表,直到您看到供应商。左侧的供应商列表中,在视图中的列列中,单击该单元格,然后单击箭头,然后单击供应商列表中。单击下一步

    Web 部件连接向导中的页面

  8. 创建上的超链接列表中,单击[当前所选内容],,然后单击下一步

    Web 部件连接向导中的页面

  9. 单击“完成”。

  10. 文件菜单上,单击保存。此外,也可以按 CTRL + S。

文本"顺序"现在是超链接,并配置 Web 部件连接。

返回页首

测试 Web 部件连接

鉴于已配置 Web 部件连接,您可以预览页面在浏览器中的测试连接。

  • 若要预览的文件在浏览器中的常见工具栏上,单击预览或按 F12。

在浏览器中的页面上显示两个 Web 部件。若要在第一个数据视图中显示的特定产品的供应商,请单击旁边的产品的 ProductName 列中的所需顺序超链接。在第二个下面的数据视图中显示该供应商的联系信息。

网页中两个相互连接的数据视图

注意: 下列液体是德威、 激活,和茴香糖浆的供应商。新奥尔良 Cajun 带来快乐是厨师 Anton Cajun Seasoning 和厨师秋葵汤供应商。

返回页首

删除 Web 部件连接

您也可以删除 Web 部件连接,以便将不再链接两个 Web 部件。当您连接的 Web 部件时,每个 Web 部件将列出该连接,以便您可以通过使用源或目标 Web 部件中删除该连接。从目标 Web 部件中删除源 Web 部件连接也删除连接。

  1. 右键单击任一的数据视图,然后单击快捷菜单上的Web 部件连接

  2. Web 部件连接对话框中,单击要删除的连接,然后单击删除

返回页首

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×