设计针对打印而进行优化的视图

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

您创建的 Microsoft Office InfoPath 表单模板被设计为在 InfoPath 本身中或通过使用 Web 浏览器联机打开和填写。但是,用户可能会选择打印一份已完成的表单以留作个人记录或用于存档目的。因此,最好验证您的表单模板在打印出来时看起来是否可以接受。例如,您可能需要确保表单模板中的控件处在打印页的边距范围内,并确保打印出的表单上的文本能够看得清楚。

此外,您可以使用“视图”任务窗格来创建一种特殊版本的表单模板(称为打印视图),该模板是专为打印目的而设计的。  

本文介绍如何为表单模板设计打印视图,并介绍了用于创建适合打印的表单模板的其他方法。

本文内容

打印表单模板和打印表单的差异

打印视图简介

设计基于现有视图的打印视图

设计专用于 Word 的打印视图

打印表单模板和打印表单的差异

您可以打印表单模板,以便对控件和其他对象在打印页上的显示方式有一个大体了解,或对诸如页眉或页脚等打印设置进行验证。在通过设计模式打印表单模板时,您可能会在打印出的表单模板上看到某些项目(如按钮),当用户打印基于表单模板的表单时,这些项目实际上不会出现。

当用户打印基于表单模板的表单时,InfoPath 会对表单进行一些调整,或删除在打印的上下文中没有意义的某些项目。例如,默认情况下出现在重复表下方的“插入项目”说明性文本将不会出现在打印出的表单中。按钮控件、列表框条目或滚动箭头也不会出现,因为这些项目在打印页上失去了意义。

返回页首

打印视图简介

尽管表单模板被设计为以电子格式收集表单数据,但您可以创建打印视图,该视图是一种专为打印设计的视图。当您想要用户使用特定版式打印出表单或者只打印出表单的某些部分时,此视图特别有用。

如果表单模板包含多个视图,您可以为每个视图创建一个打印视图。或者,您可以指定适用于表单模板中所有视图的单一打印视图。例如,如果表单模板包含三个不同的视图,您可以创建一个将这些视图的每个视图中的关键信息合并到单一打印页中的打印视图。

要创建打印视图并将其与现有视图相关联,您可以使用“视图”任务窗格中的“创建视图的打印版本”链接。单击此链接时,InfoPath 将执行下列操作:

  • 创建一个名为“打印版本名称”的空白新视图,其中名称是打印视图所基于的视图的名称。

  • 将打印视图与它所基于的视图相关联。此关联是在“打印设置”选项卡上的“视图属性”对话框中记录的。例如,假设您创建了一个打印视图,该打印视图基于表单模板中的“审批”视图。当用户在“审批”视图中单击“打印”按钮时,InfoPath 将打印出现在“打印版本审批”视图上的任何内容。

创建了打印视图后,可以对其进行设计,以反映在打印表单时您想要如何显示表单。这通常涉及到将控件从表单模板中的其他视图复制并粘贴到打印视图中。如有必要,您可以用某些控件替换打印视图中的其他控件。例如,您可以将默认情况下隐藏列表框条目的下拉列表框替换为默认情况下显示条目的标准列表框。通过执行此操作,所有条目都将显示在打印出的表单上。您还可以在“视图属性”对话框中为打印视图指定自定义打印选项,比如页眉、页脚和页边距等。

返回页首

设计基于现有视图的打印视图

默认情况下,当用户打印没有特定打印视图与其关联的表单时,将会打印出当前显示在用户的计算机上的视图。如果创建了打印视图,InfoPath 将打印该视图(而不是当前视图)。您可以指定任何现有视图作为打印视图。以下过程介绍如何使用现有视图作为打印视图的基础。

  1. 视图菜单上,单击管理视图

  2. “视图”任务窗格的“选择视图”列表中,单击要为其创建打印视图的视图。

  3. “操作”下,单击“创建视图的打印版本”

  4. “创建打印版本”对话框中,为打印视图键入名称,然后单击“确定”

  5. “视图”任务窗格中,双击打印视图。

  6. “视图属性”对话框中的“打印设置”“页面设置”选项卡上选择所需的选项,然后单击“确定”。例如,您可以为打印视图指定默认边距设置,或者添加页眉或页脚。

  7. 要切换到原始视图,请在“视图”任务窗格的“选择视图”列表中单击视图的名称。

  8. 要选择视图中的所有内容,请按 Ctrl+A。

  9. 要将所选内容复制到剪贴板,请按 Ctrl+C。

  10. 要切换到打印视图,请在“视图”任务窗格的“选择视图”列表中单击视图的名称。

  11. 要将所选内容从原始视图粘贴到打印视图中,请按 Ctrl+V。

  12. 删除任何不需要的控件或版式元素,或添加其他控件。

    提示: 要快速确定控件和其他设计元素是否将显示在打印页上,您可以通过单击“视图”菜单上的“页宽参考线”,沿表单模板的右侧显示一条页宽参考线。页宽参考线在表单模板上显示为一条垂直虚线。此参考线根据计算机的默认打印机指明打印页的右边距所在的位置。

  13. 要向打印视图中添加分页符,请在想要新页面开始的位置单击,然后在“插入”菜单上单击“分页符”

    注意: 为表单模板上的水平的虚线显示分页符。预览表单模板时,如果您不会看到此虚线线条或任何其他指示分页符。若要查看的分页符对基于表单模板的打印窗体的影响,单击标准工具栏上的打印预览 按钮图像

返回页首

设计专用于 Word 的打印视图

如果您是理解 XML 技术高级的表单设计人员,您可用于添加打印视图 Word 向导创建打印表单数据直接从 Word 基于 Microsoft Office Word 打印视图。这使您能够充分利用打印在 Word 中可用的功能的区域。若要执行此操作,您必须对表单模板中的数据转换为适合从 Word 中打印的格式的现有 XSL 转换 (XSLT) 文件具有访问权限。当用户打印包含基于 Word 的打印视图子窗体时,该窗体中的数据将直接从打印在 Word 中。必须使用 Microsoft Office Word 2003 或Microsoft Office Word 2007创建 XSLT 文件。

注意: 若要了解有关创建 XSLT 文件的详细信息,请参阅向 Microsoft Office InfoPath 2003 软件开发工具包 (SDK)。SDK 包含一个名为 Word 向导,允许您使用 Word 2003 或 Word 2007 打印 InfoPath 表单数据在 InfoPath 中的工具。若要查找的 InfoPath 2003 SDK,请参阅另请参阅部分。

  1. 视图菜单上,单击管理视图

  2. “视图”任务窗格中的“操作”下,单击“添加 Word 打印视图”

  3. 按照“添加 Word 打印视图向导”中的说明进行操作,指定要用于基于 Word 的打印视图的 XSLT 文件。

  4. “视图”任务窗格的“选择视图”列表中,单击要为其指定基于 Word 的打印视图的视图,然后单击“视图属性”

  5. 单击“打印设置”选项卡。

  6. “选择一个打印该视图时使用的现有视图”列表中,单击基于 Word 的打印视图。

返回页首

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×