设计针对打印而进行优化的视图

注意:  我们希望能够尽快以你的语言为你提供最新的帮助内容。 本页面是自动翻译的,可能包含语法错误或不准确之处。我们的目的是使此内容能对你有所帮助。可以在本页面底部告诉我们此信息是否对你有帮助吗? 请在此处查看本文的 英文版本 以便参考。

您创建的 Microsoft Office InfoPath 表单模板用于打开和联机,填写 InfoPath 本身中或通过使用 Web 浏览器。但是,用户可能会选择打印为其个人记录或为了存档已完成表单的副本。因此,它是验证表单模板在打印时看上去可接受的好办法。例如,您可能想要确保您的表单模板中的控件适合打印的页的边距和打印的表单上的文本可读。

此外,您可以使用视图任务窗格创建表单模板的特殊版本 — 称为打印视图-旨在专为打印目的。

本文介绍如何设计表单模板的打印视图和创建适合打印的表单模板的其他方法。

本文内容

打印的表单模板和表单之间的区别

打印视图简介

设计基于现有视图打印视图

Word for 专门设计打印视图

打印的表单模板和表单之间的区别

您可以打印表单模板以获取常规有意义的控件和其他对象的打印页面上的显示方式或验证打印设置,如页眉或页脚。从设计模式打印的表单模板时,您可能会看到打印的表单模板,例如,如果用户打印基于表单模板的表单实际上不会出现的按钮上的特定项目。

当用户打印基于表单模板的表单时,InfoPath 将对表单进行调整,或删除不打印在上下文中意义的特定项目。例如,默认情况下重复表中显示的插入项目说明文本不会显示在打印的表单。两者均不检查将按钮控件、 列表框项或滚动箭头,因为这些项目丢失其含义打印页上。

返回页首

打印视图简介

虽然设计表单模板为了收集电子格式的表单数据,您可以创建打印视图中,这是专门用于打印的视图。如果您希望用户能够使用特定版式打印表单或仅打印窗体的特定部分,这很有用。

如果您的表单模板包含多个视图,您可以创建每个视图的打印视图。或者,您可以指定应用于表单模板中的所有视图的单个打印视图。例如,如果您的表单模板包含三个不同的视图,您可能会创建合并到一个打印页面的关键信息从每个视图的打印视图。

若要创建并打印视图与现有视图,可以在视图任务窗格中使用创建视图的打印版本链接。当您单击此链接时,InfoPath 执行下列操作:

  • 创建新的空白视图中打印版本名称,其中名称是打印视图所基于的视图的名称。

  • 将与它所基于的视图的打印视图。在查看属性对话框中,在打印设置选项卡上录制中的此关联。例如,假设您创建了一个打印视图,基于表单模板中的审批视图。当用户单击审批视图中的打印按钮时,InfoPath 将打印出现在打印版本审批视图中的任何内容。

创建打印视图后,您可以设计它以反映您希望打印时显示的窗体的方式。这通常涉及复制并粘贴表单模板中的其他视图中的控件,到打印视图。如有必要,您可以替换为打印视图中的其他控件的某些控件。例如,您可能会替换标准列表框中,默认情况下显示条目下拉列表框中,默认情况下,隐藏列表框项。通过执行此操作,所有条目将显示在打印的表单。在查看属性对话框中,如页眉、 页脚和页边距,您还可以指定自定义打印选项的打印视图。

返回页首

设计基于现有视图打印视图

默认情况下,用户打印的窗体没有与之关联的特定打印视图时被打印在用户计算机当前显示的视图。如果您创建一个打印视图,InfoPath 将打印该视图,而不是当前视图。为打印视图,您可以指定任何现有的视图。以下过程介绍如何为基础的现有视图用于打印的视图。

  1. 视图菜单上,单击管理视图

  2. 选择视图列表中,在视图任务窗格中,单击您要为其创建打印视图的视图。

  3. 操作下单击创建视图的打印版本

  4. 创建打印版本对话框中,为打印视图中,键入一个名称,然后单击确定

  5. 视图任务窗格中,双击打印视图。

  6. 查看属性对话框中,选择打印设置页面设置选项卡的所需的选项,然后单击确定。例如,您可能指定默认页边距设置为打印视图,或添加页眉或页脚。

  7. 若要切换到原始视图,在视图任务窗格中,单击视图的名称,在选择视图列表。

  8. 若要选择在视图中的所有内容,请按 CTRL + A。

  9. 若要将所选内容复制到剪贴板,请按 CTRL + C。

  10. 若要切换到打印视图,在视图任务窗格中,单击视图的名称,在选择视图列表。

  11. 若要粘贴到打印视图从原始视图所选内容,请按 CTRL + V。

  12. 删除所有控件或布局元素,您不需要或添加其他控件。

    提示: 若要快速确定控件和其他设计元素将显示在打印页面上,可以通过单击视图菜单上的页宽参考线显示表单模板的右侧页宽参考线。为表单模板上垂直虚线显示页宽参考线。行指示打印页的右边距所在的位置,根据您的计算机的默认打印机。

  13. 若要打印的视图中添加分页符,单击要开始,新页的位置,然后单击插入菜单上的分页符

    注意: 为表单模板上的水平的虚线显示分页符。预览表单模板时,如果您不会看到此虚线线条或任何其他指示分页符。若要查看的分页符对基于表单模板的打印窗体的影响,单击标准工具栏上的打印预览 按钮图像

返回页首

Word for 专门设计打印视图

如果您是理解 XML 技术高级的表单设计人员,您可用于添加打印视图 Word 向导创建打印表单数据直接从 Word 基于 Microsoft Office Word 打印视图。这使您能够充分利用打印在 Word 中可用的功能的区域。若要执行此操作,您必须对表单模板中的数据转换为适合从 Word 中打印的格式的现有 XSL 转换 (XSLT) 文件具有访问权限。当用户打印包含基于 Word 的打印视图子窗体时,该窗体中的数据将直接从打印在 Word 中。必须使用 Microsoft Office Word 2003 或Microsoft Office Word 2007创建 XSLT 文件。

注意: 若要了解有关创建 XSLT 文件的详细信息,请参阅向 Microsoft Office InfoPath 2003 软件开发工具包 (SDK)。SDK 包含一个名为 Word 向导,允许您使用 Word 2003 或 Word 2007 打印 InfoPath 表单数据在 InfoPath 中的工具。若要查找 InfoPath 2003 SDK,请参阅另请参阅部分。

  1. 视图菜单上,单击管理视图

  2. 操作,在视图任务窗格中,单击添加 Word 打印视图

  3. 按照说明添加打印视图中的 Word 向导来指定您想要对基于 Word 的打印视图使用 XSLT 文件。

  4. 选择视图列表中,在视图任务窗格中,单击您要为其指定基于 Word 的打印视图的视图,然后单击查看属性

  5. 单击打印设置选项卡。

  6. 选择要打印此视图时,使用现有视图列表中,单击基于 Word 的打印视图。

返回页首

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×