设计基于 Microsoft SQL Server 数据库的表单模板

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

您可以设计可使用 Microsoft SQL Server 数据库来查询数据或者查询并提交数据的表单模板。

本文内容

概述

兼容性的注意事项

开始之前

设计表单模板

配置提交选项

概述

表单可以包含一个主要数据连接,称为主数据连接,还可以选择性地包含一个或多个辅助数据连接。根据表单的用途,数据连接可以从外部数据源(例如 Microsoft SQL Server 数据库或 Web 服务)查询表单数据或将表单数据提交到外部数据源。

设计基于数据库的表单模板,Microsoft Office InfoPath 将使用包含查询字段和数据字段和查询数据连接,作为表单模板的主数据连接的组创建主数据源 。这些字段和组对应于该数据库中的表中存储数据的方式。查询字段包含由用户以将查询结果限制为查询字段中的数据相匹配的记录输入的数据。当基于该表单模板的表单中使用主数据连接时,InfoPath 将通过使用查询字段中的数据创建的查询。InfoPath 发送通过查询数据连接查询。数据库返回查询的结果返回到通过查询数据连接窗体。查询的结果放入数据字段,可以通过控件绑定到这些字段进行编辑。

由于查询和数据域的数据结构必须与在数据库中存储数据的方式相匹配,因此您不能修改主数据源中的这些域或组。只能向主数据域中的根组添加域或组。在“请参阅”节中可以找到指向有关数据源的详细信息的链接。

窗体可以将数据提交到数据库中窗体的主数据连接通过如果满足下列要求,表单基于表单模板和数据库︰

  • 表单模板不在浏览器兼容的表单模板   如果您要设计一个浏览器兼容的表单模板,InfoPath 不会在主数据连接创建提交数据连接。若要允许用户提交基于浏览器兼容的表单模板的窗体中的数据,请使用配合该数据库的 Web 服务。

  • 左的表的每对主数据源中的相关表中包含一个主键   至少一个相关表的每对关系必须包括从左表的主键。

  • 无主数据源中的较大的二进制数据类型的窗体存储的数据字段   如果查询包含可在其中存储较大的二进制数据类型,如图片、 图像、 OLE 对象、 文件附件,Office Access 备注数据类型或 SQL 文本数据类型的字段,InfoPath 将禁用提交数据连接。

InfoPath 启用提交数据连接之后,将允许用户将主数据源的数据域中的数据提交到数据库。如果 InfoPath 启用了提交数据连接,您就可以自定义基于该表单模板的表单的提交选项。

返回页首

兼容性考虑

设计基于数据库的表单模板时,您可以选择设计浏览器兼容的表单模板。InfoPath 将创建一个查询数据连接,作为与浏览器兼容的表单模板中的主数据连接。但是,不能将与浏览器兼容的表单模板配置为允许用户向数据库提交数据。因此,如果您要设计基于 SQL Server 数据库的表单模板,并且希望用户通过主数据连接向数据库提交他们的表单数据,就不能使该表单模板与浏览器兼容。

返回页首

开始之前

要设计基于 SQL Server 数据库的表单模板,您需要从数据库管理员那里了解以下信息:

  • 包含您要将表单模板连接到的数据库的服务器的名称。

  • 您将用于该表单模板的数据库的名称。

  • 数据库所需的身份验证。数据库可以使用 Microsoft Windows 身份验证或 SQL Server 身份验证来确定用户访问数据库的方式。

  • 包含您要发送到表单或将从表单接收的数据的表的名称。这是主表。如果您打算在数据库中使用多个表,则需要那些子表的名称。您还需要子表中与主表中的域具有关系的域的名称。

返回页首

设计表单模板

要设计具有查询数据连接的表单模板,需要执行下列操作:

  1. 创建表单模板    创建基于数据库的表单模板时,InfoPath 会创建一个查询数据连接,作为表单模板和数据库之间的主数据连接。该过程会自动创建表单模板的主数据源。

  2. 添加一个或多个控件以显示查询结果   若要允许用户查看和编辑主数据源中的字段中的数据,在打开的表单时,可以向表单模板中添加控件并将该控件绑定到主数据源中的字段。

步骤 1:创建表单模板

  1. 文件菜单上,单击设计表单模板

  2. “设计表单模板”对话框中的“设计新”下,单击“表单模板”

  3. “基于”列表中,单击“数据库”

  4. 如果您要设计与浏览器兼容的表单模板,请选中“仅启用浏览器兼容性功能”复选框。

    注意: “数据连接向导”将不会在与浏览器兼容的表单模板中启用提交数据连接。要允许用户向数据库提交基于与浏览器兼容的表单模板的表单中的数据,请向处理该数据库的 Web 服务添加一个辅助数据连接。在请参阅节中可以找到指向有关辅助数据连接的详细信息的链接。

  5. 单击“确定”

  6. 在“数据连接向导”中,单击“选择数据库”

  7. “选择数据源”对话框中,单击“新建源”

  8. “您想要连接哪种数据源”列表下,单击“Microsoft SQL Server”,然后单击“下一步”

  9. “服务器名称”框中键入 SQL Server 数据库所在的服务器的名称。

  10. “登录凭据”下,执行下列操作之一:

    • 如果数据库根据 Microsoft Windows 网络中使用的凭据来确定具有访问权限的用户,请单击“使用 Windows 身份验证”

    • 如果数据库根据您从数据库管理员那里获得的指定用户名和密码来确定具有访问权限的用户,请单击“使用下列用户名和密码”,然后在“用户名”“密码”框中键入您的用户名和密码。

  11. 单击“下一步”

  12. “选择数据库”列表中,单击想要使用的数据库的名称,选中“连接到指定表格”复选框,单击主表的名称,然后单击“下一步”

  13. 在向导的下一页上,在“文件名”框中键入存储数据连接信息的文件的名称,然后单击“完成”以保存这些设置。

    如果您计划在查询数据连接中使用其他表,可以在向导的这一页中添加它们。

    如何?

    1. 单击“添加表”

    2. 添加表或查询对话框中单击子表的名称,然后单击下一步。InfoPath 尝试通过匹配两个表中的字段名称设置关系。如果不想使用建议的关系,选择该关系,,然后单击删除关系。若要添加的关系,请单击添加关系。在添加关系对话框中,单击相应的列中,在每个相关字段的名称,然后单击确定

    3. 单击“完成”

    4. 要添加其他子表,请重复这些步骤。

  14. 单击“下一步”

  15. 在向导的最后一页上,键入主数据连接的名称。此名称将显示在数据源任务窗格中的数据源列表中。

  16. 如果表单模板满足的要求,在概述部分中,此向导页将指示 InfoPath 启用主数据连接中的提交数据连接。若要更改提交数据连接的名称,请相应的框中键入新名称。如果您希望用户提交到另一种其表单数据提交您将在以后添加到表单模板的数据连接,请单击以清除为此连接启用提交复选框。

    注意: 如果您的表单模板不满足的要求,在概述部分中,InfoPath 将禁用提交数据连接,且输入提交连接的名称框和启用此连接的提交复选框不可用 (被禁用)。如果 InfoPath 禁用提交数据连接,您的表单模板的主数据连接都必须只查询数据连接。

步骤 2︰ 添加一个或多个控件以显示查询结果

  1. 如果看不到“控件”任务窗格,请单击“插入”菜单上的“其他控件”,或按 Alt+I、C。

  2. 将控件拖动到您的表单模板上。

  3. 控件绑定对话框中,选择您想要将控件绑定到的域的组。

返回页首

配置提交选项

如果表单模板和数据连接向导中的所选表满足的要求,在概述部分中,InfoPath 将配置表单模板以提交通过其主数据连接的数据。如果您选择使用该提交数据连接,InfoPath 配置表单模板,以便用户可以其表单数据提交到数据库,并将提交按钮添加到标准工具栏和到文件菜单上的提交命令,当用户填写表单。InfoPath 还会配置表单模板,以便当用户提交表单,窗体保持打开状态,并向用户指示是否已成功提交窗体显示一条消息。在用户提交表单后,您可以更改的文本上的提交按钮和行为。

  1. 工具菜单上,单击提交选项

    1. 若要更改的提交按钮出现在标准工具栏和用户填写表单时,将显示在文件菜单的提交命令的名称,请在提交选项对话框中的标题框中键入新名称。

      提示: 如果您想要将键盘快捷键分配给此按钮和命令,请键入与号 (&) 之前要用作键盘快捷方式的字符。例如,要分配 ALT + B 为提交按钮和命令的键盘快捷方式,请键入& 交

  2. 如果您不希望用户在填写窗体时在标准工具栏上使用提交命令或提交按钮,,清除显示提交菜单项和提交工具栏按钮复选框。

    1. 默认情况下,用户提交表单之后, InfoPath 使窗体保持打开状态,显示一条消息,指示表单已成功提交。若要更改此默认行为,请单击高级,然后执行下列操作之一︰

      • 若要关闭该窗体或创建新的空白表单用户提交完成的表单后,单击之后提交列表中所需的选项。

      • 以创建自定义消息说明已成功提交表单,选择使用自定义消息复选框,然后在成功失败框中键入您的邮件。

        提示: 使用失败框中一条消息告诉用户如何操作如果他们无法提交表单。例如,您可以建议用户保存其窗体和联系某人进一步的说明。

      • 如果您不希望在用户提交表单后显示一条消息,请清除显示成功或失败的邮件复选框。

返回页首

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×