设计基于 Microsoft Access 数据库的表单模板

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

您可以设计可与 Microsoft Office Access 数据库一起工作的 Microsoft Office InfoPath 表单模板,来查询数据或者查询并提交数据。您可以基于 Microsoft Office Access 2007 数据库(.accdb 格式)或用早期版本保存的 Access 数据库(.mdb 格式)设计此表单模板。

本文内容

概述

兼容性的注意事项

开始之前

设计表单模板

配置提交选项

概述

表单可以有一个主要数据连接,该连接可以有一个或多个辅助数据连接。您可以使用主要数据连接查询 Access 数据库中的表单数据,或者将表单数据提交到 Access 数据库。也可以使用辅助数据连接查询外部数据源中的数据,或者将数据提交到外部数据源,不过也有例外。例如,您可以使用到 Access 数据库的辅助数据连接从而仅查询该数据库。您不能向表单添加辅助数据连接以便将表单数据目录提交到 Access 数据库。

设计基于 Access 数据库的表单模板,InfoPath 使用包含查询字段和数据字段的组创建主data source并创建查询数据连接,作为表单模板的主数据连接。这些字段和组对应于该数据库中的表中存储数据的方式。

查询字段包含要将查询结果限制为查询字段中的数据相匹配的记录的用户表单中输入的数据。当窗体基于该表单模板中使用主数据连接时,InfoPath 将通过使用查询字段中的数据创建的查询。InfoPath 发送通过数据连接查询。数据库返回到表单的数据连接通过查询的结果。查询的结果放入数据字段,可以通过在窗体控件绑定到的那些数据字段进行编辑。

由于查询和数据域的数据结构必须与在数据库中存储数据的方式相匹配,因此您不能修改主数据源中的这些域或组。只能向主数据域中的根组添加域或组。在“请参阅”节中可以找到指向有关数据源的详细信息的链接。

窗体可以将数据提交到数据库中窗体的主数据连接通过如果满足下列要求,表单基于表单模板和数据库︰

  • 表单模板不在浏览器兼容的表单模板   如果您要设计一个浏览器兼容的表单模板,InfoPath 不会在主数据连接创建提交数据连接。若要允许用户提交基于浏览器兼容的表单模板的窗体中的数据,请使用配合该数据库的 Web 服务。

  • 左的表的每对主数据源中的相关表中包含一个主键   至少一个相关表的每对关系必须包括从左表的主键。

  • 无主数据源中的较大的二进制数据类型的窗体存储的数据字段   如果查询包含可在其中存储较大的二进制数据类型,如图片、 图像、 OLE 对象、 文件附件,Office Access 备注数据类型或 SQL 文本数据类型的字段,InfoPath 将禁用提交数据连接。

如果 InfoPath 启用了提交数据连接,则用户就可以将主数据源的数据域中存储的数据提交到数据库中。您可以对基于此表单模板的表单的提交选项进行自定义。

返回页首

兼容性考虑

您无法设计基于 Access 数据库且与浏览器兼容的表单模板。

返回页首

开始之前

要想成功地设计基于 Access 数据库的表单模板,您需要以下有关 Access 数据库的信息:

  • 数据库的名称和位置。

    注意: 确保数据库位于用户可访问的网络位置。

  • 如果表单模板允许用户将表单提交到数据库,则需要知道接收所提交数据的表的名称。配置提交数据连接时您将使用此表作为主表。

  • 如果表单模板仅查询数据库,则需要知道提供发送到数据库的查询结果的表的名称。配置查询连接时您将使用此表作为主表。

  • 主表可能需要从数据的任何其他表的名称。在大多数情况下,在数据库中已建立了表关系。如果您需要手动建立主表与另一个表之间的关系,您需要两个表的相关的字段名称。

返回页首

设计表单模板

要设计具有查询数据连接的表单模板,您需要首先创建表单模板。创建基于数据库的表单模板时,InfoPath 会创建一个查询数据连接作为表单模板和数据库之间的主要数据连接。此过程自动创建表单模板的主数据源。

创建表单模板后,则需要向该表单模板添加一个控件,然后将该控件绑定到主数据源中的一个域。这样,用户就可以在表单中查看查询结果。

步骤 1:创建表单模板

  1. 文件菜单上,单击设计表单模板

  2. “设计表单模板”对话框中的“设计新的”下面,单击“表单模板”

  3. “基于”列表中,单击“数据库”,然后单击“确定”

    “数据连接向导”随即启动

  4. 在“数据连接向导”的第一页上单击“选择数据库”

  5. “选择数据源”对话框中,浏览以找到数据库所在位置。

    注意: 如果您的数据库存储在网络位置中,浏览到该位置的通用命名约定 (UNC) 路径。不要浏览到通过映射的网络驱动器的网络位置。如果您使用的映射的网络驱动器,基于该表单模板创建窗体的用户将搜索从映射的网络驱动器数据库。如果用户没有映射的网络驱动器,窗体将找不到该数据库。

  6. 单击数据库的名称,然后单击“打开”

  7. “选择表格”对话框中,单击要使用的主表或查询,然后单击“确定”

  8. 在向导的下一页上,选中“显示表列”复选框。

  9. 默认情况下,表中的所有域都会添加到表单模板的主数据源中。清除您不想在主数据源中包含的域所对应的复选框。

    添加要在查询数据连接中使用的其他表或查询。

    如何?

    1. 单击“添加表”

    2. 添加表或查询对话框中单击子表的名称,然后单击下一步。InfoPath 尝试通过匹配两个表中的字段名称设置关系。如果不想使用建议的关系,选择该关系,,然后单击删除关系。若要添加的关系,请单击添加关系。在添加关系对话框中,单击相应的列中,在每个相关字段的名称,然后单击确定

    3. 单击“完成”

    4. 要添加其他子表,请重复这些步骤。

  10. 单击“下一步”

  11. 在向导的最后一页上,键入主数据连接的名称。该名称将显示在“数据源”任务窗格的“数据源”列表中。

  12. 如果您的表单模板满足的要求,在概述部分中,向导在此页面上的摘要部分将指示 InfoPath 启用主数据连接中的提交数据连接。

  13. 要更改提交数据连接的名称,请在相应的框中键入新名称。

  14. 要允许用户通过您以后添加到表单模板的其他提交数据连接提交表单数据,请清除“为该连接启用提交”复选框。

    注意: 如果表单模板不满足的要求,在概述部分中,InfoPath 将禁用提交数据连接,然后输入提交连接的名称框和启用此连接的提交复选框不可用。如果 InfoPath 禁用提交数据连接,您的表单模板的主数据连接将包含仅查询数据连接。

步骤 2:将控件绑定到域

  1. 如果看不到“控件”任务窗格,请单击“插入”菜单上的“其他控件”,或按 Alt+I、C。

  2. 将控件拖动到您的表单模板上。

  3. 控件绑定对话框中,选择您想要将控件绑定到的字段。

返回页首

配置提交选项

如果表单模板和数据连接向导中的所选表满足的要求,在概述部分中,InfoPath 将配置表单模板以将数据提交使用其主数据连接。

如果您选择使用此提交数据连接,InfoPath 会对表单模板进行配置,使用户可以将表单数据提交到数据库,并在“常用”工具栏中添加一个“提交”按钮,在表单的“文件”菜单中添加一个“提交”命令。InfoPath 还会将表单模板配置为在用户提交表单时使表单保持打开,并显示一条消息,指示表单提交是否成功。您可以更改“提交”按钮上显示的文本,还可以更改用户提交表单后表单的行为。

  1. 工具菜单上,单击提交选项

    1. 若要更改的提交按钮出现在标准工具栏和用户填写表单时,将显示在文件菜单的提交命令的名称,请在提交选项对话框中的标题框中键入新名称。

      提示: 如果您想要将键盘快捷键分配给此按钮和命令,请键入与号 (&) 之前要用作键盘快捷方式的字符。例如,要分配 ALT + B 为提交按钮和命令的键盘快捷方式,请键入& 交

  2. 如果您不希望用户在填写窗体时在标准工具栏上使用提交命令或提交按钮,,清除显示提交菜单项和提交工具栏按钮复选框。

    1. 默认情况下,用户提交表单之后, InfoPath 使窗体保持打开状态,显示一条消息,指示表单已成功提交。若要更改此默认行为,请单击高级,然后执行下列操作之一︰

      • 若要关闭该窗体或创建新的空白表单用户提交完成的表单后,单击之后提交列表中所需的选项。

      • 以创建自定义消息说明已成功提交表单,选择使用自定义消息复选框,然后在成功失败框中键入您的邮件。

        提示: 使用失败框中一条消息告诉用户如何操作如果他们无法提交表单。例如,您可以建议用户保存其窗体和联系某人进一步的说明。

      • 如果您不希望在用户提交表单后显示一条消息,请清除显示成功或失败的邮件复选框。

返回页首

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×