设计基于 Microsoft Access 数据库的表单模板

注意:  我们希望能够尽快以你的语言为你提供最新的帮助内容。 本页面是自动翻译的,可能包含语法错误或不准确之处。我们的目的是使此内容能对你有所帮助。可以在本页面底部告诉我们此信息是否对你有帮助吗? 请在此处查看本文的 英文版本 以便参考。

您可以设计适用于 Microsoft Office Access 数据库以查询数据,或要查询和提交数据的 Microsoft Office InfoPath 表单模板。您可以设计基于Microsoft Office Access 2007 (.accdb 格式) 数据库或 Access 数据库 (.mdb 格式) 的早期版本中保存此表单模板。

本文内容

概述

兼容性的注意事项

开始之前

设计表单模板

配置提交选项

概述

窗体可以有一个主数据连接,称为主数据连接,并且该连接可以具有一个或多个辅助数据连接。您可以使用主数据连接查询或提交表单数据发送到 Access 数据库。您可以使用辅助数据连接查询并将数据提交到外部数据源,有一些例外。例如,您可以使用辅助数据连接到 Access 数据库,以便它仅查询数据库。您不能向窗体提交表单数据目录对 Access 数据库中添加辅助数据连接。

设计基于 Access 数据库的表单模板,InfoPath 使用包含查询字段和数据字段的组创建主数据源并创建查询数据连接,作为表单模板的主数据连接。这些字段和组对应于该数据库中的表中存储数据的方式。

查询字段包含要将查询结果限制为查询字段中的数据相匹配的记录的用户表单中输入的数据。当窗体基于该表单模板中使用主数据连接时,InfoPath 将通过使用查询字段中的数据创建的查询。InfoPath 发送通过数据连接查询。数据库返回到表单的数据连接通过查询的结果。查询的结果放入数据字段,可以通过在窗体控件绑定到的那些数据字段进行编辑。

由于查询和数据字段的数据结构必须匹配的数据库中存储数据的方式,不能修改这些字段或主数据源中的组。仅将域或组添加到主数据源中的根组。在另请参阅部分找到有关数据源的详细信息的链接。

窗体可以将数据提交到数据库中窗体的主数据连接通过如果满足下列要求,表单基于表单模板和数据库:

  • 表单模板不在浏览器兼容的表单模板   如果您要设计一个浏览器兼容的表单模板,InfoPath 不会在主数据连接创建提交数据连接。若要允许用户提交基于浏览器兼容的表单模板的窗体中的数据,请使用配合该数据库的 Web 服务。

  • 左的表的每对主数据源中的相关表中包含一个主键   至少一个相关表的每对关系必须包括从左表的主键。

  • 无主数据源中的较大的二进制数据类型的窗体存储的数据字段   如果查询包含可在其中存储较大的二进制数据类型,如图片、 图像、 OLE 对象、 文件附件,Office Access 备注数据类型或 SQL 文本数据类型的字段,InfoPath 将禁用提交数据连接。

InfoPath 启用提交数据连接,允许用户提交到数据库的主数据源中的数据字段中存储的数据。您可以自定义基于该表单模板的窗体的提交选项。

返回页首

兼容性的注意事项

不能设计基于 Access 数据库的浏览器兼容的表单模板。

返回页首

准备工作

您可以成功设计基于 Access 数据库的表单模板之前,您需要 Access 数据库中的以下信息:

  • 名称和数据库的位置。

    注意: 确保您的数据库在您的用户可以访问网络位置。

  • 将收到的表名称提交数据,如果您的表单模板允许用户将表单提交到数据库。当您配置提交数据连接时,您将使用此表的主表。

  • 如果您的表单模板将仅查询数据库提供发送到数据库,查询的结果的表中的名称。当您配置查询数据连接时,您将使用此表的主表。

  • 主表可能需要从数据的任何其他表的名称。在大多数情况下,在数据库中已建立了表关系。如果您需要手动建立主表与另一个表之间的关系,您需要两个表的相关的字段名称。

返回页首

设计表单模板

若要设计表单模板与查询数据连接,首先需要创建的表单模板。当您创建基于数据库的表单模板时,InfoPath 将创建查询的数据连接,作为表单模板和数据库之间的主数据连接。此过程中自动创建表单模板的主数据源。

创建表单模板后,您需要添加到表单模板的控件,然后将该控件绑定到主数据源中的字段。这允许您查看的窗体中的查询结果的用户。

步骤 1: 创建表单模板

  1. 文件菜单上,单击设计表单模板

  2. 设计表单模板对话框中,在设计新下单击表单模板

  3. 基于列表中,单击数据库,然后单击确定

    启动数据连接向导

  4. 在数据连接向导的第一页上,单击选择数据库

  5. 选择数据源对话框中,浏览到您的数据库的位置。

    注意: 如果您的数据库存储在网络位置中,浏览到该位置的通用命名约定 (UNC) 路径。不要浏览到通过映射的网络驱动器的网络位置。如果您使用的映射的网络驱动器,基于该表单模板创建窗体的用户将搜索从映射的网络驱动器数据库。如果用户没有映射的网络驱动器,窗体将找不到该数据库。

  6. 单击您的数据库的名称,然后单击打开

  7. 选择表对话框中的主表或查询,您想要使用,,请单击,然后单击确定

  8. 在向导的下一页上,选择显示表中的列复选框。

  9. 默认情况下,所有的表中的字段将添加到主数据源的表单模板。清除不希望包括在主数据源中的字段所对应的复选框。

    添加任何其他表或查询所需用于查询数据连接。

    操作方法

    1. 单击添加表

    2. 添加表或查询对话框中,单击子表的名称,然后单击下一步。InfoPath 尝试通过匹配两个表中的字段名称设置关系。如果不想使用建议的关系,选择该关系,,然后单击删除关系。若要添加的关系,请单击添加关系。在添加关系对话框中,单击相应的列中,在每个相关字段的名称,然后单击确定

    3. 单击“完成”。

    4. 若要添加其他子表,请重复这些步骤。

  10. 单击“下一步”

  11. 在向导的最后一页上,键入主数据连接的名称。此名称将显示在数据源任务窗格中的数据源列表中。

  12. 如果您的表单模板满足的要求,在概述部分中,向导在此页面上的摘要部分将指示 InfoPath 启用主数据连接中的提交数据连接。

  13. 若要更改提交数据连接的名称,请相应的框中键入新名称。

  14. 若要允许用户提交到另一种其表单数据提交您将在以后添加到表单模板的数据连接,清除为此连接启用提交复选框。

    注意: 如果您的表单模板不满足的要求,在概述部分中,InfoPath 将禁用提交数据连接,并输入提交连接的名称框和启用此连接的提交复选框不可用。如果 InfoPath 禁用提交数据连接,您的表单模板的主数据连接将包含仅查询数据连接。

步骤 2: 将控件绑定到的字段

  1. 如果看不到“控件”任务窗格,请单击“插入”菜单上的“其他控件”,或按 Alt+I、C。

  2. 控件拖到表单模板。

  3. 控件绑定对话框中,选择您想要将控件绑定到的字段。

返回页首

配置提交选项

如果表单模板和数据连接向导中的所选表满足的要求,在概述部分中,InfoPath 将配置表单模板以将数据提交使用其主数据连接。

如果您选择使用此提交数据连接,InfoPath 配置表单模板,以便用户可以提交到数据库,其表单数据,并且还将提交按钮添加到标准工具栏和到文件的提交命令窗体上的菜单。InfoPath 还会配置表单模板,以便当用户提交表单,窗体保持打开状态,并显示一条消息,指示是否已成功提交表单。您可以更改提交按钮显示的文本,也在用户提交后更改窗体的行为。

  1. 工具菜单上,单击提交选项

    1. 若要更改的提交按钮出现在标准工具栏和用户填写表单时,将显示在文件菜单的提交命令的名称,可在提交的标题框中键入新名称选项对话框。

      提示: 如果您想要将键盘快捷键分配给此按钮和命令,请键入与号 (&) 之前要用作键盘快捷方式的字符。例如,要分配 ALT + B 为提交按钮和命令的键盘快捷方式,请键入& 交

  2. 如果您不希望用户在填写窗体时在标准工具栏上使用提交命令或提交按钮,,清除显示提交菜单项和提交工具栏按钮复选框。

    1. 默认情况下,用户提交表单之后, InfoPath 使窗体保持打开状态,显示一条消息,指示表单已成功提交。若要更改此默认行为,请单击高级,然后执行下列操作之一:

      • 若要关闭该窗体或创建新的空白表单用户提交完成的表单后,单击之后提交列表中所需的选项。

      • 以创建自定义消息说明已成功提交表单,选择使用自定义消息复选框,然后在成功失败框中键入您的邮件。

        提示: 使用失败框中一条消息告诉用户如何操作如果他们无法提交表单。例如,您可以建议用户保存其窗体和联系某人进一步的说明。

      • 如果您不希望在用户提交表单后显示一条消息,请清除显示成功或失败的邮件复选框。

返回页首

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×