设计只读视图

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

在 Microsoft Office InfoPath,您可以创建相同的表单模板的不同视图。视图是一种方法来显示表单模板中的数据。在填写基于表单模板的表单,用户可以切换视图可供选择的表单中显示的数据量。例如,在状态报告表单模板中,您可能设计的详细信息视图除了摘要视图。然后,用户可以选择他们想要查看,具体取决于他们需要什么类型的信息的视图。

本文说明如何设计用户无法编辑的视图,以及在用户单击读写视图中的按钮时如何使用规则自动切换到表单的只读视图。

您要做什么?

设计只读视图

插入一个用于在读写视图和只读视图之间进行切换的按钮

插入一个用于在用户提交表单后切换到只读视图的按钮

设计只读视图

如果想汇总用户的表单数据,并且不希望用户无意中更改该数据,则可以使用只读视图。例如,假设在用户将表单提交到 Web 服务后,想帮助阻止用户更改表单中的数据。在用户单击表单上的“提交”按钮时,可以配置表单模板从数据读写视图切换到只读视图。这样,用户可以查看他们已提交的数据,但可以帮助阻止他们修改数据。

  1. 视图菜单上,单击管理视图

  2. “操作”下面,单击“添加新视图”

  3. “添加视图”对话框中,为视图键入一个名称,然后单击“确定”

  4. 通过向视图添加布局表和控件来设计视图。

    提示: 如果要基于某个现有视图设计新视图,请打开该现有视图,按 Ctrl+A 选择该视图中的所有内容,然后按 Ctrl+C 将所选内容复制到剪贴板。在“视图”任务窗格中,切换到新视图,然后按 Ctrl+V 在新视图中粘贴所选内容。此时,您可以从新视图中删除任何不需要的控件或版式元素。

  5. 视图任务窗格中,单击查看属性

  6. 单击“常规”选项卡。

  7. “视图设置”下面,选中“只读”复选框,然后单击“确定”

  8. 若要测试视图是否为只读视图,请单击“常用”工具栏上的“预览”

  9. 在“预览”窗口中,确保无法在表单中输入数据。

  10. 若要返回到设计模式,请单击“常用”工具栏上的“关闭预览”

返回页首

插入一个用于在读写视图和只读视图之间进行切换的按钮

经常会想让视图使用一些按钮和规则,这样就可以在表单模板中自动执行某些任务,以对填写表单的人员所进行的活动或操作做出响应。 例如,可以在表单模板上插入一个按钮,然后创建一个在单击该按钮时切换视图的规则。在下面的示例中,表单设计人员在“规则”对话框中创建了一个规则,该规则可以将视图切换到只读汇总视图。每当用户单击表单中的按钮时,便会运行此规则。

“规则”对话框的组成部分

插入一个用于在视图之间进行切换的按钮

  1. 视图菜单上,单击管理视图

  2. “选择视图”下面,单击要向其添加按钮的读写视图。

  3. 如果看不到“控件”任务窗格,请单击“插入”菜单上的“其他控件”,或按 Alt+I、C。

  4. 在表单模板上,将光标放在要插入按钮的地方。

  5. “插入控件”下面,单击“按钮”

  6. 在表单模板上,双击刚才插入的按钮。

  7. 单击“常规”选项卡。

  8. “操作”列表中,单击“规则和自定义代码”

  9. “标签”框中,键入要出现在按钮上的文本。

  10. 单击“规则”

  11. “规则”对话框中,单击“添加”

  12. “名称”框中,为规则键入一个名称。

  13. 单击“添加操作”

  14. “操作”列表中,单击“切换视图”

  15. “视图”列表中,单击要切换到的视图,然后单击“确定”

  16. 单击“确定”关闭所有打开的对话框。

  17. 要测试所做的更改,请单击“常用”工具栏上的“预览”,或者按 Ctrl+Shift+B。

  18. 在“预览”窗口中,单击该按钮。

    此时应会打开在步骤 15 中指定的视图。

  19. 若要返回到设计模式,请单击“常用”工具栏上的“关闭预览”

  20. 若要向只读视图中添加另一个按钮和规则,以便用户可以切换回读写视图,请打开此只读视图,然后重复步骤 3 到 19。

返回页首

插入一个用于在用户提交表单后切换到只读视图的按钮

以下过程描述如何向表单模板中添加一个按钮以显示提交数据的只读视图。如果想允许用户从默认视图切换到表单数据的只读汇总视图,可以在状态报告表单中执行此操作。

注意: 只有表单模板包括用于提交表单数据的现有数据连接,此过程才适用。如果尚未配置用于提交数据的连接,则在完成此过程之前必须先进行配置,否则以下步骤将不适用。请在“请参阅”部分中查找有关数据连接的详细信息的链接。

  1. 视图菜单上,单击管理视图

  2. “选择视图”下面,单击想要包含“提交”按钮的视图。

  3. 如果看不到“控件”任务窗格,请单击“插入”菜单上的“其他控件”,或按 Alt+I、C。

  4. 在表单模板上,将光标放在要插入按钮的地方。

  5. “插入控件”下面,单击“按钮”

  6. 在表单模板上,双击刚才插入的按钮。

  7. 单击“常规”选项卡。

  8. “操作”列表中,单击“提交”

  9. 如果想让“提交”以外的其他文本显示为按钮标签,请在“标签”框中键入所需的文本。

  10. 单击“提交选项”

  11. “提交选项”对话框中,确保选中“允许用户提交此表单”复选框。

  12. 单击“使用规则执行自定义操作”,然后单击“规则”

  13. “用于提交表单的规则”对话框中,单击“添加”

  14. “名称”框中,为规则键入一个名称,然后单击“添加操作”

  15. “操作”列表中,单击“切换视图”

  16. “视图”列表中,单击要切换到的只读视图,然后单击“确定”

  17. 单击“确定”以关闭所有打开的对话框。

  18. 要测试所做的更改,请单击“常用”工具栏上的“预览”,或者按 Ctrl+Shift+B。

  19. 在“预览”窗口中,单击用于提交表单的按钮。

    此时应会打开只读视图。

  20. 若要返回到设计模式,请单击“常用”工具栏上的“关闭预览”

返回页首

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×