设置表单模板的所需的安全级别

注意:  我们希望能够尽快以你的语言为你提供最新的帮助内容。 本页面是自动翻译的,可能包含语法错误或不准确之处。我们的目的是使此内容能对你有所帮助。可以在本页面底部告诉我们此信息是否对你有帮助吗? 请在此处查看本文的 英文版本 以便参考。

设计表单模板时,Microsoft Office InfoPath 自动选择适当的安全级别的用户填写基于表单模板的窗体时所需的功能。此设置支持的最小信任所需的窗体级别。例如,受限的安全级别限制用户的计算机上的其他域和文件上的 access 数据和设置窗体的能力。您可以覆盖默认设置,并且设计表单模板时手动选择不同的安全级别。在另请参阅部分中查找有关 InfoPath 表单模板的安全级别的详细信息。

默认情况下,所有新的空白表单模板,除托管代码、 使用受限的安全级别。向表单模板添加某些功能时,将安全级别自动引发至域级别。

注意: 要添加或编辑托管的代码,必须在计算机上安装Microsoft Visual Studio Tools for Applications (VSTA) 。安装 VSTA 之前,必须安装 Microsoft.NET Framework 2.0 和 Microsoft Core XML Services 6.0。若要安装 VSTA,在控制面板中,打开添加或删除程序,找到2007 Microsoft Office 系统,,然后单击更改

最好使用适当的安全级别为表单模板以帮助您避免不必要的安全风险的用户。

若要设置的表单模板的安全级别,请执行下列操作:

  1. 工具菜单上,单击表单选项

  2. 类别下单击安全和信任

  3. 安全级别,请清除自动决定安全级别 (推荐)复选框。

  4. 单击所需的安全级别。

注意: 如果表单模板需要完全信任安全级别,表单模板必须在用户计算机上安装或使用受信任的根证书进行数字签名。否则为用户将不能授予完全信任向窗体基于该表单模板,并在填写的窗体中的功能的一些可能无法正常工作。可通过使用发布向导 InfoPath 表单模板的安装文件。

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×