设置当前数据库的用户选项

若要自定义用户设置,如对象窗口显示方式、键盘快捷方式和当前处于打开状态的 Access 桌面数据库的自动更正选项,请依次单击“文件”>“选项”,并更改“当前数据库”类别中的选项。

注意: 除非另有说明,否则只有关闭并重新打开数据库之后,才会应用对设置所做的更改。

注意: 本文不适用于 Access Web 应用 - 使用 Access 设计并联机发布的数据库。

您要做什么?

自定义当前数据库的选项

可以快速自定义应用程序名称和徽标的显示方式、对象窗口的显示方式以及当前应用程序或数据库的文件管理方式。在当前打开的数据库中,执行下列操作:

  1. 单击“文件”>“选项”>“当前数据库”。请注意,如果使用 Access 2007,请依次单击 Microsoft Office 按钮 >“Access 选项”>“当前数据库”。

  2. 为当前数据库选择设置。下面是一些常用设置;稍后将介绍更多。

    设置

    说明

    应用程序标题

    指定要在当前数据库的窗口标题栏中显示的自定义名称。

    应用程序图标

    为当前数据库选择一个图标。键入图像文件的名称,或者单击“浏览”以查找映像文件。选定的图标将显示在窗口标题栏中。

    用作窗体和报表图标

    选中此选项时,应用程序图标将显示在当前数据库的所有窗体和报表选项卡中。如果未启用文档选项卡,该图标将不会显示。

    显示窗体

    指定打开当前数据库时显示的窗体。如果不希望在打开数据库时显示任何窗体,请保留默认设置“(无)”。

    Web 显示窗体

    选中此选项时,用户可以设置、更改或删除在 Web 上显示的窗体。使用 Web 数据库时,Access 2010 和更高版本可使用此选项。

    显示状态栏

    选中此选项时,将在 Access 工作区底部显示状态栏。

  3. 完成时单击“确定”

    一些设置要求您先关闭然后重新打开数据库以使设置生效。

返回页首

选择对象窗口显示方式设置

Access 提供了一个选项,可以在对象窗口顶部的一系列易于访问的选项卡中显示所有打开的对象。通过“当前数据库”类别中的“文档窗口选项”区域,可以设置以下显示选项。

设置

说明

重叠窗口

选中此选项时,多个打开的对象将以相互重叠的方式显示。

对象窗口以重叠视图显示的情况

选项卡式文档

选中此选项时,即使打开了多个对象,一次也只能看到一个对象。

选择“选项卡式文档”选项时打开的对象的显示方式

可以使用“选项卡式文档”设置而不显示文档选项卡,这在用户需要一次处理一个对象时很有用。如果清除此选项,请确保启用了其他导航选项,以便用户能够切换到不同对象。

显示文档选项卡

如果选中“选项卡式文档”选项,则还可以选中此选项,以便显示所有打开对象的选项卡。

在窗体上使用应用了 Windows 主题的控件

选中此选项时,将对当前数据库中窗体和报表的控件使用 Windows 主题。

启用布局视图

选中此选项时,将在 Access 状态栏上以及在右键单击对象选项卡时出现的快捷菜单中显示“布局视图”按钮。如果清除此选项,则用户将无法在“布局”视图中打开窗体和报表。

注意: 清除此选项后,将无法通过“视图”组或任何快捷菜单访问“布局视图”按钮。

为数据表视图中的表启用设计更改

选中此选项时,将允许通过“数据表”视图更改表的设计。

检查截断的数字字段

选中此选项时,如果列太窄,无法显示完整的值,则 Access 将数字显示为“#####”。如果未选中该选项,则列中的可见值将根据适合列的内容截断。

图片属性存储格式

选中此选项时,Access 将以图像原始格式存储图像。选择此选项可减小数据库大小。

将所有图片数据转换成位图(与 Access 2003 和更早的版本兼容)

选中此选项时,Access 将以 Windows 位图或与设备无关的位图格式创建原始图像文件的副本。选中此选项后,可以查看在 Office Access 2003 及更早版本中创建的数据库中的图像。

返回页首

允许使用 Access 键盘快捷方式

选中“使用 Access 特殊键”选项后,用户可以在当前数据库中使用以下键盘快捷方式:

结果

F11

显示或隐藏导航窗格。

Ctrl+G

在 Visual Basic 编辑器中显示“立即”窗口。

Alt+F11

启动 Visual Basic 编辑器。

Ctrl+Break

按该组合键可停止 Access 从服务器检索记录。

返回页首

设置当前数据库的文件管理选项

这些文件管理设置仅应用于在选择选项时打开的数据库。

设置

说明

关闭时压缩

选中此选项时,将在关闭数据库时自动对其进行压缩和修复。

保存时从文件属性中删除个人信息

选中此选项时,将在保存文件时自动从文件属性中删除个人信息。

返回页首

选择当前数据库的导航选项

通过以下选项,可以自定义当前应用程序的导航操作:

导航选项设置

设置

说明

显示导航窗格

如果清除此选项,则打开当前数据库时将不显示导航窗格。

导航选项

选中此选项时,可以更改导航窗格中显示的类别和组,并可设置对象在当前数据库中打开方式的选项。

功能区名称

选择自定义功能区组的名称。

快捷菜单栏

设置或更改快捷菜单的默认菜单栏。

允许全部菜单

如果清除此复选框,则仅在功能区上显示“开始”选项卡。此外,单击“文件”时也无法使用“保存”“另存为”命令。

允许默认快捷菜单

打开或关闭右击导航窗格中的数据库对象或者窗体或报表上的控件时出现的快捷(弹出)菜单。必须关闭并重新打开当前数据库才能使指定选项生效。

返回页首

设置选项以跟踪和更正当前数据库中的字段名称

“名称自动更正”选项要求 Access 跟踪和更正窗体、报表和查询中的字段名称引用。可以为当前数据库设置以下选项:

设置

说明

跟踪名称自动更正信息

选中此选项时,Access 将存储更正命名错误所需的信息。允许您使用“对象相关性”功能。但是,在您选中“执行名称自动更正”选项之前,Access 不会修复错误。

执行名称自动更正

选中此选项时,Access 将修复发生的命名错误。如果选中“跟踪名称自动更正信息”选项但将此选项留空,则 Access 将存储所有错误数据,直到您选中此选项。

记录名称自动更正的更改

Access 将记录其在修复名称错误时所做的数据库更改,并将数据保存在名为 AutoCorrect.log 的表中。

返回页首

设置当前数据库的筛选选项

可以通过使用“按窗体筛选”定义筛选器对窗体中显示的信息排序,并可为当前数据库选择“按窗体筛选”窗口的显示值。

此部分中的选项可控制多项功能,如为“按窗体筛选”窗口中的指定字段显示的值列表的大小。可以选择选项,指定用户是否可显示索引字段或非索引字段的值,以及是否可显示外部文件中的链接表。此外,还可以选择选项,指定在使用“按窗体筛选”时,窗体上控件中是否显示值列表。

设置

说明

局部索引字段

选中此选项时,将在“按窗体筛选”窗口的值列表中显示局部索引字段中的值。

局部非索引字段

“按窗体筛选”窗口的值列表中显示局部非索引字段中的值。

ODBC 字段

显示您使用开放式数据库连链接到的表中的值。

读取的记录超过以下数目时不显示列表:

输入 Access 在创建“按窗体筛选”操作的值列表时,您希望 Access 读取的最大记录数。如果完成列表所需的记录数超过了指定数目,则将不显示值列表。即使值列表的字段未建立索引,所有值列表也仅包含唯一值。默认值为 1000。

返回页首

设置缓存 Web 服务和 SharePoint 表选项

适用于 Access 2010 及更高版本中新数据库的默认设置用于缓存 Web 服务和 SharePoint 链接表。

  • 使用与 Microsoft Access 2010 及更高版本兼容的缓存格式 选择此选项可使 Access 缓存链接数据的本地副本。此设置可在使用链接数据时提高性能。使用此选项可以更快地加载和查看链接数据。如果要使用 Access 2007 中的原有缓存行为,则清除此选项。

  • 关闭时清除缓存 选择此选项可使 Access 在关闭数据库时清除内存中的任何本地缓存数据。

  • 从不缓存 选择此选项,Access 将不会在使用链接的 SharePoint 数据源时缓存数据的本地副本。

    注意: 如果清除“使用与 Microsoft Access 2010 及更高版本兼容的缓存格式”选项,“关闭时清除缓存”和“从不缓存”选项将不可用。

返回页首

对链接和导入启用大数数据类型支持

大数数据类型可存储非货币的数值,并与 ODBC 中的 SQL_BIGINT 数据类型兼容。这种数据类型可高效计算大数,范围为 -2^63 到 2^63-1。

注意: 若要使用大数数据类型,必须具有 Office 365 订阅。如果你是 Office 365 订阅者,请确保拥有最新版本的 Office。如果你是管理 Office 365 更新进程的 IT 专业人员,请查看频道发布页面,了解每个频道提供哪些更新。

设置

说明

支持已链接/已导入表的 Bigint 数据类型

选中后,启用大数数据类型支持链接到使用等效数据类型(如 SQL Server 中的 bigint)的外部数据库,或从中导入。Access ? 将发出警告,称设置此选项会对数据库文件格式(具有后向兼容性注意事项)做出永久更改。请执行下列操作之一:

  • 选择“确定”可永久更改。更改后便不能撤销。

  • 选择“取消”可放弃更改。

有关详细信息,请参阅使用大数数据类型

注意: 启用此选项后,可在关闭数据库之前使用大数数据类型进行链接和导入。但须先关闭并重新打开数据库,才可在数据库标题栏中看到对文件格式戳所做的更改。

返回页首

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×