使用宏

编辑宏

浏览器中不支持视频。安装 Microsoft Silverlight、 Adobe Flash Player 或 Internet Explorer 9。

观看此视频,请参阅如何编辑名为 Visual Basic 编辑器中的特殊文本编辑器中的宏。Visual Basic 是在录制宏的编程语言。

首先,显示开发工具选项卡

开发工具选项卡上,在功能区中,是所有宏命令所在的位置。

  • 若要让其显示在功能区上,单击文件>选项>自定义功能区中,选中开发工具,然后单击确定

  • 开发工具选项卡的代码组中,是录制宏按钮,并将提供便利的一些其他按钮。

使用 Visual Basic 创建宏

  1. 单击开发人员> Visual Basic

  2. 如果需要在 Visual Basic 编辑器中,在插入菜单上,单击模块

    注意: 在工作簿中的所有工作表的自动创建模块。

  3. 在模块的代码窗口中中,,键入或复制要使用的宏代码。

  4. 若要从模块窗口中运行宏,请按 F5。

  5. 编写完宏后,在 Visual Basic 编辑器中,在文件菜单上,单击关闭并返回到 Microsoft Excel

编辑宏

  1. 开发工具选项卡的代码组中,单击

  2. 宏名框中,单击要编辑的宏。

  3. 单击编辑。Visual Basic 编辑器中显示。

需要更多信息?

创建或删除宏

编辑宏

将宏分配给按钮

创建并保存在单个工作簿中的所有宏

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×