表关系指南

表关系指南

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

之所以需要良好的数据库设计,目标之一就是为了消除数据冗余(重复数据)。为了实现该目标,可将数据拆分为多个基于主题的表,以使每个数据只显示一次。然后,通过在相关表中放置公共字段来为 Access 提供将拆分的信息组合到一起 的方法。但是,若要正确执行该步骤,必须了解表之间的关系,然后在数据库中指定这些关系。

本文内容

简介

表关系的类型

为什么创建表关系?

了解参照完整性

查看表关系

创建表关系

删除表关系

更改表关系

实施参照完整性

简介

在数据库中为每个主题创建一个表后,必须为 Access 提供在需要时将这些信息重新组合到一起的方法。具体方法是在相关的表中放置公共字段,并定义表之间的关系。然后,可以创建查询、窗体和报表,以同时显示几个表中的信息。例如,下面显示的窗体包含来自几个表的信息:

在“订单”窗体中同时显示来自五个表的相关信息

1. 此窗体中的信息来自“客户”表...

2. ...“订单”表...

3. ...“产品”表...

4. ...和“订单明细”表。

“受票方”框中的客户名称是从“客户”表中检索到的,“订单 ID”和“订单日期”值来自“订单”表,“产品名称”来自“产品”表,“单价”和“数量”值来自“订单明细”表。这些表以多种方式互相链接在一起,以便将各自的信息呈现到窗体中。

在上述示例中,表中的各个字段必须互相协调,这样它们才能显示有关相同订单的信息。这种协调是使用表之间的关系来实现的。表关系是通过匹配键字段中的数据来运作的 ,键字段通常是两个表中使用相同名称的字段。在大多数情况下,这些匹配字段是其中一个表的主键(它为每条记录提供唯一标识符),并且是另一个表的外键。例如,通过在“员工”和“订单”表的“员工 ID”字段之间创建表关系,可以将员工和他们负责的订单相关联。

“员工 ID”在“员工”表中用作主键,在“订单”表中用作外键。

1. “员工 ID”出现在两个表 中,一个是主键...

2. ...一个是外键。

返回页首

表关系的类型

有三种类型的在 Access 中的表关系。

  • 一对多关系

    使用一个订单跟踪数据库作为示例,其中包含“客户”表和“订单”表作为 客户可以签署任意数量的订单。“客户”表中显示的任何客户都是这样,“订单”表中可以显示很多订单。因此,“客户”表和“订单”表之间的关系就是一对多关系。

    为了在数据库设计中表示一对多关系,请获取关系“一”方的主键,并将其作为附加的一个或多个字段添加到关系“多”方的表中。例如在本例中,可将一个新字段 (即“客户”表中的 ID 字段) 添加到“订单”表中,并将其命名为“客户 ID”。 Access 随后即可使用“订单”表中的“客户 ID”号来查找每个订单的正确客户。

  • 多对多关系

    现在,我们来看一下“产品”表和“订单”表之间的关系。单个订单中可以包含多个产品。另一方面,一个产品可能出现在多个订单中。因此,对于“订单”表中的每条记录,都可能与“产品”表中的多条记录对应。此外,对于“产品”表中的每条记录,都可以与“订单”表中的多条记录对应。此关系称为多对多关系。请注意,为了检测到表之间的现有多对多关系,务必考虑关系的双方。

    要表示多对多关系,您必须创建第三个表,该表通常称为联接表,它将多对多关系划分为两个一对多关系。将这两个表的主键都插入到第三个表中。因此,第三个表记录关系的每个匹配项或实例。例如,“订单”表和“产品”表有一种多对多的关系,这种关系是通过与“订单明细”表建立两个一对多关系来定义的。一个订单可以有多个产品,每个产品可以出现在多个订单中。

  • 一对一关系

    在一对一关系中,第一个表中的每条记录在第二个表中只有一个匹配记录,而第二个表中的每条记录在第一个表中只有一个匹配记录。这种关系并不常见,因为通常以此方式相关的信息都存储在同一个表中。可以使用一对一关系将一个表分成许多字段,或出于安全原因隔离表中的部分数据,或存储仅应用于主表的子集的信息。标识此类关系时,这两个表必须共享一个公共字段。

返回页首

为什么创建表关系?

您可以使用“关系”窗口或从“字段列表”窗格中拖动字段来显式创建表关系。当需要在数据库对象中使用表时, Access 会使用表关系来确定如何联接这些表。应该在创建其他数据库对象(如窗体、查询和报表)之前创建表关系,这样做有以下几个原因:

  • 表关系可为查询设计提供信息

    若要使用多个表中的记录,通常必须创建联接这些表的查询。查询的工作方式为将第一个表主键字段中的值与第二个表的外键字段进行匹配。例如,若要返回列出每个客户所有订单的行,您需要构建一个查询,该查询基于“客户 ID”字段将“客户”表与“订单”表联接起来。在“关系”窗口中,可以手动指定要联接的字段。但是,如果已经定义了表间的关系,Access 会基于现有表关系提供默认联接。此外,如果使用其中一个查询向导,Access 会使用从已定义的表关系中收集的信息为您提供可能的选择,并用适当的默认值预填充属性设置。

  • 表关系可为窗体和报表设计提供信息

    在设计窗体或报表时,Access 会使用从已定义的表关系中收集的信息为您提供可能的选择,并用适当的默认值预填充属性设置。

  • 可以将表关系作为基础来实施参照完整性,这样有助于防止数据库中出现孤立记录。孤立记录指的是这样的一些记录:它所参照的其他记录根本不存在, 例如参照不存在的客户记录的订单记录。

    在设计数据库时,您将信息拆分为表,每个表都有一个主键。然后,您向相关表中添加参照这些主键的外键。这些外键-主键对构成了表关系和多表查询的基础。这些外键-主键参照保持同步非常重要。参照完整性依赖于表关系,有助于确保参照保持同步。

返回页首

了解参照完整性

在设计数据库时,您将数据库信息拆分为许多基于主题的表,以最大限度地降低数据冗余。然后,您通过在相关表中放置公共字段来为 Access 提供将数据重新组合到一起的方法。例如,为表示一对多关系,您从“一方”表中获得主键,将其作为附加字段添加到“多方”表。若要将数据重新组合到一起,Access 获得“多方”表中的值,并在“一方”表中查找相应的值。通过这种方法,“多方”表中的值参照“一方”表中相应的值。

假设“运货商”和“订单”之间存在一对多关系,您希望删除一个运货商。如果要删除的运货商在“订单”表中具有订单,则删除该运货商记录后,这些订单将成为“孤立记录”。这些订单仍然包含运货商 ID,但该 ID 不再有效,因为它所参照的记录不再存在。

参照完整性的目的是防止出现孤立记录并使参照保持同步,以使这种假设的情况永远不会发生。

可以通过为表关系启用参照完整性来实施参照完整性(请参阅实施参照完整性,以了解详细步骤)。实施后,Access 将拒绝违反此表关系参照完整性的任何操作。这意味着 Access 会拒绝更改参照目标的更新操作,也会拒绝删除参照目标的删除操作。您可能确实需要更改某个运货商的主键,而该运货商在“订单”表中有订单。在此类情况下,您真正需要的是 Access 在一次操作中自动更新所有受影响的行。这样,Access 可以确保进行完整更新,以便数据库不会出现不一致的状态(即更新某些行,不更新其他行)。因此,Access 支持“级联更新相关字段”选项。如果您实施了参照完整性并选择“级联更新相关字段”选项,在您更新主键时,Access 将自动更新参照主键的所有字段。

您可能还会需要删除某一行及所有相关记录, 例如,某个运货商记录以及其所有相关订单。因此,Access 支持“级联删除相关记录”选项。如果实施了参照完整性并选择“级联删除相关记录”选项,则当您删除关系主键方的记录时,Access 会自动删除参照该主键的所有记录。

返回页首

查看表关系

要查看表关系,请单击“数据库工具”选项卡上的“关系”。将打开“关系”窗口,并显示所有现存的关系。如果尚未定义表关系,并且您是第一次打开“关系”窗口,则 Access 会提示您向窗口中添加表或查询。

打开“关系”窗口

  1. 单击“文件”,然后单击“打开”

  2. 选择并打开该数据库。

  3. 在“数据库工具”选项卡上的“关系”组中,单击“关系”。

    如果该数据库包含关系,将显示“关系”窗口。如果数据库不包含任何关系,并且您是第一次打开“关系”窗口,则会出现“显示表”对话框。单击“关闭”关闭该对话框。

  4. 在“设计”选项卡上的“关系”组中,单击“所有关系”。

    这将显示数据库中的所有已定义关系。请注意,除非在“导航选项”对话框中选中了“显示隐藏对象”复选框,否则不会显示隐藏的表(在表的“属性”对话框中选中“隐藏”复选框的表)及其关系。

表关系由“关系”窗口中表之间绘制的关系线表示。不实施参照完整性的关系在支持该关系的公共字段之间显示为细线。单击关系线选择关系时,该线变粗指示它被选中。如果对此关系实施参照完整性,则该线在两端都会变粗。此外,在关系一侧线条较粗部分上会显示数字“1”,而在另一侧线条较粗部分上会显示无限大符号 ()。

在“关系”窗口处于活动状态时,可以选择功能区中的以下命令:

“设计”选项卡上的“工具”组中:

  • 编辑关系    打开“编辑关系”对话框。在选择关系线时,可以单击“编辑关系”以更改表关系。也可以双击关系线。

  • 清除布局    从“关系”窗口中删除所有显示的表和关系。请注意,该命令只隐藏这些表和关系, 而不会删除它们。

  • 关系报表    创建显示数据库中的表和关系的报表。该报表只显示“关系”窗口中未隐藏的表和关系。

“设计”选项卡上的“关系”组中:

  • 显示表    打开“显示表”对话框,使您可以选择表和查询以在“关系”窗口中进行查看。

  • 隐藏表    隐藏“关系”窗口中的所选表。

  • 直接关系    在“关系”窗口中显示所选表的所有关系和相关表(如果尚未显示)。

  • 所有关系    在“关系”窗口中显示数据库中所有关系和相关表。请注意,除非在“导航选项”对话框中选中“显示隐藏对象”,否则不会显示隐藏的表(在表的“属性”对话框中选中“隐藏”复选框的表)及其关系。

  • 关闭    关闭“关系”窗口。如果对“关系”窗口的布局进行了任何更改,则会询问您是否保存这些更改。

返回页首

创建表关系

可以使用“关系”窗口或从“字段列表”窗格向数据表拖动字段来创建表关系。在表之间创建关系时,不要求公共字段具有相同的名称,但实际情况往往是这样。但这些字段必须具有相同的数据类型。不过,如果主键字段为“自动编号”字段,并且两个字段的“字段大小”属性相同,则外键字段可以为“数字”字段。例如,如果两个字段的“字段大小”属性都是长整型,则可以将“自动编号”字段与“数字”字段匹配。在两个公共字段都是“数字”字段时,它们必须具有相同的“字段大小”属性设置。

使用“关系”窗口创建表关系

  1. 单击“文件”,然后单击“打开”

  2. 选择并打开该数据库。

  3. “数据库工具”选项卡上的“关系”组中,单击“关系”

  4. 如果您尚未定义过任何关系,则会自动显示“显示表”对话框。如果未出现该对话框,请在“设计”选项卡上的“关系”组中单击“显示表”

    “显示表”对话框会显示数据库中的所有表和查询。要只查看表,请单击“表”。若要只查看查询,请单击“查询”。要同时查看表和查询,请单击“两者”

  5. 选择一个或多个表或查询,然后单击“添加”。将表和查询添加到“关系”窗口之后,请单击“关闭”

  6. 将字段(通常为主键)从一个表拖至另一个表中的公共字段(外键)。要拖动多个字段,请按 Ctrl 键,单击每个字段,然后拖动这些字段。

    将显示“编辑关系”对话框。

  7. 验证显示的字段名称是否是关系的公共字段。如果字段名称不正确,请单击该字段名称并从列表中选择新字段。

    要对此关系实施参照完整性,请选中“实施参照完整性”复选框。有关参照完整性的详细信息,请参阅了解参照完整性实施参照完整性部分。

  8. 单击“创建”

    关系线是在两个表之间绘制的。如果已选中“实施参照完整性”复选框,则该线两端都显示为较粗。此外,仅当再次选中“实施参照完整性”复选框后,在关系一侧线条较粗部分上会显示数字“1”,而在另一侧线条较粗部分上会显示无限大符号 ()。

    注释: 

    • 创建一对一关系    两个公共字段(通常为主键字段和外键字段)都必须具有唯一索引。这意味着应将这些字段的“索引”属性设置为“是(不允许重复)”。如果两个字段都具有唯一索引,Access 将创建一对一关系。

    • 创建一对多关系    在关系“一方”的字段(通常为主键)必须具有唯一索引。这意味着应将此字段的“索引”属性设置为“是(不允许重复)”。多侧上的字段应具有唯一索引。“多”方的字段可以具有索引,但它必须允许重复项。这意味着应将此字段的“索引”属性设置为“否”“是(允许重复)”。当一个字段具有唯一索引,而其他字段不具有唯一索引时,Access 将创建一对多关系。

通过使用“字段列表”窗格添加字段来创建表关系

可以向在“数据表”视图中打开的现有表中添加字段,方法是将该字段从“字段列表”窗格拖动到该表中。“字段列表”窗格显示相关表中可用的字段以及其他表中可用的字段。从其他(无关联)的表中拖动一个字段并完成“查阅向导”时,会在“字段列表”窗格中的表和您将该字段拖至其中的表之间自动创建新的一对多关系。默认情况下,由 Access 创建的这种关系不实施参照完整性。要实施参照完整性,必须对该关系进行编辑。有关详细信息,请参阅更改表关系一节

在“数据表”视图中打开表

  1. “文件”选项卡上,单击“打开”

  2. “打开”对话框中,选择并打开数据库。

  3. 在导航窗格中,右键单击要向其添加字段并创建关系的表,然后单击“打开”

打开“字段列表”窗格

  • 按 Alt+F8。

    随即会显示“字段列表”窗格。

“字段列表”窗格显示数据库中的所有其他表,它们分成几类。在“数据表”视图中处理表时,Access 在“字段列表”窗格中显示以下两个类别中任一类别的字段:“相关表中的可用字段”“其他表中的可用字段”。第一个类别列出了与当前正在处理的表有关系的所有表。第二个类别列出了与您的表没有关系的所有表。

“字段列表”窗格中,单击表名称旁边的加号 (+) 时,您会看到该表中所有可用字段的列表。要向您的表中添加字段,请将所需字段从“字段列表”窗格拖动到“数据表”视图中的表中。

添加字段并从“字段列表”窗格中创建关系

  1. “字段列表”窗格中的“其他表中的可用字段”下,单击表名称旁边的加号 (+),以显示该表中的字段列表。

  2. 将所需字段从“字段列表”窗格拖动到“数据表”视图中打开的表中。

  3. 当插入行出现时,将该字段放到适当位置。

    将启动“查阅向导”

  4. 按照说明完成“查阅向导”

    该字段显示在“数据表”视图中的表中。

从其他(无关联)的表中拖动一个字段并完成“查阅向导”时,会在“字段列表”窗格中的表和您将该字段拖至其中的表之间自动创建新的一对多关系。默认情况下,由 Access 创建的这种关系不实施参照完整性。要实施参照完整性,必须对该关系进行编辑。有关详细信息,请参阅更改表关系一节

返回页首

删除表关系

要删除表关系,必须在“关系”窗口中删除关系线。小心放置光标,以使其指向关系线,然后单击该线。选中关系线时,它会显示得较粗。在选中关系线的情况下,按 Delete。请注意,删除关系时,如果启用了参照完整性支持,则同时会删除对该关系的参照完整性支持。因此,Access 将不再自动禁止在关系的“多”方创建孤立记录。

  1. 在“数据库工具”选项卡上的“关系”组中,单击“关系”。

    随后将显示“关系”窗口。如果您尚未定义过任何关系,这是您第一次打开“关系”窗口,则会出现“显示表”对话框。如果出现该对话框,请单击“关闭”

  2. 在“设计”选项卡上的“关系”组中,单击“所有关系”。

    随后将显示所有具有关系的表以及关系线。

  3. 单击要删除的关系的关系线。选中关系线时,它会显示得较粗。

  4. 按 Delete 键。

    - 或 -

单击右键,然后单击“删除”

  • Access 可能会显示消息“确实要从数据库中永久删除选中的关系吗?”。如果出现此确认消息,请单击“是”

注意: 如果表关系中涉及的任何一个表正被其他人或进程使用,或处于打开的窗体等数据库对象中,您将无法删除关系。必须首先将使用这些表的所有已打开对象全部关闭,才能删除关系。

返回页首

更改表关系

更该表关系的方法是在“关系”窗口中选择表关系,然后对其进行编辑。小心放置光标,以使其指向关系线,然后单击该线以将其选中。选中关系线时,它会显示得较粗。选中关系线后,双击该线,或者单击“设计”选项卡上“工具”组中的“编辑关系”。将显示“编辑关系”对话框。

在“编辑关系”对话框中进行更改

  1. 在“数据库工具”选项卡上的“关系”组中,单击“关系”。

    随后将显示“关系”窗口。如果您尚未定义过任何关系,这是您第一次打开“关系”窗口,则会出现“显示表”对话框。如果出现该对话框,请单击“关闭”

  2. 在“设计”选项卡上的“关系”组中,单击“所有关系”。

    随后将显示所有具有关系的表以及关系线。

  3. 单击要更改的关系的关系线。选中关系线时,它会显示得较粗。

  4. 双击该关系线。

  5. 进行更改,然后单击“确定”

    通过“编辑关系”对话框可以更改表关系。特别需要指出的是,您可以更改关系任意一侧的表或查询,或任意一侧的字段。还可以设置联接类型,或实施参照完整性,以及选择级联选项。有关联接类型以及如何设置联接类型的详细信息,请参阅设置联接类型部分。有关如何实施参照完整性以及选择级联选项的详细信息,请参阅实施参照完整性部分。

设置联接类型

定义表关系时,有关关系的事实可以为查询设计提供信息。例如,如果在两个表之间定义关系,然后创建一个使用这些表的查询,Access 将根据关系中指定的字段来自动选择默认匹配字段。可在查询中覆盖这些初始默认值,但该关系提供的值经过验证通常是正确的。在除了最简单的数据库之外的所有数据库中,由于匹配和从多个表中汇聚数据是经常要执行的操作,因此通过创建关系来设置默认值可以节省时间,并且非常有用。

多表查询通过匹配公共字段中的值来组合多个表中的信息。执行匹配和组合的操作称为联接。例如,假设您要显示客户订单。可以创建一个查询,以使“客户”表和“订单”表通过“客户 ID”字段联接起来。查询结果中只包含找到对应匹配的行的客户信息和订单信息。

可为每个关系指定的一个值是联接类型。联接类型通知 Access 要在查询结果中包括哪些记录。例如,再次考虑这样一个查询,它将“客户”表和“订单”表通过代表“客户 ID”的公共字段联接起来。使用默认联接类型(称为内部联接)时,查询只返回公共字段(也称为联接字段)相等的“客户”行和“订单”行。

但是,假设您要包括所有客户  - 即使是尚未下任何订单的客户。要实现此功能,必须将联接类型由内部联接更改为左外部联接。左外部联接将返回关系左侧表中的所有行,以及关系右侧表中的匹配行。右外部联接则返回右侧的所有行,以及左侧的匹配行。

注意: 在这种情况下,“左”和“右”指的是表在“编辑关系”对话框中而不是在“关系”窗口中的位置。

应该先考虑最希望通过在此关系中联接表的查询获取的结果,然后再相应设置联接类型。

设置联接类型

  1. “编辑关系”对话框中,单击“联接类型”

    将显示“联接属性”对话框。

  2. 单击您的选项,然后单击“确定”

下表(使用“客户”和“订单”表)显示“联接属性”对话框中显示的三种选项、它们使用的联接以及为每个表包括所有行还是匹配行。

选择

关系联接

左表

右表

1. 只包括两个表中的联接字段相同的行。

内部联接

匹配行

匹配行

2. 包括“客户”表中的所有记录以及“订单”表中联接字段相同的记录。

左外部联接

所有行

匹配行

3. 包括“订单”表中的所有记录以及“客户”表中联接字段相同的记录。

右外部联接

匹配行

所有行

当您选择选项 2 或选项 3 时,会在关系线上显示一个箭头。此箭头指向只显示匹配行的关系一侧。

在“联接属性”对话框中进行更改

  1. 在“数据库工具”选项卡上的“关系”组中,单击“关系”。

    随后将显示“关系”窗口。如果您尚未定义过任何关系,这是您第一次打开“关系”窗口,则会出现“显示表”对话框。如果出现该对话框,请单击“关闭”

  2. “设计”选项卡上的“关系”组中,单击“所有关系”

    将显示具有关系的所有表,同时显示关系线

  3. 单击要更改的关系的关系线。选中关系线时,它会显示得较粗。

  4. 双击该关系线。

    将显示“编辑关系”对话框。

  5. 单击“联接类型”。

  6. “联接属性”对话框中,单击一个选项,然后单击“确定”

  7. 对关系进行任何其他更改,然后单击“确定”

返回页首

实施参照完整性

使用参照完整性的目的是防止出现孤立记录并保持参照同步,以便不会有任何记录参照不再存在的其他记录。实施参照完整性的方法是为表关系启用参照完整性。实施后,Access 将拒绝违反此表关系参照完整性的任何操作。 Access 拒绝更改参照目标的更新,还拒绝删除参照目标的删除。若要让 Access 传播参照更新和删除,以便所有相关行都进行相应更改,请参阅设置级联选项部分。

打开或关闭参照完整性

  1. 在“关系”窗口中,单击要更改的关系的关系线。选中关系线时,它会显示得较粗。

  2. 双击该关系线。

将显示“编辑关系”对话框。

  1. 选中“实施参照完整性”复选框。

  2. 对关系进行任何其他更改,然后单击“确定”

实施了参照完整性之后,以下规则将适用:

  • 如果值在主表的主键字段中不存在,则不能在相关表的外键字段中输入该值 - 否则会创建孤立记录。 

  • 如果某记录在相关表中有匹配记录,则不能从主表中删除它。例如,如果在“订单”表中有分配给某雇员的订单,则不能从“员工”表中删除该雇员的记录。但通过选中“级联删除相关记录”复选框可以选择在一次操作中删除主记录所有相关记录。

  • 如果更改主表中的主键值会创建孤立记录,则不能执行此操作。例如,如果在“订单明细”表中为某一订单指定了行项目,则不能更改“订单”表中该订单的编号。通过选中“级联更新相关字段”复选框可以选择在一次操作中更新主记录所有相关记录。

    注释: 如果在启用参照完整性时遇到困难,请注意在实施参照完整性时需要满足以下条件:

    • 来自于主表的公共字段必须为主键或具有唯一索引。

    • 公共字段必须具有相同的数据类型。例外情况是自动编号字段可与“字段大小”属性设置为“长整型”的数字字段相关。

    • 这两个表必须存在于同一个 Access 数据库中。不能对链接表实施参照完整性。但是,如果来源表为 Access 格式,则可打开存储这些表的数据库,并在该数据库中启用参照完整性。

设置级联选项

您可能会遇到这样的情况,即需要更改关系“一方”的值。在这种情况下,您需要 Access 在一次操作中自动更新所有受影响的行。这样便可完成全部更新,因此数据库不会保留为不一致状态  - 更新一些行,而不更新另外一些行。 Access 通过支持“级联更新相关字段”选项避免了这一问题。如果您实施了参照完整性并选择“级联更新相关字段”选项,在您更新主键时,Access 将自动更新参照主键的所有字段。

您可能还会需要删除一行及所有相关记录 ,例如,某个运货商记录及其所有相关订单。因此,Access 支持“级联删除相关记录”选项。如果实施了参照完整性并选择“级联删除相关记录”选项,则当您删除包含主键的记录时,Access 会自动删除参照该主键的所有记录。

打开或关闭级联更新和/或级联删除

  1. 在“关系”窗口中,单击要更改的关系的关系线。选中关系线时,它会显示得较粗。

  2. 双击该关系线。

将显示“编辑关系”对话框。

  1. 选中“实施参照完整性”复选框。

  2. 选中“级联更新相关字段”“级联删除相关字段”复选框,或同时选中两者。

  3. 对关系进行任何其他更改,然后单击“确定”

注意: 如果主键是“自动编号”字段,则选中“级联更新相关字段”复选框将不起作用,因为您无法更改自动编号字段中的值。

返回页首

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×