编辑连接线线条、箭头或点

编辑连接线线条、箭头或点

Office 365 订阅, Office 2019, Office 2016, Office 2013, Office 2010

可以非常灵活地编辑和使用连接线。可以编辑线条粗细、样式和曲率,控制端点和箭头的外观,创建曲线连接线、直角连接线或直线连接线并以多种方式管理连接点。

提示   “开始”选项卡上“工具”组中的命令会使 Visio 处于不同的状态或模式,不可否认,这有时会让人感到困惑。使用键盘在“指针工具选择对象 (按 Ctrl+1)和“连接线按钮图像 (按 Ctrl+3)工具之间轻松切换。无论使用何种工具(例如,“文本块”或“连接点”),请多次按 Esc 以返回到“指针工具”(Visio 2010 中除外)。

本文的大部分内容与默认的动态连接线形状相关,该形状可以自动围绕其他形状对其自身进行重新排列。一些类型的连接线不会自动重新排列,例如“更多形状”\“其他 Visio 方案”\“连接线”模具中提供的大多数连接线。

想进行什么操作?   

创建曲线连接线、直角连接线或直线连接线

向连接线添加箭头或其他线端

更改连接线的粗细、样式或曲率

反转连接线箭头的方向

对连接线执行重新路由或相交操作

更多使用连接点的方法

另请参阅

创建曲线连接线、直角连接线或直线连接线

可以更改连接线,也可以更改新连接线的默认设置。

更改连接线

  1. 选择连接线。

  2. 在“设计”选项卡上的“布局”组中,选择“连接线”,然后选择所需排列样式“直角连接线”、“直线连接线”或“曲线连接线”。

  3. 或者,鼠标右击连接线形状的“操作”菜单也可以更改连接线排列样式。

更改新连接线的默认设置

  • 将默认连接线设置为直角连接线、直线连接线或曲线连接线:

    • Visio Online 计划 2 2016、2013    通过选择页面取消选择所有形状。选择“设计”选项卡,然后在“布局”组中选择“连接线”下拉菜单。然后选择“直角”、“直线”或“曲线”。

    • 或者,依次选择“文件”选项卡、“打印”、“页面设置”和“布局与排列”选项卡,然后在“外观”列表中,选择“直线”或“曲线”。

    • 2010    依次选择“文件”选项卡、“打印”、“打印预览”、“页面设置”和“布局与排列”选项卡,然后在“外观”列表中,选择“直线”或“曲线”。

返回页首

向连接线添加箭头或其他线端

可以向连接线添加箭头、点或其他线端。

  1. 选择某一连接线。

  2. 执行下列操作之一:

    • Visio Online 计划 2 2016、2013    从鼠标右击“操作”菜单中,选择“设置形状格式”选项。或者,在“开始”选项卡上的“形状样式”组中,选择“线条”,然后选择“线条选项”。

    • 2010    在“开始”选项卡上的“形状”组中,选择“线条”,然后选择“箭头”。

  3. 执行下列操作之一:

    • Visio Online 计划 2、2016 和 2013    在“设置形状格式”窗格中的“线条”下,请确保“实线”处于已选中状态,然后选择类型、大小或线端类型。

      用于连接线端点的设置
    • 2010    选择“更多箭头”,然后在“线条”窗口中选择类型、大小或线端类型,然后单击“确定”。

      箭头末端

返回页首

更改连接线的粗细、样式或曲率

  1. 选择某一连接线。

  2. 执行下列操作之一:

    • Visio Online 计划 2 2016、2013    从鼠标右击“操作”菜单中,选择“设置形状格式”选项。或者,在“开始”选项卡上的“形状样式”组中,选择“线条”,然后选择“线条选项”。

    • 2010    在“开始”选项卡上的“形状”组中,选择“线条”,然后选择“线条选项”。

  3. 执行下列操作之一:

    • Visio Online 计划 2、2016 和 2013    在“设置形状格式”窗格中的“线条”下,选择粗细、样式或曲率。

      用于连接线样式的设置
    • 2010    在“线条”窗口中,选择粗细、样式或曲率,然后单击“确定”。

      线条粗细和其他设置

返回页首

反转连接线箭头的方向

注意:在某些类型的关系图(例如各种过程流程图)中,连接方向很重要。因此,应对这些连接线使用“两端颠倒”命令,而不是重新格式化端点。使用“文件”\“选项”\“自定义功能区...”功能,可以将“两端颠倒”命令按钮轻松地添加到功能区。借助此命令,可以反转所有选定连接线的流。

或者,要在不使用“两端颠倒”命令的情况下更改连接线的方向,请向没有箭头的一端添加新箭头,然后删除另一端的现有箭头。

  1. 选择某一连接线。

  2. 执行下列操作之一:

    • Visio Online 计划 2、2016 和 2013    在“开始”选项卡上的“形状样式”组中,选择“线条”,然后选择“线条选项”。

    • 2010    在“开始”选项卡上的“形状”组中,选择“线条”,然后选择“线条选项”。

  3. 执行下列操作之一:

    • Visio Online 计划 2、2016 和 2013    在“设置形状格式”窗格中的“线条”下,选择:

      • 开始箭头类型”,然后执行步骤 4。

      • 结束箭头类型”,然后执行步骤 4。

      用于反转箭头的设置
    • 2010    在“线条”窗口中选择:

      • 开始箭头类型”,然后执行步骤 4。

      • 结束箭头类型”,然后执行步骤 4。

      开始箭头和结束箭头
  4. 若要在所选连接线的起始和结束位置添加、更改或删除箭头,请在“箭头”菜单上选择箭头或“”。

    在“箭头样式”菜单上选择一种箭头样式或选择“无”。

返回页首

对连接线执行重新路由或相交操作

大多数情况下,可以依赖连接线的默认行为。但有时,可能需要对图表中连接线的路由和相交操作拥有更多控制。

提示    使用“缩放”功能可以更好地查看小细节并拥有更多细微点控制:“放大”(按 Alt+F6)、“缩小”(Alt+Shift+F6) 和“适应窗口大小”(Ctrl+Shift+W)。

  • 执行下列一项或多项操作:

    • 若要将连接线连接到另一连接线,请将连接线添加到形状,然后将此连接线拖动到另一连接线。

      与连接线连接
    • 若要对连接线进行重新路由,请选择它,然后将中点拖动到新位置。

      对连接线进行重新路由
    • 若要逐像素地调整连接线,请选择连接线,然后根据所需方向按 Shift+箭头键。

      按像素移动连接线

注意    若要创建树形图,请参阅创建树形图

返回页首

更多使用连接点的方法

以下部分讨论了可控制连接点的多种方法。

提示    使用“缩放”功能可以更好地查看小细节并拥有更多细微点控制:“放大”(按 Alt+F6)、“缩小”(Alt+Shift+F6) 和“适应窗口大小”(Ctrl+Shift+W)。

连接点概述

连接点是形状上的特殊点,可以向它“粘附”连接线和其他形状。当将连接线或形状粘附至连接点时,即使某个形状发生移动,该连接线和连接点都保持连接状态。

当尝试连接各个形状时,连接点保持可见。当通过“连接线工具”悬停在形状附近,或者拖动任何连接线的端点或具有连接点的形状附近的线条时,会看到该形状的连接点。

具有连接点的圆圈附近的连接线工具

注意    连接点不是可以粘附连接线的唯一位置。还可以将连接线(和线条)粘附到形状顶点、形状手柄和形状几何图形。有关详细信息,请参阅“对齐和粘附”对话框

使用点或动态连接

连接线可对形状采用两种连接类型:点连接(有时称为静态连接)或动态连接。可以在连接线的任一端采用任意类型的连接线。如果使用“自动连接”功能或“连接形状”命令连接形状,则两端将采用动态连接。如果手动选择连接线在形状上的连接点,则可以指定连接类型。

在下图中,形状 A 具有到形状 C 的点连接,无论 C 是否移动,从 A 引出的连接线始终连接到 C 上的同一点。相反,形状 B 具有到 C 的动态连接,从 B 引出的连接线会连接到离 C 上最近的连接点。

A 具有到 C 的点连接,但 B 具有到 C 的动态连接。

创建点连接   

点连接使连接线粘附到形状上的某个特定点,即使该形状被移动或旋转后也不例外。

  1. 请从第一个形状上的连接点拖动到第二个形状上的连接点。

  2. 形状连接后,连接线端点会变为绿色。

将连接线粘附到形状上的特定点来修复到该点的连接线。

创建动态连接   

动态连接使连接线能够更改其在形状上的位置,这样,某个形状被移动或旋转时,连接线会移至该形状上离连接线的起始点最近的连接点。

  1. 将“连接线工具”放置在第一个形状中心的上方,直到该形状周围出现绿色的框。

  2. 按住鼠标按钮,并拖动到第二个形状的中心。

  3. 第二个形状周围出现绿色的框时,释放鼠标按钮。

将连接线粘附到形状,以使连接线能够动态移动至形状上的连接点。

向形状添加连接点

如果要向其粘附连接线的形状在需要连接点的位置没有连接点,可添加一个连接点。

  1. 选择形状。

  2. 在“开始”选项卡上的“工具”组中,单击“连接点”工具 按钮图像

  3. 如果连接点未显示,在“视图”选项卡上的“视觉帮助”组中选择“连接点”复选框。

  4. 按 Ctrl 并单击要添加连接点的位置。放置新连接点后,会自动选择该连接点。

  5. 在“开始”选项卡上的“工具”组中,单击“指针工具选择对象 以返回正常编辑状态。

向形状添加连接点

移动形状上的连接点

如果对连接点的位置不满意,可以移动它。

  1. 选择形状。

  2. 在“开始”选项卡上的“工具”组中,选择“连接点”工具 按钮图像

  3. 如果连接点未显示,在“视图”选项卡上的“视觉帮助”组中选择“连接点”复选框。

  4. 按 Ctrl 并拖动要移动的连接点。

  5. 在“开始”选项卡上的“工具”组中,单击“指针工具选择对象 以返回正常编辑状态。

如果将连接点准确移动到所需位置时遇到困难,请尝试其他对齐设置。有关详细信息,请参阅调整对齐强度,或关闭对齐

删除连接点

有时连接点会妨碍操作。在此情况下,可以删除连接点。

  1. 选择具有要删除的连接点的形状。

  2. 在“开始”选项卡上的“工具”组中,单击“连接点”工具。

  3. 如果连接点未显示,在“视图”选项卡上的“视觉帮助”组中选择“连接点”复选框。

  4. 单击要删除的连接点。连接点将变为洋红色。

  5. 按 Delete。

  6. 在“开始”选项卡上的“工具”组中,单击“指针工具选择对象 以返回正常编辑状态。

删除连接点

隐藏连接点

有时需要隐藏连接点以更好地查看图表。

  • 在“视图”选项卡上的“视觉帮助”组中,清除“连接点”复选框。

在连接点旁添加文本

不能直接在连接点上添加文本。但是,可以在形状旁添加文本,然后将该文本移动到连接点旁。

  1. 选择要添加文本的形状,然后开始键入文本。键入的文本显示在形状中。

  2. 选择“开始”\“工具”\“文本块”工具 “文本块”工具图标 (Ctrl+Shift+4)

  3. 这时将会选中文本块

    选中的文本块
  4. 拖动文本块,根据需要移动并调整其大小

    移动并重设文本块的大小

要退出“文本块​​”工具时,选择“指针工具选择对象 (Ctrl+1)

另一种方法是创建多个唯一标记的形状,每个形状都有单个连接点,然后将这些形状组合在一起,形成更大的形状。连接点仍将可用。

创建多个已命名的连接点

创建向内和/或向外连接点

使用向内和向外连接点可以控制在形状上吸引连接线端点的方式。

  1. 选择形状。

  2. 在“开始”选项卡上的“工具”组中,单击“连接点”工具 按钮图像

  3. 如果连接点未显示,在“视图”选项卡上的“视觉帮助”组中选择“连接点”复选框。

  4. 如果需要向外连接点或向内和向外连接点,请右键单击该连接点并单击:

    • 向内    在大多数情况下,需要向内连接点。向内连接点吸引连接线上的端点以及二维 (2-D) 形状上的向外连接点与向内和向外连接点。

    • 向外    如果要将一个二维形状粘附到另一个形状,则需要向外连接点。向外连接点被吸引到向内连接点。

    • 向内和向外    如果要将某个形状粘附到其他形状而又不知如何粘附,很可能需要向内和向外连接点

返回页首

使用连接点

以下部分讨论了可控制连接点的多种方法。

连接点概述

具有四个连接点的形状。

具有四个连接点的形状。

添加连接点

如果要向其粘附连接线或形状的形状在需要连接点的位置没有连接点,可轻松添加一个连接点。

  1. 如果连接点未显示,在“视图”菜单中单击“连接点”。

  2. 选择形状。

    注意: 如果事先没有选中该形状,则无法向其添加连接点。如果形状周围有一个绿色的虚框,则该形状已被选中。

  3. 单击“连接点”工具 按钮图像

    如果“连接点”工具未显示,请单击“连接线”工具 按钮图像 旁的向下键,然后单击“连接点”工具 按钮图像

  4. 按 Ctrl 并单击要添加连接点的位置。

  5. 如果您需要向外连接点或向内和向外连接点,请右键单击该连接点并单击“向内”、“向外”或“向内和向外”。

    • 在大多数情况下,需要向内连接点。向内连接点“吸引”连接线上的端点以及二维 (2-D) 形状上的向外连接点与向内和向外连接点。

    • 如果要将一个二维形状粘附到另一个形状,则需要向外连接点。向外连接点被“吸引到”向内连接点。

    • 如果要将某个形状粘附到其他形状而又不知如何粘附,向内和向外连接点。

  6. 单击“指针”工具 指针按钮 ,返回正常编辑状态。

在连接点旁添加文本

遗憾的是,不能直接向连接点添加文本。但是,可以在形状旁添加文本,然后将该文本移动到连接点旁。

  1. 选择形状。

  2. 开始键入。键入的文本显示在形状中。

  3. 单击“文本块”工具 按钮图像

    如果“文本块”工具未显示,请单击“文本”工具 “文本工具”按钮 旁的向下键,然后单击“文本块”工具 按钮图像

  4. 拖动文本。

提示: 如果该形状具有控制手柄 控制手柄图像 - 黄色菱形 ,则可以拖动它来快速移动形状文本。

移动连接点

如果对连接点的位置不满意,可以移动它。

  1. 选择形状。

    注意: 如果事先没有选中该形状,则无法移动连接点。如果形状周围有一个绿色的虚框,则该形状已被选中。

  2. 单击“连接点”工具 按钮图像

    如果“连接点”工具未显示,请单击“连接线”工具 按钮图像 旁的向下键,然后单击“连接点”工具 按钮图像

  3. 拖动要移动的连接点。

    如果未显示任何连接点,在“视图”菜单中单击“连接点”。

  4. 单击“指针”工具 指针按钮 ,返回正常编辑状态。

如果将连接点准确移动到所需位置时遇到困难,请尝试其他对齐设置:

  • 在“工具”菜单上,单击“对齐和粘附”,然后在“常规”选项卡上的“对其到”下选择所需选项。

删除或隐藏连接点

有时连接点会碍事。出现这种情况时您有两种选择:删除连接点或隐藏连接点。

删除形状上的连接点

  1. 选择形状。

    注意: 如果事先没有选中该形状,则无法删除连接点。如果形状周围有一个绿色的虚框,则该形状已被选中。

  2. 单击“连接点”工具 按钮图像

    如果“连接点”工具未显示,请单击“连接线”工具 按钮图像 旁的向下键,然后单击“连接点”工具 按钮图像

  3. 单击要删除的连接点。连接点将变为洋红色。

    如果未显示任何连接点,在“视图”菜单中单击“连接点”。

  4. 按 Delete。

  5. 单击“指针”工具 指针按钮 ,返回正常编辑状态。

隐藏连接点

  • 在“视图”菜单上,单击“连接点”。

返回页首

向连接线添加箭头或其他线端

可以向连接线添加元素(如箭头、点或其他线端)。

  1. 选择某一连接线。

  2. 在“格式”菜单上,单击“线条”。

  3. 在“线端”下,选择所需线端的类型和大小。

  4. 单击“确定”。

提示: 也可以使用“格式”工具栏上的“线端”工具。

创建曲线连接线、直角连接线或直线连接线

更改图表上的连接线

  1. 右键单击连接线。

  2. 单击“直角连接线”、“直线连接线”或“曲线连接线”。

注意    无法将手柄添加到直线连接线或直角连接线,但可以使用“铅笔”工具 按钮图像 将手柄添加到曲线连接线。

更改新连接线的默认设置

  • 若要将默认连接线设置为直线连接线或曲线连接线,请在“文件”菜单上,依次单击“页面设置”和“布局与排列”选项卡,然后在“外观”列表中,单击“直线”或“曲线”。

反转连接线箭头的方向

若要更改连接线的方向,请向没有箭头的一端添加新箭头,然后删除另一端的现有箭头,从而更改连接线的方向。

  1. 选择要更改的连接线。

  2. 在“开始”选项卡上的“形状”组中,单击“线条”,然后指向“箭头”以打开“箭头”菜单。

    单击“形状样式”中的“线条”以打开菜单,然后单击“箭头”。
  3. 在“箭头”菜单底部,单击“更多箭头”。

    单击“箭头”菜单底部的“更多箭头”。

    Visio 将显示展开“线条”的“设置形状格式”任务窗格。

  4. 若要在所选连接线的起始位置添加、更改或删除箭头,请在“开始箭头类型”的“箭头”菜单上选择箭头或“”。

    在所选连接线线条上,添加、更改或删除箭头。

    “箭头”菜单显示所选连接线的当前选中的箭头样式或“”。

    在“箭头样式”菜单上选择一种箭头样式或选择“无”。
  5. 若要在所选连接线的结束位置添加、更改或删除箭头,请在“结束箭头类型”的“箭头”菜单上选择箭头或“”。

另请参阅

添加和编辑连接线文本

在形状之间添加连接线

粘附和取消粘附连接线

创建自定义连接线

添加或删除连接线跨线

Visio 培训

有关 Visio 桌面版连接线的一切(Visio 团队博客)

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×