编辑宏

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

若要编辑的宏,连接到 Microsoft Excel 工作簿,您可以使用Visual Basic 编辑器。

重要: 您可以使用宏之前,您必须启用开发工具选项卡。有关详细信息,请参阅显示开发工具选项卡

更改宏安全设置

要编辑和运行宏,必须将安全级别设置为临时启用所有宏:

  1. “开发工具”选项卡上的“代码”组中,单击“宏安全性”

    “开发工具”选项卡上的“代码”组

  2. “宏设置”下,单击“启用所有宏(不推荐,可能会运行有潜在危险的代码)”,然后单击“确定”

    警告: 为帮助防止运行有潜在危险的代码,我们建议您在使用完宏之后恢复任何禁用所有宏的设置。

编辑宏

  1. “开发工具”选项卡上的“代码”组中,单击“宏”

  2. “宏名称”框中,单击要编辑的宏。

  3. 单击“编辑”。此时显示 Visual Basic 编辑器。

提示: 获取帮助,而您正在在 Visual Basic 编辑器中,在帮助菜单上,单击Microsoft Visual Basic 帮助或按 F1。

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×