管理外部数据区域及其属性

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

您可以将外部数据区域的属性更改控件数据已导入到外部数据源的连接到工作表。

你想如何操作?

了解有关外部数据区域和属性的详细信息

查找外部数据区域

更改外部数据区域的名称

更改外部数据区域的基础查询

复制外部数据区域及其基础查询

指定向外部数据区域添加新数据的方式

指定数据格式及布局

在外部数据区域扩展时复制公式

冻结外部数据区域中的数据

自定义外部数据区域中的字段名称

删除外部数据区域

了解有关外部数据区域及属性的详细信息

外部数据区域(也称为查询表)是一个已定义名称或表名称,用于定义导入到工作表中的数据的位置。当您连接到外部数据时,Excel 会自动创建一个外部数据区域。唯一的例外情况是连接到数据源的数据透视表,数据透视表不使用外部数据区域。在 Excel 中,您可以设置外部数据区域的格式并进行布局,或者将其用在计算中,就像对任何其他数据一样。

外部数据区域属性

外部数据区域有额外的属性(不要与连接属性混淆),可以使用这些属性控制数据,例如保留单元格格式和列宽。通过单击“数据”选项卡上的“连接”组中的“属性”,可以更改这些外部数据区域属性。然后执行下列操作进行更改:

  • 对于通过 Microsoft Query 及数据连接向导创建的外部数据区域,使用“外部数据属性”对话框。

  • 对于使用导入的文本文件或者检索 HTML 数据的 Web 查询创建的外部数据区域,使用“外部数据区域属性”对话框。

  • 对于使用检索 XML 数据的 Web 查询创建的外部数据区域,使用“XML 映射属性”对话框。

对外部数据区域使用模板

如果您想要共享摘要或基于外部数据的报表,您可以授予其他用户的工作簿包含外部数据区域,也可以创建报表模板。报表模板允许您保存外部数据,以使文件更小的情况下保存汇总或报表。当用户打开的报告模板检索外部数据。

返回页首

查找外部数据区域

  1. 选择要在其中搜索外部数据区域工作的表。

  2. 在编辑栏中,单击在名称框旁边的箭头,然后单击外部数据区域所需的名称。

返回页首

更改外部数据区域的名称

  1. 在“公式”选项卡的“已定义名称”组中,单击“名称管理器”。

    Excel 功能区图像

  2. “名称管理器”对话框中,单击外部数据区域的名称,然后单击“编辑”。也可以双击该名称。

  3. “编辑名称”对话框的“名称”框中,为引用键入新名称。

注意: “关闭”按钮仅关闭“名称管理器”对话框。您不必为了提交所做的更改而单击“关闭”

返回页首

更改外部数据区域的基础查询

对于通过 Microsoft Query、导入的文本文件、Web 查询或数据连接向导创建的外部数据区域,您可以更改其基础查询。

更改通过 Microsoft Query 创建的外部数据区域的基础查询

  1. 在要更改其基础查询的外部数据区域中,单击一个单元格。

  2. “数据”选项卡上的“连接”组中,单击“属性”

    Excel 功能区图像

  3. 外部数据属性对话框中,单击连接属性 属性

  4. “连接属性”对话框中,单击“定义”选项卡,然后单击“编辑查询”

有关在 Microsoft Query 中构造和编辑查询的详细信息,请参阅 Microsoft Query 帮助。

更改通过已导入文本文件创建的外部数据区域的基础查询

  1. 在要更改其基础查询的外部数据区域中,单击一个单元格。

  2. “数据”选项卡上的“连接”组中,单击“连接”

    Excel 功能区图像

  3. “工作簿连接”对话框中,单击“属性”

  4. “连接属性”对话框中,单击“定义”选项卡,然后单击“编辑查询”

  5. “导入文本文件”对话框中,单击“导入”

  6. 在文本导入向导中更改导入的文本文件,然后单击“完成”

    有关导入文本文件的详细信息,请参阅导入或导出文本文件

更改通过 Web 查询创建的外部数据区域的基础查询

  1. 在要更改其基础查询的外部数据区域中,单击一个单元格。

  2. “数据”选项卡上的“连接”组中,单击“属性”

    Excel 功能区图像

  3. “工作簿连接”对话框中,单击“属性”

  4. “连接属性”对话框中,单击“定义”选项卡,然后单击“编辑查询”

  5. “编辑 Web 查询”对话框中更改 Web 查询,然后单击“完成”

有关创建和编辑 Web 查询的详细信息,请参阅从网页中获取外部数据

更改使用数据连接向导创建的外部数据区域的基础查询

  1. 在要更改其基础查询的外部数据区域中,单击一个单元格。

  2. “数据”选项卡上的“连接”组中,单击“属性”

    Excel 功能区图像

  3. 外部数据属性对话框中,单击连接属性 属性

  4. “连接属性”对话框中,单击“定义”选项卡。

  5. 请执行下列操作之一:

    • “命令类型”框中,单击“表”,然后在“命令文本”框中,将值更改为相应表、视图或查询的名称。

    • “命令类型”框中,单击“SQL”“默认”,然后在“命令文本”框中编辑 SQL 语句。

      注意: 根据连接的定义方式,“命令类型”框可能不可用(灰显)。

返回页首

复制外部数据区域及其基础查询

  1. 在编辑栏上,单击“名称”框旁边的箭头,选择要复制的外部数据区域的名称。

    对于 Excel 表格,选择该区域的名称,然后按 Ctrl+A 选择表头。

    如果要包含不属于该外部数据区域的列标签或公式,请选择包含要复制的列标签或公式的单元格。在编辑栏上单击“名称”框旁边的箭头,然后单击要复制的外部数据区域的名称。

  2. 在“开始”选项卡上的“剪贴板”组中,单击“复制”。

    Excel 功能区图像

  3. 切换到要在其中粘贴该外部数据区域的工作簿。

  4. 单击粘贴区域的左上角单元格。

    要确保外部数据不能取代现有的数据,请确保工作表具有下方或右侧的单元格,单击任何数据。

  5. 在“开始”选项卡上的“剪贴板”组中,单击“粘贴”。

注意: 如果您只复制一部分的外部数据区域,不复制基础查询 ,并无法刷新所复制的数据。

返回页首

指定向外部数据区域添加新数据的方式

可以控制在刷新数据时如何处理返回到 Excel 的较小或较大数据集。

  1. “数据”选项卡上的“连接”组中,单击“属性”

    Excel 功能区图像

  2. “外部数据区域属性”对话框中的“当数据区域中的行数随刷新而更改时”下,单击下列选项之一:

    • 为新数据插入单元格,并删除没有使用的单元格

      注释: 

      • 在数据源中添加一行或多行时,该外部数据区域正下方的单元格下移,但该外部数据区域右侧的单元格不移动。

      • 在数据源中删除一行或多行时,该外部数据区域正下方的单元格上移,但该外部数据区域右侧的单元格不移动。

    • 为新数据插入整行,清除没有使用的单元格

      注释: 

      • 在数据源中添加一行或多行时,该外部数据区域正下方及右侧的单元格都下移。

      • 在数据源中删除一行或多行时,该外部数据区域正下方及右侧的单元格不移动。

    • 用新数据覆盖现有单元格,清除没有使用的单元格

      注释: 

      • 在数据源中添加一行或多行时,该外部数据区域正下方的单元格被覆盖,但该外部数据区域右侧的单元格不移动。

      • 在数据源中删除一行或多行时,该外部数据区域正下方及右侧的单元格不移动。

返回页首

指定数据格式及布局

  1. “数据”选项卡上的“连接”组中,单击“属性”

    Excel 功能区图像

  2. “数据格式及布局”下,执行下列一项或多项操作:

    • 要将字段名称作为第一行包括,请选中“包含字段名称”复选框。

      注意: 此复选框仅对从 Microsoft Office 2003 程序转换的外部数据区域可用,或对以编程方式创建的外部数据区域可用。

    • 要添加行号列,请选中“包含行号”复选框。

      注意: 此复选框对导入的文本文件、XML 文件或 Web 查询不可用。

    • 要保留您应用的单元格格式,请选中“保留单元格格式”复选框。

      注意: 对于 Web 查询,在您选择“选项”对话框中的“完全 HTML 格式”时,此选项被自动清除。可以通过“编辑查询”对话框访问“选项”对话框。

    • 要保留您设置的列宽,请选中“调整列宽”复选框。

    • 要保留您应用的列排序、筛选和布局,请选中“保留列排序/筛选/布局”复选框。

      注意: 此复选框对 Web 查询不可用。

    • 要保留您应用的列筛选,请选中“保留列筛选”复选框。

      注意: 此复选框仅对基于 XML 数据的 Web 查询可用。

返回页首

在外部数据区域扩展时复制公式

注意: 以下过程仅适用于 Microsoft Office 2003 程序,请从转换的外部数据区域或为以编程方式创建外部数据区域。在Office Excel 2007,通过使用用户界面创建的所有外部数据区域用作 Excel 表格。当添加新行,且填充,这些表自动扩展向下计算的列。

  1. 在邻近外部数据区域中第一个数据行的单元格中输入公式。

    注意: 第一个数据行可能是外部数据区域内的第一行或第二行,具体取决于第一行是否包含标题。

  2. 选择单元格,然后双击填充柄将公式复制到外部数据区域中的所有行。

  3. 单击外部数据区域中的某个单元格。

  4. “数据”选项卡上的“连接”组中,单击“属性”

    Excel 功能区图像

  5. “外部数据区域属性”对话框中,选中“在与数据相邻的列向下填充公式”复选框。

    注意: 如果您刷新,Excel 将复制到或在外部数据区域内立即相邻公式时,将扩展的外部数据区域。

返回页首

冻结外部数据区域中的数据

冻结外部数据区域将保留数据但不保留其基础查询,因此无法刷新冻结的外部数据区域。

冻结 Excel 表格中的数据

  1. 单击包含要从中删除数据连接的 Excel 表格的工作表。

  2. 在编辑栏中,单击名称框旁边的箭头,然后单击您想要删除的数据连接的外部数据区域的名称。然后选择数据范围。

  3. 工具选项卡上的外部表数据组中,单击取消链接。数据区域仍保留,仍具有相同的名称,但在删除的连接。

冻结区域中的数据

注意: 以下过程仅适用于 Microsoft Office 2003 程序,请从转换的外部数据区域或为以编程方式创建外部数据区域。在Office Excel 2007,通过使用用户界面创建的所有外部数据区域用作 Excel 表格。当添加新行,且填充,这些表自动扩展向下计算的列。

  1. “数据”选项卡上的“连接”组中,单击“属性”

    Excel 功能区图像

  2. “查询定义”下,清除“保存查询定义”复选框。

注意: 保存工作簿时,基础查询将从工作簿中删除。但是,不会删除已保存的数据库查询文件(.dqy 或 .odc 文件)。如果在查询向导或 Microsoft Query 中创建查询时对查询进行保存,则查询文件将保存在您的计算机中,并且您可以再次使用该查询来检索外部数据。有关详细信息,请参阅 Microsoft Query 帮助。

返回页首

自定义外部数据区域中的字段名称

注意: 以下过程仅适用于使用数据连接向导或 Microsoft Query 创建的外部数据区域 (和不能为导入的文本文件或 Web 查询),转换 Microsoft Office 2003 程序,请从外部数据区域或以编程方式创建外部数据区域。在Office Excel 2007,通过使用用户界面创建的所有外部数据区域用作 Excel 表格。

  1. 外部数据区域上方插入一个空白行。

    了解如何插入一个空行

    1. 请执行下列操作之一:

      • 插入新的空白单元格   选择您要在其中插入新的空白单元格的单元格范围 。根据您要插入,请选择相同数量的单元格。

      • 插入一行   在新行的位置下,立即单击行中的单元格。例如,若要插入新行 5 行上方,单击第 5 行中的单元格。

      • 插入多行   选择所需的新行的位置下方的行。根据您要插入,请选择相同的行数。

      • 插入一个列   单击立即您希望插入新列的右侧列中的单元格。例如,若要插入新列与 B 列的左侧,单击 B 列中的单元格

      • 插入多列   选择您要在其中插入新列的右侧紧挨的列。根据您要插入,请选择相同的列数。

    2. 开始选项卡的单元格组中,单击插入,旁边的箭头,然后依次下列操作之一 ︰插入单元格插入工作表行插入工作表列

      如果您要插入空白单元格,请单击活动单元格右移活动单元格下移来定义要移动的现有单元格。

      如果带有格式,可以在开始选项卡上的剪贴板组中使用格式刷 按钮图像 来选择如何设置插入单元格、 行或列的格式。

  2. 在空行的单元格中键入所需标签。

  3. 单击外部数据区域中的某个单元格。

  4. “数据”选项卡上的“连接”组中,单击“属性”

    Excel 功能区图像

  5. “外部数据区域属性”对话框中的“数据格式及布局”下,清除“包含字段名称”复选框,然后单击“确定”

  6. 若要删除现有的字段名称并刷新外部数据区域,单击外部数据区域中的单元格,然后单击刷新数据 按钮图像

注意: 从数据库中检索数据时,在 Microsoft Query 中对列名称所做的任何更改都会保留在外部数据区域内。有关更改查询中的列名称的信息,请参阅 Microsoft Query 帮助。

返回页首

删除外部数据区域

  1. 单击包含要删除的外部数据区域的工作表。

  2. 在编辑栏上,单击“名称”框旁边的箭头,然后单击要删除的外部数据区域的名称。

    如果外部数据区域是 Excel 表格,请按 Ctrl+A 选择整个表格。

  3. 要删除外部数据区域,请按 Delete。

  4. 要删除基础查询,请在 Excel 提示时单击“是”

返回页首

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×