管理外部数据区域及其属性

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

您可以将外部数据区域的属性更改已导入到工作表连接到外部数据源,如数据库、 Web 查询或文本文件通过控制数据。

外部数据区域 (也称为查询表) 是已定义的名称或表名称,用于定义导入工作表数据的位置。当您连接到外部数据时,Excel 会自动创建外部数据区域。此规则的唯一例外是数据透视表连接到数据源,数据透视表报表不使用外部数据区域。在 Excel 中,您可以设置格式和排放外部数据区域,或在计算中使用它与任何其他数据。

外部数据区域属性

外部数据区域具有其他属性 (不会与连接属性混淆) 可用于控制数据,例如保留的单元格格式和列宽。您可以通过单击数据选项卡上的连接组中的属性更改这些外部数据区域属性。通过执行下列操作,然后进行所需的更改:

  • 对于 Microsoft 查询和数据连接向导中创建的外部数据范围,使用外部数据属性对话框。

  • 对于从导入的文本文件或 Web 查询检索 HTML 数据创建的外部数据范围,使用外部数据区域属性对话框。

  • 对于从 Web 查询检索 XML 数据创建的外部数据范围,使用XML 映射属性对话框。

模板中使用外部数据区域

如果您想要共享摘要或基于外部数据的报表,您可以授予其他用户的工作簿包含外部数据区域,也可以创建报表模板。报表模板允许您保存外部数据,以使文件更小的情况下保存汇总或报表。当用户打开的报告模板检索外部数据。

  1. 选择要在其中搜索外部数据区域工作的表。

  2. 在编辑栏中,单击在名称框旁边的箭头,然后单击外部数据区域所需的名称。

  1. “公式”选项卡上的“已定义名称”组中,单击“名称管理器”

    Excel 功能区图像

  2. 名称管理器对话框中,单击外部数据区域的名称,然后单击编辑。您也可以双击名称。

  3. 编辑名称对话框中,键入名称框中的引用的新名称。

注意: 关闭按钮关闭名称管理器对话框。您不必所做的更改提交才能单击关闭

您可以更改从 Microsoft Query、 导入的文本文件、 Web 查询或数据连接向导创建外部数据区域的基础查询。

  1. 单击要为其更改基础查询的外部数据区域中的单元格。

  2. 数据选项卡的连接组中,单击属性

    Excel 功能区图像

  3. 外部数据属性对话框中,单击连接属性 属性

  4. 连接属性对话框中,单击定义选项卡,,然后单击编辑查询

有关构建和编辑 Microsoft Query 中的查询的详细信息,请参阅 Microsoft Query 帮助。

  1. 单击要为其更改基础查询的外部数据区域中的单元格。

  2. 在“数据”选项卡上的“连接”组中,单击“连接”。

    Excel 功能区图像

  3. 工作簿连接对话框中,单击属性

  4. 连接属性对话框中,单击定义选项卡,,然后单击编辑查询

  5. 导入文本文件对话框中,单击导入

  6. 更改在文本导入向导导入的文本文件,然后单击完成

    有关导入文本文件的详细信息,请参阅导入或导出文本文件

  1. 单击要为其更改基础查询的外部数据区域中的单元格。

  2. 数据选项卡的连接组中,单击属性

    Excel 功能区图像

  3. 工作簿连接对话框中,单击属性

  4. 连接属性对话框中,单击定义选项卡,,然后单击编辑查询

  5. 对 Web 查询在编辑 Web 查询对话框中进行更改,然后单击完成

有关创建和编辑 Web 查询的详细信息,请参阅连接到网页 (Power Query)

  1. 单击要为其更改基础查询的外部数据区域中的单元格。

  2. 数据选项卡的连接组中,单击属性

    Excel 功能区图像

  3. 外部数据属性对话框中,单击连接属性 属性

  4. 连接属性对话框中,单击定义选项卡。

  5. 执行下列操作之一:

    • 命令类型框中,单击表格,然后,在命令文本框中,将值更改为相应的表、 视图或查询的名称。

    • 命令类型框中,单击SQL默认,然后在命令文本框中,编辑 SQL 语句。

      注意: 根据连接的定义方式,命令类型框中可能不可用 (灰显)。

  1. 在编辑栏中,单击在名称框旁边的箭头,然后选择要复制的外部数据区域的名称。

    Excel 表中,选择范围的名称,然后按 CTRL + A 选择表标题。

    如果您想要包括列标签或不属于外部数据区域的公式,请选择包含列标签或您想要复制的公式的单元格。单击编辑栏中,在名称框旁边的箭头,然后单击要复制的外部数据区域的名称。

  2. 在“开始”选项卡上的“剪贴板”组中,单击“复制”。

    Excel 功能区图像

  3. 切换到要在其中粘贴的外部数据区域的工作簿。

  4. 单击粘贴区域的左上角单元格。

    要确保外部数据不能取代现有的数据,请确保工作表具有下方或右侧的单元格,单击任何数据。

  5. 在“开始”选项卡上的“剪贴板”组中,单击“粘贴”。

注意: 如果您只复制一部分的外部数据区域,不复制基础查询 ,并无法刷新所复制的数据。

您可以控制如何处理一个小或更大的数据集,刷新数据时将返回到 Excel。

  1. 数据选项卡的连接组中,单击属性

    Excel 功能区图像

  2. 外部数据区域属性对话框中,如果在刷新时更改的数据区域中的行数下, 单击下列选项之一:

    • 插入新的数据的单元格、 删除未使用的单元格

      注意: 

      • 当数据源中添加一个或多个行时,直接在外部数据区域下的单元格下移,但不是会移动到外部数据区域右侧的单元格。

      • 当数据源中删除一个或多个行时,直接在外部数据区域下的单元格向上移动,但不是会移动到外部数据区域右侧的单元格。

    • 插入整行,为新数据,请清除未使用的单元格

      注意: 

      • 数据源中添加一个或多个行后,向下移动单元格下方和右侧的外部数据区域。

      • 在数据源中删除一个或多个行时, 不会移动单元格直接下和向右的外部数据区域。

    • 用新数据覆盖现有单元格,请清除未使用的单元格

      注意: 

      • 当数据源中添加一个或多个行时,覆盖直接在外部数据区域下的单元格,但不是会移动到外部数据区域右侧的单元格。

      • 在数据源中删除一个或多个行时, 不会移动单元格直接下和向右的外部数据区域。

  1. 数据选项卡的连接组中,单击属性

    Excel 功能区图像

  2. 数据格式和布局,请执行一个或多个下列操作:

    • 若要为第一行包含字段名称,选择包含字段名复选框。

      注意: 此复选框才可用于从 Microsoft Office 2003 程序,或以编程方式创建外部数据区域转换外部数据区域。

    • 若要添加行号的列,请选择包含行号复选框。

      注意: 此复选框不可用导入的文本文件、 XML 文件,或 Web 查询。

    • 若要保留您应用的格式的单元格,请选择保留单元格格式复选框。

      注意: Web 查询,当您选择选项对话框中完整 HTML 格式时自动清除此选项。从编辑查询对话框中访问选项对话框。

    • 若要保留您设置列宽,请选择调整列宽复选框。

    • 要保留列排序、 筛选和应用时的布局,,请选择保留列排序/筛选/版式复选框。

      注意: 此复选框不可用的 Web 查询。

    • 若要保留您应用的列筛选,请选择保留列筛选复选框。

      注意: 此复选框可仅对 Web 查询的基于 XML 的数据。

注意: 以下过程仅适用于 Microsoft Office 2003 程序,请从转换的外部数据区域或为以编程方式创建外部数据区域。通过使用用户界面创建的所有外部数据区域创建为 Excel 表格。当添加新行,且填充,这些表自动扩展向下计算的列。

  1. 与外部数据区域中的数据的第一个行相邻的单元格中输入公式。

    注意: 第一个数据行可能在外部数据区域中,具体取决于是否第一行包含标题的第一个或第二行。

  2. 选择单元格,然后双击填充柄将公式复制到外部数据区域中的所有行。

  3. 单击外部数据区域中的某个单元格。

  4. 数据选项卡的连接组中,单击属性

    Excel 功能区图像

  5. 外部数据区域属性对话框中,选择向下填充公式中与数据相邻的列复选框。

    注意: 如果您刷新,Excel 将复制到或在外部数据区域内立即相邻公式时,将扩展的外部数据区域。

冻结外部数据区域保留数据,但不是将其基础查询,因此无法刷新冻结的外部数据区域。

  1. 单击包含您要从中删除数据连接的 Excel 表的工作表。

  2. 在编辑栏中,单击名称框旁边的箭头,然后单击您想要删除的数据连接的外部数据区域的名称。然后选择数据范围。

  3. 工具选项卡上的外部表数据组中,单击取消链接。数据区域仍保留,仍具有相同的名称,但在删除的连接。

注意: 以下过程仅适用于 Microsoft Office 2003 程序,请从转换的外部数据区域或为以编程方式创建外部数据区域。通过使用用户界面创建的所有外部数据区域创建为 Excel 表格。当添加新行,且填充,这些表自动扩展向下计算的列。

  1. 数据选项卡的连接组中,单击属性

    Excel 功能区图像

  2. 查询定义下,清除保存查询定义复选框。

注意: 保存您的工作簿时,将从工作簿中删除基础查询。但是,不会删除已保存的数据库查询文件 (.dqy 或.odc 文件)。如果您在查询向导中创建或在 Microsoft Query 查询文件保存在您的计算机上,您可以使用查询再次检索外部数据时,您可以保存查询。有关详细信息,请参阅 Microsoft Query 帮助。

注意: 以下过程仅适用于使用数据连接向导或 Microsoft Query 创建的外部数据区域 (和不能为导入的文本文件或 Web 查询),从 Microsoft Office 2003 程序或外部转换外部数据区域以编程方式创建的数据区域。通过使用用户界面创建的所有外部数据区域创建为 Excel 表格。

  1. 插入一个空白行的外部数据区域上方通过执行下列操作之一:

    • 选择单元格上面的要插入新行。然后,在开始选项卡的单元格组中,单击插入,旁边的箭头,然后单击插入工作表行。选择了一个单元格,因为当前行的上方插入一个新行。

    • 单击要插入新行其上方的行的行选择器。然后,在开始选项卡的单元格组中,单击插入。选择了一个整行,因为所选行的上方插入一个新行。

  2. 键入所需的空白的行中的单元格的标签。

  3. 单击外部数据区域中的某个单元格。

  4. 数据选项卡的连接组中,单击属性

    Excel 功能区图像

  5. 外部数据区域属性对话框中,在数据格式和布局清除包含字段名复选框,,然后单击确定

  6. 若要删除现有的字段名称并刷新外部数据区域,单击外部数据区域中的单元格,然后单击刷新数据 按钮图像

注意: 当从数据库中检索数据时,Microsoft Query 中的列名称对任何更改将保留在外部数据区域。有关更改列名在查询中的信息,请参阅 Microsoft Query 帮助。

  1. 单击包含要删除的外部数据区域的工作表。

  2. 在编辑栏中,单击名称框旁边的箭头,然后单击要删除的外部数据区域的名称。

    Excel 表格的外部数据区域时,请按 CTRL + A 选择整个表格。

  3. 若要删除的外部数据区域,请按 DELETE。

  4. 要删除基础查询,请单击时,Excel 会提示您。

需要更多帮助吗?

可随时在 Excel 技术社区中咨询专家,在解答社区获得支持,或在 Excel User Voice 上建议新功能或功能改进。

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×