移动到新的 SharePoint 库发布的表单模板

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

本文内容

概述

开始之前

获取表单模板的工作副本

步骤 1︰ 将表单模板发布到新文档库

步骤 2︰ 复制和重新链接现有窗体

概述

在将某一表单模板发布到文档库以供用户填写之后,可能需要将此表单模板移动到其他文档库。例如,您可能需要将表单模板移动到具有更多空间的服务器,这样更多用户就可以同时填写表单。有些用户可能已填写了基于存储在原始文档库中的表单模板的表单。当您将表单模板移动到新的文档库时,可能也需要移动这些现有表单。同时,可能还需要确保在存档或删除旧的文档库之前,这些现有表单在新文档库中有效。

提示: 在将发布的表单模板移动到新文档库之前,请创建一个包括通知用户他们的表单已移动到新文档库的计划。您希望用户使用新文档库来存储新表单或修改现有表单。该计划还应包括存档或删除原始文档库的过程。

要将表单模板及其现有表单移动到新文档库,首先需要将表单模板的工作副本发布到新文档库。工作副本是存储在计算机上或版本控制程序(如 Microsoft Visual SourceSafe)中的版本。

提示: 如果没有表单模板的工作副本,可以将表单模板的副本从原始文档库保存到计算机,以用作工作副本。

在将工作副本发布到新文档库之后,需要将所有表单从旧文档库复制到新文档库,然后将新文档库中的表单重新链接到新发布的表单模板。

如果因移动表单模板而需要进行任何更改,请在发布表单模板之前进行这些更改。例如,基于此表单模板的表单所使用的外部数据源的位置可能也会因移动表单模板而更改。在这种情况下,您需要在发布表单模板之前,将表单模板中的数据连接更改为外部数据源的新位置。有关更改数据连接的详细信息,请在“请参阅”一节中查找相关链接。

注意: 发布表单模板不是与保存的表单模板。发布表单模板时,发布向导中添加发布位置和处理到表单模板的说明,以便用户可以打开基于该表单模板的表单。保存表单模板时,将保存表单模板中,的副本,就像将文件保存到您的计算机时。当您想要让可供用户填写的表单模板时,应始终使用发布向导。

返回页首

开始之前

在将表单模板和任何基于此表单模板的现有表单移动到新文档库之前,将需要下列信息:

  • 表单模板的工作副本    这是表单模板的副本,您将修改此副本,然后将其重新发布到新文档库。工作副本可能存储在计算机上或版本控制程序(如 Visual SourceSafe)中。

  • 任何新的外部数据源的位置    如果基于此表单模板的表单使用的外部数据源发生更改,您将需要外部数据源的新位置。请与管理员确认您和您的用户具有使用外部数据源的相应权限。如果此表单模板使用数据连接文件中的设置来连接到外部数据源,请确保已使用外部数据源的新位置更新了数据连接文件。

  • 对运行 Windows SharePoint Services 3.0 的服务器的相应权限    您将需要对服务器具有相应权限,才能发布表单模板以及将任何现有表单从旧文档库复制到新文档库。请与服务器管理员确认您具有这些权限。

返回页首

获取表单模板的工作副本

如果要修改已发布到文档库或共享网络位置的表单模板,但却没有表单模板的工作副本,那么可以将表单模板的工作副本从发布位置保存到计算机。

提示: 考虑使用版本控制程序(如 Microsoft Visual SourceSafe)来管理表单模板的工作副本。

将表单模板的副本从文档库保存到计算机

  1. 在 Web 浏览器中打开文档库发布表单模板的位置。

  2. 设置菜单上,单击设置,然后单击表单库设置

  3. “常规设置”下,单击“高级设置”

  4. 文档模板部分中,单击编辑模板

    表单模板将在 Microsoft Office InfoPath 中打开。

  5. “Microsoft Office InfoPath”对话框中,单击“是”

  6. “文件”菜单上,单击“另存为”

  7. Microsoft Office InfoPath对话框中,单击确定

  8. “另存为”对话框中,通过浏览找到要保存表单模板副本的位置,然后单击“保存”

将表单模板的副本从共享网络文件夹保存到计算机

  1. 文件菜单上,单击设计表单模板

  2. “打开表单模板”下面,单击“在我的电脑上”

  3. 通过浏览找到已发布的表单模板的共享的网络文件夹、 表单模板中,单击,然后单击打开

  4. “文件”菜单上,单击“另存为”

  5. Microsoft Office InfoPath对话框中,单击确定

  6. 另存为对话框中,选择一个位置以外原始发布您要在其中保存的表单模板中,使用副本的位置,然后单击保存

返回页首

步骤 1:将表单模板发布到新的文档库

  1. 在设计模式中打开表单模板的工作副本。

  2. 在“文件”菜单上,单击“发布”。

  3. 在发布向导中,单击“具有或不具有 InfoPath Forms Services 的 SharePoint 服务器”,然后单击“下一步”

  4. “请输入 SharePoint 或 InfoPath Forms Services 网站的位置”框中,键入包含要将表单模板移动到其中的新文档库的 SharePoint 网站位置,然后单击“下一步”

  5. 在向导的下一页上,单击“文档库”,然后单击“下一步”

  6. 单击“新建文档库”,然后单击“下一步”

  7. 在向导的下一页上,键入新文档库的名称和说明,然后单击“下一步”

  8. 选择表单模板中的域,您希望该表单模板作为列显示在文档库的默认视图中。

    如何?

    1. 单击“添加”

    2. 选择您想要为一列中的文档库中,添加的字段,然后执行下列操作之一︰

      • 列名称框中,键入栏的名称。

      • 网站列组列表中选择网站列在列名称列表中,选择一个名称,然后单击确定

        注意: 如果您选择的重复域显示在文档库中的数据,您可以定义要如何显示在文档库中的字段,通过单击函数列表中的值。您可以选择是否显示在域,字段中或计数的所有匹配项的字段中的最后一个值中的第一个值或是否的所有值合并在一起。

    3. 单击“确定”。

    有关显示文档库中列的数据的详细信息,请在“请参阅”一节中查找相关链接。

  9. 单击“下一步”

  10. 在向导的下一页上,验证所显示的信息是否正确,然后单击“发布”

  11. 要打开文档库并测试填写基于此表单模板的表单的过程,请选中“打开此文档库”复选框,然后单击“关闭”

    文档库将在浏览器中打开。单击列表工具栏上的“新建”时,基于此表单模板的表单将在 Microsoft Office InfoPath 中打开。

在将表单模板发布到新文档库之后,可以将基于旧版本的表单模板的现有表单从旧文档库复制到新文档库。在复制现有表单之后,可以将现有表单重新链接到新版本的表单模板。如果不链接现有表单,则用户可能无法打开这些现有表单。

返回页首

步骤 2:复制和重新链接现有表单

此过程假设两个文档库都位于运行 Windows SharePoint Services 3.0 的计算机上。

  1. 在 Web 浏览器中打开旧文档库。

  2. “视图”菜单上,单击“资源管理器视图”

  3. 按住 Ctrl,选择要移动的每个表单,然后右键单击其中一个表单。

  4. “Internet Explorer”对话框中,单击“是”,然后单击快捷菜单上的“复制”

  5. 打开新文档库。

  6. “选择视图”下,单击“资源管理器视图”

  7. 右键单击文件夹窗口中的空白区域。

  8. “Internet Explorer”对话框中,单击“是”,然后单击快捷菜单上的“粘贴”

  9. “视图”菜单上,单击“重新链接文档”

  10. “重新链接”列中,选择要链接到新表单模板的每个表单的复选框。

  11. 在列表工具栏上,单击“重新链接选择的文档”

在将现有表单重新链接到新表单模板之后,您的用户可以更改您复制到新文档库的现有表单,或者填写基于新发布的表单模板的新表单。

返回页首

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×