添加指向 Microsoft Access 数据库的数据连接

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

如果您的用户需要使用 Microsoft Office Access 2007 数据库(.accdb 格式)或用早期版本保存的 Access 数据库(.mdb 格式)中的数据,来填写基于您的基于 Microsoft Office InfoPath 表单模板的表单,则您可以添加一个查询 Access 数据库的指向表单模板的辅助数据连接。

您可以添加辅助数据连接,但该数据连接只能查询 Access 数据库。不能添加用于将表单数据提交到 Access 数据库的辅助数据连接。

如果您希望用户将其表单数据提交到 Access 数据库,则可设计一个基于 Access 数据库的表单模板,然后在主要数据连接中启用提交数据连接。或者,您也可以向与 Access 数据库一起使用的 Web 服务添加一个辅助数据连接。

有关设计基于 Access 数据库的表单模板和向 Web 服务添加辅助数据连接的详细信息,请在“请参阅”部分中查找相应的链接。

本文内容

概述

兼容性的注意事项

开始之前

步骤 1︰ 添加辅助数据连接

步骤 2︰ 配置要使用的数据连接的表单模板

概述

辅助数据连接是添加到表单模板的连接。辅助数据连接与主要数据连接不同,主要数据连接在您设计基于数据库或 Web 服务的新表单模板时创建。表单模板的主要数据连接可以接收来自外部数据源的数据,也可以将表单数据提交到外部数据源。但是,一个表单模板只能有一个主要数据连接。

您可以向表单模板添加任意多个辅助数据连接。例如,假定您具有一个 Access 数据库,其中包含一个存储雇员数据的表和一个存储客户数据的表。那么您可以添加两个辅助数据连接,一个用来检索该 Access 数据库中雇员表的数据,一个用来检索同一数据库中客户表的数据。

您可以向可将表单数据提交到外部数据源(例如 Web 服务或 Windows SharePoint Services 库)的表单模板添加辅助数据连接,但只能使用辅助数据连接检索 Access 数据库的数据。不能添加用于将表单数据提交到 Access 数据库的辅助数据连接。

向数据库中添加查询数据连接,InfoPath 将创建辅助数据源包含数据字段和对应于数据库中的数据的存储方式的组。由于辅助数据源中的数据结构必须匹配的数据库表中存储数据的方式,不能修改字段或辅助数据源中的组。

您可以将每个查询数据连接配置为保存结果,以便当用户的表单没有连接到网络时,也可以访问数据。不过,这取决于数据的性质,有时候您可能希望仅当用户连接到网络时才显示查询结果。

安全注释 : 如果您使用辅助数据连接以从外部数据源检索敏感数据,您可能想要禁用此功能,以帮助防止未经授权使用的数据,以防丢失或盗取计算机。如果您禁用此功能,数据将用户连接到网络时才可用。

向表单模板添加查询数据连接时,默认情况下,当用户打开基于此表单模板的表单时,这些表单将使用数据连接。您也可以将表单模板配置为按下列任一方式使用查询数据连接:

  • 添加规则   您可以配置规则以使用查询数据连接,每次发生时在规则的条件。

  • 添加按钮。   您可以向用户可以单击以获取使用查询数据连接的数据的表单模板中添加按钮。

  • 使用自定义代码   如果不能添加规则或按钮,您可以使用自定义代码以获取使用查询数据连接的数据。使用自定义代码需要开发人员创建的自定义代码。

返回页首

兼容性考虑

您不能在浏览器兼容的表单模板中添加到 Access 数据库的数据连接。

返回页首

开始之前

在表单模板中添加到 Access 数据库的辅助数据连接前,您需要知道下面的信息:

  • 数据库的名称和位置。

    注意: 如果您的 Access 数据库存储在网络位置,请确保用户可以访问该数据库。

  • 要向基于此表单模板的表单提供数据的表或查询的名称。在配置查询数据连接时,将使用此表或查询作为主表或主查询。

  • 其他表或提供附加到主表或查询数据的查询的名称。在大多数情况下,在数据库中已建立了表关系。如果您必须手动之间建立关系的主表或查询和另一个表或查询,您将需要相关的字段名称的表或查询。

返回页首

第 1 步:添加辅助数据连接

  1. “工具”菜单上,单击“数据连接”

  2. 数据连接对话框中,单击添加

  3. 在“数据连接向导”中,单击“新建连接”,单击“接收数据”,然后单击“下一步”

  4. 在向导的下一页上,单击“数据库(仅 Microsoft SQL Server 或 Microsoft Office Access)”,然后单击“下一步”

  5. 在向导的下一页上,单击“选择数据库”

  6. “选择数据源”对话框中,浏览以找到数据库所在位置。

    注意: 如果您的数据库存储在网络位置中,浏览到通用命名约定 (UNC) 路径的位置。不要浏览到通过映射的网络驱动器的网络位置。如果您使用的映射的网络驱动器,基于该表单模板创建窗体的用户将搜索从映射的网络驱动器数据库。如果用户没有映射的网络驱动器,窗体将找不到该数据库。

  7. 单击数据库的名称,然后单击“打开”

  8. “选择表格”对话框中,单击要使用的主表或查询,然后单击“确定”

  9. 在向导的下一页上,选中“显示表列”复选框。

    默认情况下,表或查询中的所有域都会添加到表单模板的主数据源中。

  10. 清除您不想在辅助数据源中包含的域所对应的复选框。

    向数据连接添加任何附加表或查询。

    如何?

    1. 单击“添加表”

    2. 添加表或查询对话框中,单击子表的名称,然后单击下一步。InfoPath 尝试通过匹配两个表中的字段名称设置关系。如果不想使用建议的关系,选择该关系,,然后单击删除关系。若要添加的关系,请单击添加关系。在添加关系对话框中,单击相应的列中,在每个相关字段的名称,然后单击确定

    3. 单击“完成”

    4. 要添加其他子表,请重复这些步骤。

  11. 单击“下一步”

  12. 要使查询数据连接的结果在表单未连接到网络时仍然可用,请选中“在表单模板中存储一份数据副本”复选框。

    安全注释 : 选中此复选框会在表单使用此数据连接时将数据存储在用户计算机上。如果该表单使用此数据连接检索敏感数据,则您可能需要禁用此功能,以便在计算机丢失或被盗时帮助保护数据。

  13. 单击“下一步”

  14. 在向导的下一页上,为该辅助数据连接键入一个描述性名称,然后验证“摘要”部分是否正确。

  15. 要将表单配置为在打开表单时自动接收数据,请选中“在打开表单时自动检索数据”复选框。

返回页首

步骤 2:将表单模板配置为使用数据连接

如果希望在用户打开基于表单模板的表单后,让表单使用此数据连接,则可为表单模板添加规则,使其在特定条件下使用此数据连接,也可以在表单模板中添加一个按钮,以便用户可以通过单击此按钮使用此数据连接。

添加规则

您可以为表单模板添加规则,使其在满足规则条件的情况下随时从查询数据连接检索数据。例如,您可以向表单模板添加一个文本框,以便用户可以通过填写该文本框从外部数据源获取特定数据。然后您可以添加一个规则,以便每当用户在该文本框中输入数据时均使用该数据连接。

下面的过程假定您已经为表单模板创建了查询数据连接,并在表单模板上配置了除按钮外的其他控件以显示来自该数据连接的数据。

  1. 如果表单模板具有多个视图,单击视图菜单上,转到与控件视图您要在其中显示辅助数据源中的数据视图名称

  2. 双击想要将规则添加到其中的控件。

  3. 单击“数据”选项卡。

  4. “验证和规则”下,单击“规则”

  5. “规则”对话框中,单击“添加”

  6. “名称”框中,为规则键入一个名称。

  7. 要指定条件时应运行此规则,单击设置条件,,然后输入条件。条件发生时,将运行此规则。如果您没有设置条件,只要用户更改该控件中的值,然后移动他或她光标离开该控件将运行规则。

  8. 单击“添加操作”

  9. “操作”列表中,单击“使用数据连接进行查询”

  10. “数据连接”列表中,单击要使用的查询数据连接,然后单击“确定”关闭每个打开的对话框。

  11. 要测试所做的更改,请单击“常用”工具栏上的“预览”,或者按 Ctrl+Shift+B。

添加按钮

您可以向表单模板添加一个按钮控件,用户可以单击该按钮从查询数据连接获取数据。

  1. 如果表单模板具有多个视图,单击视图菜单上,转到与控件视图您要在其中显示辅助数据源中的数据视图名称

  2. 如果看不到“控件”任务窗格,请单击“插入”菜单上的“其他控件”,或按 Alt+I、C。

  3. 将按钮控件拖到表单模板上。

  4. 双击刚刚添加到表单模板上的按钮控件。

  5. 单击“常规”选项卡。

  6. “操作”列表中,单击“刷新”

  7. “标签”框中,键入想要显示在表单模板上的按钮上的名称。

  8. 单击“设置”

  9. “刷新”对话框中,执行以下操作之一:

    • 要使用到此表单模板的辅助数据连接从所有外部数据源接收最新数据,请单击“所有辅助数据源”

    • 要将按钮配置为使用表单模板的辅助数据连接从某个外部数据源接收最新数据,请单击“一个辅助数据连接”,然后在“选择辅助数据源”列表中单击一个辅助数据源。

  10. 单击“确定”关闭打开的所有对话框。

  11. 要测试所做的更改,请单击“常用”工具栏上的“预览”,或者按 Ctrl+Shift+B。

返回页首

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×