添加、 删除,和窗体中切换视图 (页)

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

通过设计窗体中的不同视图,您可以为用户提供不同的方式查看数据,或者从具体取决于您想要创建的窗体的类型或正在演示到窗体的用户的类型。例如,使用多个视图您可以 ︰

  • 简化长的复杂表单,如冗长的调查,通过将其拆分为多个用户可以通过单击下一步返回按钮导航到的页面。

  • 显示不同的人在您的组织,例如,当处理保险索赔让保险客户、 代理和调整视图中的角色基于不同版本的窗体。

  • 创建窗体的适合打印的视图。

在 InfoPath 表单的同样的所有视图都共享相同的数据。因此,如果窗体有两种视图,其中一个具有电子邮件地址的文本框中,您可以将该文本框复制到第二个视图。当用户在一个视图中键入其电子邮件地址时,它将自动显示在其他视图中。

本文内容

视图简介

用户体验

设计时的注意事项

在页面设计选项卡上视图组

添加视图

删除视图

更改默认视图

重命名视图

添加用于切换视图的按钮

显示使用窗体加载规则的视图

视图简介

用户体验

默认情况下,表单的用户可以通过从视图中选择所需的视图切换视图 /页面视图功能区上的组。将列出每个视图的名称,然后将突出显示活动视图。将列出所有视图,除非已在查看属性对话框中在视图菜单时填写此窗体上显示复选框未选中这些视图。

如果没有视图的选择,不会显示在开始选项卡上的页面视图在视图菜单时填写此窗体上显示复选框。这是非常有用的位置不希望用户能够访问而不是您希望他们填写的一部分的视图。例如,用于收集有关应聘人员反馈窗体可能具有与之关联的三个不同的用户角色 — 一个用于招聘人员,一个用于面试人员,一个用于招聘经理。对于每个用户角色,您可以设计表单稍有不同视图。

注意: 隐藏视图从用户的能力不安全功能。如果他们了解如何访问自己的 XML 数据,用户仍然可以查看数据。

若要防止面试切换到招聘人员或招聘经理的视图,在设计招聘人员和招聘经理视图,您可以打开查看属性对话框中,清除在视图菜单时填写此窗体上显示复选框。

注意: 在表单选项,切换视图的能力可以禁用的用户的 Web 浏览器中填写。单击文件选项卡,单击信息、 单击表单选项,然后在Web 浏览器部分中,清除视图复选框。

若要自定义视图切换体验,将添加到窗体,本文后面所述的视图切换按钮。

设计时的注意事项

设计新视图时,您通常需要执行以下任务 ︰

  1. 规划视图。

规划每个视图和如何将协同工作时关注类似的考虑事项 ︰

  • 首次打开表单时应显示哪个视图?

  • 用户是否需要使用多个视图?如何将它们之间移动它们?

  • 是否需要将某些视图设置为只读?

  • 是用户可能会从 InfoPath 表单中打印任何视图?

  • 填充视图。

当您向表单添加新视图时,它将页面布局从模板开始。从这里,您可以从功能区结构窗体并将控件添加从控件组中的开始选项卡上的插入选项卡添加布局表格。

您也可以将控件添加到新共享同一字段从字段任务窗格拖动相应的字段使用其他视图的控件的视图。

  1. 自定义导航体验。

如何将用户能够窗体中导航?将用户知道切换视图的默认命令的含义是什么?默认命令足够,或执行您希望用户能够通过单击直接在窗体显示的按钮视图之间切换?如果用户将单击按钮,您将使用选项卡式的用户界面或后退和下一步按钮?打印视图时,您要为用户打印所有的视图,一次或仅活动视图?

在页面设计选项卡上视图组

在功能区,在视图组中的页面设计选项卡上,您可以添加或删除的视图,或不同视图之间切换。若要自定义设置和选中的视图的行为,请单击属性按钮要打开查看属性对话框。

您也可以创建和打印的视图与现有视图通过首先创建打印视图时所需的表单视图,打印,然后将其分配给现有视图通过查看属性对话框中显示。您还可以指定自定义为打印视图打印设置页面设置选项卡上的查看属性对话框中,如页眉、 页脚和页边距的打印选项。

返回页首

添加视图

使用以下过程向窗体中添加其他视图。

  1. 单击页面设计选项卡,然后从视图组中,单击新视图

  2. 为视图中,键入一个名称,然后单击确定

添加、 删除,并在窗体视图切换

  1. 若要打开查看属性对话框中,单击页面设计选项卡,然后从视图组中,单击属性

  2. 查看属性对话框中,更改或指定所需的设置或的视图选项,然后单击确定

添加、 删除,并在窗体视图切换

  1. 在工作区中,通过向视图中添加版式表格和控件来设计视图。

如果您想要的基础上设计基于现有视图的新视图,打开现有的视图,按CTRL + A选择视图中的所有内容,然后按CTRL + C将所选内容复制到剪贴板。从页面设计选项卡上的视图组中的视图列表中选择新建视图,删除视图中预先填充的内容,然后按 CTRL + V 粘贴到新视图所选内容。

返回页首

删除视图

您无法恢复或还原视图后将其删除。如果删除的窗体只有一个视图中的默认视图,InfoPath 将自动创建新的默认视图。如果删除了具有多个视图的窗体中的默认视图,InfoPath 会将默认视图状态分配到视图上的页面设计选项卡上,在视图组中,在视图列表中显示的列表中的下一个视图。

  1. 选择要在页面设计选项卡上,在视图组中,从视图列表中删除的视图。

  2. 页面设计选项卡的视图组中,单击删除

  3. 当系统提示您要删除的视图,请单击

返回页首

更改默认视图

每个窗体具有默认视图。在打开基于窗体的窗体时,用户将看到此视图。如果您创建自定义窗体视图,您可以选择其可用视图将您的用户的默认视图。

  1. 选择您想要查看在页面设计选项卡上,在视图组中,从视图列表中的默认视图。

  2. 页面设计选项卡的视图组中,单击属性

  3. 选择设置为默认视图复选框,然后单击确定

如果表单具有只有一个视图然后被自动指定为默认视图。

返回页首

重命名视图

  1. 选择要在页面设计选项卡上,在视图组中,从视图列表中重命名的视图。

  2. 页面设计选项卡的视图组中,单击属性

  3. 查看属性对话框中,在视图名称文本框中键入选项卡的新名称,然后单击确定

注意: 如果您重命名与自定义代码相关联的视图,该代码可能不会按预期工作。若要修复此问题,必须在代码中查找所有引用到旧视图的名称,并更新它们以新视图的名称。

返回页首

添加用于切换视图的按钮

视图通常用于处理规则。规则使您能够自动执行某些任务在响应事件或填写表单的人员发起的操作。例如,可以在窗体上插入按钮,并创建的规则,单击按钮,并在窗体中插入按钮后,您可以将相关联规则与按钮,以便在用户单击它时,它切换视图时切换视图。

更具体地说,保险索赔表单中,您可能在打开的高级视图索赔数据时,单击显示摘要按钮。摘要视图中,用户无法然后单击显示的详细信息按钮以返回到更详细的视图。同样,如果您有很长的窗体,可以将其分为多个视图和添加下一步,后退按钮或选项卡式的导航若要允许用户导航窗体上。

  1. 每个视图中插入按钮。

若要完成以下过程,您必须具有两个现有视图的窗体。

  1. 选择您想要向其中添加按钮在页面设计选项卡的视图组中,从视图列表的视图。

  2. 将光标放在窗体上您要在其中插入按钮。

  3. 开始选项卡上,在控件组中,选择按钮

  4. 控件工具中,单击功能区中的属性选项卡。

  5. 标签框中,为按钮,键入一个名称,然后单击确定

  • 创建规则的视图之间进行切换。

    1. 选择按钮。

    2. 管理工具属性选项卡的规则组中,单击添加规则

      添加、 删除,并在窗体视图切换

    3. 选择此按钮,然后从操作列表中选择切换视图

    4. 视图文本框中,选择要在单击按钮时显示的视图,然后单击确定

      添加、 删除,并在窗体视图切换

  • 重复步骤 1 和 2 以创建其他按钮和每个视图的相应规则。

  • 您已添加到您的视图的按钮,并创建所需的规则后,建议您测试窗体以确保预期方式工作。

  • 开始选项卡的窗体组中,单击预览

  • 单击按钮以确保您是能够为所需的视图之间切换。

    已最近处理的大多数视图是将显示预览窗口中,在视图,除非创建的规则以基于用户的角色在窗体加载视图切换。

注意: 在只读视图按钮不可用。使用图片按钮只读视图,如 SharePoint 列表表单,在显示视图中导航和清除从功能区的属性选项卡上控件属性对话框的隐藏只读视图中的图片按钮复选框。

返回页首

显示使用窗体加载规则的视图

当用户打开窗体时,该视图可以是特定于该用户或其他条件。例如,如果您要设计一个表单,包括用户角色,并包含多个视图,它可用于显示基于用户角色分配给用户的视图。具体而言,规则可用于分配给特定用户角色的用户打开基于窗体的窗体时显示的视图。

仅可在 InfoPath filler 为设计的表单中使用用户角色。若要切换视图基于 web 的组成员身份启用窗体,请考虑创建窗体加载规则来使用的用户配置文件的 Web 服务,以确定用户成员getUserMemberships 方法。

此过程假定您拥有您的窗体中定义的用户角色。如果您没有在表单中至少一个用户角色,从数据选项卡添加用户角色开始此过程之前。

  1. 数据选项卡上的规则组中,单击窗体加载

  2. 单击新建,单击操作,然后在详细信息文本框中输入规则的名称。

  3. 要让窗体加载基于用户角色的视图,请单击条件部分下的链接。在第一个列表中,单击用户当前的角色,然后选择用户的角色。

您可以选择其他选项,具体取决于您想要影响加载窗体的方式的条件。

添加、 删除,并在窗体视图切换

  1. 单击“确定”。

  2. 单击添加按钮,然后选择切换视图

添加、 删除,并在窗体视图切换

  1. 视图列表中,单击所需,视图,然后单击确定

返回页首

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×