步骤 4 - 与他人共享宏

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

有关共享宏需要了解的一个重点是,宏存储在 Office 文件中,所以你需要与其他人共享该文件。 如果宏是在 Word 中创建的,则需要将其保存为启用宏的 Word 模板 (.dotm) 或启用宏的 Word 文档 (.docm)。 如果宏是在 Excel 中创建的,则需要将其保存为启用宏的 Excel 工作簿 (.xlsm) 或启用宏的 Excel 模板 (.xltm)。

如果创建了 Word 宏,还需要执行一些步骤才能共享该宏:

创建空白 Word 模板

  1. 打开一个新的 Word 文档。

  2. “文件”菜单上,单击“另存为”

  3. 将该文件命名为 global_macros.dotm。

  4. 从“格式”下拉菜单中选择“启用宏的 Word 模板 (*.dotm)”作为“格式”。

  5. 选择文件在网络中的存储位置。

  6. 单击“保存”,然后关闭模板。

从文档中导出 Word 宏

对“步骤 1”中录制的宏执行下列步骤,以便导出该宏:

  1. 打开包含要导出的宏的文档或模板。

  2. 在“工具”菜单上,指向“”,然后单击“”。

  3. 选择要导出的宏,然后单击“编辑”。 选择要导出的宏

  4. 在 Visual Basic 编辑器中,单击“文件”>“导出文件”。

  5. 将该宏与启用宏的模板 global_macros . dotm 保存在同一个文件夹中。

将 Word 宏导入新空白模板中

  1. 打开 global_macros.dotm,然后单击“工具”>“”>“Visual Basic 编辑”。

  2. 要导入该宏,请单击“文件”>“ 导入文件”,转到宏导出到的文件夹,选择该文件,然后单击“打开”。

  3. 保存模块,退出 Visual Basic 编辑器,然后退出 Word。

现在,你可以与他人共享你的宏,告诉他们按照下面的步骤将该宏安装在他们的计算机上。

安装模板:将 Word 设置为使用你的宏

  1. 将 global_macro.dotm 文件放到下面的位置中:

    • Word for Mac 2011:Macintosh HD: Users: Username: Library: Application Support: Microsoft: Office: User Templates: My Templates

    • Windows 上的 Word 2003 或更高版本:C:\Documents and Settings\Username\Application Data\Microsoft\Word\STARTUP

      注意:  Username 是用户的登录名。

  2. 在 Word 中,单击“Word”>“首选项...”。

Word 首选项

  1. 在“个人设置”区域中,单击“文件位置”。 

  2. 从“文件位置”列表选择“启动”,然后单击“修改…”。

文件位置

  1. 验证 Word 是否将你放置 global_macro.dotm 文件的同一个文件夹用作“启动”文件夹。

  2. 单击“选择”以关闭“选择文件夹”对话框,然后单击“确定”以关闭“文件位置”对话框。

最后一步是告诉 Word 启动时使用 global_macros.dotm 文件。

  1. 在 Word 中,单击“工具”>“模板和加载项...”。

  2. 从列表中选中 global_macros.dotm 文件,然后单击“确定”。

    提示:  如果在该列表中看不到你的模板,说明 Word 启动文件夹中不包含你的 global_macros.dotm file 文件。 请返回到本部分中的步骤 1,验证“启动”文件夹是否是你将 global_macros.dotm 文件复制到的同一个文件夹。

在 Word 中设置全局模板

 步骤 1 - 从宏录制器入手

步骤 2 - 阅读和理解代码

步骤 3 - 了解编程基础知识

步骤 4 - 与他人共享宏

步骤 5 - 实际示例

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×