检查拼写和语法在 Office for Mac

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

键入时,office for Mac 应用程序自动检查潜在的拼写和语法错误。如果您希望等待以检查拼写和语法,直到完成编写,您可以关闭自动检查,或可以一次性检查拼写和语法。

注意: 有关检查拼写和语法在 Office for Windows 中的信息,请参阅检查拼写和语法在 Office 2010 和更高版本

Word 2016 for Mac

Word 自动检查并标记潜在的拼写错误,使用红色波浪线。

拼写错误标有红色波浪线

Word 也会检查,并标记潜在的语法错误,使用绿色波浪线。

语法错误标有绿色波浪线

提示: 如果未标记拼写或语法错误,可能需要打开自动拼写和语法检查

看到拼写或语法错误时,请按住 Control 并单击相应单词或短语,然后选择其中一个选项。

语法错误带有显示更正选项的上下文菜单

  1. 在“Word”菜单上,单击“首选项”>“拼写和语法”。

  2. 在“拼写和语法”对话框中的“拼写”下,选中或清除“键入时检查拼写”框。

  3. 在“语法”下,选中或清除“键入时检查语法”复选框。

  4. 关闭对话框保存所做更改。

  1. 在“审阅”选项卡上,单击“拼写和语法”。

  2. 如果 Word 找到了潜在错误,将打开“拼写和语法”对话框,而拼写错误将显示为红色文本,语法错误则显示为绿色文本。

  3. 要修正错误,请执行下列操作之一:

    • 在框中键入更正内容,然后单击“更改”。

    • 在“建议”下,单击要使用的单词,然后单击“更改”。

    要跳过错误,请执行下列操作之一:

    • 单击“忽略”仅跳过该错误的此实例。

    • 单击“全部忽略”跳过该错误的所有实例。

    • 对于语法错误,单击“下一句”跳过该错误的此实例,移动到下一个错误。

    要在所有文档中跳过某个拼写错误的单词,请单击“添加”将其添加到词典。 这仅适用于拼写错误的单词。 不能向词典添加自定义语法。

  4. 更正、忽略或跳过错误后,Word 将移至下一项。 Word 审阅完文档后,你将看到一条消息,说明已完成了拼写和语法检查。

  5. 请单击“确定”返回到文档。

您可以清除或重置忽略的单词和语法的列表,以便 Word 检查拼写和语法问题以前判断其忽略。

注意: 当你重置忽略的字词和语法列表时,将仅清除当前打开的文档的列表。 你在其他文档中指示 Word 忽略的任何拼写或语法问题不会受到影响。

  1. 打开需要检查的文档。

  2. 在“工具”菜单上,指向“拼写和语法”,然后单击“重置忽略的字词和语法”。

    要清除 Word 忽略的字词和语法的列表,请单击“重置忽略的字词和语法”。

    Word 会显示一条有关重置拼写检查和语法检查的操作的警告。

    通过单击“是”,让 Word 检查你之前指示 Word 忽略的拼写和语法。
  3. 单击以继续。

  4. 单击“审阅”选项卡,然后单击“拼写和语法”以检查拼写和语法。

Outlook 2016 for Mac

默认情况下,Outlook 会检查拼写错误键入时。Outlook 使用红色虚线的下划线指示可能出现拼写错误和绿色虚线表示可能的语法错误。

拼写错误标有红色虚线下划线

  1. 当您看到带有虚线下划线的单词时,控件单击相应单词或短语,然后选择其中一个选项。

    拼写错误带有显示更正选项的菜单

  2. 在快捷菜单上,执行下列操作之一:

    • 单击快捷菜单顶部的其中一个猜测。

    • 单击忽略拼写检查忽略的单词一个实例。

    • 单击学习拼写将单词添加到拼写词典。

后打开电子邮件:

  • 若要关闭自动拼写检查打开或关闭,在编辑菜单上,指向拼写和语法,,然后单击键入时检查拼写

  • 若要关闭自动语法检查打开或关闭,在编辑菜单上,指向拼写和语法,,然后单击随拼写检查语法

  • 若要让 Outlook 自动更正拼写错误,在编辑菜单上,指向拼写和语法,,然后单击自动更正拼写

在编辑选项 > 拼写和语法菜单

可以在撰写完邮件或其他项之后,集中更正所有拼写和语法错误。

  1. 在“编辑”菜单上,指向“拼写和语法”,然后单击“显示拼写和语法”。

  2. 请执行以下任一操作:

    • 选择检查语法复选框以打开语法检查。

    • 在建议列表中,单击要使用,或在顶部的框中输入新拼写的单词,然后单击更改

    • 单击忽略以忽略该单词,移动到下一个拼错的单词。

    • 单击了解详细信息添加到拼写词典的单词。

提示: 用于跳至下一个拼写或语法错误的键盘快捷方式是 COMMAND + ;。

另请参阅

在 Office 2016 for Mac 中检查其他语言的拼写和语法

我不希望或不期望在 Word 2016 for Mac 标记拼写或语法检查器标记的文本

添加词添至您的拼写检查词典中 Word 2016 for Mac

在 Office for Mac 中使用自定义词典

Word for Mac 2011

Word 使用红色下划线指明拼写错误和绿色的行,以指示语法错误。

  1. 按住 CONTROL,单击带有红色下划线的字词。

  2. 在快捷菜单中,执行下列任意操作。

    若要

    单击

    使用任一建议字词更正拼写错误

    拼写建议。

    从展开的建议列表中选择

    依次在“拼写”和“建议”框中,双击某个字词。

    更正拼写自己

    选择和编辑文档中的文本。

    注意: 如果看不到所需的建议列表中的单词,您可以查找 Office 词典中的某个字词。若要执行此操作,在工具菜单上,单击词典

  1. 按住 CONTROL,单击带有红色下划线的字词。

  2. 在快捷菜单中,执行下列任意操作。

    若要

    单击

    忽略该词的这一个实例

    忽略

    忽略文档中的所有字词实例

    全部忽略

    将该字词添加到你的词典中,以使 Microsoft Office 将其识别为正确拼写的字词

    添加

  1. 在“Word”菜单上,单击“首选项”。

  2. 在“创作和校对工具”下,单击“拼写和语法”。

  3. 在“拼写”下,清除“键入时检查拼写”复选框。

  1. 按住 CONTROL,单击带有绿色波浪下划线的短语。

  2. 执行下列操作之一。

    若要

    执行此操作

    使用任一建议更正语法错误

    在快捷菜单上,单击所需的更正。

    提示: 有关某个语法错误的详细信息,请单击“语法”。 在“语法”对话框的顶部将显示错误说明,如“主谓一致”。

    通过自己更改文字来更正语法错误

    选择和编辑文档中的文本。

  1. 按住 CONTROL,单击带有绿色波浪下划线的短语。

  2. 在快捷菜单上,单击“忽略”。

  1. 在“Word”菜单上,单击“首选项”。

  2. 在“创作和校对工具”下,单击“拼写和语法”。

  3. 在“语法”下,清除“键入时检查语法”复选框。

Outlook

Outlook使用红色虚线下划线指示可能出现拼写错误。

默认情况下,Outlook 会在键入时检查拼写错误。Outlook 使用红色虚线下划线指示可能的拼写错误。

  1. 如果看到某个单词带有红色虚线下划线,请按住 CONTROL,然后单击该单词。

  2. 在快捷菜单中,请执行下列操作之一。

    若要

    要执行的操作

    从建议的更正列表中选择

    单击快捷菜单顶部的其中一个猜测。

    删除单词一个实例的红色虚线下划线

    单击“忽略拼写”。

    向拼写词典添加单词

    单击“学习拼写”。

注意: 若要关闭自动拼写检查,请在“编辑”菜单上,指向“拼写和语法”,然后清除“键入时检查拼写”旁边的复选标记。

如果需要,Outlook 可以自动更正某些经常拼写错误的单词。例如,如果键入“freind”,Outlook 会将其更改为“friend”。

注意: 只有 Mac OS X v10.6 (Snow Leopard) 或更高版本提供此功能。

  • 在“编辑”菜单上,指向“拼写和语法”,然后单击“自动更正拼写”。

Outlook 可在键入时检查语法错误。Outlook 使用绿色虚线下划线指示可能的语法错误。

  • 在“编辑”菜单上,指向“拼写和语法”,然后单击“随拼写检查语法”。

可以在撰写完邮件或其他项之后,集中更正所有拼写和语法错误。

  1. 在“编辑”菜单上,指向“拼写和语法”,然后单击“显示拼写和语法”。

  2. 执行下列任一操作。

    若要

    执行此操作

    打开语法检查

    选中“检查与法”复选框

    更正拼写错误的单词

    在建议列表中,单击要使用的单词,然后单击“更改”。

    忽略该单词,移动到下一个拼写错误的单词

    单击“忽略”。

    向拼写词典添加字词

    单击“学习”。

提示: 用于跳至下一个拼写或语法错误的键盘快捷方式是 COMMAND + ;。

PowerPoint

可在 PowerPoint 中检查拼写,但不能检查语法。

  1. 在“工具”菜单上,单击“拼写检查”。

    注意: 如果未检测到拼写错误,或者字典中已经包含你在尝试的单词,将不打开“拼写检查”对话框。

  2. 执行下列任一操作。

    若要

    执行此操作

    更改单词

    在“建议”下,单击要使用的单词,然后单击“更改”。

    更改这个文档中出现的所有该单词

    在“建议”下,单击要使用的单词,然后单击“全部更改”。

    忽略该单词,移动到下一个拼写错误的单词

    单击“忽略”。

    忽略此文档中出现的所有此单词,移动到下一个拼写错误的单词

    单击“全部忽略”。

你可以在文档中键入时检查拼写错误,以便你在工作时发现并更正。

  1. 要开始检查拼写错误,只需开始在文档中键入。

    Office for Mac 2011 通过红色波浪下划线指示疑似拼写错误。

  2. 要更正拼写错误,请按住 CONTROL,单击带有红色波浪下划线的单词,然后在快捷方式菜单上,单击建议更正列表内要使用的单词。

    注意: 默认情况下,键入时自动检查拼写。若要禁用此行为,请在“PowerPoint”菜单中,依次单击“首选项”、“拼写检查”选项卡,然后清除“键入时检查拼写”复选框。

Excel

可在 Excel 中检查拼写,但不能检查语法。

  1. 在“审阅”选项卡中的“校对”下,单击“拼写检查”。

    "审阅"选项卡,"校对"组

    注意: 如果未检测到拼写错误,或者字典中已经包含你在尝试的单词,将不打开“拼写检查”对话框。

  2. 执行下列任一操作。

    若要

    执行此操作

    更改单词

    在“建议”下,单击要使用的单词,然后单击“更改”。

    更改这个文档中出现的所有该单词

    在“建议”下,单击要使用的单词,然后单击“全部更改”。

    忽略该单词,移动到下一个拼写错误的单词

    单击“忽略”。

    忽略此文档中出现的所有此单词,移动到下一个拼写错误的单词

    单击“全部忽略”。

另请参阅

Word for Mac 2011 中无法使用拼写检查

使用自定义词典

使用不同语言检查拼写和语法

每种语言的可用校对工具

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×