更改三维图表的显示

若要使三维图表(例如三维柱形图、三维折线图或三维曲面图)更易于阅读,您可以更改图表的三维格式、旋转和缩放。)。

对于在三维情况下不使用第三个的图表元素的图表(如3d 中的饼图、三维图表中的饼图或三维图表的堆积区域),您可以更改三维图表元素的三维格式。 但是,3D 旋转和缩放选项对单个图表元素不可用,您只能更改整个图表的三维旋转和缩放。

显示水平坐标轴、垂直坐标轴和竖坐标轴的三维图表

如果较小的数据标记隐藏在三维图表中的较大区域之后,则可以反转图表中绘制的 数据系列 的顺序,也可以使用透明度来改善所有数据标记的可见性。

注意: 

  • 此处的示例来自 Excel,但图表也在 Word、PowerPoint 和 Outlook 中可用。 如果你使用其中一个程序,这些功能是相同的,但是在获取初始图表时可能稍有不同。

  • 以下过程适用于 Office 2013 和更新的版本。 Office 2010 步骤

创建三维图表

  1. 在工作表上,选择包含要用于图表的数据的单元格。

  2. 在 "插入" 选项卡上,如果只看到图标,或者单击要使用的图表,请单击 "图表"。

    Excel 图表按钮

您也可以单击 "图表" 部分右下角的 "查看所有图表" 图标。 这将打开 "图表" 对话框,您可以在其中选择任意图表类型。 每个类别通常都显示2D 和3D。 选择一个。

更改图表元素的三维格式

  1. 在三维图表上,单击要更改三维格式的图表元素(如条形图或线条),或执行下列操作以从图表元素列表中选择它。

    1. 单击图表。
      这将显示 "图表工具"、"设计" 和 "格式" 选项卡。

    2. 在“格式”选项卡的“当前所选内容”组中,单击“图表元素”框旁边的箭头,然后单击要使用的图表元素。

      突出显示元素选择的当前选择区域

  2. 键盘快捷方式您可以改为单击要更改其三维格式的图表元素,然后按 CTRL + 1。 继续执行步骤3。

  3. 在 "当前选择" 组中,单击 "设置所选内容格式"。

  4. 单击 "效果",单击 "三维格式",然后选择以下一个或多个选项。

    "图表效果" 按钮

    1. 单击 "顶部棱台" 或 "底部棱台",然后单击要使用的棱台格式。

      在 "宽度" 和 "高度" 框中,选择要使用的磅值。

    2. 单击 "材料",然后单击要使用的效果。

    3D 格式设置

    注意: 这些选项的可用性取决于所选的图表元素。 此对话框中显示的某些选项对所有图表不可用。

    此对话框中的设置将对所选图表元素进行操作。 如果选择整个图表,则会创建框架,而如果选择了数据系列,它将仅适用于该系列的元素。

更改三维图表中的深度和间距

你可以更改具有坐标轴的三维图表中的图表深度、三维透视图表中的间距深度以及三维条形图或柱形图中的分类间距。

  1. 单击要更改的三维图表。

  2. 在 "格式" 菜单上,单击 "数据系列"。

  3. 在 "设置数据系列格式" 选项卡上,单击 "系列选项",然后选择要使用的 "深度" 和 "宽度" 选项。

    设置数据系列间距深度和宽度属性

注意: 这些选项的可用性取决于所选的图表元素。 此对话框中显示的某些选项对图表不可用。

更改三维图表的旋转

  1. 单击要旋转的三维图表的图表区域,或从 "格式" 选项卡上 "当前选定内容" 下的 "图表元素" 列表中选择 "图表区"。

  2. 键盘快捷方式您可以改为单击图表区域,然后按 CTRL + 1。 继续执行步骤3。

  3. 在 "设置图表区域格式" 选项卡上,单击 "效果",然后单击 "三维旋转"。

    "图表效果" 按钮

  4. 执行下列一项或多项操作:

    3D 旋转属性

    1. 若要更改旋转,请在 " X 旋转" 和 " Y 旋转" 框中单击所需的旋转度数。

      注意: 图表可以围绕水平轴和垂直轴旋转,但永远不围绕深度轴。 因此,不能在Z框中指定旋转角度。

    2. 若要更改图表上的视图字段,请在 "透视" 框中单击所需的透视角度,或单击 "视图" 按钮的 "缩小" 字段或 "视图" 按钮扩大字段,直到达到所需的结果。

      视图按钮的字段

      注意: 此对话框中显示的某些选项对图表不可用。 您不能将已更改的选项重置为以前的设置。

更改三维图表的比例

可以通过将三维图表的高度和深度指定为图表基础的百分比来更改三维图表的比例。

  1. 单击要更改的三维图表的图表区域,或从 "格式" 选项卡上 "当前选定内容" 下的 "图表元素" 列表中选择 "图表区"。

  2. 键盘快捷方式您可以改为单击图表区域,然后按 CTRL + 1。 继续执行步骤3。

  3. 在 "设置图表区域格式" 对话框中,单击 "三维旋转"。

    3D 旋转属性

  4. 在 "三维旋转属性" 中,执行下列操作之一:

    1. 若要更改图表的深度,请在 "深度百分比" (底数百分比)框中指定深度百分比。

    2. 若要更改图表的深度和高度,请清除 "自动缩放" 复选框,然后在 "深度" ("百分比")和 "高度" ("基数百分比" 框中指定所需的深度和高度的百分比。

    3. 若要使用直角轴视图,请选中 "直角坐标" 复选框,然后在 "深度百分比" (底数百分比)框中指定所需的深度百分比。

反转三维图表中数据系列的顺序

你可以更改数据系列的绘制顺序,以便大型三维数据标记不会阻止较小的数据标记。

以相反顺序显示的三维图表

  1. 在图表上,单击 "深度" 轴,或从 "格式" 选项卡上 "当前选定内容" 下的 "图表元素" 列表中选择 "深度坐标轴"。

  2. 在“格式”选项卡上的“当前所选内容”组中,单击“设置所选内容格式”。

  3. 在 "坐标轴选项" 类别中的 "坐标轴选项" 下,选中 "系列次序反转" 复选框。

    3D 序列反转顺序选项

在三维图表中使用透明度

尽管透明度可在三维图表和二维图表中使用,但在三维图表中,较大的数据标记可能会遮住较小的数据标记尤其有用。

  1. 在三维图表中,单击要使其成为透明的数据系列或数据点,或从 "格式" 选项卡上 "当前所选内容" 下的 "图表元素" 列表中选择数据系列。

  2. 键盘快捷方式您可以改为单击要更改其三维格式的图表元素,然后按 CTRL + 1。 继续执行步骤3。

  3. 在“格式”选项卡上的“当前所选内容”组中,单击“设置所选内容格式”。

  4. 单击 "填充 & 线条",单击 "填充",然后单击 "纯色填充"、"渐变填充" 或 "图片或纹理填充"。

    填充和线条属性

  5. 如果想要更改元素的颜色,请单击并选择一种颜色。

  6. 单击透明条上的控点,然后将其滑动到要使用的透明度百分比。

在 Office 2010 中创建散点图或折线图

  1. 在工作表上,选择包含要用于图表的数据的单元格。

  2. 在“插入”选项卡上的“图表”组中,执行下列操作之一:

    Excel 功能区图像

    • 若要创建三维柱形图,请单击 "",然后在 "三维柱形图" 下,单击 "三维柱形图"。

    • 若要创建三维圆柱图,请单击 "",然后在 "柱面" 下单击 "三维圆柱图"。

    • 若要创建三维圆锥图,请单击 "",然后在 "圆锥" 下,单击 "三维圆锥"。

    • 若要创建三维棱锥图,请单击 "",然后在 "棱锥图" 下,单击 "三维棱锥图"。

    • 若要创建三维折线图,请单击 "线条",然后在 "三维折线图" 下,单击 "三维线条"。

    • 若要创建三维面积图,请单击 "区域",然后在 "三维区域" 下,单击 "三维区域"。

    • 若要创建三维曲面图,请单击 "其他图表",然后在 "图面" 下,单击 "三维曲面" 或 "线框 3-d 曲面"。

      提示: 当您将鼠标指针停留在任何图表类型或图表子类型上时,屏幕提示将显示图表类型的名称。 有关可用图表类型的详细信息,请参阅可用图表类型

  1. 在三维图表上,单击要更改其三维格式的图表元素,或执行下列操作以从图表元素列表中选择它。

    1. 单击图表。
      这将显示 "图表工具"、"设计"、"布局" 和 "格式" 选项卡。

    2. 在“格式”选项卡的“当前所选内容”组中,单击“图表元素”框旁边的箭头,然后单击要使用的图表元素。

      Excel 功能区图像

  2. 键盘快捷方式您可以改为单击要更改其三维格式的图表元素,然后按 CTRL + 1。 继续执行步骤3。

  3. 在“布局”选项卡上的“当前所选内容”组中,单击“设置所选内容格式”。

  4. 单击 "三维格式",然后选择下列一个或多个选项。

    1. 在 "棱台" 下,单击 "顶部" 和 "底部",然后单击要使用的棱台格式。 在 "宽度" 和 "高度" 框中,选择要使用的磅值。

    2. 在 "表面" 下,单击 "材料",然后单击要使用的效果。

      注意: 这些选项的可用性取决于所选的图表元素。 此对话框中显示的某些选项对图表不可用。

提示: 您也可以使用此过程更改二维图表中的图表元素的三维格式。

你可以更改具有坐标轴的三维图表中的图表深度、三维透视图表中的间距深度以及三维条形图或柱形图中的分类间距。

  1. 单击要更改的三维图表。

  2. 在 "格式" 菜单上,单击 "数据系列"。

  3. 在 "选项" 选项卡上,选择要使用的 "深度" 和 "宽度" 选项。

  1. 单击要旋转的三维图表的图表区域,或执行下列操作以从图表元素列表中选择图表区域:

    1. 单击图表。
      这将显示 "图表工具"、"设计"、"布局" 和 "格式" 选项卡。

    2. 在“格式”选项卡的“当前所选内容”组中,单击“图表元素”框旁边的箭头,然后单击要使用的图表元素。

      Excel 功能区图像

  2. 键盘快捷方式您可以改为单击图表区域,然后按 CTRL + 1。 继续执行步骤3。

  3. 在 "布局" 选项卡上的 "背景" 组中,单击 "三维旋转"。

    Excel 功能区图像

  4. 在 "三维旋转" 类别中的 "旋转" 下,执行下列一项或多项操作:

    1. 若要更改旋转,请在 " X " 和 " Y " 框中单击所需的旋转度数。

      注意: 图表可以围绕水平轴和垂直轴旋转,但永远不围绕深度轴。 因此,不能在Z框中指定旋转角度。

    2. 若要更改图表上的视图字段,请在 "透视" 框中单击所需的透视角度,或单击 "视图" 按钮的 "缩小" 字段或 "视图" 按钮扩大字段,直到达到所需的结果。

      注意: 此对话框中显示的某些选项对图表不可用。 您不能将已更改的选项重置为以前的设置。

可以通过将三维图表的高度和深度指定为图表基础的百分比来更改三维图表的比例。

  1. 单击要更改的三维图表的图表区域,或执行下列操作以从图表元素列表中进行选择:

    1. 单击图表。
      这将显示 "图表工具"、"设计"、"布局" 和 "格式" 选项卡。

    2. 在“格式”选项卡的“当前所选内容”组中,单击“图表元素”框旁边的箭头,然后单击要使用的图表元素。

      Excel 功能区图像

  2. 键盘快捷方式您可以改为单击图表区域,然后按 CTRL + 1。 继续执行步骤3。

  3. 在 "布局" 选项卡上的 "背景" 组中,单击 "三维旋转"。

    Excel 功能区图像

  4. 在 "三维旋转" 类别中的 "图表缩放比例" 下,执行下列操作之一:

    1. 若要更改图表的深度,请在 "深度百分比" (底数百分比)框中指定深度百分比。

    2. 若要更改图表的深度和高度,请清除 "自动缩放" 复选框,然后在 "深度" ("百分比")和 "高度" ("基数百分比" 框中指定所需的深度和高度的百分比。

    3. 若要使用直角轴视图,请选中 "直角坐标" 复选框,然后在 "深度百分比" (底数百分比)框中指定所需的深度百分比。

你可以更改数据系列的绘制顺序,以便大型三维数据标记不会阻止较小的数据标记。

以相反顺序显示的三维图表

  1. 在图表上,单击 "深度" 轴,或执行下列操作,从图表元素列表中选择它:

    1. 单击图表。
      这将显示 "图表工具"、"设计"、"布局" 和 "格式" 选项卡。

    2. 在“格式”选项卡的“当前所选内容”组中,单击“图表元素”框旁边的箭头,然后单击要使用的图表元素。

      Excel 功能区图像

  2. 在“格式”选项卡上的“当前所选内容”组中,单击“设置所选内容格式”。

  3. 在 "坐标轴选项" 类别中的 "坐标轴选项" 下,选中 "系列次序反转" 复选框。

尽管透明度可在三维图表和二维图表中使用,但在三维图表中,较大的数据标记可能会遮住较小的数据标记尤其有用。

  1. 在三维图表中,单击要使其成为透明的数据系列或数据点,或执行下列操作以从图表元素列表中选择它:

    1. 单击图表。
      这将显示 "图表工具"、"设计"、"布局" 和 "格式" 选项卡。

    2. 在“格式”选项卡的“当前所选内容”组中,单击“图表元素”框旁边的箭头,然后单击要使用的图表元素。

      Excel 功能区图像

  2. 键盘快捷方式您可以改为单击要更改其三维格式的图表元素,然后按 CTRL + 1。 继续执行步骤3。

  3. 在“布局”选项卡上的“当前所选内容”组中,单击“设置所选内容格式”。

  4. 单击 "填充",然后单击 "纯色填充"、"渐变填充" 或 "图片或纹理填充"。

  5. 单击透明条上的控点,然后将手柄滑动到要使用的透明度百分比。

了解如何在 Word for mac、PowerPoint for Mac 和 Excel for Mac 中更改三维图表的旋转或透视。

注意: 虽然 Word 和 PowerPoint 中的功能相同,但在 Excel 中已执行以下过程中的屏幕截图。

  1. 单击图表,然后单击功能区上的 "格式" 选项卡。

  2. 单击 "形状效果",然后单击 "三维旋转",然后单击 "三维旋转选项"。

    三维旋转选项
  3. 在 "设置图表区域格式" 窗格的 "三维旋转" 部分中,执行下列操作:

    "设置图表区域格式" 窗格
    1. 若要更改旋转,请在 " X 旋转" 和 " Y 旋转" 框中输入旋转度。

    2. 若要更改透视角度,请在 "视角" 框中输入所需的透视角度。 你还可以使用 缩小 "查看" 图标的字段"视图" 图标的 "扩大" 字段 箭头缩小或放宽视图的字段。

注意:  本页面是自动翻译的,可能包含语法错误或不准确之处。 我们的目的是使此内容能对你有所帮助。 能否告知我们此信息是否有所帮助? 下面是该参考内容的英文版

另请参阅

更新现有图表中的数据

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×