教程:在 Excel 2013 中使用数据模型执行数据透视表数据分析

只需不到 1 个小时的时间,您就可以在 Excel 中构建组合多个表中的数据的数据透视表。本教程的第一部分指导您逐步完成数据导入和浏览过程。在第二部分中,您将使用 Power Pivot 加载项优化报表背后的数据模型,了解如何为 Power View 报表添加计算、层次结构和优化。

导入一些数据

需要一些数据才能创建数据透视表。我们从下载的示例数据库获得一些销售数据。

  1. 下载本教程的示例数据 (ContosoV2)。有关详细信息,请参阅获取针对 DAX 和数据模型教程的示例数据。提取数据文件并保存到易于访问的位置,例如“下载”或“我的文档”文件夹。

  2. 在 Excel 中,打开一个空白工作簿。

  3. 单击“数据”>“获取外部数据”>“从 Access”。

  4. 转到包含示例数据文件的文件夹,然后选择 ContosoSales

  5. 单击“打开”。由于您是连接到包含多个表的数据库文件,“选择表”对话框将会显示,以便您可以选择要导入的表。

    “选择表”对话框

  6. 在“选择表”中,选中“支持选择多个表”。

  7. 选择所有表,然后单击“确定”。

  8. 在“导入数据”中,单击“数据透视表”,然后单击“确定”。

发生了什么情况?

您可能还未意识到您刚才已经创建了一个数据模型。该模型是当您在相同数据透视表中同时导入或使用多个表时自动创建的。模型在 Excel 中大多数是透明的,但是您可以使用 Power Pivot 加载项直接查看和修改它。在 Excel 中,当您在“数据透视表字段”列表中看到表的集合时,则表示存在数据模型。可以通过多种方式创建模型。有关详细信息,请参阅在 Excel 中创建数据模型

使用数据透视表浏览数据

当您将字段拖动到数据透视表字段列表上的“”、“”和“”区域时,浏览数据非常轻松。

  1. 在字段列表中,向下滚动,直到找到 FactSales 表。

  2. 单击“SalesAmount”。由于此数据为数值,Excel 会自动将 SalesAmount 放入“值”区域。

  3. 在 DimDate 中,将 CalendarYear 拖至“列”。

  4. 在 DimProductSubcategory 中,将 ProductSubcategoryName 拖至“行”。

  5. 在 DimProduct 中,将 BrandName 拖至“行”中的子类别之下。

数据透视表应该与以下画面相似。

显示示例数据的数据透视表

您现在已经轻而易举地构建了一个包含来自四个不同表中的字段的基本数据透视表。由于表之间已经预先存在关系,执行此任务非常简单。由于表关系已存在于源中,并且您在单个操作中导入了所有表,Excel 可以在模型中重新创建这些关系。

但是,如果数据来自不同源或以后导入,该怎么办?通常,您可以通过基于匹配列创建关系来合并新数据。在下一步中,您将导入其他表,并了解创建新关系的要求和步骤。

添加更多表

了解如何设置表关系要求您具有其他一些要使用的未连接的表。在此步骤中,您将通过导入一个附加数据库文件并从其他两个工作簿粘贴数据来获得本教程中使用的其余数据。

添加产品类别

  1. 在工作簿中打开一个新的工作表。您将使用它存储其他数据。

  2. 单击“数据”>“获取外部数据”>“从 Access”。

  3. 转到包含示例数据文件的文件夹,然后选择 ProductCategories。单击“打开”。

  4. 在“导入数据”中,选择“”,然后单击“确定”。

添加地理数据

  1. 插入另一个工作表。

  2. 从示例数据文件中,打开 Geography.xlsx,将光标置于 A1,然后同时按 Ctrl-Shift-End 选择所有数据。

  3. 将数据复制到剪贴板。

  4. 将数据粘贴到您刚添加的空工作表中。

  5. 单击“套用表格格式”,选择任意样式。将数据格式设置为表将允许您为其命名,供您在后续步骤中定义关系时使用。

  6. 在“套用表格格式”中,确认已选定“表包含标题”。单击“确定”

  7. 将该表命名为 Geography。在“表格工具”>“设计”中,在“表名称”中键入 Geography。

  8. 关闭 Geography.xlsx,将其从您的工作区中清除。

添加商店数据

  • 对于 Stores.xlsx 文件重复执行上述步骤,将其内容粘贴到空工作表中。将该表命名为 Stores。

您现在应该有四个工作表。Sheet1 包含数据透视表,Sheet2 包含 ProductCategories,Sheet3 包含 Geography,Sheet4 包含 Stores。由于您已经花时间为每个表命名,所以在下一步中创建关系时将会简单得多。

使用新导入的表中的字段

您可以立即开始使用您刚刚导入的表中的字段。如果 Excel 无法确定如何将字段合并到数据透视表中,您需要创建一个表关系来将新表与属于模型既有的一部分的表相关联。

  1. 在数据透视表字段的顶部,单击“全部”以查看可用表的完整列表。

  2. 滚动到当前页的底部。这是您将找到刚刚添加的新表的位置。

  3. 展开 Stores。

  4. 将 StoreName 拖动到“筛选器”区域。

  5. 请注意,Excel 会提示您创建关系。出现此通知的原因是您曾使用过与模型不相关的表中的字段。

  6. 单击“创建”以打开“创建关系”对话框。

  7. 在“表”中,选择 FactSales。在您正在使用的示例数据中,FactSales 包含有关 Contoso 业务的详细销售和成本信息以及指向其他表的键,包括您在上一步中导入的 Stores.xlsx 文件中已经存在的商店代码。

  8. 在“列(外来)”中,选择 StoreKey。

  9. 在“相关表”中,选择 Stores。

  10. 在“相关列(主要)”中,选择 StoreKey。

  11. 单击“确定”

在后台,Excel 正在构建可在整个工作簿中任意数目的数据透视表、图表或 Power View 报表内全局使用的数据模型。此模型的基础是确定在数据透视表中使用的导航和计算路径的表关系。在下一个任务中,您将手动创建关系以连接您刚刚导入的数据。

添加关系

你可以系统性地为所导入的所有新表创建表关系。如果您与同事共享工作簿,但是您和他们都不知道数据,那么具有预定义的关系非常重要。

手动创建关系时,您将一次使用两个表。对于每个表,您可以选择指示 Excel 如何在另一个表中查找相关行的列。

您的浏览器不支持视频。 安装 Microsoft Silverlight、Adobe Flash Player 或 Internet Explorer 9。

将 ProductSubcategory 关联到 ProductCategory

  1. 在 Excel 中,单击“数据”>“关系”>“新建”。

  2. 在“表”中,选择 DimProductSubcategory。

  3. 在“列(外来)”中,选择 ProductCategoryKey。

  4. 在“相关表”中,选择 Table_ProductCategory.accdb。

  5. 在“相关列(主要)”中,选择 ProductCategoryKey。

  6. 单击“确定”

  7. 关闭“管理关系”对话框。

向数据透视表添加类别

尽管已经更新数据模型以包含其他表和关系,但数据透视表并未使用它们。在本任务中,您将向“数据透视表字段”列表添加 ProductCategory。

  1. 在“数据透视表字段”中,单击“全部”显示数据模型中包含的表。

  2. 滚动到当前页的底部。

  3. 在“行”区域中,删除 BrandName。

  4. 展开 Table_DimProductCategories.accdb。

  5. 将 ProductCategoryName 拖至“行”区域中并放在 ProductSubcategory 上方。

  6. 在“数据透视表字段”中,单击“活动”可验证您刚使用的表是否已在数据透视表中使用。

检查点:回顾您学习的内容

您现在具有一个包括来自多个表的数据的数据透视表,其中有部分表要在后面的步骤中导入。要汇聚此数据,您必须创建 Excel 用来关联各行的表关系。您了解到拥有提供匹配数据的列对于查找相关数据至关重要。在示例数据文件中,所有表都包含一个可用于此目的的列。

尽管数据透视表已能发挥作用,但您可能已经注意到有几项功能尚待改进。“数据透视表字段”列表中有一些额外的表 (DimEntity) 和列 (ETLLoadID) 看起来与康浦业务无关。另外,我们尚未集成 Geography 数据。

后续内容:使用 Power Pivot 查看和扩展您的模型

在接下来的一系列任务中,您将使用 Microsoft Office Microsoft Excel 2013 中的 Power Pivot 加载项来扩展模型。您会发现使用该加载项提供的关系图视图可以更轻松地创建关系。您还可以使用该加载项创建计算和层次结构、隐藏不应出现在字段列表中的项目,并优化数据以便用于其他报告。

注意: Office 专业增强版中提供 Microsoft Excel 2013 中的 Power Pivot 加载项。有关详细信息,请参阅 Microsoft Excel 2013 中的 Power Pivot 加载项

将“Power Pivot”添加到 Excel 功能区,方法是启用 Power Pivot 加载项。

  1. 转到“文件”>“选项”>“加载项”。

  2. 在“管理”框中,单击“COM 加载项”>“转到”。

  3. 选中“Microsoft Office Microsoft Excel 2013 中的 Power Pivot”框,然后单击“确定”。

现在,功能区出现一个“Power Pivot选项卡”。

使用 Power Pivot 中的“关系图视图”添加关系

  1. 在 Excel 中,单击 Sheet3 以使其成为活动工作表。Sheet3 包含您之前导入的 Geography 表。

  2. 在功能区中,单击“Power Pivot”>“添加到数据模型”。此步骤会将 Geography 表添加到模型中。此步骤还将打开 Power Pivot 加载项,您将使用它执行此任务的其余步骤。

  3. 请注意,Power Pivot 窗口显示该模型中的所有表,包括 Geography 表。连续单击几个表。在加载项中,您可以查看模型中包含的全部数据。

  4. 在 Power Pivot 窗口的“视图”部分中,单击“关系图视图”。

  5. 使用滑动条调整关系图大小,以便您可以查看关系图中的所有对象。请注意,有两个表与关系图的其余部分无关:DimEntity 和 Geography。

  6. 右键单击 DimEntity,然后单击“删除”。此表是原始数据库中的一个项目,在模型中不需要。

  7. 放大 Geography,以便查看其中所有字段。您可以使用滑块放大表关系图。

  8. 请注意,Geography 具有 GeographyKey。此列包含可唯一标识 Geography 表中的每行的值。让我们看看模型中的其他表是否也使用此键。如果使用,我们可以创建连接 Geography 与模型其余部分的关系。

  9. 单击“查找”。

  10. 在“查找元数据”中,键入 GeographyKey。

  11. 多次单击“查找下一个”。您会注意到 GeographyKey 显示在 Geography 表和 Stores 表中。

  12. 重新定位 Geography 表以便它位于 Stores 旁边。

  13. 将 Stores 中的 GeographyKey 列拖到 Geography 中的 GeographyKey 列。Power Pivot 将在这两列之间绘制一条线,用来指示关系。

在此任务中,您了解到一种添加表和创建关系的新方法。您现在有了一个完全集成的模型,其中所有表都相互连接并且可用于 Sheet1 中的数据透视表。

提示: 在关系图视图中,有些表关系图完全展开,显示 ETLLoadID、LoadDate 和 UpdateDate 之类的列。这些特殊字段是来自原始康浦数据仓库的项目,添加这些字段用于支持数据提取和加载操作。您的模型并不需要这些字段。要删除它们,请突出显示并右键单击字段,然后单击“删除”。

创建计算列

在 Power Pivot 中,您可以使用 Data Analysis Expressions (DAX) 添加计算。在本任务中,您将计算总利润,并添加引用其他表中的数据值的计算列。稍后,您将了解如何使用这些引用列来简化您的模型。

  1. 在 Power Pivot 窗口中,切换回“数据视图”。

  2. 将 Table_ProductCategories accdb 表重命名为较好记的名称。您将在以下步骤中引用此表,较短名称将使计算更易于读取。右键单击表名称,单击“重命名”,键入 ProductCategories,然后按 Enter。

  3. 选择 FactSales 表。

  4. 单击“设计”>“”>“添加”。

  5. 在表上方的编辑栏中,键入以下公式。自动完成功能将帮助您键入列和表的完全限定的名称,并且列出可用的函数。您也可以单击列,Power Pivot 会将列名称添加到公式。

    = [SalesAmount] - [TotalCost] - [ReturnAmount]

  6. 在您完成构建公式后,按 Enter 以接受该公式。

    将为计算列中的所有行填充值。如果在表中向下滚动,您将看到行对于此列可以具有不同的值(基于每行中的数据)。

  7. 右键单击 CalculatedColumn1 并选择“重命名列”以重命名列。键入 Profit,然后按 Enter。

  8. 现在选择 DimProduct 表。

  9. 单击“设计”>“”>“添加”。

  10. 在表上方的编辑栏中,键入以下公式。

    = RELATED(ProductCategories[ProductCategoryName])

    RELATED 函数将返回相关表中的一个值。在这种情况下,ProductCategories 表包含产品类别的名称,当您生成包含类别信息的层次结构时,在 DimProduct 表中包含这些名称将非常有用。有关此函数的详细信息,请参阅 RELATED 函数 (DAX)

  11. 在您完成构建公式后,按 Enter 以接受该公式。

    将为计算列中的所有行填充值。如果在表中向下滚动,将看到此时各个行都具产品类别名称。

  12. 右键单击 CalculatedColumn1 并选择“重命名列”以重命名列。键入 ProductCategory,然后按 Enter。

  13. 单击“设计”>“”>“添加”。

  14. 在表上方的编辑栏中,键入以下公式,然后按 Enter 以接受该公式。

    = RELATED(DimProductSubcategory[ProductSubcategoryName])

  15. 右键单击 CalculatedColumn1 并选择“重命名列”以重命名列。键入 ProductSubcategory,然后按 Enter。

创建层次结构

大多数模型都包含具有层次结构的数据。常见示例包括日历数据、地理位置数据和产品类别。创建层次结构非常有用,因为可以将某一项(层次结构)拖入报表,而不必反复对相同的字段进行组合和排序。

  1. 在 Power Pivot 中,切换到关系图视图。展开 DimDate 表,以便可以轻松地查看该表的所有字段。

  2. 按住 Ctrl,然后依次单击 CalendarYear、CalendarQuarter 和 CalendarMonth 列(您将需要向下滚动该表)。

  3. 选中三列后,右键单击其中之一,然后单击“创建层次结构”。一个父层次结构节点(即层次结构 1)将在表的底部创建,并且所选列将作为子节点复制到该层次结构的下方。

  4. 键入 Dates 作为您的新层次结构的名称。

  5. 将 FullDateLabel 列添加到层次结构。右键单击 FullDateLabel 并选择“添加到层次结构”。选择“日期”。FullDateLabel 包含完整的日期,包括年、月和日。验证 FullDateLabel 是否显示在层次结构最后。您现在具有多级层次结构,包括年、季度、月和各个日历日。

  6. 在关系图视图中,指向 DimProduct 表,然后单击表标题中的“创建层次结构”按钮。一个空的层次结构父节点将出现在该表的底部。

  7. 键入 Product Categories 作为您的新层次结构的名称。

  8. 若要创建层次结构子节点,请将 ProductCategory 和 ProductSubcategory 拖到该层次结构上。

  9. 右键单击 ProductName 并选择“添加到层次结构”。选择 Product Categories。

既然您已经了解有几种不同方式都可以创建层次结构,我们来在数据透视表中使用它们。

  1. 返回到 Excel。

  2. 在 Sheet1(这是包含数据透视表的工作表)中,删除“行”区域中的字段。

  3. 用 DimProduct 中新的 Product Categories 层次结构替换它们。

  4. 同样,用 DimDate 中的 Dates 层次结构替换“列”区域中的 CalendarYear。

现在在浏览数据时,就很容易看到使用层次结构的好处。您可以独立地展开和关闭数据透视表的不同区域,更好地控制对可用区域的使用。此外,通过向“行”和“列”添加单个层次结构,您可以立即向下钻取以获得更多内容,无需堆叠多个字段即可实现相似的效果。

隐藏列

由于您已经创建了一个 Product Categories 层次结构并将其置于 DimProduct 中,您就不再需要“数据透视表字段”列表中的 DimProductCategory 或 DimProductSubcategory。在本任务中,您将了解如何隐藏“数据透视表字段”列表中占用空间的多余表和列。通过隐藏表和列,您可以改进报表体验,而不会影响提供数据关系和计算的模型。

您的浏览器不支持视频。 安装 Microsoft Silverlight、Adobe Flash Player 或 Internet Explorer 9。

您可以隐藏单个列、一定范围内的列或整个表。表和列的名称将灰显,以反映它们将对使用该模型的报表客户端隐藏。隐藏列将在模型中灰显以指示其状态,但在“数据视图”中仍保持可见,以便您可继续使用它们。

  1. 在 Power Pivot 中,确保已选择“数据视图”。

  2. 在底部的页签中,右键单击 DimProductSubcategory,然后选择“从客户端工具中隐藏”。

  3. 对 ProductCategories 重复以上步骤。

  4. 打开 DimProduct。

  5. 右键单击以下列,然后单击“从客户端工具中隐藏”:

    • ProductKey

    • ProductLabel

    • ProductSubcategory

  6. 选择多个相邻的列。从 ClassID 开始,一直选择到末尾的 ProductSubcategory。右键单击,将它们隐藏起来。

  7. 为其他表重复该过程,删除此报表中不使用的 ID、键或其他详细信息。

切换回 Excel Sheet1(包含“数据透视表字段”列表)以查看差异。表数目已减少,并且 DimProduct 只包括在分析销售数据时很可能使用的那些项。

创建 Power View 报表

数据透视表不是从数据模型受益的唯一报表类型。使用您刚刚构建的模型,您可以添加一个 Power View 工作表,尝试它所提供的一些布局。

  1. 在 Excel 中,单击“插入”>“Power View”。

    注意: 如果这是您首次在此计算机上使用 Power View,系统会提示您首先启用加载项并安装 Silverlight。

  2. 在“Power View 字段”中,单击 FactSales 表旁边的箭头,并单击 SalesAmount。

  3. 展开 Geography 表,然后单击 RegionCountryName。

  4. 在功能区中,单击“地图”。

  5. 将显示地图报告。拖动一角调整其大小。在地图上,大小不一的蓝色圆圈表示不同国家或地区的销售业绩。

为 Power View 报表进行优化

对您的模型做一些较小的改动,以便在设计 Power View 报表时产生更加直观的响应。在本任务中,您将为多个制造商添加网站 URL,然后将数据作为 Web URL 进行分类,以便 URL 地址显示为链接。

第一步,将 URL 添加到您的工作簿。

  1. 在 Excel 中,打开一个新的工作表并复制这些值:

ManufacturerURL

ManufacturerID

http://www.contoso.com

康浦有限公司

http://www.adventure-works.com

嘉元实业

http://www.fabrikam.com

世邦公司

  1. 将单元格的格式设置为表格,然后将表格命名为 URL。

  2. 在 URL 和包含制造商名称的表 DimProduct 之间创建关系:

    1. 单击“数据”>“关系”。将显示“创建关系”对话框。

    2. 单击“新建”。

    3. 在“表”中,选择 DimProduct。

    4. 在“列”中,选择 Manufacturer。

    5. 在“相关表”中,选择 URL。

    6. 在“相关列(主要)”中,选择 ManufacturerID。

要比较之前和之后的结果,请启动一个新的 Power View 报表并向报表添加 FactSales | SalesAmount、dimProduct | Manufacturer 和 URL | ManufacturerURL。请注意,这些 URL 显示为静态文本。

将 URL 呈现为活动超链接需要分类。要对列进行分类,您将使用 Power Pivot。

  1. 在 Power Pivot 中,打开 URL。

  2. 选择 ManufacturerURL。

  3. 单击“高级”>“报表属性”>“数据类别:未分类”。

  4. 单击向下箭头。

  5. 选择“Web URL”。

  6. 在 Excel 中,单击“插入”>“Power View”。

  7. 在“Power View 字段”中,选择“FactSales | SalesAmount”、“dimProduct | Manufacturer”和“URL | ManufacturerURL”。此时,URL 显示为实际的超链接。

其他 Power View 优化包括为每个表定义默认字段集,以及设置决定是汇总还是单独列出包含重复数据的行的属性。有关详细信息,请参阅配置 Power View 报表的默认字段集和为 Power View 报表配置表行为属性。

创建计算字段

在第二个任务中,使用数据透视表浏览数据,您已单击了“数据透视表字段”列表中的 SalesAmount 字段。由于 SalesAmount 是数字列,它已自动放置到数据透视表的“值”区域中。然后,SalesAmount 总和可以计算应用了筛选器的内容的销售额。在这种情况下,最初没有筛选器,但后来有 CalendarYear、ProductSubcategoryName 和 BrandName 筛选器。

您真正执行的操作是创建了一个隐式计算字段,使得您能够针对产品类别、区域和日期等其它字段轻松地分析 FactSales 表中的销售额。当您将字段拖动到“值”区域或者单击数字字段(就像对 SalesAmount 所做的那样)时,将创建一个隐式 Excel 计算字段。隐式计算字段是指使用自动为您创建的标准聚合函数(例如,SUM、COUNT 和 AVERAGE)的公式。

还有其他类型的计算字段。您可以在 Power Pivot 中创建显式计算字段。与隐式计算字段不同,隐式计算字段只能在创建它们的数据透视表中使用,而显式计算字段可在工作簿中的任何数据透视表中使用,或者由使用数据模型作为数据源的任何报表使用。通过在 Power Pivot 中创建的显式计算字段,您可以使用“自动求和”功能通过标准聚合自动创建计算字段,也可以使用通过数据分析表达式 (DAX) 创建的公式创建您自己的计算字段。

如您所想,创建计算字段可以帮助您以功能强大的方式分析数据,我们来开始学习如何创建它们。

在 Power Pivot 中创建计算字段非常简单。您可以使用“自动求和”。

  1. FactSales 表中,单击 Profit 列。

  2. 单击“计算”>“自动求和”。请注意,已在 Profit 列的正下方的计算区域的单元格中自动创建了名为“Profit 的总和”的新计算字段。

  3. 在 Excel Sheet1 中的字段列表中,在 FactSales,单击“Profit 的总和”。

搞定!只需使用 Power Pivot 中的标准聚合创建计算字段。正如您看到的,只需几分钟,您已创建了“Profit 的总和”计算字段并将其添加到数据透视表,使得根据应用的筛选器分析利润更容易。在本例中,您会看到“Profit 的总和”按“Product Category”和“Dates”层次结构进行筛选。

但是,如果您需要执行一些更详细的分析,例如特定渠道、产品或类别的销售数量,该怎么办? 您将需要创建另一个计算字段来统计行数,FactSales 表中的每个销售需要创建一个计算字段,具体取决于应用的筛选器。

  1. FactSales 表中,单击 SalesKey 列。

  2. 在“计算”中,单击“自动求和”>“计数”上的向下箭头。

  3. 通过单击计算区域中的“SalesKey 的计数”重命名新的计算字段,然后在编辑栏中将“SalesKey 的计数”更改为只是“计数”,再按 Enter。与计算列不同,计算字段名称作为 DAX 公式的组成部分包含在内。

  4. 在 Excel Sheet1 中的字段列表中,在 FactSales 表中,单击“Count”。

请注意,新列 Count 会添加到数据透视表以根据应用的筛选器显示销售数量。与“Profit 的总和”计算字段一样,您会看到“Count”按 Product Category 和 Dates 层次结构进行筛选。

我们来创建另一个计算字段。这次,您将创建一个计算字段来计算特定上下文或筛选器的销售总计的百分比。但是,与您以前使用“自动求和”创建的计算字段不同,这次您将手动输入公式。

  1. 在 FactSales 表的计算区域中,单击空单元格。提示:左上角单元格是开始放置计算字段的好位置。它使其更容易查找。您可以在计算区域中四处移动任意计算字段。

  2. 在编辑栏中,键入并使用 IntelliSense 创建以下公式: Percentage of All Products:=[Count]/CALCULATE([Count], ALL(DimProduct))

  3. 按 Enter 接受公式。

  4. 在 Excel Sheet1 中的字段列表中,在 FactSales,单击“Percentage of All Products”。

  5. 在数据透视表中,选择“Percentage of All Products”列中的多项。

  6. 在“开始”选项卡上,单击“数字”>“百分比”。使用两个小数位数来设置每个新列的格式。

此新计算字段的用途是为给定筛选器上下文计算总销售额的百分比。在本例中,我们的筛选器上下文仍然是 Product Category 和 Dates 层次结构。例如,您可以看到计算机占产品总销售额的百分比逐年提高。

如果您熟悉创建 Excel 公式,那么为计算列和计算字段创建公式对于您非常容易。无论您是否熟悉 Excel 公式,了解 DAX 公式基础知识的极佳位置是分步学习快速入门:在 30 分钟内了解 DAX 基础知识中的课程。

保存工作

保存您的工作簿,以便您可以在其他教程或进一步探讨中使用它。

后续步骤

尽管您可以轻松地从 Excel 导入数据,但使用 Power Pivot 加载项进行导入通常更快且更加高效。您可以筛选您导入的数据,排除不需要的列。您也可以选择是使用查询生成器还是查询命令来检索数据。下一个步骤是了解这些备用方法:从 PowerPivot 的数据馈送中获取数据从 Analysis Services 或 PowerPivot 导入数据

Power View 报表用于与数据模型(就像您刚刚创建的数据模型)一同使用。继续学习,了解关于 Power View 为 Excel 带来的丰富的数据可视化效果的更多信息:在 Excel 2013 中启动 Power View 和 Power View:浏览、可视化和呈现数据。

请按照此教程:优化用于 Power View 报表的数据模型尝试增强您的数据模型以获得更好的 Power View 报表

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×