插入或编辑公式或表达式

Word for Mac 中包含的公式,您可以将其拖入文档 — 没有所需的格式。如果内置公式不能满足您的需要,可以对其进行修改或构建您自己从头复杂的公式。

插入内置公式

  1. 在文档中,单击您要在其中插入公式。

  2. 插入选项卡上,单击公式旁边的箭头,滚动浏览各个选项在列表中,,然后单击所需的公式。

    在“插入”选项卡上突出显示了“公式”按钮。

    公式插入到文档中。

编写或更改公式

  1. 插入选项卡上,单击公式

    公式按钮

    插入新公式的占位符,然后您将看到一组工具,用于自定义和向公式添加各种元素的公式选项卡上。

  2. 若要插入符号,请单击符号组中的符号。您将找到多个相关数学符号,可供选择。

    注意: 如果看不到的组标题,在公式选项卡上,单击Word >首选项、,然后在Word 首选项对话框中,单击视图。选择对话框的底部显示组标题

    要查看所有符号,请将鼠标放在其中一个符号上方,然后单击符号库下显示的箭头。 滚动查看所有可用的符号。

    在“公式”选项卡上,将显示所有可用符号的列表。

  3. 若要插入的结构,请单击结构组中的结构,然后替换占位符 — 小虚线框-使用您自己的值。

    “结构”组

  4. 选择通过单击工具组中的选项页面上显示公式如何。

    “工具”组

    专业型”选项将公式显示为一个二维值。“线性”选项将公式显示在一行上。

  5. 若要编辑数学公式,请单击在公式中进行所需的更改。执行操作时, Word将显示公式选项卡。

可以直接在 Word 中插入和编辑数学公式和表达式,并将其另存为模板以便日后再次使用。

早期版本的 Word 使用的 Microsoft 公式编辑器加载项或数学类型加载项。但是,可以使用 Microsoft Word for Mac 2011 打开和编辑数学公式或表达式所创建的早期版本的 Word 或数学类型。您还可以创建公式或表达式与兼容的早期版本的 Word 使用 Microsoft 公式编辑器。有关如何使用 Microsoft 公式编辑器的详细信息,请参阅编辑用早期版本的 Word 中所做的公式

为了节省时间,可以插入内置公式并对其进行编辑以满足你的需求,而不是逐字符键入公式。

  1. 单击要插入公式或表达式的位置。

  2. 在“文档元素”选项卡上,在“数学”下,单击“公式”旁边的箭头,然后从公式库中选择所需的公式或表达式。

    "文档元素"选项卡,"数学"组

    若要编辑公式或表达式中的变量,请按住向右键或向左键,直到突出显示要编辑的变量。 然后,按住 Shift 并按向右键或向左键以选择变量。

可以通过选择单个数学符号和内置数学结构的任意组合来编写公式或表达式,如下例所示:

圆形面积

  1. 单击要插入公式或表达式的位置。

  2. 在“文档元素”选项卡上,在“数学”下,单击“公式”。

    "文档元素"选项卡,"数学"组

  3. 请执行以下任一操作:

    若要

    执行此操作

    将单个数学符号插入公式中

    在“公式工具”选项卡上,在“数学符号”下,通过选择合适的数学符号和键入变量和数字来构建公式。

    若要查看更多数学符号,请将鼠标指针停留在数学符号上,然后单击 "更多"下箭头

    将内置数学结构插入公式中

    在“公式工具”选项卡上,在“结构”下,通过从可用类别中选择数学表达式来构建公式。 例如,要插入分数,请单击“分数”,然后单击所需的分数样式。

    若要编辑公式或表达式中的变量,请按住向右键或向左键,直到突出显示要编辑的变量。 然后,按住 Shift 并按向右键或向左键以选择变量。

  4. 在公式或表达式外部单击以退出,然后返回到文档。

    注释: 

    • 插入公式或表达式时,Word 会自动将其转换为专业格式。 要将公式或表达式从专业格式  专业格式的二次公式 更改为线性  线性格式的二次公式 ,请单击公式旁边的箭头,然后单击“线性”。

    • 要将公式或表达式更改到独立图形中,请单击公式旁边的箭头,然后单击“更改为‘显示’”。 在将公式或表达式更改到独立图形中后,可以将两端对齐设置为“左对齐”、“右对齐”、“居中”或“整体居中”。

    • 可以使用 Unicode 字符和“数学自动更正”项将文本替换为符号。 有关详细信息,请参阅插入符号

可以使用数学自动更正快速将常用的数学符号添加到公式或表达式中,例如 pi 符号,而不用搜索数学符号库来创建公式或表达式。

注意: 要查看所有可用的数学自动更正项,请在“工具”菜单上,单击“自动更正”,然后单击“数学自动更正”选项卡。

  1. 单击要插入公式或表达式的位置。

  2. 在“文档元素”选项卡上,在“数学”下,单击“公式”。

  3. 在公式框中,先键入反斜杠后键入要插入的数学符号的友好名称或别名。 例如,要插入 pi 符号,请键入 \pi,然后按空格键。

  1. 单击公式或表达式。

  2. 在“公式工具”选项卡上,在“数学符号”下或在“结构”下,选择要添加到公式的数学符号或结构,或者键入或删除公式中的变量和数字。

    若要编辑公式或表达式中的变量,请按住向右键或向左键,直到突出显示要编辑的变量。 然后,按住 Shift 并按向右键或向左键以选择变量。

  3. 在公式或表达式外部单击以退出,然后返回到文档。

    注释: 

    • 要将公式或表达式从专业格式  专业格式的二次公式 更改为线性  线性格式的二次公式 ,请单击公式旁边的箭头,然后单击“线性”。

    • 要将公式或表达式更改到独立图形中,请单击公式旁边的箭头,然后单击“更改为‘显示’”。 在将公式或表达式更改到独立图形中后,可以将两端对齐设置为“左对齐”、“右对齐”、“居中”或“整体居中”。

  1. 单击公式或表达式。

  2. 单击公式或表达式旁边的箭头,然后单击“另存为新公式”。

  3. 在“名称”框中,键入公式或表达式的名称。

  4. 在“类别”弹出菜单上,选择某个现有类别,或通过在“类别”框中键入新类别来添加新类别。 例如,“我的公式”。

  5. 在“描述”框中,键入公式或表达式的简短描述,然后单击“确定”。

    注意:  若要以后访问公式或表达式,请在“文档元素”选项卡上,在“数学”下,单击“公式”旁边的箭头,然后从公式和表达式库中选择公式或表达式。

当不再需要某个公式时,可以将其从常用公式或表达式列表中删除。

警告: 请确保仅删除你已创建并添加到常用公式列表中的公式和表达式。 尽管你可以删除随 Word 一起安装的“内置”类别中的任何公式,但要恢复这些公式,只能手动重新创建它们或重新安装 Word。 所有内置和用户定义的公式都存储在 /Users/用户名/Library/Application Support/Microsoft/Office/User Templates/My Document Elements/Equations.dotx 文件中。 如果你使用的是 Mac OS X 7 (Lion),则默认情况下将隐藏 Library 文件夹。 要显示 Library 文件夹,请在查找工具中单击“转到”菜单,然后按住 OPTION。

  1. 在“文档元素”选项卡上,在“数学”下,单击“公式”旁边的箭头。

    "文档元素"选项卡,"数学"组

  2. 按住 CONTROL,单击要删除的公式或表达式,然后在快捷菜单上单击“删除”。

可以使用数学自动更正快速插入数学自动更正项内置列表中包含的符号。 例如,键入 \pi 以插入 pi 符号。 如果内置项列表不包含所需的更正内容,则可以添加新项。

  1. 在“工具”菜单上,单击“自动更正”,然后单击“数学自动更正”选项卡。

  2. 在“替换”框中,先键入反斜杠再键入要使用的数学符号的友好名称或别名。 例如,\plus

  3. 在“替换为”框中,键入在键入反斜杠和友好名称时要出现的符号。 例如,加号 (+)。

  4. 单击“添加”。

    注意: 若要删除数学自动更正项,请在列表中选中该项,然后单击“删除”。

与早期版本的 Word 兼容性提供了此过程。使用此过程编辑公式或您想要共享与早期版本的 Word 的表达式。如果您不需要与早期版本的 Word 中共享文件,使用文档元素选项卡以打开和编辑数学公式或表达式所创建的早期版本的 Word 或数学类型。

  1. 双击公式。

  2. 使用公式编辑器工具和菜单编辑公式。

    提示: 有关编辑公式的帮助,请单击公式编辑器“帮助”菜单,然后单击“公式编辑器帮助”。

  3. 若要使用经过编辑的公式来更新文档,请在“公式编辑器”菜单上,单击“退出公式编辑器”。

注释: 

  • 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

  • 请在 此处 中查找本文的英文版本以便参考。你和 Microsoft 社区的其他成员可以使用 Community Translation Framework (CTF) 来改进本文。只需将鼠标悬停在文章中的句子上,然后在 CTF 小组件中单击“IMPROVE TRANSLATION”即可。 单击此处了解有关 CTF 的详细信息。 使用 CTF 即表示你同意服务条款

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×