拼写和语法检查器未按预期的方式工作

拼写和语法检查器未按预期的方式工作

注意:  我们希望能够尽快以你的语言为你提供最新的帮助内容。 本页面是自动翻译的,可能包含语法错误或不准确之处。我们的目的是使此内容能对你有所帮助。可以在本页面底部告诉我们此信息是否对你有帮助吗? 请在此处查看本文的 英文版本 以便参考。

有时,你可能希望 Office 程序中的拼写和语法检查器忽略某些拼写或语法结构。在其他情况下,你可能不知道为什么语法或拼写检查器会标记或者不标记出一些文本。

当拼写和语法检查器未按预期的方式工作或者你想要自定义结果时,可以尝试以下一些建议。

注意: Excel 不执行拼写检查在键入时。而是您需要通过按 F7 或转到审阅启动手动拼写检查 >拼写检查

单击下面的标题了解详细信息。

如果想让拼写检查器忽略某些专有名称、技术术语、缩写词或者专用的大写词,则可以将此类词语或大写词添加到自定义词典中以防止它们在拼写检查中被标记出来。

太添加单词已标记为拼写错误到您的自定义词典只需右键单击它并选择添加到词典

有关使用和管理自定义词典的详细信息,请参阅将词添至您的拼写检查词典

如果选中“不检查拼写和语法”复选框,则不会检查文档中的拼写。

若要清除不检查拼写和语法复选框,请执行下列操作:

  1. 单击文件中的任意位置。

  2. 审阅选项卡上,单击语言>设置校对语言

    (在 Word 2007 中,单击“校对”组中的“设置语言”)。

  3. 在“语言”对话框中,清除“不检查拼写或语法”复选框。

    “语言”对话框

提示: 不检查拼写和语法设置可能会应用于整个文件或只是部分。要确保整个文件,正在的拼写和语法检查,请清除该复选框之前选择所有 (CTRL + A)。

如果拼写被标记为你不打算使用或未使用的某种语言,则可以更改 Office 使用的校对或词典语言。若要了解如何操作,请参阅使用不同语言检查拼写和语法

如果拼写和语法检查没有标记出你知道不正确的单词或短语,则可能是你在之前的拼写检查中选择了忽略这些单词或短语。在 Word、Outlook、PowerPoint 2013 和 PowerPoint 2016 中,可强制重新检查之前选择忽略的单词和语法。若要了解如何操作,请参阅重新检查之前选择忽略的拼写和语法

如果拼写和语法检查器会跳过文档的某些部分,可能是这些部分已被标记为忽略。若要了解如何清除此设置,请参阅下面的清除标记为不进行拼写检查的文本

如果语法检查器标记出了你不想修复的错误,你可以自定义语法和写作风格规则,使其较为宽松。有关如何关闭特定语法或写作风格的规则的详细信息,请参阅选择语法选项和写作风格选项。在某些程序中,也可以直接关闭语法检查。

完全关闭语法检查:

  1. 打开拼写和语法选项:

    • 在 Word 2010 及更高版本、PowerPoint 2013 和 PowerPoint 2016 中:在“文件”菜单上,单击“选项”,然后单击“校对​​”。

    • 在 Outlook 2010 及更高版本中:在“文件”菜单上,依次单击“选项”、“邮件”以及“拼写检查和自动更正”。

    • 在 Word 2007 中:单击“Microsoft Office 按钮Office 按钮图像 >“Word 选项”>“校对”。

    • 在 Outlook 2007 中:在“工具”菜单上,依次单击“选项”、“拼写”选项卡和“拼写检查和自动更正”。

  2. 清除“随拼写检查语法”复选框。

在 Word、Outlook 和 PowerPoint 中,你可以让拼写和语法检查器忽略文本。例如,如果插入来自非正式电子邮件的某些文本,该文本中包含了不完整的句子和俚语词,而你希望拼写和语法检查器忽略此文本块中的所有错误。

在 Office 2010、Office 2013 和 Office 2016 中

  1. 选择想让拼写和语法检查器忽略的文本。

  2. 在“审阅”选项卡上的“语言”组中,单击“语言”,然后单击“设置校对语言”。

  3. 选中“不检查拼写或语法”复选框。

在 Office 2007 中

  1. 选择想让拼写和语法检查器忽略的文本。

  2. 打开“语言”对话框:

    • 在 Word 中:在“审阅”选项卡上的“校对”组中,单击“设置语言”。

    • 在 Outlook 中:在“拼写”下拉列表中的“校对”组中,单击“设置语言”。

    • 在 PowerPoint 中:在“审阅”选项卡上的“校对”组中,单击“语言”。

  3. 选中“不检查拼写或语法”复选框。

在 Word、Outlook 和 PowerPoint 中,如果拼写和语法检查器会跳过某些你想要检查的文本,则可以更改此设置,然后再次运行拼写和语法检查器。

在 Office 2010、Office 2013 和 Office 2016 中

  1. 通过按 Ctrl+A 选择整个文档。

  2. 在“审阅”选项卡上的“语言”组中,单击“语言”,然后单击“设置校对语言”。

  3. 清除“不检查拼写或语法”复选框。

在 Office 2007 中

  1. 通过按 Ctrl+A 选择整个文档。

  2. 打开“语言”对话框:

    • 在 Word 中:在“审阅”选项卡上的“校对”组中,单击“设置语言”。

    • 在 Outlook 中:在“拼写”下拉列表中的“校对”组中,单击“设置语言”。

    • 在 PowerPoint 中:在“审阅”选项卡上的“校对”组中,单击“语言”。

  3. 清除“不检查拼写或语法”复选框。

例如,如果某些单词未被标记为拼写错误,你则可能已选中了需要更改的自定义设置 — 例如忽略全部大写的单词或忽略包含数字的单词。请参阅检查拼写时忽略大写单词、数字或 Internet 地址以了解可以查看和更改的设置。

如果你使用的是 Word 或 Outlook,并且不确定为什么语法检查器将某些文本标记为了语法错误,则可以通过以下方式了解详细信息:

了解有关可能的语法错误的详细信息:

  • 使用自动拼写和语法检查器    右键单击单词,然后单击“关于此句型”。

    右键单击某个语法错误

  • 运行拼写和语法检查器    在“拼写和语法”对话框中单击“解释”。

在 Outlook 中,您可以指定在回复或转发邮件时不检查原始邮件文本的拼写。

在 Outlook 2010、Outlook 2013 和 Outlook 2016 中

  1. 依次单击“文件”选项卡、“选项”和“邮件”。

  2. 在“撰写邮件”下,选中“在答复或转发时忽略原件的正文”复选框。

在 Outlook 2007 中

  1. 在“工具”菜单上,单击“选项”,然后单击“拼写”选项卡。

  2. 选中“在答复或转发时忽略原件的正文”复选框。

Access 中的某些表包含在检查拼写时不应纳入的数据。

  1. 在查看表、查询、表单或报表中的数据时,选择想要排除的字段。

  2. 打开“拼写检查”对话框:

    • 在 Access 2010、Access 2013 和 Access 2016 中:在“开始”选项卡上的“记录”组中,单击“拼写检查”。

    • 在 Access 2007 中:在“数据”选项卡上的“编辑”组中,单击“拼写检查”。

  3. 单击“忽略‘字段名称’字段”。

如果有关于拼写和语法功能的反馈或建议,请在此处发布

另请参阅

检查拼写和语法

向拼写检查词典添加单词

使用不同语言检查拼写和语法

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×