拼写和语法检查器无法正常工作

拼写和语法检查器无法正常工作

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

有时您可能希望拼写和语法检查器在 Office 程序中忽略某些拼写或语法构造。在其他情况下,您可能不知道为何语法或拼写检查器标记,或不标记一些文本。

下面是当拼写和语法检查器无法正常工作,或者您想要自定义您的结果时可尝试的一些建议。单击在下方标题中的详细信息。

如果希望拼写检查器忽略某些专有名词、 技术术语、 缩写或专用的大小写,您可以向自定义词典以防止被标记拼写检查期间添加这些单词或字母大写。

若要了解如何使用和管理自定义词典,请参阅将词添至您的拼写检查词典

如果选择不检查拼写和语法复选框,不检查您的文档中的拼写。

若要在 Word 中清除“自动检测语言”复选框,请执行下列操作:

  1. 审阅选项卡上的语言组中,单击语言>设置校对语言

    (在 Word 2007 中,单击设置语言校对组中。)

  2. 在“语言”对话框中,清除“不检查拼写或语法”复选框。

    “语言”对话框

不检查拼写和语法设置可能会应用于整个文档或只是部分。要确保整个文档,正在的拼写和语法检查,请清除该复选框之前选择所有 (CTRL + A)。

如果拼写被标记为不打算或未使用的语言,您可以更改 Office 将使用校对或词典语言。若要了解如何,看到的不同语言检查拼写和语法

如果拼写和语法未标记单词或短语,您知道不正确,您可能已选择以前的拼写检查过程中忽略。在 Word、 Outlook、 PowerPoint 2013 和 PowerPoint 2016 中,您可以强制重新检查以前选择忽略的字词和语法。若要了解如何,请参阅重新检查拼写和您以前选择忽略的语法

如果拼写和语法检查器正在跳过文档的某些部分,这些分区可能标记为忽略。若要了解如何清除此设置,请参阅清除标记为不检查拼写文本下方。

如果语法检查器标记了不希望修复的错误,您可以自定义的语法选项和写作风格规则是限制性较小。如何关闭特定语法或写作风格规则的详细信息,请参阅选择语法选项和写作风格选项。在某些程序,您可以也只需关闭语法检查。

若要启用语法检查完全关闭:

  1. 打开拼写和语法选项:

    • 2010年和更高版本的 Word、 PowerPoint 2013 和 PowerPoint 2016 中:文件菜单上,单击选项,然后单击校对

    • 在 Outlook 2010 和更高版本:文件菜单上,单击选项,单击邮件,,然后单击拼写检查和自动更正

    • 在 Word 2007 中:单击Microsoft Office 按钮 Office 按钮图像 > Word 选项>校对

    • 在 Outlook 2007:工具菜单上单击选项,单击拼写检查选项卡,然后单击拼写检查和自动更正

  2. 清除随拼写检查语法复选框。

在 Word、 Outlook 和 PowerPoint 中,您可以使拼写和语法检查器忽略文本。例如,假设您插入一些文本从非正式的电子邮件,其中包含断句和俚语术语,并且您希望拼写和语法检查器忽略此文本块中的所有错误。

在 Office 2010、 Office 2013 和 Office 2016

  1. 选择想要拼写和语法检查器忽略的文本。

  2. 在“审阅”选项卡上的“语言”组中,单击“语言”,然后单击“设置校对语言”。

  3. 选中“不检查拼写或语法”复选框。

在 Office 2007

  1. 选择想要拼写和语法检查器忽略的文本。

  2. 打开语言对话框中:

    • 在 Word 中: 在审阅选项卡的校对组中,单击设置语言

    • 在 Outlook 中: 在拼写检查下拉列表中校对组中,单击设置语言

    • 在 PowerPoint 中: 在审阅选项卡上的校对组中,单击语言

  3. 选中“不检查拼写或语法”复选框。

在 Word、 Outlook 和 PowerPoint 中,如果拼写和语法检查器正在跳过要检查,某些文本您可以更改此设置,然后再次运行拼写和语法检查。

在 Office 2010、 Office 2013 和 Office 2016

  1. 通过按 Ctrl+A 选择整个文档。

  2. 在“审阅”选项卡上的“语言”组中,单击“语言”,然后单击“设置校对语言”。

  3. 清除“不检查拼写或语法”复选框。

在 Office 2007

  1. 通过按 Ctrl+A 选择整个文档。

  2. 打开语言对话框中:

    • 在 Word 中: 在审阅选项卡的校对组中,单击设置语言

    • 在 Outlook 中: 在拼写检查下拉列表中校对组中,单击设置语言

    • 在 PowerPoint 中: 在审阅选项卡上的校对组中,单击语言

  3. 清除“不检查拼写或语法”复选框。

如果,例如,不特定单词标记为拼写错误,您可能必须自定义设置,如忽略全部大写的单词或包含数字的单词-选择您想要更改。请参阅忽略全部大写的单词、 数字或 Internet 地址时检查拼写以了解您可以查看和更改的设置。

如果您正在使用 Word 或 Outlook,并且您不确定为何语法检查器将某文本标记为语法不正确,您可以了解详情,请执行下列操作:

若要了解有关可能的语法错误的详细信息:

  • 使用自动时的拼写和语法检查器    Word 中,右键单击,然后单击关于此句型

    右键单击某个语法错误

  • 运行时的拼写和语法检查器    单击拼写和语法对话框中的说明

在 Outlook 中,您可以指定在回复或转发邮件时不检查原始邮件文本的拼写。

在 Outlook 2010、 Outlook 2013 和 Outlook 2016 中

  1. 依次单击“文件”选项卡、“选项”和“邮件”。

  2. 在“撰写邮件”下,选中“在答复或转发时忽略原件的正文”复选框。

在 Outlook 2007 中

  1. 工具菜单上,单击选项,然后单击拼写检查选项卡。

  2. 选择在答复或转发忽略原件的正文复选框。

Access 中的某些表包含在检查拼写时不应纳入的数据。

  1. 在查看表、查询、表单或报表中的数据时,选择想要排除的字段。

  2. 打开拼写检查对话框中:

    • 在 Access 2010、 Access 2013 和 Access 2016:开始选项卡,在记录组中,单击拼写检查

    • 在 Access 2007 中:数据选项卡的编辑组中,单击检查拼写

  3. 单击忽略字段名称字段

如果您有反馈意见或建议的拼写和语法功能,请将其下面发布

另请参阅

检查拼写和语法

向拼写检查词典添加单词

使用不同语言检查拼写和语法

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×