报表简介

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

当您使用数据库时,一般使用报表来查看数据、设置数据格式和汇总数据。例如,您可以创建列表类型报表以显示所有联系人的电话号码,也可以使用摘要报表来计算公司在不同地区和时间段内的总销售额。

本文将概述 Microsoft Access 2010 中的报表,并介绍全新或发生更改的报表功能。本文还解释如何创建报表、如何对数据进行排序、分组和汇总以及如何预览和打印报表。

您将找到创建有意义的报表,如果您的数据库具有精心设计的表结构和关系容易得多。有关规划和设计数据库简介,请参阅文章数据库设计基础

本文内容

概述

新增内容

创建新的报表

添加分组、排序或汇总

使用条件格式突出显示值

使用主题获得专业外观

添加图像

预览和打印报表

概述

报表是一种数据库对象,您可使用报表来显示和汇总数据。报表提供了一种分发或存档数据快照的方法,您可以将它打印出来、转换为 PDF 或 XPS 文件或导出为其他文件格式。

打印预览中的员工报表

报表可提供有关各个记录的详细信息和/或许多记录的汇总信息。您还可使用 Access 报表来创建标签以用于邮寄或其他目的。

您可以创建不显示数据的“未绑定”报表,在本文中,为了方便起见,我们假定报表与诸如表或查询等数据源相绑定。

客户端报表与 Web 报表对比

Access 2010 提供了一个新功能,允许您通过将 Access 数据库发布到运行 Access Services 的 SharePoint 服务器上来创建“Web 数据库”。当您创建 Web 数据库后,将在使用 SQL Server Reporting Services 的浏览器中呈现 Access 报表。对于要在浏览器中呈现的报表,此转换限制了您可在该报表中使用的功能。但是,如果您不考虑在浏览器中呈现报表,则可使用 Access 报表设计器所提供的一整套功能。

报表的组成部分

在 Access 中,报表的设计分为多节。在客户端数据库中,您可以在设计视图以查看其分区中查看报表。在布局 视图中,部分不明显,但是他们仍然存在,并且可通过使用格式选项卡上的所选内容组中的下拉列表中选择。若要创建有用的报表,您需要了解每个节的工作方式。例如,部分中选择要放置计算的控件确定 Access 如何计算结果。下面是部分类型和其使用方法的摘要︰

  • 报表页眉   页眉只需一次,报表的开头。使用报表页眉的封面,如徽标、 标题、 或日期可能会正常显示的信息。将报表页眉中使用 Sum 聚合函数的计算的控件时,计算总和是整个报表。报表页眉打印之前的页面页眉。

  • 页面页眉   在每页顶部打印本部分。例如,使用页面页眉重复报表标题在每页上。

  • 组页眉   此部分打印的每个新记录组的开头。使用组页眉中打印组名称。例如,在按产品分组报表中,使用组页眉中打印产品名称。当您将在组页眉中使用 Sum 聚合函数的计算的控件时,总和是当前组。您可以在一个报表中,多个组页眉节具体取决于您已经添加分组级别数。有关如何创建组页眉和页脚的详细信息,请参阅部分中添加分组、 排序或汇总

  • 详细信息   本部分中的记录源的每一行的打印一次。这是您放置组成报表主体的控件。

  • 组页脚   页眉在每个组记录的结尾处。组页脚用于打印组的摘要信息。您可以在一个报表中,多个组页脚节具体取决于您已经添加分组级别数。

  • 页面页脚   页眉在每页的末尾。使用页面页脚可打印的页码或每页信息。

  • 报表页脚   页眉只需一次,在报表的末尾。整个报表中使用报表页脚打印的报表总和或其他汇总信息。

注意: 在设计视图中,报表页脚页面页脚下方显示。不过,所有其他视图 (布局视图,例如,或打印或预览报表),在报表页脚出现上方页脚,紧随其后的最后一页上最后一个组页脚或明细数据行。

文档顶部

新增内容

在 Access 2010 和 Access 2007 中创建报表的过程非常相似。但是,Access 2010 中提供了一些与报表相关的新功能:

  • 共享图像库   在 Access 2010 中,可以立即将图像附加到数据库,然后使用跨多个对象的图像。更新单个图像更新它,它能够跨整个数据库使用的任意位置。

  • Office 主题   在 Access 2010 中,您现在可以使用标准的 Microsoft Office 主题要一次应用于所有 Access 窗体和报表的字体和颜色经过专业设计的设置。

  • 更强大的条件格式   Access 2010 中包含突出显示报表上的数据更强大的工具。您可以添加的每个控件或一组控件,最多 50 个条件格式规则,并且可以在客户端报表中添加数据条以比较跨记录的数据。

  • 更灵活的版式   Access 2010 中的报表的默认设计方法是将控件放在版式。这些网格帮助您对齐和轻松,调整控件的大小和所需的任何您想要在浏览器中呈现的报告。虽然版式本身不是 Access 2010 中的新增功能,有一些变化您在其中使用它们来移动、 对齐和调整控件的方法。有关详细信息,请参阅视频窗体和报表布局简介.

文档顶部

创建新报表

步骤 1:选择记录源

报表的记录源可以是表、命名查询或嵌入式查询。记录源必须包含您要在报表上显示的数据的所有行和列。

有关创建表或查询的详细信息,请参阅文章简介表查询简介

有关创建和选择记录源的详细信息,请参阅文章设置报表的记录源

步骤 2:选择报表工具

报表工具位于功能区的“创建”选项卡上的“报表”组中。下表简述了每个工具的用途:

Web 兼容的报表

使用这些工具创建的报表与“发布到 Access Services”功能相兼容,将在浏览器中进行呈现。注意,Web 兼容的对象的图标上带有地球符号。

按钮图像

工具

说明

按钮图像

报表

创建简单的表格式报表,其中包含您在导航窗格中选择的记录源中的所有字段。

按钮图像

空报表

在布局视图中打开一个空报表,并显示出字段列表任务窗格。Access 将在您将字段从字段列表拖到报表中时创建一个记录源查询。

发布到 Access Services 功能有关的详细信息,请参阅生成可在 Web 上共享的 Access 数据库一文。

客户端报表

使用这些工具创建的报表与“发布到 Access Services”功能不兼容。向 Web 数据库添加客户端报表将不会阻止发布数据库,但无法在浏览器中查看客户端报表。不过,当在 Access 中打开数据库时,可使用客户端报表。

按钮图像

工具

说明

按钮图像

报表

创建简单的表格式报表,其中包含您在导航窗格中选择的记录源中的所有字段。

按钮图像

报表设计

在设计视图中打开一个空报表,您可在该报表中只添加所需的字段和控件。

按钮图像

空报表

在布局视图中打开一个空报表,并显示出字段列表任务窗格。当您将字段从字段列表拖到报表中时,Access 将创建一个嵌入式查询并将其存储在报表的记录源属性中。

按钮图像

报表向导

显示一个多步骤向导,允许您指定字段、分组/排序级别和布局选项。该向导将基于您所做的选择创建报表。

按钮图像

标签

显示一个向导,允许您选择标准或自定义的标签大小、您要显示哪些字段以及希望这些字段采用的排序方式。该向导将基于您所做的选择创建报表。


步骤 3:创建报表

  1. 单击与您要使用的工具所对应的按钮。如果出现向导,则按照向导中的步骤操作,然后单击最后一页上的“完成”

    Access 在布局视图中显示所创建的报表。

  2. 调整报表格式直到符合您的要求:

    • 调整字段和标签的大小,方法是选择字段和标签,然后拖动边缘直到达到您需要的大小。

    • 选择一个字段及其标签(如果有),然后拖到新位置来移动字段。

    • 右键单击一个字段,使用快捷菜单上的命令合并或拆分单元格、删除或选择字段以及执行其他格式化任务。

      此外,您还可使用下列部分中所述的功能使报表更加美观易读。

文档顶部

添加分组、排序或汇总

在报表中添加分组、排序或汇总的最快方法是右键单击您要对其应用分组、排序或汇总的字段,然后单击快捷菜单上的所需命令。

在布局视图或设计视图中打开报表时,您还可使用“组”、“排序”和“汇总”窗格来添加分组、排序或汇总:

  1. 如果“组”、“排序”和“汇总”窗格尚未打开,则在“设计”选项卡上的“分组和汇总”组中,单击“分组和排序”

  2. 单击“添加组”“添加排序”,然后选择您要在其上执行分组或排序的字段。

  3. 在分组或排序行上单击“更多”以设置更多选项和添加汇总。

有关分组、 排序和汇总的更多详细信息,请参阅创建分组或汇总报表一文。

文档顶部

使用条件格式突出显示值

Access 2010 包括用于在报表上突出显示数据的更强大的工具。您最多可为每个控件或控件组添加 50 个条件格式规则,在客户端报表中,可添加数据栏以比较各记录中的数据。

若要添加条件格式 :

  1. 在导航窗格中右键单击报表,然后单击“布局视图”,以在布局视图中打开报表。

  2. 选择所有要对其应用条件格式的控件。若要选择多个控件,请按住 SHIFT 或 CTRL 键,然后单击所需的控件。

  3. “格式”选项卡上的“控件格式”组中,单击“条件格式”

    Access 将打开“条件格式规则管理器”对话框。

  4. “条件格式规则管理器”对话框中,单击“新建规则”

  5. “新建格式规则”对话框中,在“选择规则类型”下选择一个值:

    • 若要创建单独针对每个记录进行评估的规则,则选择“检查当前记录值或使用表达式”

    • 若要创建使用数据栏互相比较记录的规则,请单击“比较其他记录”

注意: 在 Web 数据库中,无法使用“比较其他记录”选项。


  1. “编辑规则描述”下,指定规则以确定何时应该应用格式以及在符合规则条件时所需要的格式。

  2. 单击“确定”以返回到“条件格式规则管理器”对话框。

  3. 若要为此控件或控件集创建附加规则,请从步骤 4 重复此过程。否则,单击“确定”以关闭该对话框。

有关向报表添加条件格式的详细信息,请参阅视频使用条件格式在报表上

文档顶部

使用主题获得专业外观

现在,您可对 Access 数据库应用 Office 2010 主题,这可帮助您为所有 Office 文档创建一致的风格。

重要: 如果您选择了某一 Office 主题、字体或颜色,它将应用到您的数据库中的所有窗体和报表(而不只是您正在处理的窗体和报表)。

  1. 通过在导航窗格中右键单击它,然后单击布局V查看在布局视图中打开报表。

  2. 设计选项卡上,在主题组中,选择主题、 颜色或所需的字体︰

    功能区图像

    • 使用“主题”库将颜色和字体同时设置为预先设计的方案。

    • 使用“颜色”“字体”库分别设置颜色或字体。


有关使用 Office 主题的详细信息,请参阅视频更一致的和使用 Office 主题吸引力,使您的 Access 窗体和报表。

文档顶部

添加图像

在 Access 中,一直以来,图像总是绑定到窗体或报表上的单独图像控件。若要更改在多个窗体和报表中使用的常用图像,则必须手动编辑每个图像控件。但是,在 Access 2010 中,现在您只需对数据库附加一次图像,然后即可在多个对象中使用该图像。更新单个图像将会在整个数据库中使用该图像的所有位置更新它。对于在整个数据库中使用的公司徽标或背景图像等内容,这一点非常有用。

添加图像

  1. 在导航窗格中,右键单击您要向其添加图像的报表,然后单击“布局视图”

  2. 单击您要为其添加图像的报表。

  3. “设计”选项卡上的“控件”组中,单击“插入图像”

  4. 然后执行下列操作之一:

    • 使用现有图像   如果所需的图像已在库中,单击它以将其添加到报表。

    • 上载新图像   在库的底部,单击浏览。在插入图片对话框中,导航到要使用的图像,然后单击打开

      Access 将把选定图像添加到报表中。

添加背景图像

注意: 无法在 Web 兼容的报表中添加背景图像。

  1. 在导航窗格中,右键单击您要在其中添加背景图像的报表,然后单击“布局视图”

  2. “格式”选项卡上的“背景”组中,单击“背景图像”

  3. 然后执行下列操作之一:

    • 使用现有图像   如果所需的图像已在库中,单击它以将其添加到报表。

    • 上载新图像   在库的底部,单击浏览。在插入图片对话框中,导航到要使用的图像,然后单击打开

      Access 将把选定图像添加到报表中。

文档顶部

预览和打印报表

预览报表

  1. 打开您要预览的报表或直接在导航窗格中选择它。

  2. “文件”选项卡上,单击“打印”,然后单击“打印预览”

    Access 将在“打印预览”中打开报表。您可使用“打印预览”选项卡上的命令来执行下列操作之一:

    • 打印报表;

    • 调整页面大小或布局;

    • 放大或缩小,或一次查看多个页;

    • 刷新报表上的数据;

    • 将报表导出到其他文件格式。

  3. 若要返回到数据库工作区,请在“打印预览”选项卡上的“关闭预览”组中,单击“关闭打印预览”

打印报表

除了从“打印预览”进行打印外,您还可在不预览的情况下打印报表:

  1. 打开您要预览的报表或直接在导航窗格中选择它。

  2. “文件”选项卡上,单击“打印”

    • 若要将报表直接发送到默认打印机而不设置打印机选项,则单击“快速打印”

    • 若要打开可在其中选择打印机的对话框以指定副本数等,单击“打印”

文档顶部

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×