打开、插入、转换以及保存 DWG 和 DXF (AutoCAD) 绘图

注意:  我们希望能够尽快以你的语言为你提供最新的帮助内容。 本页面是自动翻译的,可能包含语法错误或不准确之处。我们的目的是使此内容能对你有所帮助。可以在本页面底部告诉我们此信息是否对你有帮助吗? 请在此处查看本文的 英文版本 以便参考。

If you have AutoCAD objects that you would like to use in your Visio drawing, you can use Visio to open them and convert them to Visio shapes. You can also convert Visio drawings to AutoCAD files.

Open an AutoCAD drawing in Visio

  1. 单击“文件”>“打开”。

  2. Find the folder in which the drawing that you want is kept. Click the folder or click Browse.

  3. 单击“所有 Visio 文件”列表,然后单击“AutoCAD 绘图”。

  4. 浏览文件并单击“打开”。

将 DWG 或 DXF 文件插入现有 Visio 图表

  1. 在“插入”选项卡上,单击“CAD 绘图”。

  2. 浏览文件并单击“打开”。

将 DWG 和 DXF 对象转换为 Visio 形状

After you import or open an AutoCAD drawing, you can convert it into shapes that you can manipulate in Visio. Please note that converting to Visio shapes cannot be undone.

  1. 单击图表空白位置以取消选择任何已选择的内容。

  2. 将光标停放在 AutoCAD 绘图的外边缘上,直到光标变为此图标:
    带有移动图标的箭头光标

  3. 右键单击,然后单击“CAD 绘图对象”>“转换​​”。

  4. 在“转换 CAD 对象”对话框中,选择要转换为 Visio 形状的 AutoCAD 图层。

  5. 单击“高级”查看更多选项。例如,可以选择删除转换后的图层,也可以将尺寸转换为尺寸形状,或将影线图案转换为形状。

When you convert a drawing in DWG or DXF format, you convert the last saved spatial view of the CAD drawing. A CAD drawing may have been saved in model space or paper space:

  • Model space    is the primary drawing workspace in which CAD drafters create drawings. When you convert a drawing saved in model space, all objects and text on the layers you select are converted into Visio shapes.

  • Paper space    is a workspace that is analogous to a sheet of paper, in which CAD drafters can arrange different views of the drawing.

    The following image shows a DWG drawing saved in paper space.

    保存在图纸空间中、显示同一平面布置图的两种视图的 CAD 绘图

    The drawing contains two rectangular viewports. A viewport is a window into the three-dimensional CAD drawing. Each viewport can be set to a different scale or angle.

    当您转换保存在图纸空间中的绘图时,只有视区边缘未剪切(剪裁)的对象,会转换成 Visio 形状。剪切对象和文本都将转换为线条。例如,一个完全包含在视区的圆将转换成 Visio 圆形形状。被视区剪裁掉的圆将转换为一系列线。

Save a Visio diagram as a DWG or DXF file

  1. 单击“文件”>“另存为”。

  2. 通过浏览找到要保存绘图的位置或文件夹。

  3. 在“保存类型”列表中,单击所需文件类型:

    • AutoCAD 绘图 (*.dwg)

    • AutoCAD 交换格式 (*.dxf)

如果您的 Visio 文件有多个绘图页,您必须单独保存每一页。

另请参阅

Introduction to working with AutoCAD drawings in Visio(在 Visio 中处理 AutoCAD 绘图简介)

Prepare for an AutoCAD import

导入 AutoCAD 绘图

转换多个 AutoCAD 绘图

Open an AutoCAD drawing in Visio

  1. 单击“文件”>“打开”。

  2. Find the folder in which the drawing that you want is kept. Click the folder.

  3. 单击“所有 Visio 文件”列表,然后单击“AutoCAD 绘图”。

  4. 浏览文件并单击“打开”。

将 DWG 或 DXF 文件插入现有 Visio 图表

  1. 在“插入”选项卡上,单击“CAD 绘图”。

  2. 浏览文件并单击“打开”。

将 DWG 和 DXF 对象转换为 Visio 形状

After you import or open an AutoCAD drawing, you can convert it into shapes that you can manipulate in Visio. Please note that converting to Visio shapes cannot be undone.

  1. Right-click the CAD drawing, point to CAD Drawing Object, and then click Convert.

  2. In the Convert CAD Object dialog box, select the check boxes for the AutoCAD layers that contain the CAD objects you want to convert.

    注意: To keep your drawing file size small and speed the conversion process, convert only the layers or levels that you need.

  3. Click Advanced for more options. For example, you can choose to delete or hide the converted layers, convert dimensions into dimension shapes, or convert hatch line patterns into shapes.

  4. 单击“确定”。

When you convert a drawing in DWG or DXF format, you convert the last saved spatial view of the CAD drawing. A CAD drawing may have been saved in model space or paper space:

  • Model space    is the primary drawing workspace in which CAD drafters create drawings. When you convert a drawing saved in model space, all objects and text on the layers you select are converted into Visio shapes.

  • Paper space    is a workspace that is analogous to a sheet of paper, in which CAD drafters can arrange different views of the drawing.

    The following image shows a DWG drawing saved in paper space.

    保存在图纸空间中、显示同一平面布置图的两种视图的 CAD 绘图

    The drawing contains two rectangular viewports. A viewport is a window into the three-dimensional CAD drawing. Each viewport can be set to a different scale or angle.

    当您转换保存在图纸空间中的绘图时,只有视区边缘未剪切(剪裁)的对象,会转换成 Visio 形状。剪切对象和文本都将转换为线条。例如,一个完全包含在视区的圆将转换成 Visio 圆形形状。被视区剪裁掉的圆将转换为一系列线。

Save a Visio diagram as a DWG or DXF file

  1. 单击“文件”>“另存为”。

  2. 通过浏览找到要保存绘图的位置或文件夹。

  3. 在“保存类型”列表中,单击所需文件类型:

    • AutoCAD 绘图 (*.dwg)

    • AutoCAD 交换格式 (*.dxf)

如果您的 Visio 文件有多个绘图页,您必须单独保存每一页。

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×