打开、插入、转换以及保存 DWG 和 DXF (AutoCAD) 绘图

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

如果您有您想要使用 Visio 绘图中的 AutoCAD 对象时,您可以使用 Visio 将其打开,并将其转换为 Visio 形状。您还可以将 Visio 绘图转换为 AutoCAD 文件。

打开 AutoCAD 绘图在 Visio 中

  1. 单击“文件”>“打开”。

  2. 找到所需的绘图将保持在其中的文件夹。单击该文件夹,或单击浏览

  3. 单击“所有 Visio 文件”列表,然后单击“AutoCAD 绘图”。

  4. 浏览文件并单击“打开”。

将 DWG 或 DXF 文件插入现有 Visio 图表

  1. 在“插入”选项卡上,单击“CAD 绘图”。

  2. 浏览文件并单击“打开”。

将 DWG 和 DXF 对象转换为 Visio 形状

之后您导入或打开 AutoCAD 绘图,您可以将其转换形状,可以在 Visio 中进行处理。请注意,将转换为 Visio 形状不能撤消。

  1. 单击图表空白位置以取消选择任何已选择的内容。

  2. 将光标停放在 AutoCAD 绘图的外边缘上,直到光标变为此图标:
    带有移动图标的箭头光标

  3. 右键单击,然后单击“CAD 绘图对象”>“转换​​”。

  4. 在“转换 CAD 对象”对话框中,选择要转换为 Visio 形状的 AutoCAD 图层。

  5. 单击“高级”查看更多选项。例如,可以选择删除转换后的图层,也可以将尺寸转换为尺寸形状,或将影线图案转换为形状。

将转换为 DWG 或 DXF 格式绘图时,您将转换上次保存该 CAD 绘图的空间视图。可能会在模型空间图纸空间中保存的 CAD 绘图︰

  • 模型空间   是 CAD 制图员在其中创建绘图的主要绘图工作区。当您转换保存在模型空间中的绘图时,所有对象和您选择的图层上的文本将都转换为 Visio 形状。

  • 图纸空间   是绘图的类似于一张纸,哪些 CAD 制图员可在排列不同视图工作区。

    下图显示保存在图纸空间中 DWG 绘图。

    保存在图纸空间中、显示同一平面布置图的两种视图的 CAD 绘图

    绘图包含两个矩形视区。视区是进入三维 CAD 绘图窗口。可以将每个视口设置为不同的比例或角度。

    当您转换保存在图纸空间中的绘图时,只有视区边缘未剪切(剪裁)的对象,会转换成 Visio 形状。剪切对象和文本都将转换为线条。例如,一个完全包含在视区的圆将转换成 Visio 圆形形状。被视区剪裁掉的圆将转换为一系列线。

将 Visio 图表另存为 DWG 或 DXF 文件

  1. 单击“文件”>“另存为”。

  2. 通过浏览找到要保存绘图的位置或文件夹。

  3. 在“保存类型”列表中,单击所需文件类型:

    • AutoCAD 绘图 (*.dwg)

    • AutoCAD 交换格式 (*.dxf)

如果您的 Visio 文件有多个绘图页,您必须单独保存每一页。

另请参阅

Introduction to working with AutoCAD drawings in Visio(在 Visio 中处理 AutoCAD 绘图简介)

准备 AutoCAD 导入

导入 AutoCAD 绘图

将多个 AutoCAD 绘图转换

打开 AutoCAD 绘图在 Visio 中

  1. 单击“文件”>“打开”。

  2. 找到所需的绘图将保持在其中的文件夹。单击文件夹。

  3. 单击“所有 Visio 文件”列表,然后单击“AutoCAD 绘图”。

  4. 浏览文件并单击“打开”。

将 DWG 或 DXF 文件插入现有 Visio 图表

  1. 在“插入”选项卡上,单击“CAD 绘图”。

  2. 浏览文件并单击“打开”。

将 DWG 和 DXF 对象转换为 Visio 形状

导入或打开 AutoCAD 绘图后,可以将其转换为形状,可以在 Visio 中进行处理。请注意,将转换为 Visio 形状不能撤消。

  1. 右键单击 CAD 绘图,指向CAD 绘图对象,,然后单击转换

  2. 转换 CAD 对象对话框中,选择包含要转换的 CAD 对象 AutoCAD 层对应的复选框。

    注意: 若要保持您绘图的文件大小较小并加快转换过程,转换的图层或所需的级别。

  3. 有关更多选项,请单击高级。例如,可以选择删除或隐藏已转换的图层,请将转换尺寸形状的尺寸,或者将转换为形状的阴影线型。

  4. 单击“确定”。

将转换为 DWG 或 DXF 格式绘图时,您将转换上次保存该 CAD 绘图的空间视图。可能会在模型空间图纸空间中保存的 CAD 绘图︰

  • 模型空间   是 CAD 制图员在其中创建绘图的主要绘图工作区。当您转换保存在模型空间中的绘图时,所有对象和您选择的图层上的文本将都转换为 Visio 形状。

  • 图纸空间   是绘图的类似于一张纸,哪些 CAD 制图员可在排列不同视图工作区。

    下图显示保存在图纸空间中 DWG 绘图。

    保存在图纸空间中、显示同一平面布置图的两种视图的 CAD 绘图

    绘图包含两个矩形视区。视区是进入三维 CAD 绘图窗口。可以将每个视口设置为不同的比例或角度。

    当您转换保存在图纸空间中的绘图时,只有视区边缘未剪切(剪裁)的对象,会转换成 Visio 形状。剪切对象和文本都将转换为线条。例如,一个完全包含在视区的圆将转换成 Visio 圆形形状。被视区剪裁掉的圆将转换为一系列线。

将 Visio 图表另存为 DWG 或 DXF 文件

  1. 单击“文件”>“另存为”。

  2. 通过浏览找到要保存绘图的位置或文件夹。

  3. 在“保存类型”列表中,单击所需文件类型:

    • AutoCAD 绘图 (*.dwg)

    • AutoCAD 交换格式 (*.dxf)

如果您的 Visio 文件有多个绘图页,您必须单独保存每一页。

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×