打开、插入、转换以及保存 DWG 和 DXF (AutoCAD) 绘图

Office 365 订阅, Office 2019, Office 2016, Office 2013, Office 2010

如果你要在 Visio 绘图中使用 AutoCAD 对象, 则可以使用 Visio 打开它们并将其转换为 Visio 形状。 您也可以将 Visio 绘图转换为 AutoCAD 文件。

注意    Microsoft Visio 支持 AutoCAD 文件格式的方式如下: 使用 Visio Online 计划 2, 可以导入从 AutoCAD 版本2017或更早版本创建的 dwg 或 dxf 文件。 使用 Visio 标准版或专业版, 您可以导入从 AutoCAD 版本2007或更早版本创建的 dwg 或 dxf 文件。 如果无法打开 dwg 或 dxf 文件, 其文件格式可能不受支持。 作为解决方法, 在 AutoCAD 中打开文件, 然后将其保存为你的 Visio 产品或计划支持的文件格式。 有关详细信息, 请参阅如何将 AutoCAD 绘图保存到以前或较旧的文件格式DWG 版本历史记录

在 Visio 中打开 AutoCAD 绘图

  1. 单击“文件”>“打开”。

  2. 查找保存所需绘图的文件夹。 单击文件夹或单击 "浏览"。

  3. 单击 "所有 Visio 文件" 列表, 然后单击 " AutoCAD 绘图"。

  4. 浏览到文件, 然后单击 "打开"。

在现有 Visio 图表中插入 DWG 或 DXF 文件

  1. 在“插入”选项卡上,单击“CAD 绘图”。

  2. 浏览到文件, 然后单击 "打开"。

将 DWG 和 DXF 对象转换为 Visio 形状

导入或打开 AutoCAD 绘图后,你可以将其转换为可以在 Visio 中操作的形状。 请注意,转换为 Visio 形状的操作不能撤消。

  1. 单击图表上的空白位置以取消选择任何可能已选择的内容。

  2. 将光标停放在 AutoCAD 绘图的外边缘上,直到光标变为此图标:
    带有移动图标的箭头光标

  3. 右键单击,然后单击“CAD 绘图对象”>“转换​​”。

  4. 在“转换 CAD 对象”对话框中,选择要转换为 Visio 形状的 AutoCAD 图层。

  5. 单击“高级”查看更多选项。 例如,可以选择删除转换后的图层,也可以将尺寸转换为尺寸形状,或将影线图案转换为形状。

以 DWG 或 DXF 格式转换绘图时, 将转换 CAD 绘图的上次保存的空间视图。 CAD 绘图可能已保存在模型空间纸张空间中:

  • 模型空间    是 CAD 制图员创建绘图的主绘图工作区。 转换保存在模型空间中的绘图时, 所选图层上的所有对象和文本都将转换为 Visio 形状。

  • 纸张空间   是类似于一张纸的工作区, 其中 CAD 制图员可以排列绘图的不同视图。

    下图显示了保存在纸张空间中的 DWG 绘图。

    保存在图纸空间中、显示同一平面布置图的两种视图的 CAD 绘图

    绘图包含两个矩形视区。 视区是三维 CAD 绘图的窗口。 每个视区可以设置为不同的比例或角度。

    当您转换保存在纸张空间中的绘图时, 仅由视区边缘不截断 (剪裁) 的对象转换为 Visio 形状。 被切断的对象和文本将转换为线条。 例如, 完全包含在视区中的圆形将转换为 Visio 圆形形状。 被视区剪裁的圆形将转换为一系列行。

将 Visio 图表另存为 DWG 或 DXF 文件

  1. 单击“文件”>“另存为”。

  2. 通过浏览找到要在其中保存绘图的位置或文件夹。

  3. 在 "保存类型" 列表中, 单击所需的文件类型:

    • AutoCAD 绘图(* dwg)

    • AutoCAD 交换(* dxf)

如果你的 Visio 有多个绘图页,必须单独保存每一页。

另请参阅

Introduction to working with AutoCAD drawings in Visio(在 Visio 中处理 AutoCAD 绘图简介)

准备导入 AutoCAD

导入 AutoCAD 绘图

转换多个 AutoCAD 绘图

在 Visio 中打开 AutoCAD 绘图

  1. 单击“文件”>“打开”。

  2. 查找保存所需绘图的文件夹。 单击该文件夹。

  3. 单击 "所有 Visio 文件" 列表, 然后单击 " AutoCAD 绘图"。

  4. 浏览到文件, 然后单击 "打开"。

在现有 Visio 图表中插入 DWG 或 DXF 文件

  1. 在“插入”选项卡上,单击“CAD 绘图”。

  2. 浏览到文件, 然后单击 "打开"。

将 DWG 和 DXF 对象转换为 Visio 形状

导入或打开 AutoCAD 绘图后,你可以将其转换为可以在 Visio 中操作的形状。 请注意,转换为 Visio 形状的操作不能撤消。

  1. 右键单击 CAD 绘图, 指向 " Cad 绘图对象", 然后单击 "转换"。

  2. 在 "转换 CAD 对象" 对话框中, 选中包含要转换的 CAD 对象的 AutoCAD 图层所对应的复选框。

    注意: 若要使绘图文件的大小保持较小并加快转换过程, 请仅转换所需的图层或级别。

  3. 单击“高级”查看更多选项。 例如, 您可以选择删除或隐藏已转换的图层、将尺寸转换为尺寸形状或将阴影线图案转换为形状。

  4. 单击“确定”。

以 DWG 或 DXF 格式转换绘图时, 将转换 CAD 绘图的上次保存的空间视图。 CAD 绘图可能已保存在模型空间纸张空间中:

  • 模型空间    是 CAD 制图员创建绘图的主绘图工作区。 转换保存在模型空间中的绘图时, 所选图层上的所有对象和文本都将转换为 Visio 形状。

  • 纸张空间   是类似于一张纸的工作区, 其中 CAD 制图员可以排列绘图的不同视图。

    下图显示了保存在纸张空间中的 DWG 绘图。

    保存在图纸空间中、显示同一平面布置图的两种视图的 CAD 绘图

    绘图包含两个矩形视区。 视区是三维 CAD 绘图的窗口。 每个视区可以设置为不同的比例或角度。

    当您转换保存在纸张空间中的绘图时, 仅由视区边缘不截断 (剪裁) 的对象转换为 Visio 形状。 被切断的对象和文本将转换为线条。 例如, 完全包含在视区中的圆形将转换为 Visio 圆形形状。 被视区剪裁的圆形将转换为一系列行。

将 Visio 图表另存为 DWG 或 DXF 文件

  1. 单击“文件”>“另存为”。

  2. 通过浏览找到要在其中保存绘图的位置或文件夹。

  3. 在 "保存类型" 列表中, 单击所需的文件类型:

    • AutoCAD 绘图(* dwg)

    • AutoCAD 交换(* dxf)

如果你的 Visio 有多个绘图页,必须单独保存每一页。

注意:  本页面是自动翻译的,可能包含语法错误或不准确之处。 我们的目的是使此内容能对你有所帮助。 能否告知我们此信息是否有所帮助? 下面是该参考内容的英文版

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×