录制宏

如果您在 Microsoft Office Project 中重复执行任务, 则可以使用宏自动执行任务。 宏是存储在 模块 中的一系列命令和函数, 可在需要执行任务时运行。

  1. 在 "视图" 选项卡上, 选择 "", 然后选择 "录制宏"。

    (在 Project 2007 中, 在 "工具" 菜单上, 指向 "", 然后选择 "录制新宏"。)

  2. 在 "宏名" 框中, 键入 宏 的名称。

    宏名的第一个字符必须是字母。 其他字符可以是字母、数字或下划线字符。 宏名称中不能包含空格, 但下划线可以像单词分隔符一样工作。

  3. 若要能够通过按 快捷键 运行宏, 请在 "快捷键" 框中输入一个字母或组合键。

    可以使用 CTRL + 字母 (对于小写字母) 或 CTRL + SHIFT + 字母 (对于大写字母), 其中字母是键盘上的任何字母键, 而不是数字或特殊字符。 不能使用已在 Microsoft Office Project 中使用的组合键。

  4. 在 "将宏保存在" 列表中, 选择要在其中保存宏的位置:

    • 若要使宏在您每次使用 Project 时可用, 请选择 "全局文件"。

    • 若要使宏仅适用于当前项目, 请选择 "此项目"。

  5. 若要包括宏的说明, 请在 "说明" 框中键入说明。

  6. 如果在录制宏时选择了单元格, 则该宏将在每次运行时选择相同的列 (字段), 而不考虑首次选择的单元格, 因为它记录对列的绝对引用。 如果你希望宏在运行宏时选择列, 而不考虑活动单元格的位置, 请选择 "列引用" 下的 "相对"。

    相反, 当你运行宏时, 宏将选择行, 而不考虑活动单元格的位置, 因为它会记录对行的相对引用。 如果希望宏始终选择同一行, 而不考虑首次选择哪个单元格, 请在 "行引用" 下选择 "绝对 (ID) "。

    注意: 录制宏时, Project 会继续使用这些设置, 直到你更改设置或关闭 Project。

  7. 选择"确定", 然后执行要录制的操作。

  8. 完成要录制的所有操作后, 在 "视图" 选项卡上, 选择 "", 然后选择 "停止录制"。

    (在 Project 2007 中, 在 "工具" 菜单上, 指向 "", 然后选择 "停止录制"。)

安全说明: 由于宏可能包含病毒, 因此运行它们时要小心。 采取以下预防措施: 在计算机上运行最新的防病毒软件;将宏安全级别设置为 "高";清除 "信任所有安装的加载项和模板" 复选框;使用数字签名;维护受信任的发布者列表。

注意:  本页面是自动翻译的,可能包含语法错误或不准确之处。 我们的目的是使此内容能对你有所帮助。 能否告知我们此信息是否有所帮助? 下面是该参考内容的英文版

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×