建立 Windows XP 界面元素的模型

注意: 我们希望能够尽快以你的语言为你提供最新的帮助内容。本页面是自动翻译的,可能包含语法错误或不准确之处。我们的目的是使此内容能对你有所帮助。可以在本页面底部告诉我们此信息是否对你有帮助吗?请在此处查看本文的英文版本以便参考。

使用Windows xp 用户界面模板, 创建使用根据 Microsoft Windows XP 指南设计的形状的用户界面的模型。这些形状包括接口中常用的元素, 如用于应用程序窗口、向导页、工具栏和菜单形状以及控件形状的空白窗体。

你可以使用这些形状将复杂的应用程序窗口或选项卡式对话框的模型中的所有内容都设置为简单的消息框或单个按钮。

您要做什么?

"创建单个" 对话框

创建选项卡式对话框

创建应用程序窗口

生成菜单和工具栏

"创建单个" 对话框

  1. 从 "窗口和对话框" 中, 将 "空白窗体" 形状拖到绘图页上。

  2. 选中形状后, 键入对话框的标题。

  3. 将 "窗口" 按钮形状拖到标题栏的右端, 然后选择按钮类型。通常有一个 "帮助" 按钮和一个 "关闭" 按钮, 它从左到右排列。

  4. 将命令按钮 (如"确定"、"取消" 和 "应用") 添加到 "空白窗体" 形状的右下角。

    1. 从 "公共控件" 中, 将 "命令按钮" 形状拖到 "空白窗体" 形状的右下边缘。

    2. 选择每个按钮并键入控件的名称。

  5. 将适当的控件拖到 "空白窗体" 形状上。右键单击形状以选择相应的选项。

    有关特定控件形状的帮助, 请右键单击该形状, 然后单击 "帮助"。

    如果你使用 "文本" 工具在空白窗体形状上创建自己的文本, 请将文本的格式设置为 Tahoma 8 磅。

  6. 将群集命令转换为逻辑组。

  7. "分组框"和 "组合线" 形状拖动到 "空白窗体" 形状上以直观地分隔组。

    使用 "参考线" 对齐控件。

    "文件" 菜单下的 "打印" 对话框是包含许多最常用元素的对话框的一个很好的示例。

返回首页

创建选项卡式对话框

  1. 从 "窗口和对话框" 中, 将 "空白窗体" 形状拖到绘图页上。

  2. 选中形状后, 键入对话框的标题。

  3. 将 "窗口" 按钮形状拖到标题栏的右端, 然后选择按钮类型。通常有一个 "帮助" 按钮和一个 "关闭" 按钮, 它从左到右排列。

  4. 将命令按钮 (如"确定"、"取消" 和 "应用") 添加到 "空白窗体" 形状的右下角。

    1. 从 "公共控件" 中, 将 "命令按钮" 形状拖到 "空白窗体" 形状的右下边缘。

    2. 选择每个按钮并键入控件的名称。

  5. "选项卡控件 (body) " 形状拖到 "空白窗体" 形状上, 并调整其大小以适合窗体, 为选项卡留出空间。

  6. 拖动"选项卡控件 (选项卡) " 形状, 并将其粘附到"选项卡控件 (body) " 形状的顶部边缘。

  7. 选中 "选项卡控件 (选项卡) " 形状后, 键入选项卡的名称。

  8. 对每个选项卡重复步骤6和 7, 将选项卡彼此粘附, 并与选项卡控件 (正文)形状对应。

  9. 右键单击要显示为前一个选项卡的选项卡, 单击 "前景选项卡", 然后将 "其他" 设置为"背景" 选项卡

  10. 将适当的控件拖到 "空白窗体" 形状上。右键单击形状以选择相应的选项。

    有关特定控件形状的帮助, 请右键单击该形状, 然后单击 "帮助"。

    如果你使用 "文本" 工具在空白窗体形状上创建自己的文本, 请将文本的格式设置为 Tahoma 8 磅。

  11. 将群集命令转换为逻辑组。

  12. "分组框"和 "组合线" 形状拖动到 "空白窗体" 形状上以直观地分隔组。

    使用 "参考线" 对齐控件。

    "文件" 菜单下的 "页面设置" 对话框是包含许多最常用元素的对话框的一个很好示例。

返回首页

创建应用程序窗口

  1. 从 "窗口和对话框" 中, 将 "空白窗体" 形状拖到绘图页上。

  2. 选中形状后, 键入应用程序窗口的标题。

  3. 若要在标题栏中的文本左侧添加图标, 请右键单击 "空白窗体" 形状, 然后选中 "为图标留出空间" 复选框。

  4. 将 "窗口按钮" 形状拖到标题栏的右端, 然后选择按钮类型。通常有三个按钮: "最小化" 按钮、"最大化" 或 "还原" 按钮和 "关闭" 按钮, 按从左到右的顺序排列。

  5. 从 "工具栏和菜单" 中, 将 "菜单栏" 形状拖到 "空白窗体" 形状上, 将其粘附到标题栏的底部, 然后添加菜单项。

    1. 将 "顶层菜单项" 形状拖到页面上, 并将其粘附到菜单栏的左边缘。

      你可以将图标放在第一个菜单项的左侧。

    2. 选中形状后, 键入名称。如果菜单项具有键盘快捷方式, 请为相应信函加下划线。

    3. 根据需要重复步骤1和2。

      若要获取有关某个形状的帮助, 请右键单击它, 然后单击 "帮助"。

      若要隐藏连接点 连接点图像 - 蓝色 X , 请在 "视图" 菜单上, 单击 "连接点"。

      列中的项目都应为最宽的项目的宽度。

    若要在菜单栏的左边缘显示控制手柄点, 请右键单击该形状, 然后清除 "锁定菜单栏" 复选框。

  6. 从 "工具栏和菜单" 中, 将 "工具栏" 形状拖到 "空白窗体" 形状上, 将其粘附到菜单栏的底部, 然后添加工具栏按钮。

    1. 将其中一个工具栏按钮形状拖到页面上, 并将其粘附到工具栏形状的左边缘。

    2. 在 "形状数据" 对话框中, 选择所需的按钮类型。如果以后要更改该按钮, 请右键单击该形状, 然后单击 "设置按钮类型" 以重新打开 "形状数据" 对话框。

    3. 根据需要拖出更多工具栏按钮按钮分隔符, 并将它们粘附到其他形状上。

      若要获取有关某个形状的帮助, 请右键单击它, 然后单击 "帮助"。

      若要隐藏连接点 连接点图像 - 蓝色 X , 请在 "视图" 菜单上, 单击 "连接点"。

    若要显示工具栏左侧边缘的控制手柄点, 请右键单击该形状, 然后清除 "锁定工具栏" 复选框。

  7. 公共控件, 根据需要将水平和垂直滚动条拖动到空白窗体形状的右侧和底部边缘。

  8. 右键单击滚动条, 然后选择 "设置缩略图大小" 以指示窗口可以滚动的距离。

    若要指示仅文档的一小部分可见, 请将缩略图的大小设置为小。若要指示文档的大部分可见, 请将缩略图的大小设置为较大。

  9. 将 " 状态栏" 形状拖到应用程序窗口的下边缘, 并相应设置格式。

    1. 将 "状态栏分隔线" 形状拖到页面上, 并将其粘附到状态栏形状的控制手柄 控制手柄

      控制手柄提供了将 "状态栏分隔线" 形状粘附到状态栏或其他状态栏分隔条形状的位置。

      如果将 "状态栏分隔线" 粘附到状态栏形状后看不到, 请选择 "状态栏" 形状, 然后在 "形状" 菜单上, 指向 "顺序", 然后单击 "下移一"。

    2. 将 "窗口调整大小" 形状拖动到状态栏的右边缘, 以指示当前窗口可调整大小。

返回首页

生成菜单和工具栏

你可以使用 Windows XP 形状生成基本菜单、下拉菜单和工具栏。

生成菜单

  1. 从 "工具栏和菜单" 中, 将 "菜单栏" 形状拖到绘图页上。若要在菜单栏的左边缘显示控制手柄点, 请右键单击该形状, 然后清除 "锁定菜单栏" 复选框。

  2. 拖出 "顶级菜单项" 形状, 并将其粘附到菜单栏的左边缘。

    提示: 你可能希望将图标放在第一个菜单项的左侧。

  3. 选中形状后, 键入名称。如果菜单项具有键盘快捷方式, 请为相应信函加下划线。

  4. 根据需要重复步骤2和3。

    若要获取有关某个形状的帮助, 请右键单击它, 然后单击 "帮助"。

    若要隐藏连接点 连接点图像 - 蓝色 X , 请在 "视图" 菜单上, 单击 "连接点"。

    列中的项目都应为最宽的项目的宽度。

构建下拉式菜单

  1. 将 "顶层菜单项" 形状拖到绘图页上。

  2. 选中形状后, 键入名称。如果菜单项具有键盘快捷方式, 请为相应信函加下划线。

  3. 拖动下拉菜单项形状, 将其粘附到顶级菜单项的底部, 然后键入名称。

  4. 对列中的所有下拉式菜单项重复步骤3。

  5. 将所有下拉菜单项的大小调整为最宽的菜单项的宽度。

  6. 右键单击每个下拉菜单项形状, 单击 "菜单项属性", 然后选择相应的选项。

    若要获取有关某个形状的帮助, 请右键单击它, 然后单击 "帮助"。

    若要隐藏连接点 连接点图像 - 蓝色 X , 请在 "视图" 菜单上, 单击 "连接点"。

生成工具栏

  1. 从 "工具栏和菜单" 中, 将 "工具栏" 形状拖到绘图页上。若要显示工具栏左侧边缘的控制手柄点, 请右键单击该形状, 然后清除 "锁定工具栏" 复选框。

  2. 拖动工具栏按钮形状, 并将其粘附到工具栏形状的左边缘。

  3. 在 "形状数据" 对话框中, 选择所需的按钮类型。如果以后要更改该按钮, 请右键单击该形状, 然后单击 "设置按钮类型" 以重新打开 "形状数据" 对话框。

  4. 根据需要拖动 "更多"工具栏按钮按钮分隔符, 并将它们粘附到其他形状上。

    若要获取有关某个形状的帮助, 请右键单击它, 然后单击 "帮助"。

    若要隐藏连接点 连接点图像 - 蓝色 X , 请在 "视图" 菜单上, 单击 "连接点"。

返回页首

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×