将 Word 文档转换为 InfoPath 表单模板

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

尽管确实可以使用 Microsoft Office Word 创建外观类似表单的文档,然而 Word 是最好的文字处理程序,而不是表单设计程序。反过来,Microsoft Office InfoPath 是专为设计和填写电子表单而设计的。如果您希望将现有 Word 文档转换为 InfoPath 表单模板,可以使用 InfoPath 中的导入向导来完成此工作。然后,您便可以利用 InfoPath 用于设计、发布和填写表单的专门功能。例如,在销售报表表单模板中,您可以使用条件格式在数字低于销售计划时自动应用红色背景颜色。在同一表单模板中,您还可以使用规则在某人单击提交按钮时使基于此表单模板的表单作为邮件附件提交出去。另外,您还可以通过创建启用浏览器功能的表单模板让更多的人使用您的表单模板。

在将 Word 文档转换为 InfoPath 表单模板时,结果表单模板将与 Word 文档的版式基本一致。另外,Word 文档中满足特定条件的项自动转换为用户可以向其中输入数据的相应控件。例如,如果 Word 文档中包含一个将多个空格括起来的括号,InfoPath 会认为您使用该括号括起来的区域作为一个文本输入域,并在结果表单模板中将其转换为一个文本框控件。所有 Word 表单域都被转换为 InfoPath 中相应的控件。

可以使用“导入选项”对话框中的设置更改将 Word 文档转换为 InfoPath 表单模板的选项。

本文介绍有关将 Word 文档转换为 InfoPath 表单模板的基本概念和步骤,包括转换过程不支持的功能和设置。

本文内容

关于将 Word 文档转换为 InfoPath 表单模板

转换过程不完全支持的 Word 功能和设置

将 Word 文档转换为 InfoPath 表单模板

将版式表格更改为重复表

将复选框更改为一组选项按钮

在“检查设计方案”任务窗格中检查转换问题

关于将 Word 文档转换为 InfoPath 表单模板

在将 Word 文档转换为 InfoPath 表单模板时,文档的作用类似于创建新表单模板的蓝图。文档的基本结构在表单模板中被重新创建,力求一致。在 Word 文档中,一个“表单域”是指特定类型的数据(如名称或地址)的存储位置。如果您在转换文档时选择包含 Word 表单域,则会向 InfoPath 表单模板中与 Word 文档中的域位置对应的位置添加文本框、复选框和下拉列表框控件。另外,InfoPath 会自动检测 Word 文档中可能适合作为重复表和格式文本框的部分,并将其转换为相应的控件。例如,如果一份零用金报销单文档包含了一个空的带下划线的区域,在此位置用户可以键入有关特定零用金的附注,InfoPath 会将此区域转换为一个格式文本框。这样,用户可以在格式文本框中输入多行文本,并根据需要设置文本格式。

若要更好地了解 Word 文档中使用 InfoPath 导入向导和生成的 InfoPath 表单模板将转换之间的关系,假设,过去几年您的组织具有用于 Word 文档名为 ExpenseReport.doc 从员工收集费用报表数据。您的 IT 部门想要将该文档转换为 InfoPath 表单模板,以便表单数据可以应付帐款系统提交可扩展标记语言 (XML)。

如果使用导入向导将 ExpenseReport.doc 转换为表单模板,InfoPath 会创建一个名为 ExpenseReport.xsn 的表单模板。在下面的示例中,Word 文档中的 Expense Details 表格已转换为结果 InfoPath 表单模板中的一个重复表。重复表可使用户通过单击快捷菜单上的命令来根据需要插入或删除零用金。

已转换为 InfoPath 重复表的 Word 表格

Word 文档被转换为 InfoPath 表单模板时,版式及其他元素仍保留。默认情况下,InfoPath 重复表中的空行数与 Word 表格中的空行数匹配。但是,通过默认只显示一行或两行,可以节约表单模板的空间。

此新表单模板包含了与 Word 文档中出现的元素相似的元素,如用于采集零用金信息的表格。但是,根据您在“导入向导”中选择的设置,某些功能在生成的表单模板中可能会有所不同:

  • 如果使用导入向导导入 Word 文档时只保留版式    结果表单模板会包含用于在零用金报销单中输入行条目的重复表。但是,结果表单模板中会去除原始文档中的所有表单域,如 Name 文本框、Department 下拉列表框以及 Division 复选框。

  • 如果使用导入向导导入 Word 文档时保留版式并将 Word 表单域转换为控件(默认)    结果表单模板会包含用于在零用金报销单中输入行条目的重复表。原始文档中的所有表单域,如 Name 文本框、Department 下拉列表框以及 Division 复选框,都被转换为 InfoPath 中相应的控件。

  • 如果使用导入向导导入 Word 文档时保留版式并将表单域转换为控件(自定义)    您可以决定导入零用金报销单时要转换的域。例如,可以禁用将文档中的空白表格单元格在结果表单模板中转换为文本框的选项。

返回页首

转换过程不完全支持的 Word 功能和设置

Word 文档中有些设置和格式在 InfoPath 表单模板中不受支持。转换包含此类设置的 Word 文档时,结果表单模板将不包含这些功能或设置。例如,如果 Word 文档有修订标记,则修订标记将从结果表单模板中去除,因为 InfoPath 不支持此功能。

可以使用设计模式下的“检查设计方案”任务窗格检查是否有任何转换问题。然后可以采取措施改正这些问题。

下面是将 Word 文档转换为 InfoPath 表单模板时不保留的功能和设置列表。有些情况下,格式虽被去除,但文本被保留下来。例如,如果您有简报式分栏内容,InfoPath 将去除这些分栏,但会导入这些分栏中的文本。

  • 书签

  • 动态文字

  • 主题

  • 水印

  • 行号

  • 页边框

  • 脚注和尾注

  • 简报式分栏版式

  • 文件附件

  • 链接或签入对象,如 Microsoft Office Excel 工作表和 Microsoft Office Visio 绘图

  • 绘图对象(包括自选图形、曲线、直线和艺术字)

  • 字符间距(包括缩放比例、缩放间距、文本位置的提升或降低以及字体的字距)

  • ActiveX 控件

  • 批注和修订(包括插入、删除以及格式更改)

  • 特定于Microsoft Office Word 2007 (包括构建基块和内容控件) 的一些功能

  • 某些打印设置(包括页眉和页脚中的混合字符格式、不同的奇偶页眉和页脚、首页不同的页眉和页脚、装订线设置、负数值的上下边距、不同的页面方向以及单独的节设置)

注意: 密码不能修改某些 Word 文档。如果这是与您的文档这种情况,您可能无法成功将其导入到 InfoPath。若要修复此问题,请尝试从文档中删除密码保护之前将其导入,。此外,某些文档用户限制到特定类型的编辑操作,如在窗体字段中输入数据。如果这是与您的文档这种情况,您可能无法成功将其导入到 InfoPath。若要修复此问题,请尝试删除文档的编辑限制之前将其导入。

下面的列表解释将 Word 文档转换为 InfoPath 表单模板时部分支持的功能和设置列表:

竖排文字    如果表格单元格中有竖排文字,InfoPath 会保留 Word 文档中的竖排文字格式。如果竖排文字出现在表格单元格之外,位于 Word 文档另外的部分中,InfoPath 会在转换 Word 文档时去除竖排文字格式。

文本框    在 Word 文档中,文本框是文本的容器,可在页面上进行定位和调整大小。如果 Word 文档包含文本框,该文本框将被转换为结果表单模板中的表格单元格。文本框中的任何文本都将出现在结果表单模板的表格单元格中。

带下划线的文本    InfoPath 表单模板支持下划线格式。但是,Word 文档中任何修饰性下划线或双下划线都转换为结果表单模板中的单下划线。

引用不支持的协议的超链接    所有超链接都会被转换,但是如果超链接使用除 HTTP、HTTPS、FILE、FTP 和 MAILTO 之外的协议,则结果表单模板中的该链接在用户单击时不起作用。

字符样式和文本效果    转换过程中会保留上标、下标和单删除线格式样式。其他格式样式和效果(包括带轮廓线的文本、隐藏文本及阴影格式)将在转换中被去除。阳文和阴文文本在结果表单模板中转换为灰色文本。

节设置    在 Word 中,节用于实现文档的一个页面中或不同页面间的不同版式。InfoPath 不支持这些类型的节,在转换过程中会将其去除。Word 文档中第一节所用的任何设置都会被应用到结果 InfoPath 表单模板中。

页眉和页脚格式    Word 文档中的页眉和页脚文本将被转换为结果 InfoPath 表单模板中的页眉和页脚文本。转换过程中会去除某些字符格式。例如,如果您在 Word 文档的页眉中同时使用了粗体和斜体两种格式,InfoPath 将在结果表单模板中使用它最先遇到的格式样式并去除其余的格式。同样,Word 文档中第一个页眉或页脚节中所用的任何设置都被应用到结果 InfoPath 表单模板中的页眉和页脚文本。

字体转换    尽管 InfoPath 在创建新表单模板时会从 Word 文档导入字体,但如果文档中的字体在您执行导入的计算机上未提供,则会为表单模板自动选择替换字体。

负页边距    负的上边距和下边距将导入为 0。

负边距、填充和缩进设置    负边距、填充和缩进设置都将导入为 0。

返回页首

将 Word 文档转换为 InfoPath 表单模板

  1. 如果您要导入的文档已经打开,请将其关闭。

  2. 在设计模式下,在“文件”菜单上单击“导入表单”

  3. 在导入向导中,单击“将 Word 文档导入 InfoPath”,然后单击“下一步”

  4. 单击“浏览”

  5. 找到并单击要转换的 Word 文档,然后单击“打开”

    注意: 如果导入的是具有受限权限的 Word 文档,您必须具有该文档的“完全控制”访问权限。如果您对该文档只有“读取”或“修改”访问权限,则在尝试导入时会看到一条错误消息。

  6. 要更改默认的导入行为,请单击“选项”,然后选择所需选项。

  7. 单击“完成”

返回页首

将版式表格更改为重复表

如果 Word 文档包含表格,InfoPath 可能在结果表单模板中将其转换为布局表格或重复表。所选择的表格类型取决于您在 Word 文档中作出的设计决定。您可以使用下列步骤将已转换好的版式表格快速更改为重复表。

您可以使用重复表时填写的表单提供您的用户程度额外的灵活性。使用重复表时,您的表单模板没有用户首次打开时显示大量空白的行。相反,用户通常只看到一行,只需时,并在需要添加详细信息。此窗体中节省空间,并提供额外程度的个性化的用户。

  1. 在表单模板中,右键单击任意位置在要转换的版式表格内。

  2. 在快捷菜单上,指向更改为,然后单击重复表

  3. 更改为重复表对话框中,请执行一个或多个下列操作 ︰

    • 若要指定的重复表标题行,请在要保留作为表格标题的行数框中输入值。您通常用于列标题的标题行。

    • 若要指定重复表中的页脚行,请在要保留为表页脚的行数框中输入值。多个表中不包含页脚行。

    • 若要指定要使用的数据行数,请在的重复行数以包括时填写表单框中输入值。数据行是可以"重复"根据需要多次为窗体中的行

  4. “插入”菜单上,单击“其他控件”,也可以先按 Alt+I,再按 C。

  5. 插入所需的表格单元格的控件。

返回页首

将复选框更改为一组选项按钮

如果您在 Word 文档中使用了多个复选框,InfoPath 会在结果 InfoPath 表单模板中将其导入为复选框。如果您希望使用一组选项按钮,可按下面的步骤将复选框转换为表单模板中的选项按钮。

如果您希望用户能够进行一次即可选择从一组有限的选项,可以使用 Microsoft Office InfoPath 表单模板上的一组选项按钮。

  1. 在表单模板中,请单击您想要将转换,然后按住 CTRL 并单击要转换的每个额外的复选框对应的复选框。

  2. 编辑菜单上,指向更改为,然后单击选项按钮

    表单模板中的复选框代替,现在将显示一组选项按钮。每个选项按钮绑定到数据源中的同一字段。当用户单击选项按钮时,在字段中存储与该选项按钮相关联的值。

返回页首

在“检查设计方案”任务窗格中检查转换问题

有时候,原始 Word 文档中的元素未按期望的形式出现在结果 InfoPath 表单模板中,或者在转换过程中被去除。例如,InfoPath 不支持 Word 艺术字功能,在结果表单模板中使用占位符图像替代艺术字对象。

如果 InfoPath 在转换过程中检测到问题,在您关闭导入向导后,“检查设计方案”任务窗格会自动打开。在任务窗格中,您可以检查问题列表并执行必要的步骤进行修复。

  1. 如果“检查设计方案”任务窗格不可见,请单击“工具”菜单上的“检查设计方案”

    如果表单模板有任何问题,您将在该任务窗格中看到消息。

  2. “检查设计方案”任务窗格中,单击要查看的消息文本。

    会有一个对话框显示有关该问题的附加信息。

    注意: 如果 Word 文档包含 InfoPath 不支持的对象,如 Word 绘图对象,InfoPath 会在结果表单模板中添加一个占位符图像,指示该对象在 Word 文档中的原始位置。若要了解与该对象有关的详细信息,请右键单击表单模板上的占位符,然后单击快捷菜单上的“详细信息”

  3. 如有必要,在表单模板中修复问题。例如,您可能不打算在完成的表单模板中使用占位符图像,因此想删除所有的占位符图像。

注意: 您可能发现检查设计方案任务窗格,包含刷新按钮。单击刷新按钮不会更新因导入 InfoPath 的 Word 文档中显示的消息。如果您想要从检查设计方案任务窗格中删除导入邮件,必须打开资源文件对话框 (工具菜单),然后删除名为 ImportErrors.xml 的文件。导入 InfoPath Word 文档时,将自动创建此文件。删除 ImportErrors.xml 文件后,单击检查设计方案任务窗格,若要永久删除导入邮件中的刷新。ImportErrors.xml 文件不需要为表单模板才能正常工作。实际上,出于安全考虑,很好的做法发布表单模板之前删除此文件。

返回页首

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×