将 Word 文档转换为 InfoPath 表单模板

注意:  我们希望能够尽快以你的语言为你提供最新的帮助内容。 本页面是自动翻译的,可能包含语法错误或不准确之处。我们的目的是使此内容能对你有所帮助。可以在本页面底部告诉我们此信息是否对你有帮助吗? 请在此处查看本文的 英文版本 以便参考。

尽管您可以使用 Microsoft Office Word 创建文档的外观和类似于表单,Word 将为文字处理程序,而不是表单设计程序最适用。相反,Microsoft Office InfoPath 创建专门针对设计并填写电子表单。如果您想要将现有 Word 文档转换为 InfoPath 表单模板,可以使用在 InfoPath 中的导入向导来执行此操作。然后,您可以利用专用的 InfoPath 功能的设计、 发布,并填写表单。例如,在销售报表表单模板中,您可以使用条件格式数字低于销售计划时,自动应用红色背景色。在同一个表单模板中,您可以使用规则使基于该表单模板,以便当用户单击提交按钮的电子邮件中以附件形式提交表单。此外,您还可以通过创建启用浏览器功能的表单模板让广泛的访问群体使用表单模板。

将 Word 文档转换为 InfoPath 表单模板时,结果的表单模板将紧密匹配 Word 文档的版式。此外,Word 文档中符合特定条件的项目将自动转换为用户可以输入数据导入到相应的控件。例如,如果 Word 文档中包含括号括起的多个空格,InfoPath 将假定您作为文本输入字段中使用该括在括号中的区域,并将其转换为文本框控件生成的表单模板中。任何 Word 窗体字段将转换为 InfoPath 中的相应控件。

您可以使用导入选项对话框中设置更改为 Word 文档转换为 InfoPath 表单模板的选项。

本文介绍基本概念和过程将 Word 文档转换为 InfoPath 表单模板,包括的功能和转换过程中不支持的设置。

本文内容

有关将 Word 文档转换为 InfoPath 表单模板

Word 功能和转换过程中不完全支持的设置

将 Word 文档转换为 InfoPath 表单模板

将版式表格更改为重复表

将复选框更改为一组选项按钮

检查设计方案任务窗格中检查转换问题

有关将 Word 文档转换为 InfoPath 表单模板

将 Word 文档转换为 InfoPath 表单模板时,文档使用类似于蓝图以创建新的表单模板。表单模板中尽可能紧密地重新创建文档的基本结构。在 Word 文档中,"窗体字段"是存储特定类型的数据,例如姓名或地址的位置。如果您选择要转换文档、 文本框、 复选框,而下拉列表框控件添加到 Word 文档中的域的位置相对应的位置在 InfoPath 表单模板时包括 Word 窗体字段。此外,InfoPath 将自动检测可能工作以及重复表和格式文本框中,并将它们转换为适当的控件的 Word 文档的部分。例如,如果费用报表文档中包含用户可以在其中键入有关特定零用金笔记空白带下划线的区域,InfoPath 将转换该区域格式的文本框。用户可以在格式文本框中,键入多行文本,然后根据需要该文本设置格式。

若要更好地了解 Word 文档中使用 InfoPath 导入向导和生成的 InfoPath 表单模板将转换之间的关系,假设过去几年完成您的组织已使用称为 ExpenseReport.doc Word 文档若要从员工收集费用报表数据。您的 IT 部门想要将该文档转换为 InfoPath 表单模板,以便表单数据可以应付帐款系统提交可扩展标记语言 (XML)。

如果您使用导入向导将 ExpenseReport.doc 转换为表单模板,InfoPath 将创建一个称为 ExpenseReport.xsn 的表单模板。在下面的示例中,费用明细表中的 Word 文档中已转换为结果 InfoPath 表单模板中的重复表。重复表使用户可以插入或删除费用根据需要通过单击快捷菜单上的命令。

已转换为 InfoPath 重复表的 Word 表格

Word 文档转换为 InfoPath 表单模板时,将保留的布局和其他元素。默认情况下,InfoPath 重复表中的空白的行数匹配空 Word 表格中的行的数。但是,可以通过显示只是一个或两个行默认情况下在表单模板上节省空间。

此新表单模板包含与类似,Word 文档,例如用于收集费用信息的表中的元素。但是,具体取决于您选择导入向导中的设置,某些功能可能各异生成的表单模板中:

  • 如果您使用导入向导来导入 Word 文档中的通过只保留版式   生成的表单模板包含用于费用报表中输入的行项目的重复表。不过,所有表单字段从原始文档,如名称文本框、 部门下拉列表中,和除复选框,将被都丢弃从生成的表单模板。

  • 如果您使用导入向导来导入 Word 文档中的同时保留布局,并将转换为控件 (默认) Word 窗体字段   生成的表单模板包含用于费用报表中输入的行项目的重复表。从原始文档,如名称文本框、 部门下拉列表中,和除复选框,任何窗体字段将转换为相应的 InfoPath 控件。

  • 如果您使用导入向导来导入 Word 文档的保留版式和转换 (自定义) 控件的窗体字段   您可以决定导入费用报表时完全转换的域。例如,您可以禁用用于转换为文本框生成的表单模板中的文档中的空表格单元格的选项。

返回页首

Word 功能和转换过程中不完全支持的设置

在 InfoPath 表单模板中不支持某些设置和 Word 文档中的格式。转换后的 Word 文档包含这种设置,这些功能或设置,将不包含生成的表单模板。例如,如果您的 Word 文档具有修订标记,修订标记将被丢弃生成的表单模板中因为 InfoPath 不支持此功能。

您可以使用检查设计方案任务窗格中设计模式 ,发现转换任何问题。然后,您可以采取措施来解决这些问题。

下面是 Word 文档转换为 InfoPath 表单模板时不保留的功能和设置的列表。在某些情况下,格式将被丢弃,但保留基础文本。例如,如果您有新闻稿样式栏,InfoPath 将放弃所列,但导入这些列中包含的文本。

  • 书签

  • 动画的文本

  • 主题

  • 水印

  • 行号

  • 页面边框

  • 脚注和尾注

  • 新闻稿样式栏布局

  • 文件附件

  • 链接或嵌入对象,如 Microsoft Office Excel 工作表和 Microsoft Office Visio 绘图

  • 图形对象 (包括自选图形、 曲线、 线条和艺术字)

  • 字符间距 (包括缩放、 间距,引发降低文本位置的和字体的字距)

  • ActiveX 控件

  • 批注和修订 (包括插入、 删除以及格式更改)

  • 特定于Microsoft Office Word 2007 (包括构建基块和内容控件) 的一些功能

  • 某些打印设置 (包括混合的字符格式中页眉和页脚、 不同的奇数页和偶数页页眉和页脚、 不同的页眉以及第一页、 装订线设置、 边距和下边距,不同的页面方向的负数的数值的页脚和单独的节设置)

注意: 密码不能修改某些 Word 文档。如果这是与您的文档这种情况,您可能无法成功将其导入到 InfoPath。若要修复此问题,请尝试从文档中删除密码保护之前将其导入,。此外,某些文档用户限制到特定类型的编辑操作,如在窗体字段中输入数据。如果这是与您的文档这种情况,您可能无法成功将其导入到 InfoPath。若要修复此问题,请尝试删除文档的编辑限制之前将其导入。

以下列表介绍的功能和部分支持的 Word 文档转换为 InfoPath 表单模板时的设置:

垂直文本   InfoPath 保留垂直文本格式在 Word 文档,如果在表格单元格内找到垂直文本。InfoPath 放弃垂直文本格式时外部表格单元格,在 Word 文档的其他部分中找到的垂直文本时将转换为 Word 文档。

文本框   在 Word 文档中,文本框是可在页面上的位置和大小的文本的容器。如果 Word 文档中包含文本框中,该文本框将转换为生成的表单模板中的表格单元格。文本框中的任何文本将显示结果的表单模板中的表格单元格中。

带下划线的文本   在 InfoPath 表单模板中支持下划线。但是,在 Word 文档中任何装饰性或双下划线将转换为生成的表单模板中的单下划线。

超链接的引用不受支持的协议    转换所有超链接,但如果超链接使用 HTTP、 HTTPS、 文件、 FTP 或 MAILTO 以外的协议,超链接不起作用时用户单击结果的表单模板中的链接。

字符样式和设置文字效果   上标、 下标和单删除线格式样式转换过程中将保留下来。其他格式样式和效果,包括分级显示的文本、 隐藏的文本和阴影格式,转换过程中将被丢弃。浮雕和阴文文本将转换为灰色生成的表单模板中的文本。

部分设置   在 Word 中,使用节改变文档内的页面或页面之间布局。InfoPath 不支持这种类型的分区,转换过程中将被丢弃。生成的 InfoPath 表单模板应用到 Word 文档中的第一部分应用任何设置。

页眉和页脚格式   在 Word 文档中的页眉和页脚文本将转换为生成的 InfoPath 表单模板中的页眉和页脚文本。转换过程可能会被丢弃某些字符格式。例如,如果您使用加粗、 倾斜格式的 Word 文档的页眉中,InfoPath 将使用遇到生成的表单模板中的第一个格式样式和放弃其余的格式。同样,Word 文档中的第一个页眉或页脚部分应用任何设置用于生成的页眉或页脚 InfoPath 表单模板中的文本。

字体转换   虽然 InfoPath 导入字体从 Word 文档时创建新的表单模板中,如果文档中的字体不在您在其中执行导入的计算机上可用,为表单模板会自动选中替换的字体。

负的页边距   负的边距和下边距将导入为 0。

负边距、 填充和缩进设置   负边距、 填充和缩进设置将作为 0 导入。

返回页首

将 Word 文档转换为 InfoPath 表单模板

  1. 如果您要导入 Word 文档处于打开状态,请将其关闭。

  2. 在设计模式下,在文件菜单上,单击导入窗体

  3. 在导入向导中,单击InfoPath 导入的 Word 文档中,,然后单击下一步

  4. 单击“浏览”。

  5. 找到并单击要转换,Word 文档,然后单击打开

    注意: 如果您要导入具有受限权限的 Word 文档,您必须具有完全控制访问文档。如果您只具有读取或更改文档的访问,当您将看到一条错误消息尝试将其导入。

  6. 要更改默认导入行为,请单击选项,然后选择所需的选项。

  7. 单击“完成”。

返回页首

将版式表格更改为重复表

如果您的 Word 文档中包括一个表,InfoPath 可能会将其转换布局表格或生成的表单模板中的重复表。选择表的类型取决于您在 Word 文档中所做的设计决策。以下过程可用于快速更改为重复表的转换后的版式表格。

您可以使用重复表时填写的表单提供您的用户程度额外的灵活性。使用重复表时,您的表单模板没有用户首次打开时显示大量空白的行。相反,用户通常只看到一行,只需时,并在需要添加详细信息。此窗体中节省空间,并提供额外程度的个性化的用户。

  1. 在表单模板中,右键单击任意位置在要转换的版式表格内。

  2. 在快捷菜单上,指向更改为,然后单击重复表

  3. 更改为重复表对话框中,请执行一个或多个下列操作:

    • 若要指定的重复表标题行,请在要保留作为表格标题的行数框中输入值。您通常用于列标题的标题行。

    • 若要指定重复表中的页脚行,请在要保留为表页脚的行数框中输入值。多个表中不包含页脚行。

    • 若要指定要使用的数据行数,请在的重复行数以包括时填写表单框中输入值。数据行是可以"重复"根据需要多次为窗体中的行

  4. 插入菜单上,单击其他控件,或按 ALT + I、 c。

  5. 插入所需的表格单元格的控件。

返回页首

将复选框更改为一组选项按钮

如果您在 Word 文档中使用多个复选框,则 InfoPath 导入其为生成的 InfoPath 表单模板中的复选框。如果您想使用一组选项按钮,请按照下列步骤操作,将对应的复选框转换为表单模板中的选项按钮。

如果您希望用户能够进行一次即可选择从一组有限的选项,可以使用 Microsoft Office InfoPath 表单模板上的一组选项按钮。

  1. 在表单模板中,请单击您想要将转换,然后按住 CTRL 并单击要转换的每个额外的复选框对应的复选框。

  2. 编辑菜单上,指向更改为,然后单击选项按钮

    表单模板中的复选框代替,现在将显示一组选项按钮。每个选项按钮绑定到数据源中的同一字段。当用户单击选项按钮时,在字段中存储与该选项按钮相关联的值。

返回页首

检查设计方案任务窗格中检查转换问题

有时,原始 Word 文档中的元素按预期结果的 InfoPath 表单模板中不会显示或转换过程中删除。例如,InfoPath 不支持 Word 艺术字功能,并替换生成的表单模板中的占位符图像的艺术字对象。

如果 InfoPath 转换过程中检测到问题,检查设计方案任务窗格会自动打开后,关闭导入向导。在任务窗格中,您可以查看的问题的列表,并采取必要的步骤以修复这些。

  1. 如果看不到检查设计方案任务窗格中,单击工具菜单上的检查设计方案

    如果有任何问题表单模板,您将看到任务窗格中的邮件。

  2. 检查设计方案任务窗格中,单击您想要查看消息的文本。

    对话框显示有关该问题的其他信息。

    注意: 如果 Word 文档中包含一个对象,InfoPath 不支持,如 Word 图形对象,然后 InfoPath 向占位符图像生成的表单模板,指示位置对象最初位于 Word 文档中。若要了解有关对象的详细信息,请右键单击表单模板上的占位符,然后单击快捷菜单上的更多详细信息

  3. 如有必要,请在表单模板中,修复问题。例如,您可能想要删除任何不应在完成的表单模板中使用的占位符图像。

注意: 您可能发现检查设计方案任务窗格,包含刷新按钮。单击刷新按钮不会更新因导入 InfoPath 的 Word 文档中显示的消息。如果您想要从检查设计方案任务窗格中删除导入邮件,必须打开资源文件对话框 (工具菜单),然后删除名为 ImportErrors.xml 的文件。导入 InfoPath Word 文档时,将自动创建此文件。删除 ImportErrors.xml 文件后,单击检查设计方案任务窗格,若要永久删除导入邮件中的刷新。ImportErrors.xml 文件不需要为表单模板才能正常工作。实际上,出于安全考虑,很好的做法发布表单模板之前删除此文件。

返回页首

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×