将 Access 2.0 和 Access 95 数据库导入到当前版本

将 Access 2.0 和 Access 95 数据库导入到当前版本

如果使用 Access 2.0 格式 (.mdb) 或 Access 95 格式 (.mdb) 的现有数据库,在某些情况下,可将该数据库中的表、查询和宏导入使用 .accdb 文件格式的较新版 Access。

要导入包含 VBA 代码(及模块)的窗体和报表,请先使用 Microsoft Office Access 2003、Access 2002 或 Access 2000 将 Access 2.0 或 Access 95 数据库转换为 Access 2002 - 2003 或 Access 2000 文件格式。然后可使用 Access 2007 等较新版本将文件转换为 .accdb 文件格式,接下来便可以使用 Access 2010、Access 2013 或 Access 2016 打开该文件。

本文以下部分说明如何执行这些任务。

使用的是 Access 2010、Access 2013 或 Access 2016?

Access 2007 是最后一个支持打开、导入、链接或导出为 Access 2.0 和 Access 95 格式的版本。要导入、导出或链接 Access 1.0 和 2.0(Red 2 或 Jet 2)文件及 Access 95 数据库中的数据,必须使用 Access 2007。在这种情况下,必须将 Access 2007 用作中间步骤才能将 Access 2.0 数据库完全转换为其中一个版本。

想进行什么操作?

在 Access 2007 中打开 Access 2.0 数据库

将 Access 2.0 数据库中的数据导入 Access 2007

将 Access 95 数据库中的数据导入 Access 2007

使用 Access 2003、Access 2002 或 Access 2000 转换 Access 2.0 或 Access 95 数据库

在 Access 2007 中打开 Access 2.0 数据库

在 Access 2007 中打开 Access 2.0 数据库时,Access​​ 会显示一系列提示。如果按这些提示操作,则最终会显示消息:“此数据库已保存为 Microsoft Access 2.0 文件格式”。

此数据库存储在 Microsoft Access 2.0 文件格式中。

可将 Access 2.0 数据库中的表、查询和宏导入 Access 2007 数据库 (.accdb)。要将窗体、报表或模块导入 Access 2007 数据库,请先使用较早版本的 Access 转换数据库,使用 Access 2007 打开转换后的数据库,然后将该数据库转换为 Access 2007 .accdb 文件格式数据库。有关详细信息,请参阅使用 Access 2003、Access 2002 或 Access 2000 转换 Access 2.0 或 Access 95 数据库

将 Access 2.0 数据库中的数据导入 Access 2007

从其他数据库导入对象时,目标数据库中会创建导入对象的副本。不会改变源内容。要将 Access 2.0 数据库中的数据导入 Access 2007,请先打开要导入数据的数据库。然后使用“外部数据”选项卡上的命令继续执行导入过程(包括调用导入向导)。

  1. 打开 Access 2007,单击“Microsoft Office 按钮”,然后单击“打开”。

  2. 在“打开”对话框中选择并打开要导入表、查询或宏的数据库。

  3. 在“外部数据”选项卡的“导入”组中,单击“Access”。

  4. 在“获取外部数据”向导的“文件名”文本框中键入源数据库的名称,或单击“浏览”以显示“打开文件”对话框,然后选择或键入源数据库的名称。

  5. 单击“将表、查询、窗体、报表、宏和模块导入当前数据库”,然后单击“确定”。

  6. 在“导入对象”对话框中,单击每个选项卡,然后选择所需对象。注意,仅可将 Access 2.0 数据库中的表、查询和宏导入 Access 2007。

    “导入对象”对话框

    要取消所选对象,请再次单击该对象。

  7. 单击“选项”,指定其他设置。

    下表介绍每个选项对操作结果的影响。

    元素

    说明

    关系”复选框

    导入所选表之间的关系。

    菜单和工具栏”复选框

    导入存在于源数据库中的任何自定义菜单和工具栏。菜单和工具栏显示在名为“加载项”的选项卡上。

    导入/导出规范”复选框

    导入存在于源数据库中的任何已保存的导入或导出规范。

    导航窗格组”复选框

    导入存在于源数据库中的任何自定义导航窗格组。

    定义和数据”按钮

    导入所有已选表的结构和数据。

    仅定义”按钮

    仅导入所选表中的字段。不会导入源记录。

    作为查询”按钮

    将选定的查询作为查询导入。在这种情况下,请记住随查询一起导入所有基础表。

    作为表”按钮

    将查询作为表导入。在这种情况下,不需要导入基础表。

  8. 单击“确定”完成操作。

    如果遇到任何问题,Access 会复制数据并显示错误消息。如果该操作成功导入这些数据,则向导的最后一页支持将操作详细信息保存为导入规范,供将来使用。

将 Access 95 数据库中的数据导入 Access 2007

要将 Access 95 数据库中的数据导入 Access 2007,请先打开要导入数据的 Access 2007 数据库。然后使用“外部数据”选项卡上的命令,其中包括调用导入向导。

可将 Access 95 格式 (.mdb) 数据库中的表、查询和宏导入 Access 2007 数据库 (.accdb)。还可导入不使用 VBA 代码的窗体和报表。要导入包含 VBA 代码(及模块)的窗体和报表,请先使用 Microsoft Office Access 2003、Access 2002 或 2000 将 Access 95 数据库转换为 Access 2002 - 2003 或 Access 2000 文件格式,然后使用 Access 2007 将该文件转换为 Access 2007 .accdb 文件格式。

  1. 打开 Access 2007,单击“Microsoft Office 按钮”,然后单击“打开”。

  2. 在“打开”对话框中选择并打开要导入表、查询或宏的数据库。

  3. 在“外部数据”选项卡的“导入”组中,单击“Access”。

  4. 在“获取外部数据”向导的“文件名”框中键入源数据库的名称,或单击“浏览”以显示“打开文件”对话框,然后选择或键入源数据库的名称。

  5. 单击“将表、查询、窗体、报表、宏和模块导入当前数据库”,然后单击“确定”。

  6. 在“导入对象”对话框中,单击每个选项卡,然后选择要导入的对象。

    要取消所选对象,请再次单击该对象。

  7. 单击“选项”,指定其他设置。这些其他设置显示在对象列表下方的组中。

  8. 单击“确定”完成操作。

    如果遇到任何问题,Access 会复制数据并显示错误消息。如果该操作成功导入这些数据,则向导的最后一页支持将操作详细信息保存为导入规范,供将来使用。

使用 Access 2003、Access 2002 或 Access 2000 转换 Access 2.0 或 Access 95 数据库

可以使用下表列出的 Access​​ 版本之一将 Access 2.0 数据库转换为 Access 2000 或 Access 2002 - 2003 文件格式,前提是购买了该版本的 Access 并已在计算机上安装。根据你的 Access 版本来看,应该已经安装了 Access 2.0 转换器。

版本

Access 2.0 转换器

Microsoft Office Access 2003

此版本要求下载并安装适用于 Access 2003 的 Access 2.0 转换器。但是,此工具现已无法通过 Microsoft 下载中心获取,因为 Access 2003 已不在扩展支持范围内。

Microsoft Access 2002

包含在该产品中。

Microsoft Access 2000

包含在该产品中。

应将 Access 2.0 或 Access 95 文件转换为 Access 2000 或 Access 2002 - 2003 .mdb 文件格式。然后使用 Access 2007 将生成的文件转换为 Access 2007 .accdb 文件格式。之后该数据库即可在 Access 2007 中使用,也可在 Access 2010、Access 2013 或 Access 2016 中打开。按照不同的 Access​​ 较早版本,执行下列步骤:

  1. 启动 Access 2003、Access 2002 或 Access 2000。

  2. 在“文件”菜单上单击“打开”,然后单击要转换的 Access 95 数据库的文件名。

  3. 在“工具”菜单上单击“数据库实用工具”,然后单击“转换数据库”、“转为 Access 2000 文件格式”。

  4. 在“将数据库转换为”对话框中,输入新文件的文件名,然后单击“保存”。

    可能会看到一条信息性消息,警告无法在早期版本的 Access 中使用转换后的数据库。如果出现此消息,请单击“确定”。

    文件以 Access 2000 文件格式保存。

  5. 启动 Access 2007。

  6. 单击“Microsoft Office 按钮”,然后单击“打开”。

  7. 在“打开”对话框中,选择并打开转换后的数据库。

  8. 单击“Microsoft Office 按钮”,然后单击“转换​​”。

  9. 在“另存为”对话框中,输入 Access 2007 文件的文件名,或者接受所提供的文件名,然后单击“保存”。

    文件以 Access 2007 .accdb 文件格式保存。

返回页首

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×