将表单数据提交到 Microsoft Access 数据库中

注意:  我们希望能够尽快以你的语言为你提供最新的帮助内容。 本页面是自动翻译的,可能包含语法错误或不准确之处。我们的目的是使此内容能对你有所帮助。可以在本页面底部告诉我们此信息是否对你有帮助吗? 请在此处查看本文的 英文版本 以便参考。

本文内容

概述

步骤 1: 启用提交数据连接

步骤 2: 配置提交选项

概述

在设计基于 Microsoft Office Access (.mdb) 或 Microsoft Office Access 2007 (.accdb) 数据库的 Microsoft Office InfoPath 表单模板时,数据连接向导创建提交数据连接到数据库,如果满足下列条件,满足。

  • 设计表单模板,以便用户必须使用 InfoPath 填写。如果将使用 Web 浏览器中填写表单,窗体无法提交直接与数据库的数据。若要配置浏览器兼容的表单模板以将数据提交到数据库,使用将数据提交到配合该数据库的 Web 服务数据连接。

  • 主数据连接中使用主数据库表包含主键、 唯一约束或唯一索引。

  • 使用此主数据连接的任何其他数据库表具有与主数据库表简单、 层次关系。

  • 数据库不包含可在其中存储较大的二进制数据类型,如图片、 图像、 OLE 对象、 文件附件,Office Access 备注数据类型或 SQL 文本数据类型的字段。

如果数据库中满足这些要求,InfoPath 将创建提交数据连接,并将提交按钮添加到标准工具栏和窗体上的文件菜单上的提交命令。

注意: 辅助数据连接不能将数据提交到数据库。如果您想要用作辅助数据连接提交数据连接到数据库,确定数据库,与其合作的 Web 服务,然后添加到该 Web 服务的提交数据连接。

启用提交数据连接后,您就可以通过以下方式提交选项自定义表单模板。

  • 更改显示在标准工具栏上的提交按钮和文件菜单上的提交命令的文本。

  • 更改为标准工具栏上的提交按钮和文件菜单上的提交命令的键盘快捷方式。

  • 创建自定义用户提交表单时向用户显示的消息。

  • 指定是否要保持表单打开、 关闭该窗体或提交表单后打开另一个空白表单。

返回页首

步骤 1: 启用提交数据连接

  1. 工具菜单上,单击数据连接

  2. 数据连接对话框中,单击主数据连接,,然后单击修改

  3. 在数据连接向导中,单击“下一步”。

  4. 在向导的下一页上,选择启用提交此连接复选框,然后单击完成

返回页首

步骤 2: 配置提交选项

启用提交数据连接后,InfoPath 将添加到标准工具栏和到文件菜单提交命令的提交按钮。InfoPath 还会配置基于该表单模板用户提交完成的表单之后向用户显示一条消息的窗体。此消息,说明是否已成功提交表单。默认情况下,InfoPath 也保持表单打开后在用户提交。若要更改显示在提交按钮,以及用户提交表单后出现的问题的文本,请执行下列操作:

  1. 工具菜单上,单击提交选项

    1. 若要更改的提交按钮出现在标准工具栏和用户填写表单时,将显示在文件菜单的提交命令的名称,可在提交的标题框中键入新名称选项对话框。

      提示: 如果您想要将键盘快捷键分配给此按钮和命令,请键入与号 (&) 之前要用作键盘快捷方式的字符。例如,要分配 ALT + B 为提交按钮和命令的键盘快捷方式,请键入Su 和交

  2. 如果您不希望用户在填写窗体时在标准工具栏上使用提交命令或提交按钮,,清除显示提交菜单项和提交工具栏按钮复选框。

    1. 默认情况下,用户提交表单之后, InfoPath 使窗体保持打开状态,显示一条消息,指示表单已成功提交。若要更改此默认行为,请单击高级,然后执行下列操作之一:

      • 若要关闭该窗体或创建新的空白表单用户提交完成的表单后,单击之后提交列表中所需的选项。

      • 以创建自定义消息说明已成功提交表单,选择使用自定义消息复选框,然后在成功失败框中键入您的邮件。

        提示: 使用失败框中一条消息告诉用户如何操作如果他们无法提交表单。例如,您可以建议用户保存其窗体和联系某人进一步的说明。

      • 如果您不希望在用户提交表单后显示一条消息,请清除显示成功或失败的邮件复选框。

返回页首

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×