将表单数据提交到文档库

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

您可以将所有用户的表单存储和组织在运行 Microsoft Windows SharePoint Services 的服务器上的一个文档库中。在文档库中,用户可以填写基于您的表单模板的表单、将数据从已完成的表单导出至 Microsoft Office Excel 2003 或 Microsoft Office Excel 2007,或将来自多个表单的数据合并在一个表单中。

为使用户能够将基于您的表单模板的表单提交到文档库中,您可以向表单模板中添加用以提交数据的辅助数据连接。添加了提交数据连接后,可以配置您的表单模板,让用户能够将其表单数据提交到文档库。进行配置以后,Microsoft Office InfoPath 会向表单上的“标准”工具栏添加一个“提交”按钮,并向“文件”菜单添加一个“提交”命令。您还可以通过以下方式自定义表单模板的提交选项:

  • 更改“常用”工具栏上的“提交”按钮以及“文件”菜单上的“提交”命令上显示的文字。

  • 更改“常用”工具栏上的“提交”按钮以及“文件”菜单上的“提交”命令的键盘快捷方式。

  • 创建在用户提交表单时向用户显示的自定义消息。

  • 指定在表单提交后,是让表单保持打开,关闭表单,还是打开另一个空白表单。

添加提交数据连接

  1. 工具菜单上,单击提交选项

  2. 提交选项对话框中,选择允许用户提交此表单复选框。

  3. 单击“将表单数据发送到单个目标”,然后在列表中单击“SharePoint 文档库”

  4. 单击“添加”

  5. 在数据连接向导的“文档库”框中,键入 SharePoint 文档库的位置。

  6. “文件名”框中,键入将用于在文档库中标识表单的名称。

    提示: 还可以使用公式以确保每个表单名称都唯一。

    操作方法

    1. 单击“插入公式公式按钮

    2. “插入公式”对话框中,执行下列操作之一:

      • 若要在公式中使用域,请单击“插入域或组”,在“选择域或组”对话框中单击要使用的域,然后单击“确定”

      • 若要在公式中使用函数,请单击“插入函数”,在“插入函数”对话框中选择要使用的函数,然后单击“确定”

        提示: 如果函数需要参数,请在“插入函数”对话框中选择该函数,单击“确定”,然后在“插入公式”对话框的“公式”框中,双击已添加的函数,然后单击一个域或组。在“请参阅”部分中可以找到有关函数的详细信息的链接。

      • 若要在公式中插入值或数学运算符,请在“公式”框中键入值或代表数学运算的符号。

    运算

    符号

    添加

    +

    -

    *

    /

    • 注意: 如果公式使用除法 (/) 运算符,请确保在该运算符的前后各留一个空格。如果除法运算符前后无空格,InfoPath 可能将“/”解释为 XPath 位置步骤的分隔符,而不是除法运算符。

    • 若要检查公式的语法是否正确,请在“插入公式”对话框中,单击“验证公式”。

      “请参阅”部分中可以找到有关公式的详细信息的链接。

  7. 若要覆盖文档库中任何同名的现有表单,请选中“如果文件存在,允许覆盖”复选框。

  8. 单击“下一步”

  9. 输入此数据连接的名称框中,在向导的下一页上键入一个描述性名称,为此提交数据连接。

  10. “摘要”部分验证信息的正确性,然后单击“完成”

    1. 若要更改的提交按钮出现在标准工具栏和用户填写表单时,将显示在文件菜单的提交命令的名称,请在提交选项对话框中的标题框中键入新名称。

      提示: 如果您想要将键盘快捷键分配给此按钮和命令,请键入与号 (&) 之前要用作键盘快捷方式的字符。例如,要分配 ALT + B 为提交按钮和命令的键盘快捷方式,请键入& 交

  11. 如果您不希望用户在填写窗体时在标准工具栏上使用提交命令或提交按钮,,清除显示提交菜单项和提交工具栏按钮复选框。

    1. 默认情况下,用户提交表单之后, InfoPath 使窗体保持打开状态,显示一条消息,指示表单已成功提交。若要更改此默认行为,请单击高级,然后执行下列操作之一 ︰

      1. 若要关闭该窗体或创建新的空白表单用户提交完成的表单后,单击之后提交列表中所需的选项。

      2. 以创建自定义消息说明已成功提交表单,选择使用自定义消息复选框,然后在成功失败框中键入您的邮件。

        提示: 在失败框中使用一条消息告诉用户如何操作如果他们无法提交表单。例如,您可以建议用户保存其窗体和联系某人进一步的说明。

      3. 如果您不希望在用户提交表单后显示一条消息,请清除显示成功或失败的邮件复选框。

返回页首

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×