将表单数据提交到文档库

注意:  我们希望能够尽快以你的语言为你提供最新的帮助内容。 本页面是自动翻译的,可能包含语法错误或不准确之处。我们的目的是使此内容能对你有所帮助。可以在本页面底部告诉我们此信息是否对你有帮助吗? 请在此处查看本文的 英文版本 以便参考。

您可以存储和组织所有运行 Microsoft Windows SharePoint Services 的服务器上的文档库中的用户表单。在文档库中,用户可以填写基于表单模板的表单、 从已完成表单数据导出到 Microsoft Office Excel 2003 或Microsoft Office Excel 2007,或将数据从多个表单合并到一个窗体。

若要允许用户提交基于表单模板与文档库的窗体,您可以添加表单模板的数据提交到辅助数据连接。添加提交数据连接后,您可以配置表单模板以允许用户将其表单数据提交到文档库。执行此操作时,Microsoft Office InfoPath 会将提交按钮添加到标准工具栏和窗体上的文件菜单上的提交命令。您也可以通过以下方式自定义表单模板的提交选项:

  • 更改显示在标准工具栏上的提交按钮和文件菜单上的提交命令的文本。

  • 更改标准工具栏上的提交按钮和文件菜单上的提交命令的键盘快捷方式。

  • 创建自定义用户提交表单时向用户显示的消息。

  • 指定是否要保持表单打开、 关闭该窗体或提交表单后打开另一个空白表单。

添加提交数据连接

  1. 工具菜单上,单击提交选项

  2. 提交选项对话框中,选择允许用户提交此表单复选框。

  3. 单击发送表单数据发送到单个目标,然后单击列表中的SharePoint 文档库

  4. 单击“添加”。

  5. 在数据连接向导中,在文档库框中,键入 SharePoint 文档库的位置。

  6. 文件名框中,键入将用于标识的文档库中的窗体的名称。

    提示: 您可以使用公式来确保每个窗体名称是唯一的。

    操作方法

    1. 单击插入公式 公式按钮

    2. 插入公式对话框中,执行下列操作之一:

      • 若要使用公式中的字段,单击插入域或组,单击您想要使用选择域或组对话框中的字段,然后单击确定

      • 要在公式中使用函数,请单击插入函数,选择您想要使用插入函数对话框中的函数,然后单击确定

        提示: 如果函数需要参数,在插入函数对话框中选择的函数,单击确定,然后在公式框中插入公式对话框中,双击您添加了,该函数并单击一个字段或组。在另请参阅部分找到有关函数的详细信息的链接。

      • 若要插入公式的值或数学运算符,请在公式框中键入值或数学运算符符号。

    运算

    符号

    添加

    +

    相减

    -

    相乘

    *

    /

    • 注意: 如果公式使用除法 (/) 运算符,请确保之前和之后除法运算符存在一个空格。如果除法运算符没有空间之前和之后,InfoPath 将解释"/"作为 XPath 位置步骤分隔符而不是作为除法运算符。

    • 若要检查的公式为正确的语法,在插入公式对话框中,单击验证公式

      另请参阅部分找到有关公式的详细信息的链接。

  7. 若要覆盖具有相同名称的文档库中的任何现有窗体,请选择允许覆盖文件是否存在复选框。

  8. 单击“下一步”

  9. 输入此数据连接的名称框中,在向导的下一页上键入一个描述性名称,为此提交数据连接。

  10. 验证在摘要部分中的信息正确,然后单击完成

    1. 若要更改的提交按钮出现在标准工具栏和用户填写表单时,将显示在文件菜单的提交命令的名称,可在提交的标题框中键入新名称选项对话框。

      提示: 如果您想要将键盘快捷键分配给此按钮和命令,请键入与号 (&) 之前要用作键盘快捷方式的字符。例如,要分配 ALT + B 为提交按钮和命令的键盘快捷方式,请键入& 交

  11. 如果您不希望用户在填写窗体时在标准工具栏上使用提交命令或提交按钮,,清除显示提交菜单项和提交工具栏按钮复选框。

    1. 默认情况下,用户提交表单之后, InfoPath 使窗体保持打开状态,显示一条消息,指示表单已成功提交。若要更改此默认行为,请单击高级,然后执行下列操作之一:

      1. 若要关闭该窗体或创建新的空白表单用户提交完成的表单后,单击之后提交列表中所需的选项。

      2. 以创建自定义消息说明已成功提交表单,选择使用自定义消息复选框,然后在成功失败框中键入您的邮件。

        提示: 使用失败框中一条消息告诉用户如何操作如果他们无法提交表单。例如,您可以建议用户保存其窗体和联系某人进一步的说明。

      3. 如果您不希望在用户提交表单后显示一条消息,请清除显示成功或失败的邮件复选框。

返回页首

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×