将表单数据提交到多个位置

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

您可以设计表单模板,让用户能够在单击“提交”按钮时将表单数据提交到多个位置。

本文内容

概述

步骤 1︰ 添加提交数据连接

步骤 2︰ 配置为允许提交表单模板

概述

若要让用户将表单数据提交到多个位置,您必须为表单模板添加辅助数据连接,该连接用于将数据提交到您希望用户向其提交表单的每个位置。在添加了所有的提交数据连接后,需要配置表单模板,通过使用规则让用户能够将其表单数据提交到多个位置。此后,Microsoft Office InfoPath 会在用户填写该表单时,在“标准”工具栏中添加一个“提交”按钮,在“文件”菜单中添加一个“提交”命令。InfoPath 按照辅助数据连接在规则中的列出顺序将表单数据提交到辅助数据连接。您无法将规则配置为同时使用所有的提交数据连接。

配置表单模板以便让用户提交其表单数据时,还可以使用下面的方法自定义提交选项:

  • 更改“常用”工具栏上的“提交”按钮以及“文件”菜单上的“提交”命令上显示的文本。

  • 更改“常用”工具栏上的“提交”按钮以及“文件”菜单上的“提交”命令的键盘快捷方式。

  • 创建在用户提交表单时向用户显示的自定义消息。

  • 指定在表单提交后,是让表单保持打开,关闭表单,还是打开另一个空白表单。

返回页首

步骤 1:添加提交数据连接

若要配置表单模板以让用户将完成的表单提交到多个位置,您需要向表单模板添加必要的提交数据连接。您可以添加到以下位置的数据连接:

  • Web 服务

  • 运行 Microsoft Windows SharePoint Services 的服务器上的文档库

  • 电子邮件中

    注意: 要将表单数据提交到电子邮件中,用户的计算机上需要安装有 Microsoft Office Outlook。

下列步骤阐述如何添加到这些位置的提交数据连接。

添加将数据提交到 Web 服务的数据连接

  1. “工具”菜单上,单击“数据连接”

  2. 数据连接对话框中,单击添加

  3. 在“数据连接向导”中,单击“新建连接”,单击“提交数据”,然后单击“下一步”

  4. 在向导的下一页上,单击“提交到 Web 服务”,然后单击“下一步”

  5. 在向导的下一页上,键入您的用户将向其提交表单的 Web 服务的位置,然后单击“下一步”

    如果希望在通用描述、发现和集成 (UDDI) 服务器上搜索 Web 服务,请单击“搜索 UDDI”,输入要搜索的 UDDI 服务器,指定需要按提供商还是按所提供的服务进行搜索,输入一个搜索关键字,然后单击“搜索”。与搜索关键字相符的 Web 服务将出现在“搜索结果”列表中。

  6. 在向导下一页的“选择操作”列表中,单击将接收表单数据的 Web 服务操作,然后单击“下一步”

  7. 在向导的下一页上,执行下列操作之一:

    提交域或组中的数据

    1. “参数”列表中,单击将接收来自表单的数据的 Web 服务参数。

    2. “参数选项”中,单击“域或组”

    3. 单击修改 数据源图像

    4. “选择域或组”对话框中,单击要提交其数据的域或组,然后单击“确定”

    5. “包含”框中,单击“仅限文本和子元素”以只提交内容和域或组的任何子元素,或单击“XML 子树(包括选定元素)”以提交内容和所选的组或域。

    提交所有窗体中的数据

    1. 单击“整个表单(XML 文档,包括处理指令)”

    将数据作为字符串

    1. 选中“将数据作为字符串提交”复选框。

      选中此复选框一般用来提交具有数字签名的数据。多数情况下,请清除此复选框。

  8. 单击“下一步”

  9. 输入此数据连接的名称框中,在向导的下一页上键入一个描述性名称,为此提交数据连接。

  10. “摘要”部分验证信息的正确性,然后单击“完成”

添加将数据提交到文档库的数据连接

  1. “工具”菜单上,单击“数据连接”

  2. 数据连接对话框中,单击添加

  3. 在“数据连接向导”中,单击“新建连接”,单击“提交数据”,然后单击“下一步”

  4. 在向导的下一页上,单击“提交到 SharePoint 网站的文档库”,然后单击“下一步”

  5. 在向导下一页的“文档库”框中,键入 SharePoint 文档库的位置。

  6. “文件名”框中,键入将用于在文档库中标识表单的名称。还可以使用公式以确保每个表单名称都唯一。

    操作方法

    1. 单击“插入公式公式按钮

    2. “插入公式”对话框中,执行下列操作之一:

      • 若要在公式中使用域,请单击“插入域或组”,在“选择域或组”对话框中单击要使用的域,然后单击“确定”

      • 若要在公式中使用函数,请单击“插入函数”,在“插入函数”对话框中选择要使用的函数,然后单击“确定”

        如果函数需要参数,请在“插入函数”对话框中选择该函数,单击“确定”,然后在“插入公式”对话框的“公式”框中,双击已添加的函数,然后单击一个域或组。在“请参阅”部分中可以找到有关函数的详细信息的链接。

      • 若要在公式中插入值或数学运算符,请在“公式”框中键入值或代表数学运算的符号。

    运算

    符号

    添加

    +

    -

    *

    /

    • 注意: 如果公式使用除法 (/) 运算符,请确保在该运算符的前后各留一个空格。如果除法运算符前后无空格,InfoPath 可能将“/”解释为 XPath 位置步骤的分隔符,而不是除法运算符。

    • 若要检查公式的语法是否正确,请在“插入公式”对话框中,单击“验证公式”。

      “请参阅”部分中可以找到有关公式的详细信息的链接。

  7. 若要覆盖文档库中任何同名的现有表单,请选中“如果文件存在,允许覆盖”复选框。

  8. 单击“下一步”

  9. 输入此数据连接的名称框中,在向导的下一页上键入一个描述性名称,为此提交数据连接。

  10. “摘要”部分验证信息的正确性,然后单击“完成”

添加将数据提交到电子邮件的数据连接

  1. “工具”菜单上,单击“数据连接”

  2. 数据连接对话框中,单击添加

  3. 在“数据连接向导”中,单击“新建连接”,单击“提交数据”,然后单击“下一步”

  4. 在向导的下一页上,单击“作为电子邮件消息提交”,然后单击“下一步”

  5. 在向导的下一页上,在相应的框中键入邮件收件人的电子邮件地址、希望显示在邮件中的主题以及所需的任何介绍性文本,然后单击“下一步”。在除“介绍”框之外的每个框中,还可以使用公式。

    操作方法

    1. 单击“插入公式公式按钮

    2. “插入公式”对话框中,执行下列操作之一:

      • 若要在公式中使用域,请单击“插入域或组”,在“选择域或组”对话框中单击要使用的域,然后单击“确定”

      • 若要在公式中使用函数,请单击“插入函数”,在“插入函数”对话框中选择要使用的函数,然后单击“确定”

        如果函数需要参数,请在“插入函数”对话框中选择该函数,单击“确定”,然后在“插入公式”对话框的“公式”框中,双击已添加的函数,然后单击一个域或组。在“请参阅”部分中可以找到有关函数的详细信息的链接。

      • 若要在公式中插入值或数学运算符,请在“公式”框中键入值或代表数学运算的符号。

    运算

    符号

    添加

    +

    -

    *

    /

    • 注意: 如果公式使用除法 (/) 运算符,请确保在该运算符的前后各留一个空格。如果除法运算符前后无空格,InfoPath 可能将“/”解释为 XPath 位置步骤的分隔符,而不是除法运算符。

    • 若要检查公式的语法是否正确,请在“插入公式”对话框中,单击“验证公式”。

      “请参阅”部分中可以找到有关公式的详细信息的链接。

  6. 在向导的下一页上,执行下列操作之一:

    1. 若要在电子邮件正文中显示表单,请单击“仅发送表单的活动视图(无附件)”

    2. 以电子邮件以附件形式发送表单数据,请依次发送表单数据作为附件和选择附加表单模板,以确保用户可以打开该窗体复选框,然后在附件名称框中键入该窗体的名称。您还可以指定字段或使用公式来确保每个窗体名称是唯一的。此选项才可用仅表单模板配置为自动确定安全级别,或者配置为受限或完全信任安全级别。

      操作方法

      1. 单击“插入公式公式按钮

      2. “插入公式”对话框中,执行下列操作之一:

        • 若要在公式中使用域,请单击“插入域或组”,在“选择域或组”对话框中单击要使用的域,然后单击“确定”

        • 若要在公式中使用函数,请单击“插入函数”,在“插入函数”对话框中选择要使用的函数,然后单击“确定”

          如果函数需要参数,请在“插入函数”对话框中选择该函数,单击“确定”,然后在“插入公式”对话框的“公式”框中,双击已添加的函数,然后单击一个域或组。在“请参阅”部分中可以找到有关函数的详细信息的链接。

        • 若要在公式中插入值或数学运算符,请在“公式”框中键入值或代表数学运算的符号。

      运算

      符号

      添加

      +

      -

      *

      /

      • 注意: 如果公式使用除法 (/) 运算符,请确保在该运算符的前后各留一个空格。如果除法运算符前后无空格,InfoPath 可能将“/”解释为 XPath 位置步骤的分隔符,而不是除法运算符。

      • 若要检查公式的语法是否正确,请在“插入公式”对话框中,单击“验证公式”。

        “请参阅”部分中可以找到有关公式的详细信息的链接。

      作为附件发送的表单数据的电子邮件收件人若要打开此附件,该收件人的计算机上需要装有 InfoPath。

  7. 单击“下一步”

  8. 输入此数据连接的名称框中,在向导的下一页上键入一个描述性名称,为此提交数据连接。

  9. “摘要”部分验证信息的正确性,然后单击“完成”

返回页首

步骤 2:配置表单模板以允许提交

向表单模板添加了必要的辅助数据连接后,需要配置表单模板,以允许用户提交其表单数据。完成配置后,InfoPath 会在用户填写表单时向“文件”菜单添加一个“提交”命令,并向“常用”工具栏添加一个“提交”按钮。之后,您可以配置当用户单击“提交”按钮时发生的操作。在这种情况下,您将添加一个规则,它在用户单击“文件”菜单上的“提交”命令或“常用”工具栏上的“提交”按钮时将表单数据提交到每个提交数据连接。

您可以在同一对话框中配置提交选项。

  1. 工具菜单上,单击提交选项

  2. 提交选项对话框中,选择允许用户提交此表单复选框。

    在选中此复选框时,InfoPath 会在用户填写表单时向“标准”工具栏添加一个“提交”按钮,并向“文件”菜单添加一个“提交”命令。

  3. 单击“使用规则执行自定义操作”,然后单击“规则”

  4. “用于提交表单的规则”对话框中,单击“添加”

  5. 单击“添加操作”

  6. “操作”框中,单击“使用数据连接进行提交”,在“数据连接”列表中单击要用于此提交操作的数据连接,然后单击“确定”

  7. 对已添加到表单模板中的每个提交数据连接重复步骤 5 和 6。

  8. 在为表单模板中的所有提交数据连接添加条件之后,单击“确定”两次。

    1. 若要更改的提交按钮出现在标准工具栏和用户填写表单时,将显示在文件菜单的提交命令的名称,请在提交选项对话框中的标题框中键入新名称。

      如果您想要将键盘快捷键分配给此按钮和命令,请键入与号 (&) 之前要用作键盘快捷方式的字符。例如,要分配 ALT + B 为提交按钮和命令的键盘快捷方式,请键入& 交

  9. 若要防止用户在填写表单时使用“提交”命令或“标准”工具栏上的“提交”按钮,请清除“显示‘提交’菜单项和‘提交’工具栏按钮”复选框。

    1. 默认情况下,用户提交表单之后, InfoPath 使窗体保持打开状态,显示一条消息,指示表单已成功提交。若要更改此默认行为,请单击高级,然后执行下列操作之一︰

      • 若要关闭该窗体或创建新的空白表单用户提交完成的表单后,单击之后提交列表中所需的选项。

      • 以创建自定义消息说明已成功提交表单,选择使用自定义消息复选框,然后在成功失败框中键入您的邮件。

        使用失败框中一条消息告诉用户如何操作如果他们无法提交表单。例如,您可以建议用户保存其窗体和联系某人进一步的说明。

      • 如果您不希望在用户提交表单后显示一条消息,请清除显示成功或失败的邮件复选框。

返回页首

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×