将表单数据提交到多个位置

注意:  我们希望能够尽快以你的语言为你提供最新的帮助内容。 本页面是自动翻译的,可能包含语法错误或不准确之处。我们的目的是使此内容能对你有所帮助。可以在本页面底部告诉我们此信息是否对你有帮助吗? 请在此处查看本文的 英文版本 以便参考。

您可以设计表单模板,以便用户可以其表单数据提交到多个位置时,可单击提交按钮。

本文内容

概述

步骤 1: 添加提交数据连接

步骤 2: 配置为允许提交表单模板

概述

若要允许用户将其表单数据提交到多个位置,必须向表单模板的数据提交的每个您希望向其提交表单的用户的位置添加辅助数据连接。添加所有提交数据连接后,您可以配置表单模板以允许用户将其表单数据提交到多个位置使用规则。因此,Microsoft Office InfoPath 向提交按钮标准工具栏和到文件菜单提交命令时用户填写表单。InfoPath 表单数据提交到规则中列出的顺序中的辅助数据连接。您将无法配置要使用的所有提交数据连接,同时的规则。

配置表单模板以允许用户提交表单数据时,也可以通过以下方式定制提交选项:

  • 更改显示在标准工具栏上的提交按钮和文件菜单上的提交命令的文本。

  • 更改标准工具栏上的提交按钮和文件菜单上的提交命令的键盘快捷方式。

  • 创建自定义用户提交表单时向用户显示的消息。

  • 指定是否要保持表单打开、 关闭该窗体或提交表单后打开另一个空白表单。

返回页首

步骤 1: 添加提交数据连接

若要配置表单模板以允许用户提交到多个位置已完成的表单,添加所需的提交到表单模板的数据连接。您可以将数据连接添加到以下位置:

  • Web 服务

  • 运行 Microsoft Windows SharePoint Services 的服务器上的文档库

  • 在电子邮件

    注意: 用户需要将电子邮件表单数据提交才能在其计算机上安装 Microsoft Office Outlook。

以下过程介绍如何添加提交到这些位置的数据连接。

添加数据提交到 Web 服务数据连接

  1. 工具菜单上,单击数据连接

  2. 数据连接对话框中,单击添加

  3. 在数据连接向导中,单击创建的新连接到,单击提交数据,然后单击下一步

  4. 在向导的下一页上,单击到 Web 服务,然后单击下一步

  5. 在向导的下一页上,键入您的用户将提交表单,,然后单击下一步的 Web 服务的位置。

    如果您想要搜索的 Web 服务的通用描述、 发现和集成 (UDDI) 服务器,请单击搜索 UDDI输入您想要搜索的 UDDI 服务器,指定是否要搜索提供商或按提供的服务输入搜索关键字,然后单击搜索。匹配搜索关键字的 web 服务将出现在搜索结果列表中。

  6. 选择操作列表中,在向导的下一页上单击 Web 服务操作,将接收表单数据,然后单击下一步

  7. 在向导的下一页上,执行下列操作之一:

    提交域或组中的数据

    1. 参数列表中,单击将接收数据从窗体的 Web 服务参数。

    2. 参数选项中,单击域或组

    3. 单击修改 数据源图像

    4. 选择域或组对话框中,单击域或组中要提交,其数据,然后单击确定

    5. 包括框中,单击文本和子元素以提交的内容只需和任何子元素的域或组,或单击XML 子树,包括选定的元素提交内容和所选的组或域。

    提交所有窗体中的数据

    1. 单击整个表单 (XML 文档,包括处理指令)

    将数据作为字符串

    1. 选择将数据作为字符串提交复选框。

      通常情况下,您选择此复选框以提交数字签名的数据。在大多数情况下,清除此复选框。

  8. 单击“下一步”

  9. 输入此数据连接的名称框中,在向导的下一页上键入一个描述性名称,为此提交数据连接。

  10. 验证在摘要部分中的信息正确,然后单击完成

添加数据提交到文档库中的数据连接

  1. 工具菜单上,单击数据连接

  2. 数据连接对话框中,单击添加

  3. 在数据连接向导中,单击创建的新连接到,单击提交数据,然后单击下一步

  4. 在向导的下一页上,单击向 SharePoint 网站上的文档库,然后单击下一步

  5. 在下一页上,在文档库框中,在向导中,键入 SharePoint 文档库的位置。

  6. 文件名框中,键入将用于标识的文档库中的窗体的名称。您可以使用公式来确保每个窗体名称是唯一的。

    操作方法

    1. 单击插入公式 公式按钮

    2. 插入公式对话框中,执行下列操作之一:

      • 若要使用公式中的字段,单击插入域或组,单击您想要使用选择域或组对话框中的字段,然后单击确定

      • 要在公式中使用函数,请单击插入函数,选择您想要使用插入函数对话框中的函数,然后单击确定

        如果函数需要参数,在插入函数对话框中选择的函数,单击确定,然后在公式框中插入公式对话框中,双击您添加了,该函数并单击一个字段或组。在另请参阅部分找到有关函数的详细信息的链接。

      • 若要插入公式的值或数学运算符,请在公式框中键入值或数学运算符符号。

    运算

    符号

    添加

    +

    相减

    -

    相乘

    *

    /

    • 注意: 如果公式使用除法 (/) 运算符,请确保之前和之后除法运算符存在一个空格。如果除法运算符没有空间之前和之后,InfoPath 将解释"/"作为 XPath 位置步骤分隔符而不是作为除法运算符。

    • 若要检查的公式为正确的语法,在插入公式对话框中,单击验证公式

      另请参阅部分找到有关公式的详细信息的链接。

  7. 若要覆盖具有相同名称的文档库中的任何现有窗体,请选择允许覆盖文件是否存在复选框。

  8. 单击“下一步”

  9. 输入此数据连接的名称框中,在向导的下一页上键入一个描述性名称,为此提交数据连接。

  10. 验证在摘要部分中的信息正确,然后单击完成

添加提交电子邮件中的数据的数据连接

  1. 工具菜单上,单击数据连接

  2. 数据连接对话框中,单击添加

  3. 在数据连接向导中,单击创建的新连接到,单击提交数据,然后单击下一步

  4. 在向导的下一页上,单击作为电子邮件,然后单击下一步

  5. 在向导的下一页上,键入邮件,您希望显示在邮件中,主题和在相应的框中,所需的任何介绍性文本的收件人的电子邮件地址,然后单击下一步。除简介框中的每个框中,您还可以使用公式。

    操作方法

    1. 单击插入公式 公式按钮

    2. 插入公式对话框中,执行下列操作之一:

      • 若要使用公式中的字段,单击插入域或组,单击您想要使用选择域或组对话框中的字段,然后单击确定

      • 要在公式中使用函数,请单击插入函数,选择您想要使用插入函数对话框中的函数,然后单击确定

        如果函数需要参数,在插入函数对话框中选择的函数,单击确定,然后在公式框中插入公式对话框中,双击您添加了,该函数并单击一个字段或组。在另请参阅部分找到有关函数的详细信息的链接。

      • 若要插入公式的值或数学运算符,请在公式框中键入值或数学运算符符号。

    运算

    符号

    添加

    +

    相减

    -

    相乘

    *

    /

    • 注意: 如果公式使用除法 (/) 运算符,请确保之前和之后除法运算符存在一个空格。如果除法运算符没有空间之前和之后,InfoPath 将解释"/"作为 XPath 位置步骤分隔符而不是作为除法运算符。

    • 若要检查的公式为正确的语法,在插入公式对话框中,单击验证公式

      另请参阅部分找到有关公式的详细信息的链接。

  6. 在向导的下一页上,执行下列操作之一:

    1. 若要显示的电子邮件正文中的窗体,请单击发送仅窗体,不发送附件活动视图

    2. 以电子邮件以附件形式发送表单数据,请单击发送作为附件的窗体数据、 选择附加表单模板,以确保用户可以打开该窗体复选框,然后键入附件名称中的窗体的名称框。您还可以指定字段或使用公式来确保每个窗体名称是唯一的。此选项才可用仅表单模板配置为自动确定安全级别,或者配置为受限或完全信任安全级别。

      操作方法

      1. 单击插入公式 公式按钮

      2. 插入公式对话框中,执行下列操作之一:

        • 若要使用公式中的字段,单击插入域或组,单击您想要使用选择域或组对话框中的字段,然后单击确定

        • 要在公式中使用函数,请单击插入函数,选择您想要使用插入函数对话框中的函数,然后单击确定

          如果函数需要参数,在插入函数对话框中选择的函数,单击确定,然后在公式框中插入公式对话框中,双击您添加了,该函数并单击一个字段或组。在另请参阅部分找到有关函数的详细信息的链接。

        • 若要插入公式的值或数学运算符,请在公式框中键入值或数学运算符符号。

      运算

      符号

      添加

      +

      相减

      -

      相乘

      *

      /

      • 注意: 如果公式使用除法 (/) 运算符,请确保之前和之后除法运算符存在一个空格。如果除法运算符没有空间之前和之后,InfoPath 将解释"/"作为 XPath 位置步骤分隔符而不是作为除法运算符。

      • 若要检查的公式为正确的语法,在插入公式对话框中,单击验证公式

        另请参阅部分找到有关公式的详细信息的链接。

      以附件形式发送表单数据的电子邮件收件人需要在其计算机上安装的 InfoPath 打开附件。

  7. 单击“下一步”

  8. 输入此数据连接的名称框中,在向导的下一页上键入一个描述性名称,为此提交数据连接。

  9. 验证在摘要部分中的信息正确,然后单击完成

返回页首

步骤 2: 配置为允许提交表单模板

向表单模板添加必要的辅助数据连接后,您可以配置表单模板以允许用户提交表单数据。执行此操作时,InfoPath提交将命令添加到文件菜单和到标准工具栏上的提交按钮时用户填写表单。您可以配置当用户单击提交按钮的操作。在此例中,您将添加的规则,将提交表单数据发送到每个提交数据连接,当用户单击文件菜单上的提交命令或标准工具栏上的提交按钮。

在相同的对话框中,您可以配置的提交选项。

  1. 工具菜单上,单击提交选项

  2. 提交选项对话框中,选择允许用户提交此表单复选框。

    当您选择此复选框时,InfoPath 添加到标准工具栏和到文件菜单提交命令提交按钮,当用户填写表单。

  3. 单击自定义使用规则执行操作,然后单击规则

  4. 提交表单的规则对话框中,单击添加

  5. 单击添加操作

  6. 操作框中,单击提交使用数据连接,单击您想要用于此数据连接提交数据连接列表中的操作,然后单击确定

  7. 重复步骤 5 和 6 对于每个提交您已添加到您的表单模板的数据连接。

  8. 表单模板中添加条件的所有提交数据连接后,单击确定两次。

    1. 若要更改的提交按钮出现在标准工具栏和用户填写表单时,将显示在文件菜单的提交命令的名称,可在提交的标题框中键入新名称选项对话框。

      如果您想要将键盘快捷键分配给此按钮和命令,请键入与号 (&) 之前要用作键盘快捷方式的字符。例如,要分配 ALT + B 为提交按钮和命令的键盘快捷方式,请键入& 交

  9. 若要防止用户在标准工具栏上使用提交命令或提交按钮在填写表单时,请清除显示提交菜单项和提交工具栏按钮复选框。

    1. 默认情况下,用户提交表单之后, InfoPath 使窗体保持打开状态,显示一条消息,指示表单已成功提交。若要更改此默认行为,请单击高级,然后执行下列操作之一:

      • 若要关闭该窗体或创建新的空白表单用户提交完成的表单后,单击之后提交列表中所需的选项。

      • 以创建自定义消息说明已成功提交表单,选择使用自定义消息复选框,然后在成功失败框中键入您的邮件。

        使用失败框中一条消息告诉用户如何操作如果他们无法提交表单。例如,您可以建议用户保存其窗体和联系某人进一步的说明。

      • 如果您不希望在用户提交表单后显示一条消息,请清除显示成功或失败的邮件复选框。

返回页首

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×