将数据添加到形状中

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

Microsoft Office Visio 绘图可以是最多图片-将很有价值的方式组织您的数据并检索一个报表中的数据。

本文讨论一些过程的最佳方法,这些过程包括如何手动将数据添加到所选形状,如何创建可应用于绘图中多个形状的一组可重用数据以及如何将数据添加到主控形状。

注意: 下面的步骤适用于Microsoft Office Visio 专业版 2007和Microsoft Office Visio 标准版 2007。如果您有 Visio 专业版,您可以自动导入数据、 将数据添加到形状,并使用数据图形的形状上显示的数据。若要了解哪种版本的 Visio 你,在帮助菜单上,单击关于 Microsoft Office Visio

你想如何操作?

将数据添加到所选形状

创建一组可重用的数据域

将数据域添加到主控形状

将数据添加到所选形状

将数据添加到绘图中已有的形状,首先将数据域添加到您的形状,并将值。

提示: 以下过程是将数据添加到形状的最简单方法。不过,如果要将相同的数据添加到多个形状,请考虑使用本文其他部分中介绍的其他某一方法。

数据域和数据值之间有何区别?

  • 数据域是一个可存放数据值的带标签的单元格。

  • 数据值是数据库表、工作表的单元格或形状(在本文中)中的文本或数字。

下面是一个示例,显示形状数据窗口中的域和判定形状从基本流程图模具中的值。在此例中,字段是小时费率、 必需,网络访问和因违约、 工期和的值为 $49.00,是的和 3 周。

显示字段和值的形状数据窗口。

将数据域添加到所选形状

  1. 选择要向其添加数据的形状。

  2. 右击所选形状,在快捷菜单上指向“数据”,然后单击“形状数据”

  3. 当您看到一条消息询问您是否要现在定义数据时,请单击

    注意: 如果形状已包含数据域,就不会显示此消息。

  4. “定义形状数据”对话框中,键入域的标签。

  5. 要创建其他域,请单击“新建”,然后重复步骤 4。

  6. 定义完所有数据域后,单击“确定”

    将出现“形状数据”对话框,其中显示您定义的域。

将数据值添加到数据域

  1. “视图”菜单上,单击“形状数据窗口”

  2. 选择各个形状(一次选择一个),然后在“形状数据”窗口的数据域中键入数据值。

    注意: “形状数据窗口”的内容只显示所选形状的数据。

返回页首

创建一组可重用的数据域

您可以创建一组数据域,然后可以将这些字段应用于以后放在绘图中的形状以及绘图中已有的形状。

  1. “视图”菜单上,单击“形状数据窗口”

  2. 右击“形状数据”窗口中的任何位置,然后单击“形状数据集”

  3. “形状数据集”窗口中,单击“添加”

  4. “添加形状数据集”对话框中,键入数据集的名称。

  5. 选择“创建新的属性集”,然后单击“确定”

    数据集即会显示在“形状数据集”窗口的“名称”列中。

    注意: 此外,如果要更改现有数据集,还可以单击其他的一个选项。

  6. “名称”下单击新的数据集,然后单击“定义”

  7. “定义形状数据”对话框中,键入域的标签。

  8. 要创建其他域,请单击“新建”,然后重复步骤 7。

  9. 定义完所有数据域后,单击“确定”

  10. 要将数据集应用于绘图中的所选形状,请在“形状数据集”窗口中选择该数据集,然后单击“应用”

    提示: 要查看已应用数据集的其中一个形状中的新域,请选择该形状,然后在“形状数据”窗口中查看。

返回页首

将数据域添加到主控形状

如果希望每次使用特定形状时都添加相同的形状数据集,可以将这些数据域添加到该形状的主控形状的副本,这样能够节省时间。例如,可以将姓名和雇员编号等数据域添加到人员形状的主控形状。

  1. 右击要向其添加形状数据的主控形状,指向“添加到我的形状”,然后单击“添加到新模具”

    注意: 如果已具有自定义模具,可以将主控形状添加到该模具,而不必创建新模具。

  2. 另存为对话框中,为新模具中,键入一个名称,然后单击保存

  3. “文件”菜单上,依次指向“形状”“我的形状”,然后单击包含复制的主控形状的模具。

  4. 右击新模具的标题栏,然后在快捷菜单上单击“编辑模具”

  5. 右击刚添加到该模具中的形状,指向“编辑主控形状”,然后单击“编辑主控形状”

  6. 在该形状的编辑窗口中,右击该形状,指向“数据”,然后单击“形状数据”

  7. 当您看到一条消息询问您是否要现在定义数据时,请单击

    注意: 如果该形状已包含数据域,则不会显示此消息,但您可以继续执行其余步骤。

  8. “定义形状数据”对话框中,键入域的名称,然后填写所需的任何其他信息。例如,此时您可能希望更改数据类型或者添加形状提示。

  9. 若要创建另一个字段,请单击新建,然后重复步骤 8。

  10. 完成定义数据域后,单击确定

    将出现“形状数据”对话框,其中显示您定义的域。

    注意: 如果想要对域进行更改,请单击“定义”,然后重复步骤 8。

  11. 要关闭形状的编辑窗口,请在“文件”菜单上单击“关闭”

  12. 当您看到一条消息询问您是否要更新形状时,请单击

  13. 当您看到另一条消息,询问您是否要保存对模具所做的更改时,请单击

返回页首

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×