将数据库转换为 .accdb 文件格式

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

Access 2016、 Access 2013、 Access 2010 和 Access 2007 中.accdb 文件格式创建数据库。此格式支持如多值的字段、 数据宏和发布到 Access Services 功能。

您可以将使用 Microsoft Office Access 2003、Access 2002、Access 2000 或 Access 97 创建的数据库转换为 .accdb 文件格式。但是请注意,使用 Access 2007 之前版本的 Access 无法打开或链接到 .accdb 文件格式的数据库。

此外,.accdb 格式不支持复制功能或用户级安全性。如果您需要与使用 Access 2003 或更早版本的用户共享您的数据库,或者如果您需要使用复制功能或用户级安全性,则您必须使用 .mdb 文件格式。

注意: 即使他们可以共享相同的文件格式,无法在 Access 2007 中使用 Access 2016、 Access 2013 和 Access 2010 中的某些功能。有关详细信息,请参阅部分中使用 Access 2007 打开已创建或修改 Access 2010、 Access 2013 或 Access 2016 中的数据库

本文内容

将 Access 2000 或 Access 2002 - 2003 数据库转换为 .accdb 格式

将 Access 97 数据库转换为 .accdb 格式

使用 Access 2007 打开在 Access 2010、 Access 2013 或 Access 2016 中创建或修改的数据库

将 Access 2000 或 Access 2002 - 2003 数据库转换为 .accdb 格式

将 Access 2000 或 Access 2002-2003年数据库 (.mdb) 转换为.accdb 文件格式,必须首先使用 Access 2007、 Access 2010、 Access 2013 或 Access 2016 打开数据库并将它保存为.accdb 文件格式。

  1. 单击“文件”,然后单击“打开”

  2. 单击要转换的 Access 2000 或 Access 2002-2003 数据库 (.mdb)。

    注意: 如果出现“数据库增强功能”对话框,则表明数据库使用的文件格式早于 Access 2000。若要继续,请参阅将 Access 97 数据库转换为 .accdb 格式一节。

  3. 依次单击“文件”和“另存为”,然后单击“将数据库另存为”

  4. 选择“Access”文件类型,然后单击“另存为”

    如果在单击“另存为”时任何数据库对象处于打开状态,Access 会提示您在创建副本之前关闭它们。单击“是”以让 Access 关闭对象,或者单击“否”以取消整个过程。如果需要,Access 还将提示您保存任何更改。

  5. “另存为”对话框的“文件名”框中,键入文件名,然后单击“保存”

    Access 创建数据库的副本,然后打开该副本。Access 自动关闭原始数据库。

返回页首

将 Access 97 数据库转换为 .accdb 格式

从 Access 2013 开始,将不能把 Access 97 数据库 (.mdb) 直接转换为 .accdb 文件格式。但是,您可以打开早期 Access 版本中的 Access 97 数据库,然后以 Access 2013 可以打开的格式保存数据库。例如,使用 Access 2003 打开 Access 97 数据库,并将其转换为 Access 2013 可以打开的格式的步骤如下:

  1. 在 Access 2003 中打开 Access 97 数据库。

  2. 单击“工具”>“数据库实用工具”>“转换数据库”>“转为 Access 2002-2003 文件格式”。

  3. 输入数据库名称,然后单击“保存”。

  4. 关闭 Access 2003 并打开 Access 2013。

  5. 打开数据库并单击“文件”>“另存为”>“Access 数据库 (.accdb)”>“另存为”>“保存”。

您也可以使用 Access 2007 或 Access 2010 把 Access 97 数据库转换成 .accdb 格式。当您以这两种产品中任意一种打开 Access 97 数据库时,将显示“数据库增强功能”向导,以帮助您转换数据库为 .accdb 格式。

返回页首

使用 Access 2007 打开在 Access 2010、 Access 2013 或 Access 2016 中创建或修改的数据库

由于 Access 2016、 Access 2013、 Access 2010 和 Access 2007 所有使用相同的文件格式,您可以使用 Access 2007 打开而不首先使用另存为命令在 Access 2010、 Access 2013或 Access 2016 中创建的数据库。但是,Access 2016、 Access 2013与 Access 2010 包含需要 Access 2016、 Access 2013和 Access 2010,若要运行的一些功能。此功能,根据下列选项之一可能会发生当您尝试在 Access 2007 中使用该数据库 ︰

  • 不能修改使用相应功能的对象。

  • 不能打开使用相应功能的对象。

  • 根本无法在 Access 2007 中打开数据库。

返回页首

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×