将形状数据导出到数据库

注意: 我们希望能够尽快以你的语言为你提供最新的帮助内容。本页面是自动翻译的,可能包含语法错误或不准确之处。我们的目的是使此内容能对你有所帮助。可以在本页面底部告诉我们此信息是否对你有帮助吗?请在此处查看本文的英文版本以便参考。

如果你的形状包含数据, 你可以运行 "数据库导出向导" 来创建包含该数据的数据库表。

"数据库导出向导" 和使用 "导出到数据库" 命令所达到的对话框之间的区别在于, 通过向导, 您可以选择导出图层上的所有形状。如果你不需要按层导出, 你可能会发现使用 "导出到数据库" 命令会更简单。

使用 "数据库导出向导"

  1. 在 "视图" 选项卡 > "加载项" > "其他Visio 方案" > "数据库导出向导"。

  2. 按照向导页上的说明进行操作。

    提示: 

    • 在列表中显示的形状数据的单元格名称前面有一些"项", 如 "对成本"。

    • 当您运行数据库导出向导以导出形状数据时, 向导会将导出相关信息与绘图页存储在一起。如果对形状进行了更改, 并且想要再次导出数据, 请右键单击绘图页, 然后选择 "数据库导出表"。

使用 "导出到数据库" 命令

  1. 在 "视图" 选项卡 > "加载项" > "其他Visio 方案" > "导出到数据库"。

  2. 选择要使用的数据库表。

    • 如果数据源存储在默认位置以外的地方,请单击“浏览”以查找文件。

    • 若要创建新的数据源, 请单击 "创建"。遵循 "创建新数据源" 向导。单击 "完成" 后, 将显示 " ODBC 设置" 对话框。你可以从此处选择一个现有数据库或创建一个新数据库。稍后将在数据库中创建表。

      注意: 

      • 如果您使用 Excel 作为数据源, 则可以选择一个现有工作簿, 但不能从该向导中创建。

      • 如果选择 Excel 工作簿, 请确保清除 "选择工作簿" 对话框中的 "只读" 复选框。

  3. 如果数据库支持所有者, 请在 "所有者" 列表中单击所有者名称以筛选表所有者列表。数据库表使用您用于登录数据库的名称创建。

  4. 如果数据库允许您访问多个数据库,请在“限定符”列表中单击您要使用的数据库。

    提示: 如果您使用的是 Access 或 Excel, 将在此处列出您的数据将被导出到的数据库的名称和位置。

  5. 在“”列表中,单击要使用的数据库表。若要创建新表,请为其键入一个名称。

  6. 如果您想要更改从 ShapeSheet 单元格导出数据的方式,请执行下列操作之一:

    向导出列表中添加 ShapeSheet 单元格

    1. 单击“添加”。

    2. 选择您要导出的 ShapeSheet 单元格。

    3. 在“求值方式”框中,为数据库字段中存储的值选择数据类型。

    4. 选择形状数据将被复制到的数据库域。

    5. 指定数据库数据类型、域长度和数据库域的小数精度。

    修改如何导出 ShapeSheet 单元格中的数据

    1. 选择一个单元格名称, 然后单击 "修改"。

    2. 更改数据的导出方式。

    从导出列表中删除 ShapeSheet 单元格

    选择一个单元格名称, 然后单击 "删除"。

使用 "数据库导出向导"

  1. 在 "工具" 菜单上, 指向 "加载项", 指向 "其他Visio 方案", 然后单击 "数据库导出向导"。

  2. 按照向导页上的说明进行操作。

    提示: 

    • 在列表中显示的形状数据的单元格名称前面有一些"项", 如 "对成本"。

    • 当您运行数据库导出向导以导出形状数据时, 向导会将导出相关信息与绘图页存储在一起。如果对形状进行了更改, 并且想要再次导出数据, 请右键单击绘图页, 然后选择 "数据库导出表"。

使用 "导出到数据库" 命令

  1. 在 "工具" 菜单上, 指向 "加载项", 然后指向 "其他Visio 方案", 然后单击 "导出到数据库"。

  2. 选择要使用的数据库表。

    • 如果数据源存储在默认位置以外的地方,请单击“浏览”以查找文件。

    • 若要创建新的数据源, 请单击 "创建"。遵循 "创建新数据源" 向导。单击 "完成" 后, 将显示 " ODBC 设置" 对话框。你可以从此处选择一个现有数据库或创建一个新数据库。稍后将在数据库中创建表。

      注意: 

      • 如果您使用的是 Microsoft Office Excel 作为数据源, 则可以选择一个现有工作簿, 但不能从该向导中创建。

      • 如果选择 Excel 工作簿, 请确保清除 "选择工作簿" 对话框中的 "只读" 复选框。

  3. 如果数据库支持所有者, 请在 "所有者" 列表中单击所有者名称以筛选表所有者列表。数据库表使用您用于登录数据库的名称创建。

  4. 如果数据库允许您访问多个数据库,请在“限定符”列表中单击您要使用的数据库。

    提示: 如果您使用的是 Microsoft Office Access 或 Excel, 将在此处列出您的数据将导出到的数据库的名称和位置。

  5. 在“”列表中,单击要使用的数据库表。若要创建新表,请为其键入一个名称。

  6. 如果您想要更改从 ShapeSheet 单元格导出数据的方式,请执行下列操作之一:

    向导出列表中添加 ShapeSheet 单元格

    1. 单击“添加”。

    2. 选择您要导出的 ShapeSheet 单元格。

    3. 在“求值方式”框中,为数据库字段中存储的值选择数据类型。

    4. 选择形状数据将被复制到的数据库域。

    5. 指定数据库数据类型、域长度和数据库域的小数精度。

    修改如何导出 ShapeSheet 单元格中的数据

    1. 选择一个单元格名称, 然后单击 "修改"。

    2. 更改数据的导出方式。

    从导出列表中删除 ShapeSheet 单元格

    选择一个单元格名称, 然后单击 "删除"。

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×