将宏模块复制到另一个工作簿中

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

如果某个工作簿中包含您希望用于别处的 Visual Basic for Applications (VBA) 宏,则可以使用 Microsoft Visual Basic 编辑器,将包含该宏的模块复制到另一个打开的工作簿中。

宏在开始处理之前,您应该:

  1. 使用宏之前,请启用开发工具选项卡。有关详细信息,请参阅显示开发工具选项卡

  2. 设置安全级别暂时以启用所有宏。若要的操作:

    1. “开发工具”选项卡上的“代码”组中,单击“宏安全性”

    2. “宏设置”类别的“宏设置”下,单击“启用所有宏(不推荐,可能会运行有潜在危险的代码)”,然后单击“确定”

      “开发工具”选项卡上的“代码”组

      重要: 为帮助防止运行有潜在危险的代码,我们建议您在使用完宏之后恢复任何禁用所有宏的设置。

将模块从一个工作簿复制到另一个工作簿

  1. 打开包含要复制的module的工作簿以及要将模块复制到其中的工作簿。

  2. 开发工具选项卡的代码组中,单击 Visual Basic.

    这将启动 Visual Basic 编辑器。

  3. 在 Visual Basic 编辑器中,在视图菜单上,单击项目资源管理器 “项目资源管理器”按钮图像 ,或按 CTRL + R。

    启动项目任务窗格,并窗格会列出两个打开的工作簿。通常情况下,您将看到vba 项目 (< 工作簿名称 >)

  4. 项目窗格中,拖动您想要复制到目标工作簿的模块。模块将为Module1复制到vba 项目 (Book1.xlsm)下方的模块节点。
    VBA 项目资源管理器

    宏 Module1 -- 从 Book2.xlsm 复制到 Book1.xlsm

    宏 Module1 的副本

宏和 VBA 概述

如果您对宏和 VBA 完全不了解,可以从以下信息中获取帮助。

  • 宏是可用于自动执行任务的一个操作或一组操作。

  • 您可以使用“录制宏”命令(“开发工具”选项卡,“代码”组)录制宏。

  • 宏使用 VBA 编程语言进行录制。

  • 您可以检查和编辑您的宏在 Visual Basic 编辑器中,由 Excel 打开一个窗口。

    包含两个存储在 Book1 的 Module1 中的宏的模块。

宏名称为MakeCellGreenSetRowHeight是名为Module1,它将存储在 Book1 的模块中。

需要更多帮助吗?

You can always ask an expert in the Excel Tech Community, get support in the Answers community, or suggest a new feature or improvement on Excel User Voice.

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×