将宏模块复制到另一个工作簿中

注意: 我们希望能够尽快以你的语言为你提供最新的帮助内容。 本页面是自动翻译的,可能包含语法错误或不准确之处。 我们的目的是使此内容能对你有所帮助。 可以在本页面底部告诉我们此信息是否对你有帮助吗? 请在此处查看本文的英文版本以便参考。

如果工作簿包含要在其他位置使用的Visual basic For Applications (VBA) 宏, 则可以通过使用Visual Basic 编辑器(VBE) 将包含该宏的模块复制到另一个打开的工作簿中。

宏和 VBA 工具位于“开发工具”选项卡上,由于该选项卡默认是隐藏的,因此第一步是启用选项卡。

  • 对于Windows, 转到 "文件>"选项> "自定义功能区"。

  • 对于Mac, 请转到Excel > "首选项 ... " >功能区 & 工具栏

  • 接下来, 在 "自定义功能区" 部分中的 "主选项卡" 下, 选中 "开发工具" 复选框。

宏和 VBA 概述

如果您对宏和 VBA 的一般不熟悉, 您可能会发现以下信息有帮助。

  • 宏是可用于自动执行任务的一个操作或一组操作。

  • 可以使用 "开发工具" 选项卡上的 "录制宏" 命令录制宏。

  • 宏将记录在 VBA 编程语言中。

  • 可以在 Visual Basic 编辑器 (由 Excel 打开的窗口) 中检查和编辑宏。 下面是一个适用于 Windows 的 VBE 窗口示例:

    包含两个存储在 Book1 的 Module1 中的宏的模块。

名为MakeCellGreenSetRowHeight的宏位于名为 " Module1" 的模块中, 该模块存储在 Book1 中。

将模块从一个工作簿复制到另一个工作簿

  1. 打开包含要复制的宏的工作簿, 以及要将其复制到的工作簿。

  2. 在 "开发工具" 选项卡上, 单击 " visual basic " 以打开 " visual basic 编辑器"。

  3. 在 Visual Basic 编辑器的 "视图" 菜单上, 单击 "项目资源管理器 “项目资源管理器”按钮图像 ", 或按CTRL + R

  4. 在 "项目资源管理器" 窗格中, 将包含要复制的宏的模块拖到目标工作簿中。 在这种情况下, 我们正在将 Book2 从 .xlsm 复制到 Book1。  

    VBA 项目资源管理器

  1. 从 Book2 复制的 Module1 .xlsm

  2. 将 Module1 复制到 Book1 的副本。 .xlsm

需要更多帮助吗?

可随时在 Excel 技术社区中咨询专家,在解答社区获得支持,或在 Excel User Voice 上建议新功能或功能改进。

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×