将合并域插入到合并出版物

注意: 我们希望能够尽快以你的语言为你提供最新的帮助内容。本页面是自动翻译的,可能包含语法错误或不准确之处。我们的目的是使此内容能对你有所帮助。可以在本页面底部告诉我们此信息是否对你有帮助吗?请在此处查看本文的英文版本以便参考。

您可以在 Publisher 中的合并出版物中插入合并域。合并域是文本和图片信息的占位符, 在完成的出版物的每个副本中将有所不同。

您的邮件合并、电子邮件合并或目录合并出版物必须先连接到数据源, 然后才能插入合并域。

  1. 如果邮件合并出版物尚未打开, 请将其打开。

  2. 在 "邮件" 选项卡上, 选择 "邮件合并>分步邮件合并向导"。

  3. 在 "邮件合并" 任务窗格中的 "创建收件人列表" 下, 选择要使用的数据源, 然后单击 "下一步: 创建或连接到收件人列表"。

  4. 在 "选择数据源" 对话框中, 单击所需的数据源, 然后单击 "打开"。根据所选数据源的类型, 可能会显示其他对话框并请求特定信息。

  5. 在 "邮件合并收件人" 对话框中, 您可以选择要包含在合并中的收件人。选中要包含的收件人旁边的复选框, 并清除要排除的收件人旁边的复选框。你可以按特定字段或条件筛选列表, 并按字母顺序对列表进行排序。

  6. 如果您的出版物不包含文本框, 而您想要添加在完成的出版物的每个副本中保持不变的文本, 请通过单击 "插入>画文本框" 插入一个或多个文本框, 然后在所需位置绘图框n 您的出版物。

  7. 若要插入您要在已完成的出版物的每个副本中保持不变的文本, 请在文本框内单击, 然后键入要显示在每个副本中的文本。

  8. 在要插入合并域的文本框内单击。

  9. 插入以下任何内容:

    图片域

    1. 在 "邮件合并" 任务窗格中的 "其他项目" 下, 单击 "图片域"。

    2. 在 "插入图片域" 对话框中, 单击包含图片文件名称或路径的数据域, 然后单击"确定"

      注意: 如果 "内容" 列中不包含包含图片的文件夹的路径, 则必须指定图片文件的位置。单击 "指定文件夹", 选择 " [数据源文件夹]", 单击 "添加", 导航到图片的位置, 然后单击 "打开"。

    地址块

    1. 在 "邮件合并" 任务窗格中的 "其他项目" 下, 单击 "地址块"。

    2. 在 "插入地址块" 对话框中, 单击要包括的地址元素, 然后单击"确定"

      注意: 如果数据源中的数据字段名称与 Publisher 为地址块使用的数据域的名称不匹配, 则可能需要在 "插入地址块" 对话框中单击 "匹配域"。在 "匹配域" 对话框中, 使用下拉列表选择与 "发布者" 字段对应的数据源中的字段。

    问候语

    1. 在 "邮件合并" 任务窗格中的 "其他项目" 下, 单击 "问候语"。

    2. 在 "插入问候语" 对话框中, 选择 "问候语" 格式, 其中包括称呼、姓名格式和后面的标点。

      您也可以在 "称呼" 和 "标点" 框中键入自己的文本。

    3. 选择要在 Publisher 无法解释收件人姓名的情况下显示的文本, 例如, 当数据源不包含收件人的名字或姓氏, 而仅包含公司名称时。

      你也可以在无效收件人姓名的框中键入自己的文本作为问候行。

    4. 单击“确定”。

      注意: 如果数据源中的数据字段名称与 Publisher 用于问候语的字段的名称不匹配, 则您可能需要在 "插入问候语" 对话框中单击 "匹配域"。在 "匹配域" 对话框中, 使用下拉列表选择与 "发布者" 字段对应的数据源中的字段。

    信息的其他字段

    在 "邮件合并" 任务窗格中, "准备您的出版物" 下的列表将包含数据源中的所有域。你可以使用此列表将任何其他字段添加到你的出版物。

    1. 在 "邮件合并" 任务窗格中的 "准备出版物" 下的列表框中, 将要包含的域拖到您为其创建的文本框中。

      注意: 从此列表中拖动图片项时, 仅插入表示图片路径的文本;它不插入图片本身。

  1. 如果尚未打开电子邮件合并出版物, 请将其打开。

  2. 在 "邮件" 选项卡上, 选择 "电子邮件合并>分步电子邮件合并向导"。

  3. 在 "电子邮件合并" 任务窗格中的 "创建收件人列表" 下, 选择要使用的数据源, 然后单击 "下一步: 创建或连接到收件人列表"。

  4. 在 "选择数据源" 对话框中, 单击所需的数据源, 然后单击 "打开"。根据所选数据源的类型, 可能会显示其他对话框并请求特定信息。

  5. 在 "邮件合并收件人" 对话框中, 您可以选择要包含在合并中的收件人。选中要包含的收件人旁边的复选框, 并清除要排除的收件人旁边的复选框。你可以按特定字段或条件筛选列表, 并按字母顺序对列表进行排序。

  6. 如果您的出版物不包含文本框, 而您想要添加在完成的出版物的每个副本中保持不变的文本, 请通过单击 "插入>画文本框" 插入一个或多个文本框, 然后在所需位置绘图框n 您的出版物。

  7. 若要插入您要在已完成的出版物的每个副本中保持不变的文本, 请在文本框内单击, 然后键入要显示在每个副本中的文本。

  8. 在电子邮件合并出版物中, 单击要在其中插入合并域的文本框。

  9. 插入以下任何内容:

    个性化超链接

    1. 在 "电子邮件合并" 任务窗格中的 "更多项目" 下, 单击 "插入个性化超链接"。

    2. 在 "插入个性化超链接" 对话框中, 键入要显示的文本, 以及您希望每个收件人在单击超链接时要转到的网站或网页的地址。

    3. 如果要在 "显示文本" 或 "超链接" 字段中使用数据字段, 请在 "显示文本" 或 "超链接" 框中单击, 然后在 "要插入的项目" 下的列表中, 单击要插入的数据字段。

      如果插入数据字段, 则可以为与插入的数据字段对应的任何空白项指定替换显示文本和 web 地址。根据需要, 选中 "对空白项使用默认文本" 和 "为空白项使用默认超链接" 复选框, 然后键入 "替换文字" 和 "Web 地址"。

      “插入个性化超链接”对话框的图像

    图片域

    1. 在 "电子邮件合并" 任务窗格中的 "其他项目" 下, 单击 "图片域"。

    2. 在 "插入图片域" 对话框中, 单击要插入的图片数据域, 然后单击"确定"

      注意: 如果 "内容" 列中不包含包含图片的文件夹的路径, 则必须指定图片文件的位置。单击 "指定文件夹", 选择 " [数据源文件夹]", 单击 "添加", 导航到图片的位置, 然后单击 "打开"。

    问候语

    1. 在 "电子邮件合并" 任务窗格中的 "更多项目" 下, 单击 "问候行"。

    2. 在 "插入问候语" 对话框中, 选择 "问候语" 格式, 其中包括称呼、姓名格式和后面的标点。

      您也可以在 "称呼" 和 "标点" 框中键入自己的文本。

    3. 选择要在 Publisher 无法解释收件人姓名的情况下显示的文本, 例如, 当数据源不包含收件人的名字或姓氏, 而仅包含公司名称时。

      你也可以在无效收件人姓名的框中键入自己的文本作为问候行。

    4. 单击“确定”。

      注意: 如果数据源中的数据字段名称与 Publisher 用于问候语的字段的名称不匹配, 则您可能需要在 "插入问候语" 对话框中单击 "匹配域"。在 "匹配域" 对话框中, 使用下拉列表选择与 "发布者" 字段对应的数据源中的字段。

    信息的其他字段

    在 "电子邮件合并" 任务窗格中, "准备您的出版物" 下的列表将包含数据源中的所有域。你可以使用此列表将任何其他字段添加到你的出版物。

    1. 在 "电子邮件合并" 任务窗格中的 "准备出版物" 下的列表框中, 将要包含的域拖到您为其创建的文本框中。

      注意: 从该列表拖动图片项时, 仅插入图片的路径。它不插入图片本身。

另请参阅

创建邮件或电子邮件合并

创建目录合并

  1. 如果邮件合并出版物尚未打开, 请将其打开。

  2. 在 "工具" 菜单上, 指向 "邮件和目录", 然后单击 "邮件合并"。

  3. 在 "邮件合并" 任务窗格中的 "创建收件人列表" 下, 选择要使用的数据源, 然后单击 "下一步: 创建或连接到收件人列表"。

  4. 在 "选择数据源" 对话框中, 单击所需的数据源, 然后单击 "打开"。

    根据所选数据源的类型, 可能会显示其他对话框并请求特定信息。

    例如, 如果数据源是包含多个工作表上的信息的 Microsoft Office Excel 工作簿, 则需要选择包含所需信息的工作表, 然后单击"确定"

  5. 在 "邮件合并收件人" 对话框中, 您可以选择要包含在合并中的收件人。选中要包含的收件人旁边的复选框, 并清除要排除的收件人旁边的复选框。你可以按特定字段或条件筛选列表, 并按字母顺序对列表进行排序。有关改进收件人列表的详细信息, 请参阅有关邮件列表的提示

  6. 如果您的出版物不包含文本框, 而您想要添加在已完成的出版物的每个副本中保持不变的文本, 请插入一个或多个文本框。

    操作方法

    1. 在 "对象" 工具栏上, 单击 "文本框 按钮图像 "。

    2. 在出版物中, 指向要显示文本框一角的位置, 然后沿对角线方向拖动, 直到达到所需的文本框大小。

  7. 若要插入您要在已完成的出版物的每个副本中保持不变的文本, 请在文本框内单击, 然后键入要显示在每个副本中的文本。

  8. 在要插入合并域的文本框内单击。

  9. 插入以下任何内容:

    图片域

    1. 在 "邮件合并" 任务窗格中的 "其他项目" 下, 单击 "图片域"。

    2. 在 "插入图片域" 对话框中, 单击包含图片文件名称或路径的数据域, 然后单击"确定"

      注意: 如果 "内容" 列中不包含包含图片的文件夹的路径, 则必须指定图片文件的位置。单击 "指定文件夹", 选择 " [数据源文件夹]", 单击 "添加", 导航到图片的位置, 然后单击 "打开"。

    包含姓名、地址和其他信息的地址块

    1. 在 "邮件合并" 任务窗格中的 "其他项目" 下, 单击 "地址块"。

    2. 在 "插入地址块" 对话框中, 单击要包括的地址元素, 然后单击"确定"

      注意: 如果数据源中的数据字段名称与 Publisher 为地址块使用的数据域的名称不匹配, 则可能需要在 "插入地址块" 对话框中单击 "匹配域"。在 "匹配域" 对话框中, 使用下拉列表选择与 "发布者" 字段对应的数据源中的字段。

    问候语

    1. 在 "邮件合并" 任务窗格中的 "其他项目" 下, 单击 "问候语"。

    2. 在 "问候语" 对话框中, 选择 "问候语" 格式, 其中包括称呼、姓名格式和后面的标点。

      您也可以在 "称呼" 和 "标点" 框中键入自己的文本。

    3. 选择要在 Publisher 无法解释收件人姓名的情况下显示的文本, 例如, 当数据源不包含收件人的名字或姓氏, 而仅包含公司名称时。

      你也可以在无效收件人姓名的框中键入自己的文本作为问候行。

    4. 单击“确定”。

      注意: 如果数据源中的数据字段名称与 Publisher 用于问候语的字段的名称不匹配, 则您可能需要在 "问候语" 对话框中单击 "匹配域"。在 "匹配域" 对话框中, 使用下拉列表选择与 "发布者" 字段对应的数据源中的字段。

    信息的其他字段

    在 "邮件合并" 任务窗格中, "准备您的出版物" 下的列表将包含数据源中的所有域。你可以使用此列表将任何其他字段添加到你的出版物。

    1. 在 "邮件合并" 任务窗格中的 "准备出版物" 下的列表框中, 将要包含的域拖到您为其创建的文本框中。

      注意: 从此列表中拖动图片项时, 仅插入表示图片路径的文本;它不插入图片本身。

  1. 如果尚未打开电子邮件合并出版物, 请将其打开。

  2. 在 "工具" 菜单上, 指向 "邮件和目录", 然后单击 "电子邮件合并"。

  3. 在 "电子邮件合并" 任务窗格中的 "创建收件人列表" 下, 选择要使用的数据源, 然后单击 "下一步: 创建或连接到收件人列表"。

  4. 在 "选择数据源" 对话框中, 单击所需的数据源, 然后单击 "打开"。

    根据所选数据源的类型, 可能会显示其他对话框并请求特定信息。

    例如, 如果数据源是包含多个工作表上的信息的 Microsoft Office Excel 工作簿, 则需要选择包含所需信息的工作表, 然后单击"确定"

  5. 在 "邮件合并收件人" 对话框中, 您可以选择要包含在合并中的收件人。选中要包含的收件人旁边的复选框, 并清除要排除的收件人旁边的复选框。你可以按特定字段或条件筛选列表, 并按字母顺序对列表进行排序。有关改进收件人列表的详细信息, 请参阅有关邮件列表的提示

  6. 如果您的出版物不包含文本框, 请插入一个或多个文字框。

    操作方法

    1. 在 "对象" 工具栏上, 单击 "文本框 按钮图像 "。

    2. 在出版物中, 指向要显示文本框一角的位置, 然后沿对角线方向拖动, 直到达到所需的文本框大小。

  7. 若要插入您要在已完成的出版物的每个副本中保持不变的文本, 请在文本框内单击, 然后键入要显示在每个副本中的文本。

  8. 在电子邮件合并出版物中, 单击要在其中插入合并域的文本框。

  9. 插入以下任何内容:

    个性化超链接

    1. 在 "电子邮件合并" 任务窗格中的 "更多项目" 下, 单击 "插入个性化超链接"。

    2. 在 "插入个性化超链接" 对话框中, 键入要显示的文本, 以及您希望每个收件人在单击超链接时要转到的网站或网页的地址。

    3. 如果要在 "显示文本" 或 "超链接" 字段中使用数据字段, 请在 "显示文本" 或 "超链接" 框中单击, 然后在 "要插入的项目" 下的列表中, 单击要插入的数据字段。

      如果插入数据字段, 则可以为与插入的数据字段对应的任何空白项指定替换显示文本和 Web 地址。根据需要, 选中 "对空白项使用默认文本" 和 "为空白项使用默认超链接" 复选框, 然后键入 "替换文字" 和 "Web 地址"。

      “插入个性化超链接”对话框的图像

    图片域

    1. 在 "电子邮件合并" 任务窗格中的 "其他项目" 下, 单击 "图片域"。

    2. 在 "插入图片域" 对话框中, 单击要插入的图片数据域, 然后单击"确定"

      注意: 如果 "内容" 列中不包含包含图片的文件夹的路径, 则必须指定图片文件的位置。单击 "指定文件夹", 选择 " [数据源文件夹]", 单击 "添加", 导航到图片的位置, 然后单击 "打开"。

    问候语

    1. 在 "电子邮件合并" 任务窗格中的 "更多项目" 下, 单击 "问候行"。

    2. 在 "问候语" 对话框中, 选择 "问候语" 格式, 其中包括称呼、姓名格式和后面的标点。

      您也可以在 "称呼" 和 "标点" 框中键入自己的文本。

    3. 选择要在 Publisher 无法解释收件人姓名的情况下显示的文本, 例如, 当数据源不包含收件人的名字或姓氏, 而仅包含公司名称时。

      你也可以在无效收件人姓名的框中键入自己的文本作为问候行。

    4. 单击“确定”。

      注意: 如果数据源中的数据字段名称与 Publisher 用于问候语的字段的名称不匹配, 则您可能需要在 "问候语" 对话框中单击 "匹配域"。在 "匹配域" 对话框中, 使用下拉列表选择与 "发布者" 字段对应的数据源中的字段。

    信息的其他字段

    在 "电子邮件合并" 任务窗格中, "准备您的出版物" 下的列表将包含数据源中的所有域。你可以使用此列表将任何其他字段添加到你的出版物。

    1. 在 "电子邮件合并" 任务窗格中的 "准备出版物" 下的列表框中, 将要包含的域拖到您为其创建的文本框中。

      注意: 从该列表拖动图片项时, 仅插入图片的路径。它不插入图片本身。

  1. 如果目录合并出版物尚未打开, 请将其打开。

  2. 在 "工具" 菜单上, 指向 "邮件和目录", 然后单击 "目录合并"。

  3. 在 "目录合并" 任务窗格中的 "选择产品列表" 下, 选择要使用的数据源, 然后单击 "下一步: 创建或连接到产品列表"。

  4. 在 "选择数据源" 对话框中, 单击所需的数据源, 然后单击 "打开"。

    根据所选数据源的类型, 可能会显示其他对话框并请求特定信息。

    例如, 如果数据源是包含多个工作表上的信息的 Microsoft Office Excel 工作簿, 则需要选择包含所需信息的工作表, 然后单击"确定"

  5. 在 "目录合并产品列表" 对话框中, 您可以选择要在合并中包含的项目。选中要包含的项目旁边的复选框, 并清除要排除的项目旁边的复选框。你可以按特定字段或条件筛选列表, 并按字母顺序对列表进行排序。

  6. 如果您的出版物不包含文本框, 请在出版物的目录合并区域中插入一个文本框, 您将在其中插入数据域。

    操作方法

    1. 在 "对象" 工具栏上, 单击 "文本框 按钮图像 "。

    2. 在出版物中, 指向要显示文本框一角的位置, 然后沿对角线方向拖动, 直到达到所需的文本框大小。

  7. 若要插入因重复目录合并区中的每条记录而异的数据, 请在文本框中单击要插入数据域的位置, 然后执行下列操作之一:

    1. 若要将文本插入到模板的重复目录合并区域中, 请在 "准备出版物" 下的 "目录合并" 任务窗格中, 单击要插入的域。

      注意: 单击 "图片" 或 "图片" 字段将插入文本 (图片的路径和文件名), 而不是图片本身。

    2. 若要插入图片, 请在 "更多项目" 下单击 "产品图片"。

      注意: 如果在插入合并域之前未单击目录合并区中的文本框, Publisher 会在新的文本框或图片框架中插入每个合并域。

  8. 重复步骤 5, 直到从数据源插入了所需的所有字段。

  9. 设置目录合并区域的格式并对其进行排列, 这将为数据源中的每条记录重复此操作。你可以调整它的大小, 以便多条记录可以完全适应页面上的所需内容。在 "另请参阅" 部分中可找到有关格式和排列文本的详细信息的链接。

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×