导入 XML 数据

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

如果您以前创建 XML 映射,您可以使用它来将 XML 数据导入的单元格映射,但也有几种方法和导入 XML 数据,而不是 XML 映射的命令。

如果您有 XML 映射,操作将 XML 数据导入映射的单元格︰

  1. 在 XML 映射中,选择一个映射的单元格。

  2. 单击开发人员>导入

    如果看不到开发工具选项卡,请参阅显示开发工具选项卡

  3. 导入 XML对话框中,查找并选择要导入 XML 数据文件 (.xml),然后单击导入

导入 XML 数据的其他方法

有关问题的详细信息,请参阅本文末尾的常见问题导入 XML 数据

作为 XML 表导入 XML 数据文件

  1. 单击开发人员>导入

    如果看不到开发工具选项卡,请参阅显示开发工具选项卡

  2. 导入 XML对话框中,查找并选择要导入 XML 数据文件 (.xml),然后单击导入

    如果 XML 数据文件未引用架构,Excel 将推断的架构从 XML 数据文件。

  3. 导入数据对话框中,执行下列操作之一︰

    1. 选择现有工作表中的 XML 表 若要导入 XML 表中的指定单元格位置的工作表中的 XML 数据文件的内容。

    2. 选择新工作表中的 XML 表 若要导入 XML 表中从单元格 A1 开始一个新工作表中的文件的内容。在XML 源任务窗格中显示的 XML 数据文件的架构。

  4. 如果 XML 数据文件未引用架构,Excel 将推断的架构从 XML 数据文件。

  5. 若要控制 XML 数据 (如数据绑定、 格式和布局) 的行为,请单击属性,其中显示了XML 映射属性对话框中。例如,当您导入数据,默认情况下,但您可以更改,则将覆盖映射的区域中的现有数据。

导入多个 XML 数据文件

  1. 选择映射的单元格将多个 XML 文件导入一组映射的单元格。

    如果您想要将多个 XML 文件导入多个映射的单元格集,请单击任意位置上的工作表的未映射的单元格。

  2. 单击开发人员>导入

    如果看不到开发工具选项卡,请参阅显示开发工具选项卡

  3. 导入 XML对话框中,找到,然后选择要导入 XML 数据文件 (.xml)。

    • 如果连续的文件,按住 Shift,然后单击第一个和最后一个文件列表中。所有 XML 文件中的数据将导入和追加到映射的单元格。

    • 如果这些文件不连续,按住 Ctrl,然后单击您要导入列表中每个的文件。

  4. 单击“导入”。

    如果您选择不相邻的文件,将出现导入 < 文件名 >.xml对话框。选择对应于 XML 数据文件导入的每个文件的 XML 映射。

    对所有选定尚不导入的文件中使用一个映射,选择使用此架构的所有选定的文件的此 XML 映射

将多个 XML 数据文件导入为外部数据

要导入多个使用相同的命名空间,但不同的 XML 架构的 XML 文件,您可以使用从 XML 数据导入命令。Excel 创建唯一每个 XML 数据文件导入 XML 映射。

注意: 如果您要导入多个不定义命名空间的 XML 文件,这些 XML 文件将被视为他们使用相同的命名空间。

  1. 如果您正在使用 Office 365 订阅使用 Excel,单击数据>获取数据>从文件>从 XML

    如果您使用的 Excel 2016 或更早版本中,单击数据>自其他来源>从 XML 数据导入

  2. 转到驱动器、 文件夹或 Internet 位置包含您要导入 XML 数据文件 (.xml)。

  3. 选择文件,然后单击“打开”。

  4. 导入数据对话框中,执行下列操作之一︰

    • 在现有工作表中的 XML 表   向新工作表中新的 XML 表导入文件的内容。如果 XML 数据文件未引用架构,Excel 将推断的架构从 XML 数据文件。

    • 现有工作表   XML 数据导入的二维表中的行和列,显示为列标题和列标题下方的行中的数据的 XML 标记。第一个元素 (根节点) 用作标题,并显示在指定单元格的位置。在第二行,其余的标记按字母顺序排序。 在这种情况下,Excel 不推断的架构,而且您无法使用 XML 映射。

    • 新的工作表   Excel 将新的工作表添加到您的工作簿,并自动将 XML 数据放在新工作表的左上角。如果 XML 数据文件未引用架构,Excel 将推断的架构从 XML 数据文件。

  5. 若要控制的行为的 XML 数据,例如数据绑定、 格式和布局,请单击属性,其中显示了XML 映射属性对话框中。例如,当您导入数据,默认情况下,但您可以更改覆盖映射的区域中的现有数据。

打开要导入其数据的 XML 数据文件

  1. 单击“文件”>“打开”。

    如果您正在使用 Excel 2007 中,单击Office 按钮 Office 按钮图像 >打开

  2. 打开对话框中,单击驱动器、 文件夹或 Internet 位置包含您要打开的文件。

  3. 选择文件,然后单击“打开”。

  4. 如果出现导入 XML对话框中,打开的文件是指一个或多个可扩展样式表语言转换 (XSLT) 样式表,以便您可以单击下列选项之一︰

    • 打开文件,而不应用样式表   XML 数据导入中显示为列标题和列标题下方的行中的数据的 XML 标记的二维表格行和列。第一个元素 (根节点) 用作标题,并显示在指定单元格的位置。在第二行,其余的标记按字母顺序排序。 在这种情况下,Excel 不推断的架构,而且您无法使用 XML 映射。

    • 打开应用以下样式表 (选择一个) 文件   选择要应用,样式表,然后单击确定。XML 数据格式根据所选样式表。

      注意: 以便您意外不保存您的原始源文件中的 excel 启用宏的工作簿文件格式 (.xlsm),以在 Excel 中以只读方式打开 XML 数据。在这种情况下,Excel 不推断的架构,而且您无法使用 XML 映射。

  5. 显示打开 XML对话框中,如果 XML 文件不具有任何 XSLT 样式表的引用。若要打开的文件,单击下列选项之一︰

    • 单击作为 XML 表,在新工作簿中创建 XML 表。

      该文件的内容导入 XML 表。如果 XML 数据文件未引用架构,Excel 将推断的架构从 XML 数据文件。

    • 单击为只读状态的工作簿

      XML 数据导入的二维表中的行和列,显示为列标题和列标题下方的行中的数据的 XML 标记。第一个元素 (根节点) 用作标题,并显示在指定单元格的位置。在第二行,其余的标记按字母顺序排序。 在这种情况下,Excel 不推断的架构,而且您无法使用 XML 映射。

      以便您意外不保存您的原始源文件中的 excel 启用宏的工作簿文件格式 (.xlsm),以在 Excel 中以只读方式打开 XML 数据。在这种情况下,Excel 不推断的架构,而且您无法使用 XML 映射。

    • 单击使用 XML 源任务窗格

      XML 源任务窗格中显示的 XML 数据文件的架构。然后,可以将架构元素拖动到工作表中,以将这些元素映射到工作表。

      如果 XML 数据文件未引用架构,Excel 将推断的架构从 XML 数据文件。

导入 XML 数据的常见问题

它无法验证数据根据 XML 映射时,Excel 将显示XML 导入错误对话框。在此对话框中,单击每个错误有关其他信息的详细信息。下表列出了一些常见导入错误︰

错误

发生了什么事

架构验证失败

单击XML 映射属性对话框中的导入和导出架构验证数据,导入数据,但根据指定的 XML 映射未验证的数据。

作为文本导入一些数据

从其声明的数据类型的图片已转换为文本部分或全部您导入的数据。若要在计算中使用此数据,您将需要将数据从文本转换为数字或日期。例如,转换为文本的日期值将无法正常工作年函数中,直到将其转换为日期数据类型。Excel 将数据转换为文本时︰

  • 数据位于 Excel 不支持的格式。

  • 数据是与 Excel 内部表示形式的 XSD 数据类型不兼容。若要解决此问题,请检查以确保您的 XML 数据是根据 XML 架构有效每个数据类型声明。

XML 分析错误

XML 分析器无法打开指定的 XML 文件。请确保 XML 文件没有语法错误和 XML 的格式正确。

找不到的数据对应的 XML 映射

选择多个 XML 数据文件导入,和 Excel 找不到一个文件的匹配的 XML 映射时,会发生此问题。文件对话框中的标题栏中名为,首先,导入适当的架构,然后尝试再次导入该文件。

XML 表不能调整大小以适应数据

您试图导入或将数据追加到 XML 表中,通过添加行,但没有用于将展开表空间。XML 表只能向下扩展从底部。例如,可能有一个对象,如图片或另一个表,紧下方的 XML 表,防止展开 XML 表。或者,要展开的 XML 表,将超过 Excel 行限制为 1048576。若要解决此问题,请重新排列的表和允许从底部向下展开 XML 表的工作表上的对象。

指定的 XML 文件未引用架构

您正在尝试打开的 XML 文件未引用 XML 架构。若要处理的文件中的 XML 数据,Excel 需要架构基于 XML 的文件的内容。 如果该架构不正确或不足,请从您的工作簿删除它。然后创建 XML 架构文件和编辑的 XML 数据文件,以便引用架构的 XML 数据文件。有关详细信息,请参阅中的 XML 映射的单元格映射 XML 元素

注意: 无法将 Excel 推断的架构导出为单独的 XML 架构数据文件 (.xsd)。尽管有 XML 架构编辑器和创建 XML 架构文件的其他方法,您可能不方便地访问它们或了解如何使用它们。

请按照下列步骤删除 Excel 创建从您的工作簿的架构操作︰

  1. 单击开发人员>

    “开发工具”选项卡上的“XML”命令

    如果看不到开发工具选项卡,请参阅显示开发工具选项卡

  2. XML 源任务窗格中,单击XML 映射

  3. XML 映射对话框中,单击 XML 映射 Excel 创建的,然后单击删除

导入多个使用相同的命名空间,但不同架构的 XML 文件无法按预期工作

当您使用多个 XML 数据文件和 XML 架构,通常创建 XML 映射的每个架构、 映射所需的元素,然后将每个 XML 数据文件导入到合适的 XML 映射。使用导入命令来使用相同的命名空间打开多个 XML 文件,您可以仅使用一个 XML 架构。当您使用此命令可打开使用相同的命名空间,但不同架构的多个 XML 文件时,您可以获得意外的结果。例如,可能会被覆盖数据,或者文件无法打开。

若要导入多个使用相同的命名空间,但不同的 XML 架构的 XML 文件,请尝试使用从 XML 数据导入命令 (单击数据>自其他来源)。此命令允许使用相同的命名空间使用多个 XML 架构的多个 XML 文件。Excel 会创建唯一的 XML 映射的每个要导入的 XML 数据文件。

注意: 如果您要导入多个不定义命名空间的 XML 文件,这些 XML 文件将被视为他们使用相同的命名空间。

显示“开发工具”选项卡

如果看不到“开发工具”选项卡,请通过执行下列操作来显示该选项卡:

  • 在 Excel 2013 和 Excel 2010 中:

    1. 单击“文件”>“选项”。

    2. 单击“自定义功能区”类别。

    3. 主选项卡,下选中开发工具框,然后单击确定

  • 在 Excel 2007 中:

    1. 单击Microsoft Office 按钮 Office 按钮图像 > Excel 选项

    2. 单击常用类别。

    3. 使用 Excel 时采用的首选项中,选中在功能区中的显示开发工具选项卡框中,并单击确定

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

另请参阅

在 Excel 中的 XML 视图

XML 映射中的单元格映射 XML 元素

导出 XML 数据

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×