导入或复制到另一台计算机的自动完成列表

注意:  我们希望能够尽快以你的语言为你提供最新的帮助内容。 本页面是自动翻译的,可能包含语法错误或不准确之处。我们的目的是使此内容能对你有所帮助。可以在本页面底部告诉我们此信息是否对你有帮助吗? 请在此处查看本文的 英文版本 以便参考。

自动完成列表是一项功能,其中显示建议的名称和电子邮件地址,当您开始键入它们。这些建议是可能匹配的名称和已发送的电子邮件从电子邮件地址的列表。

自动完成列表

记忆式键入列表复制到另一台计算机的方法取决于您已添加到 Outlook 的电子邮件帐户类型。如果您有 Office 365 帐户、 Exchange Server 帐户或 IMAP 帐户 (这是最常见的其他电子邮件帐户类型),然后为您的 Outlook 数据文件中的隐藏文件存储记忆式键入列表。有关说明,请参阅复制记忆式键入列表

如果您有 POP3 帐户 (不太常见,但通常使用第三方电子邮件提供商 Comcast、 Earthlink 和 Verizon 等) 时,自动完成列表存储在您的计算机上存储的文件。请参阅复制并导入.nk2 文件

如果您不知道你拥有的帐户类型,选择文件>帐户设置>帐户设置。您可以找到你的帐户类型。

复制记忆式键入列表

步骤 1: 导出记忆式键入邮箱邮件

  1. 退出 Outlook,并关闭 Outlook Web Access 或连接到您的邮箱的所有工作站上的 Outlook Web App (OWA)。

  2. 下载并安装 MFCMAPI 从 http://mfcmapi.codeplex.com。

  3. 运行 mfcmapi.exe。

  4. 会话菜单上,单击登录

  5. 如果系统提示您的配置文件,选择所需的配置文件名称,然后单击确定

  6. 在顶部的窗格中,找到您的邮箱,对应的行,然后双击它。

  7. 在左侧导航窗格中,展开根容器,,然后展开顶部的信息存储IPM_SUBTREE

  8. 右键单击收件箱文件夹,然后单击打开关联的内容表。此操作将打开一个新的 MFCMAPI 窗口,其中包含各种属性。

  9. 主题列中,右键单击具有主题IPM 的项目。Configuration.Autocomplete,然后单击导出消息。此操作将打开保存到文件的消息窗口。

  10. 在下拉列表中,选择邮件文件 (UNICODE),,然后单击确定

  11. 选择您要保存的邮件文件夹位置,然后单击保存。注意此位置。

步骤 2: 导入记忆式键入邮箱邮件

  1. 退出 Outlook,并关闭 Outlook Web Access 或连接到您的邮箱的所有工作站上的 Outlook Web App (OWA)。

  2. 下载并安装 MFCMAPI 从 http://mfcmapi.codeplex.com。

  3. 运行 mfcmapi.exe。

  4. 会话菜单上,单击登录

  5. 如果系统提示您的配置文件,选择所需的配置文件名称,然后单击确定

  6. 在顶部的窗格中,找到您的邮箱,对应的行,然后双击它。

  7. 在左侧导航窗格中,展开根容器,,然后展开顶部的信息存储IPM_SUBTREE

  8. 右键单击收件箱文件夹,然后单击打开关联的内容表。此操作将打开一个新的 MFCMAPI 窗口,其中包含各种属性。

  9. 若要避免重复项,必须删除现有的记忆式键入邮件。

    注意:然后再删除 IPM。Configuration.Autocomplete 邮件中,您必须通过使用"如何导出自动完成缓存"部分中的步骤导出邮件。

    若要删除现有的记忆式键入消息,请按照下列步骤:

    1. 主题列中,找到具有主题IPM 的项目。Configuration.Autocomplete

    2. 右键单击该项目,,然后单击删除邮件。此时将打开删除项目窗口。

    3. 在下拉列表中,选择永久删除 (如果受支持的已删除的项目保留到删除),,然后单击确定

  10. 在文件夹菜单上,单击导入,,然后单击从消息。

  11. 找到您在步骤中创建 11"导出记忆式键入邮箱邮件"的上方,.msg 文件,然后单击确定

  12. 加载消息窗口中显示,在加载样式列表中,选择加载到当前文件夹的邮件,然后单击确定

从 IPM 导入的记忆式键入信息。Configuration.Autocomplete_ <十六进制代码>.msg,其中占位符 <十六进制代码> 表示长字符串的数字和字母。

Coy 并导入.nk2 文件

步骤 1: 从旧计算机复制自动完成文件

  1. 默认文件夹是隐藏的文件夹,因为打开的文件夹的最简单方法是使用命令%APPDATA%\Microsoft\Outlook在 Windows搜索框 (或中,浏览到 C:\Users\用户名\AppData\Roaming\Microsoft\Outlook)。

  2. 在 Outlook 文件夹中,查找您的自动完成列表 (.nk2) 文件。

    注意: 默认情况下,在 Windows 中隐藏文件扩展名。若要更改是否显示文件扩展名,在工具菜单上的窗口资源管理器 (在 Windows 7 或 Windows Vista 中,请按 ALT 键以查看工具菜单),单击文件夹选项。在视图选项卡中,选中或清除隐藏已知的文件类型的扩展名复选框。

  3. 将文件复制到新的计算机。文件小,并且可以放置在可移动媒体,例如 USB 内存条。

步骤 2: 将自动完成文件复制到新的计算机

  1. 在新计算机上,在控制面板中,单击或双击邮件

    邮件出现在不同的控制面板位置,具体取决于 Microsoft Windows 操作系统,选中,控制面板视图的版本,并且安装 32 位或 64 位操作系统或版本的 Outlook 2010。

    找到“邮件”的最简单的方法是,打开 Windows 中的“控制面板”,然后在窗口顶部的“搜索”框中,键入“邮件”。在 Windows XP 的控制面板中,在“地址”框中键入“邮件”

    注意: “邮件”图标会在 Outlook 首次启动后显示。

  2. 单击“显示配置文件”

  3. 记下的配置文件的名称。您将需要更改.nk2 文件名称,以更高版本匹配的名称。

  4. 将.nk2 文件复制到新的计算机中保存的 Outlook 配置的文件夹。默认文件夹是隐藏的文件夹,因为打开的文件夹的最简单方法是使用命令%APPDATA%\Microsoft\Outlook在 Windows搜索框 (或中,浏览到 C:\Users\用户名\AppData\Roaming\Microsoft\Outlook)。

  5. 文件水平到的文件夹后,右键单击文件、 单击重命名,并更改名称以与步骤 3 中显示的配置文件名称匹配。

步骤 3: 导入自动完成列表

现在您可以启动 Outlook 并导入该文件,但您必须使用特殊的一次性命令启动 Outlook。

  • 在 Windows搜索框中键入outlook /importnk2 ,然后按 Enter。

撰写邮件并开始在抄送密件抄送框中键入时,自动完成列表现在应拥有从其他计算机的条目。

返回页首

在 Outlook 2007 中,您可以从一台计算机复制到另一个的名称和自动完成列表中的电子邮件地址。例如,如果您升级到新的计算机,并且不希望丢失存储在自动完成列表中的所有信息,您可以将复制的姓名和电子邮件地址从旧计算机到您的新计算机。

重要: 在开始以下过程之前,必须退出Microsoft Outlook 。重新启动 Outlook 时,将自动完成列表中包括的名称。

从旧计算机复制自动完成文件

  1. 旧在计算机上,转到驱动器: \user\AppData\Local\Microsoft\Outlook。

    注意: 根据您的文件设置可能隐藏此文件夹。

  2. 右键单击配置文件 name.nk2,然后单击复制

    提示: 可以将文件复制到可移动介质,例如 USB 媒体棒,并在新计算机上,然后复制到正确的位置的文件。或者,您可以将该文件附加到电子邮件并发送给您自己的邮件。在新计算机上,在 Outlook 中,打开附件,然后将它保存正确的位置。

  3. 在计算机上要填充自动完成列表的位置,右键单击驱动器: \user\AppData\Local\Microsoft\Outlook 中的任意位置,然后单击粘贴以保存个人资料 name.nk2。

  4. 如果 Outlook 用户配置文件名称从中移动.nk2 文件的计算机上的不同,您必须重命名后将文件复制到正确的文件夹正在使用的新计算机的 Outlook 用户配置文件名称的文件。例如,如果从原始计算机与 Outlook 配置文件的用户名 Kim Akers 移动 Kim Akers.nk2 Kim Akers.nk2 文件复制到新的计算机,您必须重命名包含在新计算机正在使用的 Outlook 配置文件名称的文件。

  5. 当系统提示您替换现有文件,请单击

  6. 打开 Outlook,以查看更改应用于自动完成列表。

返回页首

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×